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What i s 010 Editor?  

010 Editor is a professional text editor and hex editor designed to quickly and easily edit 

the contents of any file on your computer. This software can edit simple text files 

including Unicode files, batch files, C/C++ source code, etc. but where 010 Editor excels 

is in editing binary files. A binary file  is a file that is computer - readable but not human -

readable (a binary file will appear as garbled characters if opened in a text editor). A hex 

editor  is a program that allows you to view and  edit the individual bytes of binary files 

and advanced hex editors including 010 Editor also allow you to edit the bytes of hard 

drives, floppy drives, memory keys, flash drives, CD -ROMs, processes, etc. Here are just 
some of the benefits of using 010 Edi tor:  

Á View and edit any binary file  on your hard drive (unlimited file size) and text 

files  including Unicode files, C/C++ source code, etc.  

Á Unique Binary Templates  technology allows you to understand any binary file 

format.  

Á Find and fix problems with hard drives , floppy drives, memory keys, flash drives, 

CD-ROMs, processes , etc.  

Á Analyze  and edit text and binary data with powerful tools including Find, Replace, 

Find in Files, Replace in Files, Binary Comparisons, Checksum/Hash Algorithms, 

Histograms, etc.  

Á Powerful scripting  engine allows automation of many tasks (language is very 

similar to C).  

Á Import  and export  your binary data in a number of different formats.  

010 Editor's unique Binary Templates  technology allows you to understand  the bytes of 

a binary file by presenting you with the file parsed into an easy - to -use structure. For an 

example of how Binary Templates work, open any ZIP, BMP, or WAV file on your 

computer and a Binary Template will automatically be run on the file. Binar y Templates 

are easy to write and look similar to C/C++ structures except they are very  powerful and 

can be configured to parse any  binary format. A repository of Templates that other 

people have written is available online. For more information on Binary Templates see 
Introduction to Templates and Scripts . 

The hex editor built into 010 Editor can load files of any size instantly, and features 

unlimited undo and redo on all editing operations. The editor can even c opy or paste 

huge blocks of data between files instantly. Try 010 Editor and we're sure you'll agree 
that 010 Editor is the most powerful hex editor available today!  

 

For more information on how 010 Editor works see:  
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Á Introduction to Number Systems   

Á Introduction to Byte Ordering   
Á Introduction to the Data Engine   

To begin editing files see:  

Á Introduction to Editing  

For information on how Binary Templates and Scripts can be used to edit files see:  

Á Introduction to Templates and Scripts  

010 Editor can be downloaded and used free for 30 days. After that time, the program 
must be registered. For more information see:  

Á How to Buy 010 Editor  

If you have any questions or problems, information on contacting SweetScape Software 
can be found here:  

Á How to Get Support  

Thank you and we hope you enjoy using 010 Editor!  

 
 

 

Related Topics:  
Introduction to Templates and Scripts  

Introduction to Number Systems  

Introduction to the Data Engine  
Introduction to Editing  

How to Buy 010 Editor  

How to Get Support  

Copyright © 2003 -2011 Swee tScape Software -  www.sweetscape.com  
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Introduction  to Number Systems  
 

 

When editing raw hex data, 010 Editor uses a variety of different number systems including decimal, 
hexadecimal, octal, and binary. Each number system has a different 'base ' that is used to convert from a set of 
digits to a numeric value. For example, the digits '246' can be converted to a number using base 10 by 2*10 2 + 
4*10 + 6 = 246. In general, if the n digits of a number A are numbered where A 0 is the right -most digit, A 1 is the 
digit to the left and so on, then the value of a number of base B is calculated:  

An-1*B n-1 + A n-2*B n-2 + ... + A 1*B + A 0 

The following is a list of the 4 number systems used:  

Á Decimal -  Numbers are represented as base 10. The digits may be any number from '0' to '9'. For 
example, in decimal 153 = 1*10 2 + 5*10 1 + 3.  

Á Hexadecimal -  Numbers are represented as base 16. All the decimal digits are used, plus the letters 
'A', 'B', 'C', 'D', 'E', and 'F' are used to represent the numbers 10 through 15. For example, in 
hexadecimal 3d7 = 3*16 2 + 13*16 1 + 7 = 983. This system is commonly referred to as Hex . 

Á Octal -  Numbers are represented as base 8. Only the digits '0' through '7' are used ('8' or '9'  is not 
allowed). For example, the number 2740 = 2*8 3 + 7*8 2 + 4*8 1 + 0 = 1504.  

Á Binary -  Numbers are represented as base 2. Only the digits '0' or '1' can be used. For example, the 
number 10110 = 1*2 4 + 0*2 3 + 1*2 2 + 1*s 1 + 0 = 22.  

 

Bits and Bytes  

A digit of a binary number is also called a ' bit '. When 8 bits are grouped together, the result is called a ' byte '. 
Since a byte has 8 binary digits, it can represent an y value from 0 up to 255 inclusive. Every file stored on a disk 
is stored as a set of bytes. Note that when 4 bits are grouped together (base 2), this can also be represented as 
a single hexadecimal digit (base 16). For example, binary 0101 = '5' hexadecim al, or binary 1111 = 'F' 
hexadecimal.  

010 Editor is designed specifically for editing the individual bytes of a file. When a file is opened for editing, a Hex 
Editor Window shows the representation of each byte as a hexadecimal number and as a character (s ee 
Introduction to Editing  for more information).  

 

Entering Numbers in Text Fields  

Almost anywhere a number is entered in 010 Editor (in most text fields, the Inspector, etc.), the program 
supports input in a number of different formats. Usually, the format of the number is assumed to be deci mal 
(some fields have a Decimal  and Hex  toggle beside them -  clicking the Hex  toggle will set the default to be hex). 
However, the other formats can be entered with a special syntax:  

Á Hex -  Use '0x' before the number or ',h', ',x', or 'h' after the number. For example, '0x100' or '3f,h', 
'd2,x', or 'FFh' represent hexadecimal numbers.  

Á Octal -  Enter ',o' after the number. For example, '377,o' is an octal number.  

Á Binary -  Enter ',b' after the n umber. For example, '0101,b' is a binary number.  

Á Decimal -  Enter ',d' after the number. For example, '123,d' is a decimal number.  

Á Characters -  Characters can be entered by placing single quotes around the character. For example, 'A' 
would be converted to t he number 65. Most standard C escape sequences are also supported using ' \ '. 
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For example, ' \ n' would be converted to the number 10.  

See Introduction to Byte Ordering  for information on how to group bytes together to make numbers larger than 
255.  

The number formats supported in Scripts and Templates are slightly different. See Introduction to Templates and 
Scripts  for more information.  

 
 

 

Related Topics:  

Introduction to Editing  
Introduction to Templates and Scripts  

Introduction to Byte Ordering  

Copyright © 2003 -2011 SweetScape Softwa re -  www.sweetscape.com  
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Introduction to Byte Ordering  
 

 

Data on a computer is usually divided into sets of 8 bits, called a byte (see Introduction to Number Systems ). A 
byte can store  256 different values but to store larger numbers, a set of bytes must be grouped together. The 
term ' Endian ' refers to how these bytes are grouped together.  

Á Little Endian -  In little -endian systems (for example, Intel machines), bytes are stored with the least 
significant byte first. For example, the hex bytes '2f 75 05' actually represent the number 0x05752f 
(357679 in decimal). '2f' is the least significant byte and '05' is  the most significant byte.  

Á Big Endian -  In big -endian systems (for example, Motorola machines), bytes are stored with the most 
significant byte first. In the same example, the hex bytes '2f 75 05' would represent the number 
0x2f7505 (3110149) in decimal.  

Which endian is used to convert bytes to numbers is very important. Every file in 010 Editor has an endian 
setting ( LIT will appear in the Status Bar in little -endian mode, and BIG will appear in big -endian mode). Most 
tools and the Inspector use this endi an setting. To change the default endian used for files, use the ' View > 
Endian ' menu. 010 Editor can be configured to automatically set the endian based on the file extension (see 
Working with File Interfaces ).  

 
 

 

Related Topics:  
Introduction to Number Systems  

Status Bar  

Working with File Interfaces  

Copyright © 2003 -2011 SweetScape Software -  www.sweetscape.com  
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Introduction to the Data Engine  
 

 

010 Editor contains a powerful data engine, called the DynaBin Data Engine. The data engine is used on all file 
and disk operations including reading data, editing, undo, redo, cut, copy, paste, inserting files, etc. As a result of 
using this engine, the p rogram gains some extremely powerful functionality but also has a few limitations.  

 

Features  

One of the post powerful features of the engine is the ability to open any hex file or drive instantly. There is no 
limit to the size of files that can be opened, but some file systems (including FAT) limit the file size to 2 
gigabytes.  

Many clipboard operations including Cut, Copy or Paste can usually (but not always) copy hex data instantly (see 
Using the Clipboard  for more information). For example, open the largest file available on the disk, p ress Ctrl+A  
to select all, Ctrl+C  to copy, Ctrl+N  to create a new file, Ctrl+H  to switch into hex -editing mode, and Ctrl+V  to 
paste the data.  

Other file operations, such as Insert Bytes, Insert File, Overwrite Bytes, Overwrite File, and Set File Size can 
operate on hex files instantly as well. For example, create a new hex file using Ctrl+N  and Ctrl+H  and then click 
'Edit > Set File Size... '. Type '10000000000' and press Enter to create a huge file (NOTE: do not try to save this 
file unless enough disk spa ce is free).  

Another feature gained by using the data engine is unlimited Undo and Redo on all operations. Regardless of the 
size of data copied, pasted, or deleted, the operation can be undone or redone using Ctrl+Z  or Ctrl+Shift+Z . 

 

Limitations  

The limitations of the data engine only apply when copying or pasting large blocks of data to or from the 
clipboard (larger than 16KB).  

The data engine uses a read -on-demand system, meaning data is not read into the editor until it is required. 
When Copy and Paste operate on large blocks, sometimes only pointers to the data are transferred.  As a result, if 
a large block of memory is copied and then the file is deleted or modified by another program, the copied data 
may become corrupted (you will be warned when this happens). If a file is open in the editor, make sure to close 
the file before  deleting it from disk using another program.  

As stated earlier, when large blocks of data are copied to the clipboard, sometimes only pointers are copied. 
When the file the data is copied from is closed or modifications are saved, the actual data is then copied to the 
clipboard. This process is calle d Unlinking  and may take some time if very large blocks have been copied. The 
Status Bar will display a progress bar while the file is being saved or closed. The ' Edit > Clipboard > Clear 
Clipboards ' menu option can be used to clear the clipboards, removing any large blocks from memory.  

 
 

 
Related Topics:  

Inserting Files  

Using the Clipboard  

Copyright © 2003 -2011 SweetScape Software -  www.sweetscape.com  
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What's new in Version 3.2?  
 

 

The following is an overview of the new functionality in version 3.2 of 010 Editor:  

Á 010 Editor is now available for Mac OS X.  

Á On-demand parsing of templates using < size=...> for lower memory usage.  

Á Can set fonts for the Template Results, Inspector, etc in the Options dialog.  

Á 'New' on the file menu now lists all types of files available for creation.  

Á Can pass arguments into scripts or templates from the command lin e.  

Á New functions for accessing process information in scripts or templates.  

Á New functions for easier reading and writing of text files.  

Á Can export or import a list of scripts or templates from the Options dialog.  

Á New help viewer with tabs.  

The followi ng is a list of all new features in version 3.2 of 010 Editor:  

Á General  

Á 010 Editor is now available for Mac OS X.  

Á Can set fonts for the Template Results, Inspector, etc in the Options dialog.  

Á 'New' on the File menu now lists all types of files available f or creation.  

Á Each file interface can either use the default text or hex font or a custom font.  

Á Separate insert/overwrite state for text and hex files.  

Á Can click INS/OVR in the status bar to toggle insert state.  

Á Histogram hotkey changed to Ctrl+Shift+T .   

Á Added option on the Help Menu to view the Release Notes.  

Á 010 Editor does a better job converting text data between formats when copying text between 
files with different character sets.  

Á Can set a custom color format for 'Edit > Insert Color' in the Opt ions dialog.  

Á Non -ANSI characters now supported in Bookmark names.  

Á Release notes added to the manual instead of separate text file.  

Á Command Line  

Á Can pass arguments to a script or template using the form: - script:File.1sc:(arg1,arg2)  

Á Added ',a' specifier  to the ' - replace' command to replace in all open files.  

Á ' - h' now displays the manual command line page instead of a separate dialog.  

Á Templates and Scripts  

Á On-demand parsing of templates using <size= number > or <size= function_name > for lower 
memory usage.   

Á Can export or import a list of scripts or templates from the Options dialog.  

Á Added ifdef constant for Windows (_010_WIN) and Mac OS X (_010_MAC).  

Á Added ifdef constant for 64 -bit versions (_010_64BIT).  

Á Non -ANSI characters now supported in comments (use  UTF-8).  

Á Functions  

Á Added GetFileNameW function to get the wide -string version of the current file name.  

Á FileSave function can accept a wide -string or no string at all to save to the current file name.  

Á Added ExpandAll function to open all nodes in the Te mplate Results.  

Á Added ExportCSV to save the Template Results to a comma -delimited file.  

Á GetNumArgs, GetArg, and GetArgW functions can be used to retrieve special arguments 
passed from the command line.  

Á IsNoUIMode function returns true if 010 Editor is being run in ' -noui' mode.  

Á RunTemplate function now returns the return value from the template that was executed.  

Á FileOpen now returns the file index of the file that was opened.  

Á Process information can be returned using the functions ProcessGetHeapLocalAddress, 
ProcessGetHeapModule, ProcessGetHeapSize, ProcessGetHeapStartAddress, 
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ProcessGetNumHeaps, ProcessHeapToLocalAddress, and ProcessLocalToHeapAddress.  

Á Added functions to read or write text data in t he editor including TextAddressToLine, 
TextAddressToColumn, TextGetNumLines, TextGetLineSize, TextLineToAddress, TextReadLine, 
TextReadLineW, TextWriteLine, TextWriteLineW.  

Á Bug Fixes  

Á Fixed some foreign characters in names not working in the Register dialo g.  

Á Fixed the temp directory displaying a short path name.  

Á The documentation listed the incorrect return value for the StringToDosDate, 
StringToDosTime, StringToFileTime, StringToOleTime, and StringToTimeT functions.  

Á Fixed bug with multi - line defines and  dos-style linefeeds.  

Á Fixed bug resetting shortcuts where the interface was not updating properly.  

Á Insert Date/Color should work now for Unicode files.  

Á Fixed issues with certain input method editors that caused them to not work properly.  

Á Now display er ror message when trying to set linefeeds to 'Auto Detect' while in binary mode.  

Á Fixed bug where the Close All icon should be available when the startup tab is selected.  

Á Fixed InputSaveFileName function not properly using the default file name.  

Á Fixed an undefined variable in a script could be displayed as an error in an associated 
template.  

Á Fixed redraw bug in the Base Converter.  

Á Fixed some code examples in the help file.  

Á Fixed occasional problem drawing underscores.  

Á Fixed template variables sometimes  not accessible after calling RunTemplate.  

Á Fixed open icon in the tutorial on Windows 7.  

Á Fixed Histogram panel initial size on Windows 7.  

Á Fixed the size of the Hex Operations dialog on Windows 7.  

Á Fixed accessing new file created during a call to RunTem plate.  

 

For a full list of changes in other versions, see the Release Notes . 

 
 

 

Related Topics:  
Release Notes  

Copyright © 2003 -2011 SweetScape Software -  www.sweetscape.com  
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Notes for Users of 010 Editor v2.1  
 

 

This section lists some important notes for users of 010 Editor v2.1 and all previous versions. Some of the 
functionality has changed in version 3.0 and this section should help describe the major changes. See What's 
New  for a full list of changes.  

 

There is no more Code Editor  

The Code Editor of 010 Editor has been removed. Now when a script or template is loaded, it is placed into a tab 
in the Floating Tab Group . Whenever a file in the main interface or in the Floating Tab Group  tab group is marked 
bold , that is the active file in the program and all file operations (save, close, find, select all, etc.) operate on 
that file. Note that now multiple scripts and templates can be loaded into the interface whereas the old program 
was limited to one script or template at a time. See Using File Tabs  for more information on the Floating Tab 
Group.  

 

All the functionality of the Code Editor has been moved to other places in the application. N ew scripts and 
templates can be generated directly from the Scripts or Templates menu. Any output from the Printf function is 
now listed in the Output  tab of the Output  panel (press Alt+3  to show the Output panel and press Alt+3  or Esc to 
hide the Output panel). After a script is run, any defined variables can be viewed in the Variables  tab of the 
Inspector . The list of functions that can be inserted into Scripts or Templates can be accessed on the Functions  
tab of the Inspector  (you may have to use the scroll arrows beside the tabs to locate the Functions  tab). Because 
multiple Scripts and Templates can now be loaded, how files are executed has changed slightl y (see the next 
section).  

 

Running Scripts and Templates  

How Scripts and Temp lates are run in version 3.0 has changed from previous versions. Scripts and Templates can 
be run as usual from the menu or command line; however, Scripts and Templates can also be run using the drop -
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down lists located in the Tool Bar. If you are editing a  regular file, the Tool Bar will appear as follows:  

 

Select which script to run on the current file from the Scripts drop -down list and click the Run icon or press F7 to 
execute that script on the file. The drop -down list will display all files on the ' Scripts ' menu plus all Scripts that 
are currently open. Similarly the Templates drop -down list displays all Templates on the ' Templates ' menu plus 
all open Templates. Select a Template and click the Run icon or press F5 to execute the Template on the current 
file.  

 

However, the interface changes slightly when a Templates is selected as the active file (the Edit As  drop -down list 
will display Template  when a template is active). The color of the Template drop -down list will change to yellow. 
Now the Template drop -down list displays all regular files that are open in the interface. Select a file from the list 
and click the Run icon or press F5 to run the  current template on that file. In effect, the Run (F5) functionality is 
slightly different depending upon what type of file is selected.  

 

Similar to running a Template, when a Script is selected in the interface ( Script  is displayed in the Edit As  drop -
down list), choose which file to execute the current Script on from the Script drop -down list in the Tool Bar (the 
background color is again yellow). Press F7 or click the Run icon to execute the current script on the selected file.  

 

Using File Tabs  

 

010 Editor version 3 contains more advanced file tabs than version 2. Tabs can be dragged to new positions and 
can even be dragged to a special Floating Tab Group . Click t he 'x' icon on each tab to close a file or middle -click 
on the tab. See Using File Tabs  for more information.  

 

Editing text files  

Starting with version 3, 010 Editor can now edit text files. Just open a text file with the regular ' File > Open File ' 
command and 010 Editor should automatically detect whether the file is text or binary. If 010 Editor incorrectly 
identifies a file, the type of editor can be changed using the Edit As  drop -down list in the Tool Bar. Also, pressing 
Ctrl+H  toggles between hex and text editing mode. See Working with File Interfaces  for more information.  

 

Location of Scripts and Templates  

In version 3, Scripts and Templates are now stored in the following directories in Windows XP:  

Á Scripts  -  "My Documents \ SweetScape \ 010 Scripts"  

Á Templates  -  "My Documents \ SweetScape \ 010 Templates"  

instead of in the 'Progra m Files' directory in version 2. The locations will differ slightly depending upon which 
operating system is used.  
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A complete list of the changes is listed in the What's New  help topic.  

 
 

 
Related Topics:  

Using File Tabs  

Using the Inspector  

What's New in Version 3.2  
Working with File Interfaces  

Copyright © 2003 -2011 SweetScape Software -  www.sweetscape.com  
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Introduction to Editing  
 

 

010 Editor is a powerful editor for text and binary files. This section describes the basic methods used to edit 
fi les. Typically, editing is performed by opening a file, applying changes, and then saving the changes to the disk. 
To see how to load files into the editor click on:  

Á Opening Files   

To begin editing the files see either:  

Á Using the Text Editor  or  

Á Using the Hex Editor   

To learn how to use the clipboard to copy and paste data see:  

Á Using the Clipboard   

The editor can be configured to display data in a number of formats. For more information see:  

Á Working with File Interfaces  

Finally, to save files see:  

Á Saving Files   

A number of other ways exist to edit files. See Using the Inspector  for a method of interpreting binary data as a 
number of different data types. For a more powerful wa y of editing files see Introduction to Templates and 
Scripts . 

010 Editor can also be used to edit hard drives and processes. See the Editing Drives  or Editing Processes  help 
topics for more information.  

 
 

 

Related Topics:  

Introduction to Templates and Scripts  
Editing Drives  

Editing Processes  

Opening Files  
Saving Files  

Selecting Bytes  

Status Bar  
Using the Clipboard  

Using the Hex Editor  

Using the Text Editor  

Using the Inspector  
Working with File Interfaces  

Copyright © 2003 -2011 SweetScape Software -  www.sweetscape.com  
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Opening Files  
 

 

010 Editor contains a number of methods for opening files. Clicking the ' File > Open File... ' menu option, or 
pressing Ctrl+O  opens a file dialog box. After selecting a file and clicking the Open  button, the file will be 
displayed as either a Text Editor W indow or a Hex Editor Window in the main display. See Using the Text Editor  
or Using the Hex Editor  for information on editing the file. When opening a file, if the Open as read -only  toggle is 
selected in the dialog, the file will be opened in read -only mode.  

The editor stores a list of files that have been recently opened. This list can be accessed from the ' File > Open 
Recent ' menu option, from the Workspace (see Using the Workspace ), or from the Startup Page (see the Using 
the Startup Page ). Click a file from the Open Recent menu to load it into memory. The number of files in the list 
can be controlle d from the General Options  dialog.  

Another way of opening files is to use the standard Windows Explorer program. When 010 Editor was installed, 
enabling the ' Add 010 Editor to explorer right -click menu ' toggle in the install program will allow files to be 
opened from the Explorer. Right click on a file and select the ' 010 Editor v3 ' option. Another method of opening 
files is to drag -and -drop a file from the Windows Explorer onto a running 010 Editor pro gram. If dragging and 
dropping an Intel Hex or Motorola S -Record file, the file will automatically be imported. Files can also be 
associated with 010 Editor, meaning that double -clicking a file in the Windows Explorer will open the file in 010 
Editor. Inte l Hex files or Motorola S -Record files can be automatically associated with 010 Editor by selecting the 
'Associate Intel Hex files with 010 Editor ' or ' Associate Motorola S -Records with 010 Editor ' toggle in the install 
program. For more information on Int el Hex or Motorola S -Record files, see Importing/Exporting Files . 

The Workspace  also contains a simplified browser that can be used to open files. Files can also be loaded from 
the Favorite Files list or the Bookmarked Files list in the Workspace.  

Files can be opened when starting 010 Editor from the command line. See Command Line Parameters  for more 
information.  

010 Editor can also be used to e dit hard drives and processes. See the Editing Drives  or Editing Processes  help 
topics for more information.  

 
 

 

Related Topics:  

Command Line Parameters  

Editing Drives  
Editing Processes  

General Options  

Importing/Exporting Files  
Using the Hex Editor  

Using the Startup Page  

Using the Text Editor  
Using the Workspace  
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Using File Tabs  
 

 

 

Each file, process, or drive that is loaded in 010 Editor is placed into a File Tab  as shown above. A collection of 
File Tabs in a single line is referred to as a Tab Group . By default all regular files that are loaded are placed into a 
single Tab Group in the main interface but all Scripts and Templates a re loaded into a Floating Tab Group (see 
the Floating Tab Group section below).  

The currently active File Tab will be displayed as bold  and all file operations (save, close, find, select all, etc.) will 
be applied to that file. Each File Tab displays a sho rtened version of the full file name but the file name can be 
viewed in a hint popup by placing the mouse cursor over top of the Tab (the file name of the active file can also 
be viewed in the application title bar). Clicking on a File Tab sets that file a s the active file in the application.  

To close a File Tab either click the 'x' button on the Tab or click the middle mouse button on the Tab (some 
computer mice have a scroll wheel and a middle click can be performed by pressing down on the scroll wheel). 
Alternately, File Tabs can be closed using the ' File > Close ' functionality. A popup menu can be accessed by right -
clicking on the Tab. From the popup menu, click the ' Close ' menu option to close the currently selected file or the 
'Close All Except This ' o ption to close all files except the file that is currently selected. See the File Menu  for an 
explanation of other options on the popup menu.  

 

If too many File Tabs are loaded to be viewed  all at once, the File Tabs can be viewed by clicking on the left and 
right arrows (shown above) to scroll through the tabs. Clicking the down arrow displays a list of all File Tabs in 
that Tab Group.  

File Tabs may be rearranged by clicking and dragging th e tabs to new positions. An arrow will appear to indicate 
where a Tab will be positioned when dropped. File Tabs may even be dropped onto other Tab Groups (see Using 
Multiple Tab Groups below).  

 

Using Multiple Tab Groups  

By default all regular files are loaded into a single Tab Group in the main interface and all Scripts and Templa tes 
are loaded into a special Floating Tab Group (see the Floating Tab Group section below). The main interface can 
be split into multiple Tab Groups oriented either horizontally or vertically. When multiple files are loaded, multiple 
horizontal Tab Groups  can be created by right -clicking on a File Tab and selecting Move to New Horizontal Tab 
Group . Another way to generate horizontal Tab Groups is to drag a File Tab towards the bottom of the Window 
until the blue selection area indicates the lower half of t he dialog (see the dialog below).  
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Similarly, multiple vertical Tab Groups can be generated by right -clicking on a Tab and selecting Move to New 
Vertical Tab Group  or by dragging a File Tab to the right until the blue selection area indicates the right side of 
the window.  

Once multiple Tab Groups have been created simply drag a File Tab between the groups. Clicking the ' Window > 
Merge All Tab Groups ' will place all tabs into a single Tab Group again . See the Window Menu  for more 
information.  

 

Floating Tab Group  

 

The Floating Tab Group  is just a floating window that contains a set of File Tabs and can be displayed by clicking 
the ' View > Floating Tab Group '. Any file can be m oved to the Floating Tab Group by dragging the File Tab to the 
window until a blue selection area appears and then dropping the Tab. Note that the active file for the application 
will be marked as bold  and only one file at a time can be the active file. Hide the Floating Tab Group easily by 
pressing the Esc key (the Esc key is also used to hide the Output window).  

By default all Scripts and Templates that are loaded are placed into this Tab Group but the y can be set to load 
into the main interface by using the Compiling Options . Usually the Floating Tab Group is displayed on top of the 
application but it can be docked by right -clicking on the window and enabling the Allow Docking  menu option.  

 
 

 

Rela ted Topics:  

File Menu  
Opening Files  

Window Menu  
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Using the Text Editor  
 

 

 

The Text Editor Window (shown above) is the main method of viewing and editing text files in 010 Editor. Each 
text file that is loaded is displayed in a File Tab  that shows a shortened form of the file name (the full  file name 
can be viewed in the application title bar or in a hint popup displayed by placing the mouse cursor over the File 
Tab). The main area of the text editor shows the file interpreted as a series of characters (if a byte cannot be 
shown as a charact er a square symbol will be displayed). On the left side of the Text Editor Window is a list of 
addresses and each address indicates the line number or the file position of the first byte on the line. A Ruler, 
located above the main area, displays the colum n offset from the start of each line and a small arrow indicates 
the current cursor position. The editor can be changed to display data in a number of different ways and to 
modify how the Text Editor Window displays data see Working with File Interfaces . 

 

The Cursor  

A cursor is shown in the Text  Editor Window as a vertical, flashing line and this cursor indicates the current 
position for inserting, deleting, or editing data. Left -click with the mouse to move the cursor or use the cursor 
keys on your keyboard (see Editor Keys below). When the Text  Editor Window is not active, a vertical gray line, 
called the shadow cursor, will indicate where the cursor was located. When the editor is in Overwrite  mode (see 
Editing Data below) the cursor will be displayed as a thick vertical line and when the edito r is in Insert  mode the 
cursor will be displayed as a thin vertical line.  

 

Editing Data  

To edit data in the editor, position the cursor over the character to edit and type on the keyboard. The result of 
editing depends on whether the editor is in Insert or Overwrite mode. In Overwrite mode ( OVR appears in the 
Status Bar ) the characters typed will replace any existing characters. In Insert mode ( INS appears in the Status 
Bar) a new character will be inserted into the file. Note that the current Insert/Overwrite  mode is stored 
separately for text and hex files. The current Insert/Overwrite mode can be changing using the Insert Key (see 
Editor Keys below) or by clicking INS/OVR in the status bar. Pressing the Delete key will delete the current 
character from the f ile.  

After any edits are made a '*' character will appear in the File Tab to indicate that the file has been modified. 
Also, if bytes have been inserted a '*' character will appear by the file size in the Status Bar. Use the ' Edit > 
Undo ' and ' Edit > Redo '  menu options to undo or redo any modifications made to the file. The file can also be 
edited using the clipboard (see Using the Clipboard ).  
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Editor Keys  

The following keys can be used while editing a text file:  

Á Left, Right, Up, Down -  move the cursor in any direction.  

Á Ctrl+Left , Ctrl+Right  -  move the cursor to the next or last word  

Á Ctrl+Up , Ctrl+Down  -  scroll the editor up or down without moving the cursor.  

Á Enter -  insert a new line.  

Á Home -  move the cursor to the first character on a line.  

Á End -  move the cursor to the last character on a line.  

Á Ctrl+Home -  move the cursor to the top of the file.  

Á Ctrl+End -  move the cursor to the end of the file.  

Á Insert -  toggle Insert and Overwrite mode.  

Á Delete -  deletes the current character from the file.  

Á Tab -  inserts a tab character or indents a blocks of lines if more that one line is selected at a time.  

Á Shift+Tab -  if more than one line is selected, this option unindents the selected lines.  

 

Right -Click Menu  

Right -clicking on the Text Editor Window displays a popup -menu of options. This menu is a sub -set of the Edit 
Menu and see the Edit Menu  help topic for more information on each menu option.  

 

Splitting th e Text Editor Window  

 

The Text Editor Window may be split into two different areas by clicking the small button above the horizontal 
scroll bar (see the diagram above) and dragging the mouse down. Once the mouse is released the window will be 
split into a top and a bottom regio n (see the diagram below). Having two different regions is useful for editing 
two different areas of the file at the same time. The areas may be resized by moving the mouse over the line 
between the areas and dragging the line up or down (the mouse cursor will appear as an up -down arrow). 
Double -click on the dividing line to return to having a single area. Alternately, the Text Editor Window may be 
split or un -split using the ' Window > Split Window ' menu option.  
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Editor Options  

The Editor Options  and Text Editor Options  dialogs can be used to control a number of options for the Text Editor 
Window.  

 
 

 

Related Topics:  
Edit Menu  

Editor Options  

Status Bar  

Text Editor Options  
Usin g the Clipboard  

Working with File Interfaces  
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Using the Hex Editor  
 

 

 

The Hex Editor Window (shown above) is the main method of viewing and editing binary files in 010 Editor (to 
edit text f iles see Using the Text Editor ). A Hex Editor Window is displayed for each binary file that is loaded in 
the editor. Each file is displayed in a File Tab  that displays a shor tened form of the file name but the full file name 
can be viewed in the application title bar or in a hint popup displayed by placing the mouse cursor over the File 
Tab. The Hex Editor Window is divided into a left and a right area. By default, the left ar ea displays the bytes of 
the file as a series of hexadecimal bytes and the right area displays the bytes as a series of characters (if a byte 
cannot be shown as a character a '.' will be displayed). To the left of the Hex Editor Window is a list of address es. 
Each address indicates the file position of the first byte on the line. At the top of the window a Ruler indicates the 
byte offsets from the address on that line. The editor can be changed to display data in a number of different 
formats. To modify how  the Hex Editor Window displays data see Working with File Interfaces . 

 

The Cursor  

A cursor is displayed in the Hex Editor Window as a vertical, flashing line. The cursor indicates the current 
position for inserting, deleting, or editing data. Move the cursor with the mouse by clicking anywhere in the main 
display with the left mouse but ton. Alternately, the cursor keys can be used to move the cursor (see Editor Keys 
below). When the cursor is in the left or right areas, the byte the cursor is currently over will be highlighted gray 
in the other area. Switch between areas by pressing the Tab  key. When the Hex Editor Window is not focused, a 
vertical gray line, called the shadow cursor, will indicate where the cursor was located. When the editor is in 
Overwrite  mode (see Editing Data below) the cursor will be displayed as a thick vertical l ine and when the editor 
is in Insert  mode the cursor will be displayed as a thin vertical line.  

 

Editing Data  

To edit data in the editor, position the cursor over the byte to edit. When the cursor is in the left area 
(hexadecimal data) enter a valid hexadecimal digit (0 to 9 or A to F) to edit the data. When the cursor is in the 
ri ght area (character data) enter any character to edit the data.  

The result of editing depends on whether the editor is in Insert or Overwrite mode. In Overwrite mode ( OVR 
appears in the Status Bar) the characters typed will replace any existing characters . In Insert mode ( INS appears 
in the Status Bar) a new byte will be inserted in the file (NOTE: when editing hexadecimal data, a byte is inserted 
only when the cursor is over the first digit in the hexadecimal byte). The current Insert/Overwrite mode is st ored 
separately for text and hex files and the current mode can be changing using the Insert Key (see Editor Keys 
below) or by clicking INS/OVR in the status bar. Pressing the Delete key will delete the current byte from the file.  

When any edits are made t o the file, a '*' character will appear in the title bar to indicate that the file has been 
modified. If bytes have been inserted, a '*' character will appear by the file size in the Status Bar. The ' Edit > 
Undo ' and ' Edit > Redo ' menu options can be used to undo or redo any changes made to the file. The file can also 
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be edited using the clipboard (see Using the Clipboard  for more information).  

 

Editor Keys  

The following keys are available when editing the file:  

Á Left, Right, Up, Down -  move the cursor in any direction.  

Á Ctrl+Left , Ctrl+Right  -  move the cursor to the next or la st group of bytes.  

Á Ctrl+Up , Ctrl+Down  -  scroll the editor up or down without moving the cursor.  

Á Home -  move the cursor to the first byte on a line.  

Á End -  move the cursor to the last byte on a line.  

Á Ctrl+Home -  move the cursor to the first byte in the file.  

Á Ctrl+End -  move the cursor to the end of the file.  

Á Insert -  toggle Insert and Overwrite mode.  

Á Delete -  deletes the current byte from the file.  

Á Tab -  switches between the left and right editing areas.  

Á Alt+ Up  -  moves to the previous sector in a hard drive.  

Á Alt+Down  -  moves to the next sector in a hard drive.  

 

Right -Click Menu  

A menu of editing options can be accessed by right -clicking on the Hex Editor Window. This menu is sub -set of 
the Edit Menu (see the Edit Menu  for an explanation of eac h menu option).  

 

Splitting the Hex Editor Window  

 

The Hex Editor Window can be split into two differe nt regions by clicking the small button above the horizontal 
scroll bar (see the diagram above) and dragging the mouse down. After releasing the mouse, the window will be 
split into a top and a bottom area (see the diagram below). This feature is useful if  you are editing two different 
areas of the file at the same time. Press the Tab  or Shift -Tab  keys to move the cursor between the different 
areas. Move the mouse over the line separating the areas and click and drag the line up or down to resize the 
areas (the mouse cursor should change to an up -down arrow). Double -click on the separating line to remove the 
separator and return to having just one area. The Hex Editor Window can also be split or un -split by clicking the 
'Window > Split Window ' menu option.  
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Template Results  

After a Binary Template has been run on the current file, t he results will be displayed in the Template Results 
panel at the bottom of the Hex Editor Window. This panel is sometimes hidden and can be shown by clicking the 
small button below the horizontal scroll bar and dragging upwards. See Working with Template Results  for more 
information on using the Template Results panel.  

 

Editor Options  

See the Editor Options  and Hex Editor Options  dialogs for a list of options that can be controlled for the Hex 
Editor Window.  

 
 

 

Related Topics:  

Edit Menu  

Editor Options  
Hex Editor Options  

Status Bar  

Using the Clipboard  
Using the Text Editor  

Working with File Interface s 

Working with Template Results  
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Working with File Interfaces  
 

 

A File Interface  is an important concept in 010 Editor. Every file that is loaded is assigned a File Interface and this 
interface controls how that file is displayed and edited. A File Interface includes the Font, Character Set, 
Linefeeds, Tabs, Addresses, Group By, Divisi on Lines, Areas, Highlighting, Ruler, Status Bar, and Endian settings 
for a file (basically all options listed at the top of the View Menu ). The name of the current file's File Interface is 
displayed in the Edit As  drop -down list as shown below. A different File Interface can be applied to the current file 
using the Edit As  drop -down list or the ' View > Edit As ' menu.  

 

File Interfaces may be either text -based , where the Text Editor  Window is used to edit the file, or hex -based , 
where the Hex Editor  Window is used to the edit the file. Edit the current interface from the View Menu  or from 
the Tool Bars  (some, but not all, options can be edited using the File Interface Options  dialog as well). Modifying 
an option for one file modifies that option for all f iles that use that interface. Any changes to the interface are 
automatically saved when 010 Editor exits so the interface will appear the same the next time the program loads.  

Multiple interfaces can be generated for files and assigned automatically when a  file loads. For example, 010 
Editor can be configured to always open a file with a certain file extension in Big Endian mode or with the EBCDIC 
character set. To create new interfaces use the ' View > Edit As ' menu (see the View Menu  for more information) 
or the File Interface Options dialog (see File Interface Options  dialog). The ' View > Edit As ' menu contains a list 
of all available File Interfaces and a checkmark will be plac ed beside the currently active interface. For more 
options on how File Interfaces are assigned to files see the Editor Options  dialog.  

The following list indicates all attributes that are stored with the File Interfa ce:  

Á Font -  Controls the font type, size, and style that are used in the editor. File Interfaces may use either 
the standard Text Editor font, the standard Hex Editor font, or their own custom font.  

Á Character Set -  Sets which character set is used to displa y data in a character area (ASCII, 
ASCII+OEM, ASCII+ANSI, EBCDIC, Unicode, UTF -8, Macintosh, or various international character sets).  

Á Linefeeds -  Specifies how 010 Editor breaks the file into a set of lines. If the linefeeds are set on Auto -
Detect  then t he interface is considered to be a text -based  File Interface. If the linefeeds are set on a 
fixed size (e.g. 16 bytes per line) the interface is considered to be a hex -based  File Interface. When 
using a fixed number of bytes per line, the program can autom atically determine the maximum number 
of bytes to display in the window by choosing the Fixed Auto  option.  

Á Tabs/Whitespace -  When editing text files the Tabs setting controls how far apart the tab stops are in 
a file. When a tab character is encountered in  a file the next character is displayed at the next tab stop 
position. The Tabs option also controls how many characters are inserted when the Tab key is pressed. 
010 Editor can be set to insert spaces instead of tabs (the default) as well.  

Á Addresses -  Controls whether the addresses on the left side of the editor are displayed in hex format, 
decimal format, octal format, or whether the current line number is displayed. The line number can also 
display the current sector number when editing hard drives or ca n be hidden altogether.  

Á Group By -  Sets how many bytes are grouped together in the Hex Editor Window (the default is one).  

Á Division Lines -  010 Editor can draw a set of lines on the Hex Editor Window to visualize how different 
bytes are grouped together. There are two types of lines that can be drawn: Division Lines  and Sector 
Lines . By default, a division line is drawn every 4 bytes in a light -gray color and a sector line is drawn 
for each sector in a dark -gray color when editing hard drives. See the View Menu  for more information 
on Division Lines.  

Á Left Area -  Controls which numeric format is displayed in the left area of the Hex Editor (Hex, Char, 
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Octal, Binary, or Decimal). This option is fixed as Char for text editing.  

Á Right Area -  Controls which numeric format is displayed in the right area of the editor (He x, Char, 
Octal, Binary, Decimal, or Hide). This option is fixed as Hide for text editing.  

Á Highlighting -  Controls which bytes are highlighted in the editor. A number of highlighting schemes 
are available by default but more can be generated through the Highlight Options  dialog. Different 
syntax highlighting rules can also be applied to text data.  

Á Ruler -  Specifies whether the Ruler is displayed at the top of the Editor Window and the units of the 
Ruler can be cont rolled as well.  

Á Status Bar -  Sets what format to display the current file position, file size, and selection size as seen in 
the status bar.  

Á Endian -  Controls which byte -ordering is used for the current editor (see In troduction to Byte 
Ordering ).  

See the View Menu  for more details about each option.  

 
 

 
Related Topics:  

Highlight Options  

Using the Hex Editor  
Using the Text Editor  

Using Tool Bars  

View Menu  
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Selecting Bytes  
 

 

Before using any of the clipboard operations such as Cut, Copy, or Paste, a selection must be made on the file 
(see Using the Clipboard ). Selections can be made with either the mouse, the keyboard, or through the Select 
Range dialog box.  

To select bytes with the mouse , click a file with the left mouse button and drag the mouse over the file. To select 
bytes with the keyboard, hold down the Shift key and move the cursor with any of the cursor movement keys 
(see Using the Text Editor  or Using the Hex Editor  for a list of keys). The bytes that are selected will be displayed 
with a blue background. The number of bytes selected and the start address of the selection are displa yed in the 
Status Bar  along the bottom of the application.  

All bytes in the file can be selected at once using the ' Edit > Select All ' menu option.  

Bytes can also be selected with the Select Range dialog box (see Selecting a Range ). The start address and 
number of bytes of the selection can be viewed at any time by opening the Select Range dialog box.  

 
 

 
Related Topics:  

Selecting a Range  

Status Bar  
Using the Clipboard  

Using the Hex Editor  

Using the Text Editor  
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Using the Clipboard  
 

 

The clipboard is a temporary scratch pad that can be used to store a block of bytes. The clipboard also makes 
possible moving data between applications. Most clipboard operations require that a set of bytes be selected in a 
file (see Selecting Bytes ). The following clipboard operations are supported:  

Á Copy -  Accessed from the ' Edit > Copy ' menu option, this operation copies the currently selected bytes 
onto the clipboard. This operation does not modify the file. The keyboard shortcuts Ctrl+C  and Ctrl+Ins  
can also be used to copy data.  

Á Cut -  The ' Edit > Cut ' menu option copies the selected bytes onto the clipboard and then deletes the 
bytes from the file. The keyboard shortcuts Ctrl+X  and Shift+Del  can also be used to cut data.  

Á Delete -  Clicking the ' Edit > Delete ' menu option will delete the currently selected bytes from the file. 
The data on the clipboard will not be modified.  

Á Paste -  The ' Edit > Paste ' menu option has two possible effects: When editing text data or when in 
Insert mode ( INS will appear in the Status Bar), the bytes on the clipboard are inserted into the file at 
the current cursor position. When editing hex data in Overwrite mode ( OVR will appear in the Status 
Bar), the bytes on the clipboard are written over the bytes in the file, starting at the cursor position. If a 
selection is made when a Paste operation is performed, th e selection will first be deleted from the file 
and then the bytes will be inserted. The Insert key can be used to toggle between Insert and Overwrite 
mode. Note that the functionality of the Paste command can be changed in the Hex Editor Options  
dialog. The keyboard shortcuts Ctrl+V  and Shift+Ins  can also be used to paste data.  

Á Paste Special -  Some applications copy data to the clipboard in a number of different formats. The 
'Edit > Paste Special ' menu option is s imilar to the Paste menu option except that the format to paste 
can be chosen explicitly. See Using Paste Special  for more information.  

Á Copy as Hex Text -  Click the ' Edit > Copy As > Copy as Hex Text ' menu option to c onvert the selected 
bytes into text characters and copy the result onto the clipboard. For example, copying the bytes 0x2F 
and 0xB7 as text would result in the string "2FB7" being placed on the clipboard. Use this option to 
transfer binary data into a text  editor or to search for a set of hex bytes in the Find tool.  

Á Copy As ( export_type ) -  This set of options provides a quick way to export data to any of the 
supported export formats (see Importing/Exporting Files ) and then copying the exported data to the 
clipboard.  

Á Paste from Hex Text -  The ' Edit > Paste From > Paste from Hex Text ' command is similar to the Paste 
command, except that the data on the clipboard is automatically converted from hex characters to 
binary by tes before pasting. For example, if the four characters "17D4" were copied onto the clipboard, 
then the two binary bytes 0x17 and 0xD4 would be pasted into the file. Note that any characters that 
are not valid hexadecimal digits will be ignored in the conv ersion. Use this option to transfer hex bytes 
from a text editor into 010 Editor.  

Á Paste From ( import_type ) -  This set of commands provides a method of importing data that is on the 
clipboard in any of the supported import formats (see Importing/Exporting Files  for a list of all import 
types). The data is imported and then inserted at the current cursor position.  

 

Multiple Clipboards  

010 Editor contains a total of 10 clipboards: the standa rd Windows clipboard plus 9 custom clipboards. Only one 
clipboard is active at a time and all Cut, Copy, and Paste commands will operate on that clipboard. The active 
clipboard will be checked in the ' Edit > Clipboard ' menu. Select another clipboard by cli cking an item in the 
Clipboard menu, or use Ctrl+0  up to Ctrl+9 . The active clipboard is also displayed in the Status Bar (see Status 
Bar  for more information).  
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Clearing Clipboards  

Large blocks of memory can easily be copied to or from the clipboard (see Introduction to the Data Engine ). Use 
the ' Edit > Cli pboard > Clear Clipboards ' menu option to remove all data from the 10 clipboards. This command 
is useful to prevent large blocks of data from being copied into memory when a file is saved or closed.  

 

Exiting with Large Blocks  

Note that when the program exits, a large block of memory copied to the Windows clipboard is deleted unless the 
Leave Large Blocks on Clipboard on Exit  toggle is set in the General Options . 

 
 

 
Related Topics:  

Edit Menu  

Editor Options  
General Options  

Importing/Exporting Files  

Introduction to the Data Engine  
Selecting Bytes  

Status Bar  

Using Find  

Using Paste Special  
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Status Bar  
 

 

 

The Status Bar, located along the bottom of the application, contains useful information about the current file and 
the current status of the editor. The Status Bar is divided up into a number of panels as listed below:  

Á Message Area (1) -  Displays informat ion about the last completed operation. When an important 
message such as an error or warning is displayed in this field, the message will be displayed with an 
orange background.  

Á File Position / Selection Start (2) -  When no bytes are selected, this panel shows the current 
address of the cursor in the file. When bytes are selected, this panel displays 'Start:' followed by the 
starting address of the selection. The address can be displayed in hex format, decimal format, octal 
format, both hex and decimal, or  can display the line number. The address format is controlled from the 
'View > Status Bar > File Position Units ' menu option or from the popup menu accessed by right -
clicking the Status Bar. Left -click on this panel to bring up the Goto  dialog.  

Á Current Byte / Selection Size (3) -  When no bytes are selected, this panel displays the current value 
of the byte the cursor is over. The value of the byte is displayed in hex, decimal, and binary formats. 
The byte value is displayed a s an Unsigned Byte but to convert to other formats see the Inspector . 
When bytes are selected in the file, this panel displays 'Sel:' followed by the size of the current 
selection. The display format used for the selecti on size can be controlled using the ' View > Status Bar 
> Selection Size Units ' menu option or by right -clicking on the Status Bar.  

Á File Size (4) -  Shows the size in bytes of the file being edited. The size format can be displayed in hex 
format, decimal for mat, octal format, both hex and decimal, or number of lines. To control the displayed 
numeric format, see the ' View > Status Bar > File Size Units ' menu option or the popup menu accessed 
by right -clicking the Status Bar. Note that a '*' will appear beside the file size if the size has been 
changed since the file was opened. Left -click on this panel to open the Set File Size  dialog.  

Á Character Set and Linefeeds (5) -  Shows which character set is being used to display the current 
file. The character set depends upon the current File Interface (see Working with File Interfaces ) and 
can be controlled through the ' View > Character Set ' menu option. The following character sets are 
supported :  

Á ASCII  -  ASCII Character Set  

Á ANSI  -  ASCII+ANSI Character Set  

Á OEM -  ASCII+OEM Character Set  

Á EBC -  EBCDIC Character Set  

Á UNI  -  Unicode Character Set  

Á UTF8 -  UTF-8 Character Set  

Á MAC -  Macintosh Character Set  

Á ARA -  Arabic Character Set  

Á BAL -  Baltic Character Set  

Á CH-S -  Chinese (Simplified) Character Set  

Á CH-T -  Chinese (Traditional) Character Set  

Á CYR -  Cyrillic Character Set  

Á EEUR -  Eastern Europe Character Set  

Á GRE -  Greek Character Set  

Á HEB -  Hebrew Character Set  

Á JAP -  Japanese Characte r Set  

Á KO-J -  Korean (Johab) Character Set  

Á KO-W -  Korean (Wansung) Character Set  

Á THAI  -  Thai Character Set  

Á TURK -  Turkish Character Set  

Á VIET  -  Vietnamese Character Set  

If the current file is a text file, the current type of linefeeds is displayed in b rackets after the character 












































































































































































































































































































































































































