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What is 010 Editor?
010 Editor is a professional text editor and hex editor designed to quickly and easily edit
the contents of any file on your computer. This software can edit text files including
Unicode files, batch files, C/C++, XML, etc. but where 010 Editor excels is in editing
binary files. A binary file is a file that is computer-readable but not human-readable (a
binary file will appear as garbled characters if opened in a text editor). A hex editor is a
program that allows you to view and edit the individual bytes of binary files and advanced
hex editors including 010 Editor also allow you to edit the bytes of hard drives, floppy
drives, memory keys, flash drives, CD-ROMs, processes, etc. Here are just some of the
benefits of using 010 Editor:
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View and edit any binary file on your hard drive (unlimited file size) and text
files including Unicode files, C/C++, XML, PHP, etc.
Unique Binary Templates technology allows you to understand any binary file
format.
Find and fix problems with hard drives, floppy drives, memory keys, flash drives,
CD-ROMs, processes, etc.
Analyze and edit text and binary data with powerful tools including Find, Replace,
Find in Files, Replace in Files, Binary Comparisons, Checksum/Hash Algorithms,
Histograms, etc.
Powerful scripting engine allows automation of many tasks (language is very
similar to C).
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Easily download and install Binary Templates and Scripts others have shared
using the 010 Editor Repository.
Import and export your binary data in a number of different formats.

010 Editor's unique Binary Templates technology allows you to understand the bytes of
a binary file by presenting you with the file parsed into an easy-to-use structure. For an
example of how Binary Templates work, open any ZIP, BMP, or WAV file on your
computer and a Binary Template will automatically be run on the file. Binary Templates
are easy to write and look similar to C/C++ structures except they are very powerful and
can be configured to parse any binary format. A repository of Templates that other
people have written is available using the Repository Dialog. For more information on
Binary Templates see Introduction to Templates and Scripts.
The hex editor built into 010 Editor can load files of any size instantly, and features
unlimited undo and redo on all editing operations. The editor can even copy or paste
huge blocks of data between files instantly. Try 010 Editor and we're sure you'll agree
that 010 Editor is the most powerful hex editor available today!

Getting Started
For more information on how 010 Editor works see:





Introduction to Number Systems
Introduction to Byte Ordering
Introduction to the Data Engine

To begin editing files see:



Introduction to Editing

For information on how Binary Templates and Scripts can be used to edit files see:



Introduction to Templates and Scripts

To easily install Templates and Scripts other people have shared see:



Introduction to the Repository

010 Editor can be downloaded and used free for 30 days. After that time, the program
must be registered. For more information see:



How to Buy 010 Editor

If you have any questions or problems, information on contacting SweetScape Software
can be found here:



How to Get Support

Thank you and we hope you enjoy using 010 Editor!
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Related Topics:
Introduction to the Repository
Introduction to Templates and Scripts
Introduction to Number Systems
Introduction to the Data Engine
Introduction to Editing
How to Buy 010 Editor
How to Get Support
010 Editor v7.0 Manual - Windows Edition
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Introduction to Number Systems
When editing raw hex data, 010 Editor uses a variety of different number systems including decimal,
hexadecimal, octal, and binary. Each number system has a different 'base' that is used to convert from a set of
digits to a numeric value. For example, the digits '246' can be converted to a number using base 10 by 2*102 +
4*10 + 6 = 246. In general, if the n digits of a number A are numbered where A0 is the right-most digit, A1 is the
digit to the left and so on, then the value of a number of base B is calculated:
An-1*Bn-1 + An-2*Bn-2 + ... + A1*B + A0
The following is a list of the 4 number systems used:






Decimal - Numbers are represented as base 10. The digits may be any number from '0' to '9'. For
example, in decimal 153 = 1*102 + 5*101 + 3.
Hexadecimal - Numbers are represented as base 16. All the decimal digits are used, plus the letters
'A', 'B', 'C', 'D', 'E', and 'F' are used to represent the numbers 10 through 15. For example, in
hexadecimal 3d7 = 3*162 + 13*161 + 7 = 983. This system is commonly referred to as Hex.
Octal - Numbers are represented as base 8. Only the digits '0' through '7' are used ('8' or '9' is not
allowed). For example, the number 2740 = 2*83 + 7*82 + 4*81 + 0 = 1504.
Binary - Numbers are represented as base 2. Only the digits '0' or '1' can be used. For example, the
number 10110 = 1*24 + 0*23 + 1*22 + 1*s1 + 0 = 22.

Bits and Bytes
A digit of a binary number is also called a 'bit'. When 8 bits are grouped together, the result is called a 'byte'.
Since a byte has 8 binary digits, it can represent any value from 0 up to 255 inclusive. Every file stored on a disk
is stored as a set of bytes. Note that when 4 bits are grouped together (base 2), this can also be represented as
a single hexadecimal digit (base 16). For example, binary 0101 = '5' hexadecimal, or binary 1111 = 'F'
hexadecimal.
010 Editor is designed specifically for editing the individual bytes of a file. When a file is opened for editing, a Hex
Editor Window shows the representation of each byte as a hexadecimal number and as a character (see
Introduction to Editing for more information).

Entering Numbers in Text Fields
Almost anywhere a number is entered in 010 Editor (in most text fields, the Inspector, etc.), the program
supports input in a number of different formats. Usually, the format of the number is assumed to be decimal
(some fields have a Decimal and Hex toggle beside them - clicking the Hex toggle will set the default to be hex).
However, the other formats can be entered with a special syntax:







Hex - Use '0x' before the number or ',h', ',x', or 'h' after the number. For example, '0x100' or '3f,h',
'd2,x', or 'FFh' represent hexadecimal numbers.
Octal - Enter ',o' after the number. For example, '377,o' is an octal number.
Binary - Enter ',b' after the number. For example, '0101,b' is a binary number.
Decimal - Enter ',d' after the number. For example, '123,d' is a decimal number.
Characters - Characters can be entered by placing single quotes around the character. For example, 'A'
would be converted to the number 65. Most standard C escape sequences are also supported using '\'.

Copyright © 2003-2016 SweetScape Software
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For example, '\n' would be converted to the number 10.
See Introduction to Byte Ordering for information on how to group bytes together to make numbers larger than
255.
The number formats supported in Scripts and Templates are slightly different. See Introduction to Templates and
Scripts for more information.

Related Topics:
Introduction to Editing
Introduction to Templates and Scripts
Introduction to Byte Ordering
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Introduction to Byte Ordering
Data on a computer is usually divided into sets of 8 bits, called a byte (see Introduction to Number Systems). A
byte can store 256 different values but to store larger numbers, a set of bytes must be grouped together. The
term 'Endian' refers to how these bytes are grouped together.




Little Endian - In little-endian systems (for example, Intel machines), bytes are stored with the least
significant byte first. For example, the hex bytes '2f 75 05' actually represent the number 0x05752f
(357679 in decimal). '2f' is the least significant byte and '05' is the most significant byte.
Big Endian - In big-endian systems (for example, Motorola machines), bytes are stored with the most
significant byte first. In the same example, the hex bytes '2f 75 05' would represent the number
0x2f7505 (3110149) in decimal.

Which endian is used to convert bytes to numbers is very important and every file in 010 Editor has an endian
setting. LIT will appear in the Status Bar when the current file is in little-endian mode, and BIG will appear in bigendian mode. Also, when in big-endian mode the Toggle Endian button in the Tool Bar will be highlighted. Most
tools and the Inspector use this endian setting. To change the default endian used for files, use the 'View >
Endian' menu. 010 Editor can be configured to automatically set the endian based on the file extension (see
Working with File Interfaces).

Related Topics:
Introduction to Number Systems
Status Bar
Using Tool Bars
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Introduction to the Data Engine
010 Editor contains a powerful data engine and this engine is used on all file and disk operations including
reading data, editing, undo, redo, cut, copy, paste, inserting files, etc. As a result of using this engine, the
program gains some extremely powerful functionality but also has a few limitations.

Features
One of the post powerful features of the engine is the ability to open any hex file or drive instantly. There is no
limit to the size of files that can be opened, but some file systems (including FAT) limit the file size to 2
gigabytes.
Many clipboard operations including Cut, Copy or Paste can usually (but not always) copy hex data instantly (see
Using the Clipboard for more information). For example, open the largest file available on the disk, press Ctrl+A
to select all, Ctrl+C to copy, Ctrl+N to create a new file, Ctrl+H to switch into hex-editing mode, and Ctrl+V to
paste the data.
Other file operations, such as Insert Bytes, Insert File, Overwrite Bytes, Overwrite File, and Set File Size can
operate on hex files instantly as well. For example, create a new hex file using Ctrl+N and Ctrl+H and then click
'Edit > Set File Size...'. Type '10000000000' and press Enter to create a huge file (NOTE: do not try to save this
file unless enough disk space is free).
Another feature gained by using the data engine is unlimited Undo and Redo on all operations. Regardless of the
size of data copied, pasted, or deleted, the operation can be undone or redone using Ctrl+Z or Ctrl+Shift+Z.

Limitations
The limitations of the data engine only apply when copying or pasting large blocks of data to or from the
clipboard (larger than 16KB).
The data engine uses a read-on-demand system, meaning data is not read into the editor until it is required.
When Copy and Paste operate on large blocks, sometimes only pointers to the data are transferred. As a result, if
a large block of memory is copied and then the file is deleted or modified by another program, the copied data
may become corrupted (you will be warned when this happens). If a file is open in the editor, make sure to close
the file before deleting it from disk using another program.
As stated earlier, when large blocks of data are copied to the clipboard, sometimes only pointers are copied.
When the file the data is copied from is closed or modifications are saved, the actual data is then copied to the
clipboard. This process is called Unlinking and may take some time if very large blocks have been copied. The
Status Bar will display a progress bar while the file is being saved or closed. The 'Edit > Clipboard > Clear
Clipboards' menu option can be used to clear the clipboards, removing any large blocks from memory.

Related Topics:
Inserting Files
Using the Clipboard
010 Editor v7.0 Manual - Windows Edition
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What's new in Version 7.0?
Version 7.0 - March 23rd, 2016
The following is an overview of the new functionality in version 7.0 of 010 Editor:











New 010 Editor Repository holds an online collection of Binary Templates and Scripts that have been
submitted by users of the software.
Files from the Repository can be downloaded and installed or uninstalled in 010 Editor with the click of a
button.
Templates or Scripts can be submitted to the Repository directly from 010 Editor.
Can handle multiple versions of files in the Repository including updates, diffs, merges, etc.
Updated the style of a number of dialogs including the Startup page and Welcome page.
Added 'Using the Repository' tutorial to teach the basics of the repository.
Major upgrade to UI library resulting in a number of minor bug fixes and visual fixes.
New webpage 'http://www.sweetscape.com/010editor/repository/' shows the Repository in real time.
New 'Repository' menu displayed in the File Bar above a Template or Script.

The following is a list of all new features in version 7.0 of 010 Editor:
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Repository
 New Repository Dialog accessed by clicking 'Templates > Template Repository' or 'Scripts >
Script Repository'.
 Repository dialog lists all files in the repository and can sort by Category, Alphabetic, or
Newest.
 Install or Uninstall files from the Repository Dialog with the click of a button.
 Can search for Scripts or Templates in the Repository Dialog with the search field.
 Licenses for 010 Editor now include free Support, Upgrades, and Repository Updates for 1 year
from the date of purchase.
 When opening a file a dialog pops up if a Template is found in the Repository that can parse
the file (can install the Template or ignore).
 Repository can check for 'ID Bytes' for data files before asking to install.
 New webpage 'http://www.sweetscape.com/010editor/repository/' shows the Repository in
real time.
 Download package includes a number of files from the Repository (called the Local Repository)
so files can be installed even on computers not connected to the internet.
 Online Repository checked for new updates every 3 days (can be changed or turned off).
 Renamed a number of files in the repository (e.g. "BMPTemplate.bt" => "BMP.bt").
 Recent repository updates are listed on the Startup page (double-click on an item to view) or
on the History tab of the Repository Dialog.
 Can submit files to the Repository directly from 010 Editor (see 'Submit File' in the 'Repository'
menu above a Script or Template).
 Submission dialog checks the header for errors and provides an easier way to add Category or
History information to the submission.
 Note that all submissions are reviewed by SweetScape Software before being allowed in the
repository.
 New 'Repository' menu in the File Bar above each Template or Script in the editor.
 Icon in the File Bar shows the file repository status (Installed from Repository, Modified,
Update Available, Conflict).
 Use the Repository Menu to Update, Check for Modifications, Diff, Revert, Delete, or View
Repository.
 Full update engine including powerful 3-way merge algorithm and showing conflicts.
 'Available Versions' table in the Repository Dialog can show multiple versions of files in the
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Repository. The different versions can be viewed, installed or compared.
Display a special warning if a template installed from the Repository asks for permissions to
read or write to other files.
 History tab of the Repository Dialog is displayed when new updates downloaded (can be
turned off).
 Included new tutorial 'Help > Tutorials > Using the Repository'.
 Default Templates and Scripts (e.g. 'BMP.bt', 'IsASCII.1sc', etc) are now installed from the
Repository.
Templates/Scripts
 New Template and Script repository allows installing and submitting Templates and Scripts
easily.
 Templates and Scripts can be listed by Category in the Templates and Scripts menu.
 Standard templates have been renamed (e.g. "BMPTemplate.bt" => "BMP.bt").
 Templates can now have 'ID Bytes' which provide an extra check that a template can parse a
data file. For example, the 'ZIP.bt' file has ID Bytes '50 4B //PK'.
 Renamed 'Templates > Online Template Repository' to 'Template Repository' which now shows
the Repository Dialog.
 Renamed 'Scripts > Online Script Repository' to 'Script Repository' which now shows the
Repository Dialog.
 Renamed 'Templates > Edit Template List' to 'View Installed Templates'.
 Renamed 'Scripts > Edit Script List' to 'View Installed Scripts'.
 The Output panel is no longer shown by default when Printf is called in a template (this can be
controlled using the Compiling Options page).
 New standard comment header at the beginning of Templates or Scripts created with
'Templates > New Template' or 'Scripts > New Script'. New header includes History, Category,
File Mask, and ID Bytes.
 Local strings are now displayed using the character set from the current file (used to always
be ANSI).
 #include now searches the Template and Script Repository Directories.
General
 Updated style for a number of dialog boxes.
 Inspector and Workspace are now docked to the right side by default (just drag-and-drop to
move to the left side).
 Updated Welcome Page with information about the repository.
 Changed default selection background color.
 A dialog now pops up when Support, Free Upgrade, and Free Repository Updates are about to
expire (about 30 days left) and when expired.
 Updated Startup page with modified style and Repository news.
 License information is now displayed on the lower-right corner of the Startup page (click to
display the Register dialog).
 Downloading application news/updates is now done in the background instead of when the
application was shut down.
 Small modifications to the default colors for the editor.
 Read-only state of files is saved with the workspace.
 When a new license is entered a dialog displays the end dates for Support, Free Upgrades and
Free Repository Updates.
 About page now displays current license info and has a button to show the Register dialog.
 Major upgrade to UI library resulting in a number of minor bug fixes and visual fixes.
Options
 Template Options and Script Options now display the list of installed files, including files that
have been installed from the Repository.
 Include the category name in the list of installed templates and scripts.
 Easier way to add local Templates and Scripts to the list. Clicking the 'Add...' button displays a
multi-select file dialog box.
 When adding local Templates or Scripts information such as File Mask, ID Bytes, and Category
can be extracted from the comments at the beginning of the file.
 Templates and Scripts now have an 'Edit...' button to load the file in the editor.
 Added 'ID Bytes' for Templates as an extra way to check that data files can be parsed by a
Template (ID Bytes can be turned off by unchecking the 'Require' toggle).
 Added 'Status' info for Templates and Scripts and click the 'Show...' button to display the
Repository dialog if installed from the Repository.
 Added 'Set Shortcut' button on Scripts and Templates Options for an easy way to set a
shortcut for these items.
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Mac







New installation method. Just drag-and-drop to install.
Now support OS X 10.7 and higher (sorry 10.6 users, we tried).
Help viewer now renders fonts better on retina displays.
Fixed some font spacing issues on dialogs on the Mac.
For OS X 10.7 and 10.8 the default hex editor font is now Andale Mono (there is a rendering
bug using Courier New on these systems).

Bugs
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New Repository Options page displays options for the Repository (some options are duplicated
in the Repository Dialog).
Directory Options now allows setting the default Template and Script directory (moved from
the Compiling Options).
Directory Options can set the directory where Scripts and Templates are installed from the
Repository.
Moved File Dialog settings to a separate File Dialog Options page.
Added an option on the Compiling page to control whether the Output panel is displayed
automatically when Printf is called in a Script or Template.
List of options on the left side of the Options Dialog is now resizable (you may need to enlarge
the dialog first).
Options Dialog remembers its size when 010 Editor is shutdown and restarted.
New constants $TEMPLATE_REPOS_DIR and $SCRIPT_REPOS_DIR can be used in file names in
the Options dialog.

Fixed a crash in the Help Viewer when doing a search for certain keywords.
Fixed problem on Linux using Save As to save a large file in certain cases.
Fixed issue with multiple warnings when running scripts or templates are split onto separate
lines.
Fixed bug in dialog asking to save a file which is marked as read-only was not displaying the
file name correctly.
Fixed issue using the regular expression anchor '$' on files with DOS linefeeds.
Fixed using increment or decrement on a variable inside a variable accessor could sometime
be called multiple times.
Fixed issue where the Addresses for the last line of a large text file were not displayed
correctly using 'Byte Number (Decimal)'.
Fixed issue with wrong the background color sometimes being set when defining structs within
structs.
Fixed bug with the FindFirst function incorrectly wrapping when starting the search from the
end of the file.
Fixed crash when using an invalid regular expression in the FindFirst function.
Fixed using ReadByte/ReadInt/etc with no arguments and positions greater than 0xFFFFFFFF.
Fixed possible crash in FindOpenFile function after using FileClose.
Fixed when a custom name function had an error an empty string was being displayed for the
name.
Fixed problem allocating a local variable after a struct definition sometimes having the
improper scope.
Fixed FindInFiles and FindFiles now return strings in UTF-8 format.
Fixed possible crash assessing types defining by a call to RunTemplate.
Fixed FindFirst and FindAll would incorrectly search the whole file when size was zero.
Fixed crash using more than 15 parameters to SScanf.
Increased the maximum parameters for SScanf from 15 to 30.
Fixed bug with WMemSet function when the value to set was more than 255.
Fixed a problem viewing process names that contained non-ASCII characters.
Fixed a memory leak in user functions in certain cases.
Fixed a crash when a script or template ends with an unmatched '*/'.
Fixed an error message when trying to allocate an array more than 4 GB.
Fixed a bug using the '+' operator to add strings and single characters in certain cases.
Fixed some focus issues on Windows when opening a file and 010 Editor was minimized to the
task bar.
Fixed restoring the application to the correct monitor when 010 Editor was maximized and
then closed.
Fixed typing a backslash character when using the Japanese character set on Mac OS X.

Copyright © 2003-2016 SweetScape Software
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Fixed issue when FileOpen failed and afterwards an incorrect file was selected.

For a full list of changes in other versions, see the Release Notes.

Related Topics:
Release Notes
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Notes for Users of 010 Editor v2.1
This section lists some important notes for users of 010 Editor v2.1 and all previous versions. Some of the
functionality has changed in version 3 and 4 and this section should help describe the major changes. See What's
New for a full list of changes.

There is no more Code Editor
The Code Editor of 010 Editor has been removed. Now when a script or template is loaded, it is placed into a tab
in the Floating Tab Group. Whenever a file in the main interface or in the Floating Tab Group tab group is marked
bold, that is the active file in the program and all file operations (save, close, find, select all, etc.) operate on
that file. Note that now multiple scripts and templates can be loaded into the interface whereas the old program
was limited to one script or template at a time. See Using File Tabs for more information on the Floating Tab
Group.

All the functionality of the Code Editor has been moved to other places in the application. New scripts and
templates can be generated directly from the Scripts or Templates menu. Any output from the Printf function is
now listed in the Output tab of the Output panel (press Alt+3 to show the Output panel and press Alt+3 or Esc to
hide the Output panel). After a script is run, any defined variables can be viewed in the Variables tab of the
Inspector. The list of functions that can be inserted into Scripts or Templates can be accessed on the Functions
tab of the Inspector (you may have to use the scroll arrows beside the tabs to locate the Functions tab). Because
multiple Scripts and Templates can now be loaded, how files are executed has changed slightly (see the next
section).

Running Scripts and Templates
How Scripts and Templates are run in version 4.0 has changed from previous versions. Scripts and Templates can
be run as usual from the menu or command line; however, Scripts and Templates can also be run using the drop-

18
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down lists located in the File Bar above each editor. See Running Templates and Scripts for more information.

Using File Tabs

010 Editor version 4 contains more advanced file tabs than version 2. Tabs can be dragged to new positions and
can even be dragged to a special Floating Tab Group. Click the 'x' icon on each tab to close a file or middle-click
on the tab. See Using File Tabs for more information.

Editing text files
Starting with version 3, 010 Editor can now edit text files. Just open a text file with the regular 'File > Open File'
command and 010 Editor should automatically detect whether the file is text or binary. If 010 Editor incorrectly
identifies a file, the type of editor can be changed using the Edit As drop-down list in the Tool Bar. Also, pressing
Ctrl+H toggles between hex and text editing mode. See Working with File Interfaces for more information.

Location of Scripts and Templates
In version 3, Scripts and Templates are now stored in the following directories in Windows 7:




Scripts - "Documents\SweetScape\010 Scripts"
Templates - "Documents\SweetScape\010 Templates"

instead of in the 'Program Files' directory in version 2. The locations will differ slightly depending upon which
operating system is used.
A complete list of the changes is listed in the What's New help topic.

Related Topics:
Using File Tabs
Using the Inspector
What's New in Version 4.0
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Introduction to Editing
010 Editor is a powerful editor for text and binary files. This section describes the basic methods used to edit
files. Typically, editing is performed by opening a file, applying changes, and then saving the changes to the disk.
To see how to load files into the editor click on:



Opening Files

To begin editing the files see either:




Using the Text Editor or
Using the Hex Editor

To learn how to use the clipboard to copy and paste data see:



Using the Clipboard

The editor can be configured to display data in a number of formats. For more information see:



Working with File Interfaces

Finally, to save files see:



Saving Files

A number of other ways exist to edit files. See Using the Inspector for a method of interpreting binary data as a
number of different data types. For a more powerful way of editing files see Introduction to Templates and
Scripts.
010 Editor can also be used to edit hard drives and processes. See the Editing Drives or Editing Processes help
topics for more information.

Related Topics:
Introduction to Templates and Scripts
Editing Drives
Editing Processes
Opening Files
Saving Files
Selecting Bytes
Status Bar
Using the Clipboard
Using the Hex Editor
Using the Text Editor
Using the Inspector
Working with File Interfaces
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Opening Files
010 Editor contains a number of methods for opening files. Clicking the 'File > Open File...' menu option, or
pressing Ctrl+O opens a file dialog box. After selecting a file and clicking the Open button, the file will be
displayed as either a Text Editor Window or a Hex Editor Window in the main display. See Using the Text Editor
or Using the Hex Editor for information on editing the file. When opening a file, if the Open as read-only toggle is
selected in the dialog, the file will be opened in read-only mode. To control which directory is used when the
Open File dialog is shown see the Directory Options dialog.
The editor stores a list of files that have been recently opened. This list can be accessed from the 'File > Open
Recent' menu option, from the Workspace (see Using the Workspace), or from the Startup Page (see the Using
the Startup Page). Click a file from the Open Recent menu to load it into memory. The number of files in the list
can be controlled from the General Options dialog.
Another way of opening files is to use the standard Windows Explorer program. When 010 Editor was installed,
enabling the 'Add 010 Editor to explorer right-click menu' toggle in the install program will allow files to be
opened from the Explorer. Right click on a file and select the '010 Editor' option. Another method of opening files
is to drag-and-drop a file from the Windows Explorer onto a running 010 Editor program. If dragging and
dropping an Intel Hex or Motorola S-Record file, the file will automatically be imported (this functionality can be
turned off using the Importing Options dialog). Files can also be associated with 010 Editor, meaning that doubleclicking a file in the Windows Explorer will open the file in 010 Editor. Intel Hex files or Motorola S-Record files
can be automatically associated with 010 Editor by selecting the 'Associate Intel Hex files with 010 Editor' or
'Associate Motorola S-Records with 010 Editor' toggle in the install program. For more information on Intel Hex or
Motorola S-Record files, see Importing/Exporting Files.
The Workspace also contains a simplified browser that can be used to open files. Files can also be loaded from
the Favorite Files list or the Bookmarked Files list in the Workspace.
Files can be opened when starting 010 Editor from the command line. See Command Line Parameters for more
information.
010 Editor can also be used to edit hard drives and processes. See the Editing Drives or Editing Processes help
topics for more information.

Related Topics:
Command Line Parameters
Directory Options
Editing Drives
Editing Processes
General Options
Importing/Exporting Files
Importing Options
Using the Hex Editor
Using the Startup Page
Using the Text Editor
Using the Workspace
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Using File Tabs

Each file, process, or drive that is loaded in 010 Editor is placed into a File Tab as shown above. A collection of
File Tabs in a single line is referred to as a Tab Group. By default all regular files that are loaded are placed into a
single Tab Group in the main interface but all Scripts and Templates are loaded into a Floating Tab Group (see
the Floating Tab Group section below).
The currently active File Tab will be displayed as bold and all file operations (save, close, find, select all, etc.) will
be applied to that file. Each File Tab displays a shortened version of the full file name but the file name can be
viewed in a hint popup by placing the mouse cursor over top of the Tab (the file name of the active file can also
be viewed in the application title bar). Clicking on a File Tab sets that file as the active file in the application.
To close a File Tab either click the 'x' button on the Tab or click the middle mouse button on the Tab (some
computer mice have a scroll wheel and a middle click can be performed by pressing down on the scroll wheel).
Alternately, File Tabs can be closed using the 'File > Close' functionality. A popup menu can be accessed by rightclicking on the Tab. From the popup menu, click the 'Close' menu option to close the currently selected file or the
'Close All Except This' option to close all files except the file that is currently selected. Clicking the 'Copy File Path'
option will place the full directory path of the current file onto the clipboard. See the File Menu for an explanation
of other options on the popup menu.

If too many File Tabs are loaded to be viewed all at once, the File Tabs can be viewed by clicking on the left and
right arrows (shown above) to scroll through the tabs. Clicking the down arrow displays a list of all File Tabs in
that Tab Group.
File Tabs may be rearranged by clicking and dragging the tabs to new positions. An arrow will appear to indicate
where a Tab will be positioned when dropped. File Tabs may even be dropped onto other Tab Groups (see Using
Multiple Tab Groups below).

Using Multiple Tab Groups
By default all regular files are loaded into a single Tab Group in the main interface and all Scripts and Templates
are loaded into a special Floating Tab Group (see the Floating Tab Group section below). The main interface can
be split into multiple Tab Groups oriented either horizontally or vertically. When multiple files are loaded, multiple
horizontal Tab Groups can be created by right-clicking on a File Tab and selecting Move to New Horizontal Tab
Group. Another way to generate horizontal Tab Groups is to drag a File Tab towards the bottom of the Window
until the blue selection area indicates the lower half of the dialog (see the dialog below).
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Similarly, multiple vertical Tab Groups can be generated by right-clicking on a Tab and selecting Move to New
Vertical Tab Group or by dragging a File Tab to the right until the blue selection area indicates the right side of
the window.
Once multiple Tab Groups have been created simply drag a File Tab between the groups. Clicking the 'Window >
Merge All Tab Groups' will place all tabs into a single Tab Group again. See the Window Menu for more
information.

Floating Tab Group

The Floating Tab Group is just a floating window that contains a set of File Tabs and can be displayed by clicking
the 'View > Floating Tab Group'. Any file can be moved to the Floating Tab Group by dragging the File Tab to the
window until a blue selection area appears and then dropping the Tab. Note that the active file for the application
will be marked as bold and only one file at a time can be the active file. Hide the Floating Tab Group easily by
pressing the Esc key (the Esc key is also used to hide the Output window). When all tabs in the Floating Tag
Group are closed, the Floating Tab Group will automatically be hidden but this behavior can be turned off using
the Editor Options dialog.
By default all Scripts and Templates that are loaded are placed into this Tab Group but they can be set to load
into the main interface by using the Compiling Options. Usually the Floating Tab Group is displayed on top of the
application but it can be docked by right-clicking on the window and enabling the Allow Docking menu option.

Related Topics:
Editor Options
File Menu
Opening Files
Window Menu
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Using the Text Editor

The Text Editor Window (shown above) is the main method of viewing and editing text files in 010 Editor. Each
text file that is loaded is displayed in a File Tab that shows a shortened form of the file name (the full file name
can be viewed in the application title bar or in a hint popup displayed by placing the mouse cursor over the File
Tab). The main area of the text editor shows the file interpreted as a series of characters (if a byte cannot be
shown as a character a square symbol or cross will be displayed). On the left side of the Text Editor Window is a
list of addresses and each address indicates the line number or the file position of the first byte on the line. A
Ruler, located above the main area, displays the column offset from the start of each line and a small arrow
indicates the current cursor position. The File Bar, located above the Ruler, is used to choose how data is
displayed in the editor using the Edit As section (see Working with File Interfaces). Also, the File Bar can be used
to execute Scripts or Templates (see Running Templates and Scripts).

The Cursor
A cursor is shown in the Text Editor Window as a vertical, flashing line and this cursor indicates the current
position for inserting, deleting, or editing data. Left-click with the mouse to move the cursor or use the cursor
keys on your keyboard (see Editor Keys below). When the Text Editor Window is not active, a vertical gray line,
called the shadow cursor, will indicate where the cursor was located. When the editor is in Overwrite mode (see
Editing Data below) the cursor will be displayed as a thick vertical line and when the editor is in Insert mode the
cursor will be displayed as a thin vertical line.

Editing Data
To edit data in the editor, position the cursor over the character to edit and type on the keyboard. The result of
editing depends on whether the editor is in Insert or Overwrite mode. In Overwrite mode (OVR appears in the
Status Bar) the characters typed will replace any existing characters. In Insert mode (INS appears in the Status
Bar) a new character will be inserted into the file. Note that the current Insert/Overwrite mode is stored
separately for text and hex files. The current Insert/Overwrite mode can be changing using the Insert Key (see
Editor Keys below) or by clicking INS/OVR in the status bar. Pressing the Delete key will delete the current
character from the file.
After any edits are made a '*' character will appear in the File Tab to indicate that the file has been modified.
Also, if bytes have been inserted a '*' character will appear by the file size in the Status Bar. Use the 'Edit >
Undo' and 'Edit > Redo' menu options to undo or redo any modifications made to the file. The file can also be
edited using the clipboard (see Using the Clipboard).
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Editor Keys
The following keys can be used while editing a text file:














Left, Right, Up, Down - move the cursor in any direction.
Ctrl+Left, Ctrl+Right - move the cursor to the next or last word
Ctrl+Up, Ctrl+Down - scroll the editor up or down without moving the cursor.
Enter - insert a new line.
Home - move the cursor to the first character on a line.
End - move the cursor to the last character on a line.
Ctrl+Home - move the cursor to the top of the file.
Ctrl+End - move the cursor to the end of the file.
Insert - toggle Insert and Overwrite mode.
Delete - deletes the current character from the file.
Tab - inserts a tab character or indents a blocks of lines if more that one line is selected at a time.
Shift+Tab - if more than one line is selected, this option unindents the selected lines.

Word Wrap

When editing text files that contain long lines, 010 Editor has the ability to automatically wrap lines that extend
beyond the edge of the Text Editor Window (see the above image as an example). This is called Word Wrap and
can be turned on or off by clicking the 'View > Linefeeds > Word Wrap' menu option, clicking the Word Wrap icon
in the Tool Bar, or typing Ctrl+;. When Word Wrap is enabled, the text /wrap will appear in the Edit As section
of the File Bar beside the File Interface name and the Word Wrap icon in the Tool Bar will be highlighted. Each
line in the text editor that is generated because of a word wrap will have a '-' mark displayed in the Address
column on the left side of the editor. As data is edited, the word wraps will automatically be updated.
A number of options exist to control how Word Wrap is performed. 010 Editor can automatically turn on Word
Wrap when a file is opened that contains long lines. To turn this ability on or off see the 'View > Linefeeds >
Initial Wrap State' menu option. By default wrapping is performed at the edge of the Text Editor Window;
however, wrapping can be performed at a specific column using the 'View > Linefeeds > Wrap Width' menu
option. Usually wrapping keeps whole words together but to allow wrapping on any letter within a word use the
'View > Linefeeds > Wrap Method' menu option. See the View Menu for more information.
When editing a word wrapped line, pressing the Home key once will go to the beginning of the line generated by
wrapping (marked with '-' in the Address column) and pressing Home again will go the beginning of the whole
line. Similarly pressing the End key once will go the end of the current generated line and pressing End again will
go the very end of the line. Even when Word Wrap is turned off, 010 Editor will wrap any lines that are longer
than the maximum allowed line length. This maximum line length can be controlled in the Text Editor Options
dialog.
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Right-Click Menu
Right-clicking on the Text Editor Window displays a popup-menu of options. This menu is a sub-set of the Edit
Menu and see the Edit Menu help topic for more information on each menu option. The Right-Click menu also
provides a way of setting the current selection and see Selecting Bytes for more information. To customize the
Right-Click Menu click the Customize... menu item at the bottom of the Right-Click Menu (see the Menu Options
dialog for more information).

Splitting the Text Editor Window

The Text Editor Window may be split into two different areas by clicking the small button above the horizontal
scroll bar (see the diagram above) and dragging the mouse down. Once the mouse is released the window will be
split into a top and a bottom region (see the diagram below). Having two different regions is useful for editing
two different areas of the file at the same time. The areas may be resized by moving the mouse over the line
between the areas and dragging the line up or down (the mouse cursor will appear as an up-down arrow).
Double-click on the dividing line to return to having a single area. Alternately, the Text Editor Window may be
split or un-split using the 'Window > Split Window' menu option.

Column Mode
Text data can be selected by column using the special Column Mode. A quick way to create a column selection is
to hold down the Ctrl key while dragging the mouse. See the separate Column Mode help topic for more
information.

Byte-Order Marks
A Byte-Order Mark or BOM is a set of special bytes at the beginning of a text file that indicate the file contains
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data in a certain character set. 010 Editor supports the following byte-order marks:





0xFF 0xFE - Unicode Little-Endian
0xFE 0xFF - Unicode Big-Endian
0xEF 0xBB 0xBF - UTF-8

If a text file starts with any of these BOMs 010 Editor will automatically set the correct File Interface when the file
is loaded. When a BOM is present in a file, '+B' will be displayed in the Status Bar and BOMs can be added or
removed using the Converting Files dialog. To automatically add byte-order marks to files when they are created,
see the File Interface Options dialog.

Reloading Changes

010 Editor checks if a file that is open in the editor has been changed by an external process. If a change is
detected the above dialog is displayed. Click Reload to load the changes from the external process and note that
any current edits on the file will be lost. Click Ignore to continue editing the file as usual without loading any
external changes. After either of these buttons is clicked and 010 Editor detects new changes to the file, the
above dialog will be displayed again. Click Always Reload to automatically reload any changes that are detected
and 010 Editor checks for new changes every few seconds (this option is useful for editing a log file that is being
written to disk from another process). Click Always Ignore to ignore any future changes to this file until the file is
closed and opened again. Note that the notice about possible corrupted data only applies if a large block of data
has been inserted into another file and then that block was modified by an external process (see Introduction to
the Data Engine for more information).

Editor Options
The Editor Options and Text Editor Options dialogs can be used to control a number of options for the Text Editor
Window.

Related Topics:
Converting Files
Edit Menu
Editor Options
File Interface Options
Introduction to the Data Engine
Menu Options
Status Bar
Text Editor Options
Running Templates and Scripts
Selecting Bytes
Status Bar
Using Column Mode
Using the Clipboard
View Menu
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
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Using the Hex Editor

The Hex Editor Window (shown above) is the main method of viewing and editing binary files in 010 Editor (to
edit text files see Using the Text Editor). A Hex Editor Window is displayed for each binary file that is loaded in
the editor. Each file is displayed in a File Tab that displays a shortened form of the file name but the full file name
can be viewed in the application title bar or in a hint popup displayed by placing the mouse cursor over the File
Tab. The Hex Editor Window is divided into a left and a right area. By default, the left area displays the bytes of
the file as a series of hexadecimal bytes and the right area displays the bytes as a series of characters (if a byte
cannot be shown as a character a '.' will be displayed). To the left of the Hex Editor Window is a list of addresses.
Each address indicates the file position of the first byte on the line. At the top of the window a Ruler indicates the
byte offsets from the address on that line. The editor can be changed to display data in a number of different
formats and to modify how the Hex Editor Window displays data see Working with File Interfaces.

The Cursor
A cursor is displayed in the Hex Editor Window as a vertical, flashing line. The cursor indicates the current
position for inserting, deleting, or editing data. Move the cursor with the mouse by clicking anywhere in the main
display with the left mouse button. Alternately, the cursor keys can be used to move the cursor (see Editor Keys
below). When the cursor is in the left or right areas, the byte the cursor is currently over will be highlighted gray
in the other area. Switch between areas by pressing the Tab key. When the Hex Editor Window is not focused, a
vertical gray line, called the shadow cursor, will indicate where the cursor was located. When the editor is in
Overwrite mode (see Editing Data below) the cursor will be displayed as a thick vertical line and when the editor
is in Insert mode the cursor will be displayed as a thin vertical line.

Editing Data
To edit data in the editor, position the cursor over the byte to edit. When the cursor is in the left area
(hexadecimal data) enter a valid hexadecimal digit (0 to 9 or A to F) to edit the data. When the cursor is in the
right area (character data) enter any character to edit the data.
The result of editing depends on whether the editor is in Insert or Overwrite mode. In Overwrite mode (OVR
appears in the Status Bar) the characters typed will replace any existing characters. In Insert mode (INS appears
in the Status Bar) a new byte will be inserted in the file (NOTE: when editing hexadecimal data, a byte is inserted
only when the cursor is over the first digit in the hexadecimal byte). The current Insert/Overwrite mode is stored
separately for text and hex files and the current mode can be changing using the Insert Key (see Editor Keys
below) or by clicking INS/OVR in the status bar. Pressing the Delete key will delete the current byte from the file.
When any edits are made to the file, a '*' character will appear in the title bar to indicate that the file has been
modified. If bytes have been inserted, a '*' character will appear by the file size in the Status Bar. The 'Edit >
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Undo' and 'Edit > Redo' menu options can be used to undo or redo any changes made to the file. The file can also
be edited using the clipboard (see Using the Clipboard for more information).

Editor Keys
The following keys are available when editing the file:














Left, Right, Up, Down - move the cursor in any direction.
Ctrl+Left, Ctrl+Right - move the cursor to the next or last group of bytes.
Ctrl+Up, Ctrl+Down - scroll the editor up or down without moving the cursor.
Home - move the cursor to the first byte on a line.
End - move the cursor to the last byte on a line.
Ctrl+Home - move the cursor to the first byte in the file.
Ctrl+End - move the cursor to the end of the file.
Insert - toggle Insert and Overwrite mode.
Delete - deletes the current byte from the file.
Tab - switches between the left and right editing areas.
Alt+Up - moves to the previous sector in a hard drive.
Alt+Down - moves to the next sector in a hard drive.

Right-Click Menu
A menu of editing options can be accessed by right-clicking on the Hex Editor Window. This menu is sub-set of
the Edit Menu (see the Edit Menu for an explanation of each menu option). The Right-Click menu can also be
used to set the current selection and see Selecting Bytes for more information. The Right-Click Menu can be
customized by right-clicking the editor and selecting the Customize... menu option (see the Menu Options dialog
for more information).

Swapping Bytes

010 Editor has the ability to visually swap bytes of data in the Hex Editor without modifying the underlying data
(for example, compare the image above with the image at the top of this page). Data can be swapped in groups
of 2 bytes, 4 bytes, 8 bytes, etc. and the number of bytes is controlled using the 'View > Group By' menu. To
swap data, choose a byte grouping in the 'View > Group By' other than Byte and then enable the 'View > Group
By > Swap Little-Endian Bytes by Group' option. Note that swapping is only performed when the current file is in
Little Endian mode and when swapping is enabled 'LIT<>' will appear in the status bar. When bytes are swapped
in the Hex Editor, the selection behaves differently because 010 Editor only supports selecting a contiguous range
of bytes. Therefore, the selection may sometimes appear disjointed because of which bytes are selected. Hold
down the Ctrl key when selecting using the keyboard to ensure that a full group is selected. To swap the bytes in
the actual data file, see the Hex Operations dialog.
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Splitting the Hex Editor Window

The Hex Editor Window can be split into two different regions by clicking the small button above the horizontal
scroll bar (see the diagram above) and dragging the mouse down. After releasing the mouse, the window will be
split into a top and a bottom area (see the diagram below). This feature is useful if you are editing two different
areas of the file at the same time. Press the Tab or Shift-Tab keys to move the cursor between the different
areas. Move the mouse over the line separating the areas and click and drag the line up or down to resize the
areas (the mouse cursor should change to an up-down arrow). Double-click on the separating line to remove the
separator and return to having just one area. The Hex Editor Window can also be split or un-split by clicking the
'Window > Split Window' menu option.

Template Results
After a Binary Template has been run on the current file, the results will be displayed in the Template Results
panel at the bottom of the Hex Editor Window. This panel is sometimes hidden and can be shown by clicking the
small button below the horizontal scroll bar and dragging upwards. See Working with Template Results for more
information on using the Template Results panel.

Column Mode
Hex data can also be edited using a special Column Mode where columns of bytes can be selected. One way to
create a column selection is to hold down the Ctrl key while dragging the mouse. See the separate Column Mode
help topic for more information.

Reloading Changes
When the editor detects that an open file has been modified by an external process, a dialog is displayed asking
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to reload the file. See the Reloading Changes section of the Text Editor for more information.

Editor Options
See the Editor Options and Hex Editor Options dialogs for a list of options that can be controlled for the Hex
Editor Window.

Related Topics:
Edit Menu
Editor Options
Hex Editor Options
Hex Operations
Introduction to Byte Ordering
Menu Options
Selecting Bytes
Status Bar
Using Column Mode
Using the Clipboard
Using the Text Editor
Working with File Interfaces
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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Working with File Interfaces
A File Interface is an important concept in 010 Editor. Every file that is loaded is assigned a File Interface and this
interface controls how that file is displayed and edited. A File Interface includes the Font, Character Set,
Linefeeds/Line Width, Tabs, Addresses, Group By, Division Lines, Areas, Highlighting, Ruler, Status Bar, and
Endian settings for a file (basically all options listed at the top of the View Menu). The name of the current file's
File Interface is displayed in the Edit As area of the File Bar above each file. A different File Interface can be
applied to the current file by clicking the Edit As area and choosing from the drop-down list or using the 'View >
Edit As' menu.

File Interfaces may be either text-based, where the Text Editor Window is used to edit the file, or hex-based,
where the Hex Editor Window is used to the edit the file. Note that some options are only applicable to one type
of File Interface. The Toggle Hex Interface button in the Tool Bar will be highlighted when the current file is using
a hex-based file interface. Edit the current interface from the View Menu and some, but not all, options can be
edited using the File Interface Options dialog as well. Modifying an option for one file modifies that option for all
files that use that interface. Any changes to the interface are automatically saved when 010 Editor exits so the
interface will appear the same the next time the program loads.
Multiple interfaces can be generated for files and assigned automatically when a file loads. For example, 010
Editor can be configured to always open a file with a certain file extension in Big Endian mode or with the EBCDIC
character set. To create new interfaces use the 'View > Edit As' menu (see the View Menu for more information)
or the File Interface Options dialog (see File Interface Options dialog). The 'View > Edit As' menu contains a list
of all available File Interfaces and a checkmark will be placed beside the currently active interface. For more
options on how File Interfaces are assigned to files see the Editor Options dialog.
The following list indicates all attributes that are stored with the File Interface:










Font - Controls the font type, size, and style that are used in the editor. File Interfaces may use either
the standard Text Editor font, the standard Hex Editor font, or their own custom font.
Character Set - Sets which character set is used to display data in a character area (ASCII,
ASCII+OEM, ASCII+ANSI, EBCDIC, Unicode, UTF-8, Macintosh, or various international character sets).
Linefeeds (text only) - Controls how 010 Editor breaks a text file into a set of lines. Can be used to
turn on Word Wrap for a file and control how the wrapping is performed.
Line Width (hex only) - Specifies how many bytes are displayed on each line of the hex editor. The
width can be set to 4, 8, 12, 16, or 20 bytes per line or any custom value. Also the editor can be set to
automatically determine the maximum number of bytes to display in the window by choosing the Auto
Width option.
Tabs/Whitespace (text only) - When editing text files the Tabs setting controls how far apart the tab
stops are in a file. When a tab character is encountered in a file the next character is displayed at the
next tab stop position. The Tabs option also controls how many characters are inserted when the Tab
key is pressed. 010 Editor can be set to insert spaces instead of tabs (the default) as well.
Addresses - Controls whether the addresses on the left side display the byte number, sector number,
line number or short number. The address can also be displayed in hex format, decimal format, or octal
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format or hidden altogether.
Group By (hex only)- Sets how many bytes are grouped together in the Hex Editor Window (the
default is one).
Division Lines (hex only) - 010 Editor can draw a set of lines on the Hex Editor Window to visualize
how different bytes are grouped together. There are two types of lines that can be drawn: Division Lines
and Sector Lines. By default, a division line is drawn every 4 bytes in a light-gray color and a sector line
is drawn for each sector in a dark-gray color when editing hard drives. See the View Menu for more
information on Division Lines.
Left Area (hex only) - Controls which numeric format is displayed in the left area of the Hex Editor
(Hex, Char, Octal, Binary, or Decimal).
Right Area (hex only) - Controls which numeric format is displayed in the right area of the Hex Editor
(Hex, Char, Octal, Binary, Decimal, or Hide).
Highlighting - Controls which bytes are highlighted in the editor. A number of highlighting schemes
are available by default but more can be generated through the Highlight Options dialog. Different
syntax highlighting rules can also be applied to text data and rules can be customized or created
through the Syntax Options dialog.
Ruler - Specifies whether the Ruler is displayed at the top of the Editor Window and the units of the
Ruler can be controlled as well.
Status Bar - Sets what format to display the current file position, file size, and selection size as seen in
the status bar.
Endian - Controls which byte-ordering is used for the current editor (see Introduction to Byte
Ordering).

See the View Menu for more details about each option.

Related Topics:
Highlight Options
Syntax Options
Using the Hex Editor
Using the Text Editor
Using Tool Bars
View Menu
010 Editor v7.0 Manual - Windows Edition
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Selecting Bytes
Before using any of the clipboard operations such as Cut, Copy, or Paste, a selection must be made on the file
(see Using the Clipboard). Selections can be made with either the mouse, the keyboard, or through the Select
bar.
To select bytes with the mouse, click a file with the left mouse button and drag the mouse over the file. To select
bytes with the keyboard, hold down the Shift key and move the cursor with any of the cursor movement keys
(see Using the Text Editor or Using the Hex Editor for a list of keys). The bytes that are selected will be displayed
with a blue background. The number of bytes selected and the start address of the selection are displayed in the
Status Bar along the bottom of the application.
All bytes in the file can be selected at once using the 'Edit > Select All' menu option. To move the cursor to the
start of the selection, right-click on the Editor Window and choose 'Selection > Goto Selection Start' from the
right-click menu. Similarly, to move the cursor to the end of the selection select 'Selection > Goto Selection End'
from the right-click menu.
Bytes can also be selected with the Select bar (see Selecting a Range). The start address and number of bytes of
the selection can be viewed at any time by opening the Select bar.

Marking a Selection
An alternate way of setting the selection involves right-clicking on a byte in an editor and then choosing either
the 'Selection > Mark Selection Start' or 'Selection > Mark Selection End' menu options from the right-click
menu. When Mark Selection Start or Mark Selection End is clicked while no selection has been made, 010 Editor
will remember the selection mark for the current file (note that there is no visual indication where the selection
marks are). If both the start and end of the selection have been marked, 010 Editor will select those bytes. If a
selection is currently active and then either Mark Selection Start or Mark Selection End is clicked, the selection
will be expanded or contracted so that the start or end lies at the correct position. This is a useful way to either
enlarge or shrink a selection on a file.

Related Topics:
Selecting a Range
Status Bar
Using the Clipboard
Using the Hex Editor
Using the Text Editor
010 Editor v7.0 Manual - Windows Edition
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Using the Clipboard
The clipboard is a temporary scratch pad that can be used to store a block of bytes. The clipboard also makes
possible moving data between applications. Most clipboard operations require that a set of bytes be selected in a
file (see Selecting Bytes). The following clipboard operations are supported:














Copy - Accessed from the 'Edit > Copy' menu option, this operation copies the currently selected bytes
onto the clipboard. This operation does not modify the file. The keyboard shortcuts Ctrl+C and Ctrl+Ins
can also be used to copy data.
Cut - The 'Edit > Cut' menu option copies the selected bytes onto the clipboard and then deletes the
bytes from the file. The keyboard shortcuts Ctrl+X and Shift+Del can also be used to cut data.
Delete - Clicking the 'Edit > Delete' menu option will delete the currently selected bytes from the file.
The data on the clipboard will not be modified.
Paste - The 'Edit > Paste' menu option has two possible effects: When editing text data or when in
Insert mode (INS will appear in the Status Bar), the bytes on the clipboard are inserted into the file at
the current cursor position. When editing hex data in Overwrite mode (OVR will appear in the Status
Bar), the bytes on the clipboard are written over the bytes in the file, starting at the cursor position. If a
selection is made when a Paste operation is performed, the selection will first be deleted from the file
and then the bytes will be inserted. The Insert key can be used to toggle between Insert and Overwrite
mode. Note that the functionality of the Paste command can be changed in the Hex Editor Options
dialog. The keyboard shortcuts Ctrl+V and Shift+Ins can also be used to paste data.
Paste Special - Some applications copy data to the clipboard in a number of different formats. The
'Edit > Paste Special' menu option is similar to the Paste menu option except that the format to paste
can be chosen explicitly. See Using Paste Special for more information.
Copy as Hex Text - Click the 'Edit > Copy As > Copy as Hex Text' menu option to convert the selected
bytes into text characters and copy the result onto the clipboard. For example, copying the bytes 0x2F
and 0xB7 as text would result in the string "2FB7" being placed on the clipboard. Use this option to
transfer binary data into a text editor or to search for a set of hex bytes in the Find tool.
Copy As (export_type) - This set of options provides a quick way to export data to any of the
supported export formats (see Importing/Exporting Files) and then copying the exported data to the
clipboard.
Paste from Hex Text - The 'Edit > Paste From > Paste from Hex Text' command is similar to the Paste
command, except that the data on the clipboard is automatically converted from hex characters to
binary bytes before pasting. For example, if the four characters "17D4" were copied onto the clipboard,
then the two binary bytes 0x17 and 0xD4 would be pasted into the file. Note that any characters that
are not valid hexadecimal digits will be ignored in the conversion. Use this option to transfer hex bytes
from a text editor into 010 Editor.
Paste From (import_type) - This set of commands provides a method of importing data that is on the
clipboard in any of the supported import formats (see Importing/Exporting Files for a list of all import
types). The data is imported and then inserted at the current cursor position.

Multiple Clipboards
010 Editor contains a total of 10 clipboards: the standard Windows clipboard plus 9 custom clipboards. Only one
clipboard is active at a time and all Cut, Copy, and Paste commands will operate on that clipboard. The active
clipboard will be checked in the 'Edit > Clipboard' menu. Select another clipboard by clicking an item in the
Clipboard menu, or use Ctrl+0 up to Ctrl+9. The active clipboard is also displayed in the Status Bar (see Status
Bar for more information).
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Clearing Clipboards
Large blocks of memory can easily be copied to or from the clipboard (see Introduction to the Data Engine). Use
the 'Edit > Clipboard > Clear Clipboards' menu option to remove all data from the 10 clipboards. This command
is useful to prevent large blocks of data from being copied into memory when a file is saved or closed.

Linux Selection Clipboard
Unix systems have the concept of a selection clipboard where every time a selection is made in any program, the
contents are automatically copied to a special clipboard. 010 Editor supports this clipboard on Linux systems and
data can be pasted at the current mouse position by clicking the middle mouse button. Note that the position of
the cursor does not change after data is pasted using this method. Any data selected in 010 Editor is available to
be pasted in other programs using the middle-click technique. Note that the selection clipboard is independent of
the regular clipboard used for copy and paste above.

Exiting with Large Blocks
Note that when the program exits, a large block of memory copied to the Windows clipboard is deleted unless the
Leave Large Blocks on Clipboard on Exit toggle is set in the General Options.

Related Topics:
Edit Menu
Editor Options
General Options
Importing/Exporting Files
Introduction to the Data Engine
Selecting Bytes
Status Bar
Using Find
Using Paste Special
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Status Bar

The Status Bar, located along the bottom of the application, contains useful information about the current file and
the current status of the editor. The Status Bar is divided up into a number of panels as listed below:
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Message Area (1) - Displays information about the last completed operation. When an important
message such as an error or warning is displayed in this field, the message will be displayed with an
orange background.
File Position / Selection Start (2) - When no bytes are selected, this panel shows the current
address of the cursor in the file. When bytes are selected, this panel displays 'Start:' followed by the
starting address of the selection. The address can display the current byte number, sector number, line
number or short number and the address can be displayed in hex format, decimal format, or octal
format. Set the address format using the 'View > Status Bar > File Position Units' menu option or the
popup menu accessed by right-clicking the Status Bar. Left-click on this panel to bring up the Goto bar.
Current Byte / Selection Size (3) - When no bytes are selected, this panel displays the current value
of the byte the cursor is over. The value of the byte is displayed in hex, decimal, and binary formats.
The byte value is displayed as an Unsigned Byte but to convert to other formats see the Inspector.
When bytes are selected in the file, this panel displays 'Sel:' followed by the size of the current
selection. The display format used for the selection size can be controlled using the 'View > Status Bar
> Selection Size Units' menu option or by right-clicking on the Status Bar. Note that when displaying
the selection size as a number of lines and less than one line is selected, the number of selected bytes
will be displayed instead.
File Size (4) - Shows the size of the file being edited. The size can be displayed in number of bytes,
sectors, lines or shorts and the size can be shown in hex format, decimal format, or octal format. To
control the displayed format, see the 'View > Status Bar > File Size Units' menu option or the popup
menu accessed by right-clicking the Status Bar. Note that a '*' will appear beside the file size if the size
has been changed since the file was opened. Left-click on this panel to open the Set File Size dialog.
Character Set and Linefeeds (5) - Shows which character set is being used to display the current
file. The character set depends upon the current File Interface (see Working with File Interfaces) and
can be controlled through the 'View > Character Set' menu option. The following character sets are
supported:
 ASCII - ASCII Character Set
 ANSI - ASCII+ANSI Character Set
 OEM - ASCII+OEM Character Set
 EBC - EBCDIC Character Set
 UNI - Unicode Character Set
 UTF8 - UTF-8 Character Set
 MAC - Macintosh Character Set
 ARA - Arabic Character Set
 BAL - Baltic Character Set
 CH-S - Chinese (Simplified) Character Set
 CH-T - Chinese (Traditional) Character Set
 CYR - Cyrillic Character Set
 EEUR - Eastern Europe Character Set
 GRE - Greek Character Set
 HEB - Hebrew Character Set
 JAP - Japanese Character Set
 KO-J - Korean (Johab) Character Set
 KO-W - Korean (Wansung) Character Set
 THAI - Thai Character Set
 TURK - Turkish Character Set
 VIET - Vietnamese Character Set
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If the current file is a text file, the current type of linefeeds is displayed in brackets after the character
set name. The following linefeed types are supported:









DOS - DOS Linefeeds (CR+LF - 0x0D0A)
UNIX - Unix Linefeeds (LF - 0x0A)
Mac - Macintosh Linefeeds (CR - 0x0D)
NEL - Next Line (0x15 in EBCDIC or 0x0085 in Unicode)
FF - Form Feed (0x000C in Unicode)
LS - Line Separator (0x2028 in Unicode)
PS - Paragraph Separator (0x2029 in Unicode)

If the current file contains a Byte-Order Mark (BOM), this panel will contain '+B' after the linefeed type.
Click the Character Set panel in the Status Bar to open the Convert dialog to translate the current file to
a different character set or linefeed type.









Tabs (6) - If the current file is being edited as a text file, this panel of the Status Bar lists the number
of characters per tab stop in the file. Clicking this panel brings up a popup-menu which can be used to
control the tab settings (this menu can also be accessed by clicking the 'View > Tabs/Whitespace' menu
option). See the View Menu for more information on other tab settings.
Endian (7) - Indicates which endian is used to interpret the current file. LIT means little endian (e.g.
Intel machines) and BIG means big endian (e.g. Motorola machines). See Introduction to Byte Ordering
for more information. 010 Editor can visually swap bytes in the Hex Editor Window without modifying
the underlying data. This swapping only occurs in little endian mode and when swapping is enabled, this
field will display LIT<> (see Swapping Bytes for more information).
Clipboard (8) - A total of 10 clipboards are available for copying and pasting data. This field indicates
which clipboard is currently selected. A 'W' means the default Windows clipboard is active and the
numbers '1' through '9' indicate that a user clipboard is active. See Using the Clipboard for more
information.
Insert Mode (9) - Displays whether the editor is in Insert (INS), or Overwrite (OVR) mode. Press the
Insert key or click this status bar area to toggle between the two states. This mode is used when editing
data in the editor, or when pasting data from the clipboard (see Using the Text Editor, Using the Hex
Editor and Using the Clipboard for more information). The cursor in the Editor Window will display as a
thick line when in Overwrite mode, or a thin line when in Insert mode.

For long operations, a progress bar will usually be displayed in the Status Bar. In most cases, pressing the Esc
key will cancel the operation.

Related Topics:
Setting the File Size
Using Goto
Using the Clipboard
Using the Hex Editor
Using the Text Editor
View Menu
Working with File Interfaces
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Saving Files
The last step in editing files is to save any modifications to disk. 010 Editor contains a number of different options
for saving files:









Save - Save a file using the 'File > Save' menu option, or by pressing Ctrl+S. If an existing file was
opened for editing, the changes will be written back to the original file. If a new file was created using
'File > New' or 'File > Import Hex...' a file dialog box will be shown to select a file name for the file.
Save As - Saves the current file to a new file name. Click the 'File > Save As...' menu option or press
Ctrl+Shift+S to access this command. A new file name must be chosen using the file dialog box that is
displayed. The name of the file in the editor will change to the new file name (the name will change in
the Title Bar of the application, the File Tab, and anywhere else the file is referenced). To control which
directory is used when the Save As dialog is shown see the Directory Options dialog.
Save a Copy - Saves a copy of the current file to a new file. The 'File > Save a Copy...' menu option
can be used to access this command. Select a file name in the file dialog box that is displayed. This
command is useful for creating a backup copy of a file that is being edited. The name of the file in the
editor will not be changed.
Save Selection - If a selection has been made on the current file (see Selecting Bytes), click the 'File >
Save Selection' menu option to save just the selected bytes to a file. Select a new file to save with the
file dialog box that is displayed. The file name of the current file will not be changed.
Save All - Click the 'File > Save All' menu option to save all modified files to the disk. Any parameters
specified with the 'Tools > Options...' dialog box will also be saved to disk.

Related Topics:
Directory Options
Opening Files
Selecting Bytes
Using the Hex Editor
Using the Text Editor
010 Editor v7.0 Manual - Windows Edition
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Using the Startup Page
The Startup page is shown by default when 010 Editor is opened or when all files are closed, but can also be
displayed by clicking on the 'View > Other Windows > Startup Page' menu option. This page provides an easy
way to open recent files, view application news and updates, and view tips for the application.

The following list describes each of the four areas of the Startup page:








Recent Files - Displays a list of all files, drives, and processes that have been recently opened in 010
Editor. Click on an item in the list to load that file. If the file is already opened in the interface the tab
containing that file will be activated. To remove a file from the Recent Files list right-click on the file and
select the Remove from Recent Files menu option, or to remove all files from the list right-click on a file
and select Clear Recent Files List. Right-clicking on a file a selecting Copy Path from the popup menu
will copy the full file name including path to the clipboard.
News and Articles - This section lists any application news or updates that the application downloads
periodically from the SweetScape Software website. To control how often news and updates are
downloaded see the General Options dialog. Clicking on a news item will either load a webpage, help
topic, or other window in the application.
Repository - Lists the recent updates to the Repository. See the Updating the Repository help topic for
more information about when the Repository is updated. Double-clicking on an item in the list displays
more information in the Repository Dialog.
Tips - Displays some hints and tricks to better using 010 Editor. A new tip is shown every time the
application is opened or the tips can be viewed by clicking the left or right arrow buttons.

Use the Startup Action drop-down list at the bottom of the Startup page to control what the application displays
when opened. The default value is Show this page and restore open files meaning that all open files are reloaded
from the last time 010 Editor was run but the Startup page is focused. Choose Show this page to just display the
Startup page and not load files, or choose Restore all open files to reload all files and focus the last file that was
being edited. Choose Create new file to automatically create a new file using 'File > New' (the Startup page is not
displayed in this case), or choose Display empty interface to not load any files or pages on startup. The Startup
Action can also be controlled using the General Options dialog.
The Options button can be used to control which of the above four areas are displayed. Click the Options button
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and check or uncheck one of the entries to show or hide that section of the page. Click the 'x' button in the
Startup tab to close the tab or press Ctrl+W. Also in the Options menu is the toggle Show Startup Page when All
Files are Closed. When this toggle is enabled and all file tabs are closed, the Startup Page will be shown. If the
toggle is disabled a blank interface will be shown and right-click on the interface and choose 'Startup Page' to
display the Startup Page. To adjust the background color or text color of the Startup page choose either Change
Background Color or Change Text Color from the Options menu. To reset the background color or text color to
the original color choose Reset Background Color or Reset Text Color.
The current license or trial status is displayed in the bottom-right corner of this page. Clicking on the license text
displays the Register Dialog.

Related Topics:
General Options
How to Buy 010 Editor
Introduction to the Repository
Opening Files
Updating the Repository
Using the Repository Dialog
010 Editor v7.0 Manual - Windows Edition
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Editing Drives
010 Editor can edit the individual bytes of hard drives, floppy drives, memory keys, flash drives, CD-ROMs, etc.
To open a drive for editing, click the 'File > Open Drive...' menu option, or press Ctrl+D to display the Open Drive
dialog box. Drives can also be opened from the Command Line.
Two main types of drives can be edited in 010 Editor: Logical Drives and Physical Drives. A Logical Drive is a
device or a partition that has been assigned a drive letter such as 'C:' or 'A:'. A Physical Drive corresponds to an
actual device inside the computer such as a hard drive or memory key. Physical Drives may be divided into
multiple Logical Drives using partitions.
When editing drives on Windows Vista and all later versions of Windows (7, 8, etc.), Windows requires that all file
handles on the drive be closed before changes can be written to the drive. If writing to a Physical Drive, all file
handles on the Logical Drives within the Physical Drive must first be closed (a list of Logical Drives within each
Physical Drive is displayed in the Open Drive dialog below). When a drive is first opened, 010 Editor displays a
warning if any file handles on the drive are open and the drive is marked as read only. To enable editing of the
drive close all open files on the drive, right-click on the Editor Window and click 'Read Only' from the pop-up
menu. Note that the Windows boot drive (e.g. C:) cannot be modified unless the OS is booted from a different
drive.
WARNING: Incorrectly editing a hard drive can cause severe loss of data. SweetScape Software will not be held
liable for data loss as the result of incorrect editing. Edit your drives at your own risk.

Open Drive Dialog

In the Open Drive dialog box a list of all Logical Drives is displayed at the top of the dialog and a list of Physical
Drives is displayed at the bottom of the dialog. If the drive size can be calculated, the size will be displayed to the
right of each drive name. To the right of each Physical Drive name is a list of Logical Drives that are contained
within that drive. Select a logical or physical drive and click the Open button to open the drive as a file in the
editor. Double-clicking on a drive name in the list also opens the drive. Click the Cancel button to dismiss the
dialog without opening a drive. If the Open as read-only toggle is enabled in the upper-right corner of the dialog,
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the drive will be opened as a read-only file.

Editing Drives
Once a drive is opened in 010 Editor, it can be edited can like any other file (see Using the Hex Editor). Bytes can
be modified and blocks of data can be copied or pasted using the clipboard. The only limitation is because the
size of drives cannot be modified, bytes cannot be inserted or deleted from a drive. Once modifications have been
made to the drive, click the 'File > Save' menu option to commit the changes to disk. On Windows Vista and all
later Windows Versions (7, 8, etc.) all files on the disk must be closed before changes can be written to the drive.
See the introduction to this help topic for more information.

Making Disk Images
Once a drive has been loaded in 010 Editor, use the 'File > Save As...' or 'File > Save a Copy...' menu option to
save a byte-by-byte copy of the drive to a file (called a disk image). A portion of the drive can be saved to disk
by selecting the desired bytes and using the 'File > Save Selection...' menu option.

Viewing Drive Properties
To view the properties of the current logical or physical drive, click the 'Edit > Properties...' menu option. See the
File Properties help topic for more information. The properties includes information about sectors, clusters,
tracks, and cylinders of the drive.

Sectors, Clusters, Tracks, and Cylinders
A typical hard drive is an electromagnetic device made up of a number of disk-shaped pieces called platters that
are stacked on top of each other (see the figure below). Each platter can store data on both sides and has a
read/write head that transfers data from the computer to the disk. To find information on these platters, drives
are divided into a number of sections called Sectors, Clusters, Tracks, and Cylinders.

The following lists each type of section:
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Sector - A sector is the smallest unit of data that can be read or written from a disk. Typically, sectors
are 512 bytes in size, but other sizes including 1024 and 2048 are common.
Cluster - A cluster is the smallest unit of data that a file system can allocate for a file. Each cluster has
a fixed size that is always a multiple of the sector size. Older file systems (FAT16) often allocated large
cluster sizes of 32K or more, meaning that even small files of 1K would take up 32K of disk space. More
modern file systems (FAT32 and NTFS) allow smaller cluster sizes. A file is stored optimally on disk as a
series of contiguous clusters (clusters that are in order on disk). However, a file can be split into
multiple clusters on different areas of the disk and this is called fragmentation.
Track - A track is a concentric ring of sectors on a platter. A read/write head can read all the data from
a certain track by moving to a position and then rotating the platter.
Cylinder - A cylinder is a group of tracks in all the platters that are on top of each other.

By default, 010 Editor displays Sector Lines in the Hex Editor Window that indicate where sectors start and stop
on the drive. For more information, see the View Menu help topic. To jump to the previous or next sector, use the
Alt+Up or Alt+Down keys respectively.

Related Topics:
Command Line Parameters
File Properties
Using the Hex Editor
View Menu
010 Editor v7.0 Manual - Windows Edition
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Editing Processes
010 Editor can open any currently running process as a file in the interface. The individual bytes of memory used
by process can then be edited and saved back to the process. To open a process, use the Open Process dialog
box which can be accessed by clicking the 'File > Open Process...' menu option, or pressing Ctrl+Shift+O.
Processes can also be opened using the Command Line.
Note: Incorrectly editing processes can lead to programs performing incorrectly or system crashes.

Open Process Dialog

Choose which process to open in the Process List on the left side of the dialog. Each process has a name and an
ID number associated with it. The process list can be sorted by clicking on the Process Name or Process ID
headings.
When a process is selected, a number of heaps and modules are displayed for the process in the tabbed section
of the dialog. A heap is simply a block of memory that has been assigned to a process. A list of all heaps for the
process can be viewed by clicking on the Heaps tab in the center of the dialog. Each heap has a position in
memory, indicated by the Address and Size columns. As well, each heap has a number of Flags, a State and a
Type. The Flags indicate the access restrictions for the heap and may include Read, Write, WriteCopy, Execute,
No access, or Unallocated. The State column may be Free (unallocated), Committed (allocated), or Reserved
(allocated but not available). The Type column may be Image, Mapped, or Private.
A module is a block of memory that is associated with an executable, DLL, or other dynamically linked library.
Each module may have a number of heaps contained within it. Click the Modules tab to view a list of all modules
for the current process. Each module has a starting Address, a Size, and a Name which is usually the name of the
executable or DLL associated with the module.
On the right-hand side of the display is a graph of all readable bytes of the process. Areas of the process that can
be modified are drawn in green, and read-only areas are drawn in gray. If heaps or modules are selected in the
heaps or modules list, those areas will be highlighted in the graph. A gray vertical line just to the left of the graph
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indicates which bytes will be opened in the editor when the Open button is clicked. Which bytes are opened is
determined by the toggles in the Options box.
The Open Options box allows control of how the process is opened and is accessed by clicking the Options button.
If the Open only Writeable Bytes toggle is enabled, then only the areas of the process that can be modified are
opened (note that a vertical gray line just to the left of the process graph indicates which bytes will be opened).
Unclick the toggle to open all readable bytes. Note that if you modify a read-only portion of the file and try to
save the changes, you will receive an error. If the Open Custom Range toggle is enabled, a custom memory start
address and size to open can be specified in the Start and Size combo boxes. If the tabs in the middle of the
dialog are displaying heaps, then the last option will indicate Open Selected Heaps. When this option is enabled,
only those heaps that are selected in the table will be opened for editing. Likewise, if the Modules tab is
displayed, the last option will indicate Open Selected Modules and only the selected modules will be opened for
editing. Enable the Open as Read Only toggle to open the file in read-only mode.
When a process is opened, each heap is mapped to an area of a file. See the Output Window section below for
more information.

Editing Processes
Once a process has been opened in the editor, it can be edited just like any other file (see Using the Hex Editor).
Since the size of a process is fixed, bytes cannot be inserted or deleted from the process. Once modifications
have been made to the process, click the 'File > Save' menu option to write the changes back to the process. If
the process has changed, or you are attempting to modify a read-only area, you may receive an error when
saving data.

Making Process Images
After a process is loaded in 010 Editor, a byte-by-byte copy of the process can be saved to disk using the 'File >
Save As...' or 'File > Save a Copy...' menu options (this is called a process image). Save a portion of the process
to disk by selecting bytes in the editor and clicking the 'File > Save Selection...' menu option.

Viewing Process Properties
Various properties of the current process can be viewed via the Properties dialog. Click the 'Edit > Properties...'
menu option to view the properties (see File Properties for more information).

Output Window
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When a process is opened in the editor, clicking on the Process tab of the Output Window displays a list of all
heaps that are currently open for the process. If the Output Window is hidden, it can be shown using the 'View >
Output' menu option. Each heap of the process will be mapped to an area of the file. The Heap Address and Heap
Size columns list the address of the heap in actual memory. The Local Start column lists where the heap is
mapped to in the file. Right-clicking on any column allows setting the display format via the Column Display
Format menu option. The Flags, State, Type, and Module columns are identical to the columns in the Open
Process dialog as discussed above.
A graph of the process is displayed on the left side of the Output Window. This graph is similar to the graph of
the Open Process dialog, but only displays those heaps that were opened. The total number of opened heaps is
displayed below the graph. Selecting a heap from the list highlights the heap in the graph and also selects the
bytes for the heap in the Hex Editor Window.

Related Topics:
Command Line Parameters
File Properties
Using the Hex Editor
010 Editor v7.0 Manual - Windows Edition
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Using the Workspace
The Workspace is the main control center for managing files in 010 Editor. Use the Workspace to open or close
files, as well as browse for files on disk. Show or hide the Workspace by clicking the 'View > Workspace' menu
option. The following sections describe the two tabs of the workspace, Files and Explorer.

Files

The Files tab is used to open files or manage files in the editor. Four lists of files are displayed with a folder icon
besides each heading. Double-click the folder title to expand or hide the list of files (the folder icon will change
from open to closed or vice-versa). Each list of files is sorted by file name, but only part of the file name will be
displayed if the name is too long. To see the full file name, place the mouse pointer over the name in the list. The
four lists are as follows:









Open Files - Displays a list of all files currently open in the editor. Double-clicking on a file name will
activate that file and bring the corresponding Editor Window to the front. Right clicking the file will
display a menu with 5 options for the file: 'Activate' brings the file to the front, 'Close' closes the file,
'Save' saves the file to disk, 'Add to Favorites' adds the file to the Favorites list (see below), and
'Properties...' displays the file properties.
Favorite Files - Displays a list of favorite files for easy access. Files can be added to the list by rightclicking on a file in the Open Files, Recent Files, or Bookmarked Files lists and clicking the 'Add to
Favorites' menu option. Remove files from the list by right-clicking on a file in the Favorites list and
selecting the 'Remove from Favorites' menu item. Select 'Open' from the right-click menu or doubleclick the file name to open the file.
Recent Files - Displays a list of all files which have been edited recently, but are not currently open.
Double-click the file name or click 'Open' from the right-click menu to open the file in the editor. Rightclicking the file and selecting 'Add to Favorites' will add the file to the Favorites list (see above). The list
of recent files can be sorted either by the order that they were accessed or sorted by file name. To sort
the list in access order, right-click the Recent Files and click 'Sort Recent Files > By Time' or to sort by
file name choose 'Sort Recent Files > By Name'. A file can be deleted from the Recent Files list by rightclicking on the file and selecting the Remove from Recent Files menu option, and all files can be
removed from the list by right-clicking on a file and selecting Clear Recent Files List. The number of
items in the Recent Files list can be configured in the General Options dialog.
Bookmarked Files - Displays a list of all files that contain bookmarks (see Using Bookmarks for more
information). Bookmarks are saved and loaded automatically when the program exits and restarts.
Double-click the file, or select 'Open' from the right-click menu to open the file in 010 Editor. From the
right-click menu, select 'Add to Favorites' to add the file to the Favorites list (see above), or click 'Clear
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Bookmarks' to remove all bookmarks from the file.

Explorer

A simplifier File Explorer is integrated directly into 010 Editor. This explorer provides an easy way to locate files
on a hard drive and can be accessed by clicking the Explorer tab of the Workspace. The Explorer is divided into 3
areas:






Directory Name - The drop-down list at the top of the window displays the current directory. To jump
to another directory, enter the directory name in the field and press the Enter key. Click the down arrow
to the right of the drop-down list to access a list of recent directories.
Directory Tree - A list of all drives and directories is displayed in a tree below the Directory Name.
Open or close directory items by double-clicking the directory name, or single-clicking the '+' or '-'
symbols. Double-clicking on a file opens that file in the editor. Files can also be opened by right-clicking
on a file name and selecting 'Open' from the popup menu. The Name, Size, Type, and Date Modified for
each file are displayed in the list by scrolling to the right.
Filter - A Filter field is displayed at the bottom of the dialog. Only the files that match this filter will be
displayed in the Directory Tree. Enter a new filter in the field and press the Enter key to refresh the
display. A list of previous filters can be accessed by clicking on the down-arrow located to the right of
the Filter field.

The Directory Tree can be refreshed by clicking the Refresh button or pressing Alt+R.
NOTE: The Workspace is a dockable window. By clicking and dragging on the title bar of the Workspace, the
window can be moved to other locations in the interface. Right-click the window and deselect the 'Allow Docking'
toggle to prevent the window from docking.

Related Topics:
General Options
Opening Files
Saving Files
Using Bookmarks
010 Editor v7.0 Manual - Windows Edition
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Using the Inspector
The Inspector is a powerful tool for examining and editing binary data as a number of different data types. As
well, the Inspector displays a list of all bookmarks (see Using Bookmarks) in the current file plus and a list of all
built-in functions that can be used in scripts or templates. After a Binary Template is run on a file, the results are
usually displayed in the Template Results panel (see Working with Template Results); alternately, the results of
the template can be edited in the Inspector in the Variables tab. Show or hide the Inspector by clicking the 'View
> Inspector' menu option.
Some options for the Inspector are accessed by right-clicking with the mouse on the window. Select the 'Copy'
option from the menu to copy the contents of the current cell to the clipboard. Clicking the 'Copy Row' or 'Copy
Column' option will copy the entire row or column to the clipboard, and the 'Copy Table' option will copy all data
(the data will be copied in a tab-delimited format). For some columns of the Inspector, the numbers in the
column can be displayed in a number of different numeric formats by selecting 'Column Display Format' from the
right-click menu and then choosing 'Hex', 'Decimal', 'Octal', or 'Binary'. Click the 'Export CSV' menu option to
write the current table to a CSV file. A CSV file (which stands for Comma Separated Value) is a text file where
each cell is written separated by commas and CSV files are written in UTF-8 format.
The Inspector has four main tabs: Auto, Variables, Bookmarks, and Functions. Note that the small left and right
arrows beside the tabs may need to be clicked to view all the tabs of the Inspector. The following sections discuss
each tab:

Auto Inspector Tab

When the Auto tab of the Inspector is selected, a list of data types will be displayed in a table. When a file is
opened, the binary data starting at the cursor is converted to each of the different data types and displayed in
the table. As the cursor is moved around the file, the Inspector will change to display the converted data. If a
selection is made in the current file, the data is converted starting at the beginning of the selection. The following
formats are supported in the Auto Inspector:






Signed Byte - 8-bit number between -128 and 127
Unsigned Byte - 8-bit number between 0 and 255
Signed Short - 16-bit number between -32768 and 32767
Unsigned Short - 16-bit number between 0 and 65535
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Signed Int - 32-bit number between -2147483648 and 2147483647
Unsigned Int - 32-bit number between 0 and 4294967295
Signed Int64 - 64-bit number -9223372036854775808 and 9223372036854775807
Unsigned Int64 - 64-bit number between 0 and 18446744073709551615
Float - 32-bit floating-point number between 1.175494351e-38 and 3.402823466e38
Double - 64-bit floating-point number between 2.2250738585072014e-308 and
1.7976931348623158e+308
Half Float - 16-bit floating-point number between 5.960464e-08 and 65504
String - Displays a null-terminated ASCII character string (limit of 256 characters). If a string is edited
and characters are inserted or deleted, when in Insert mode, bytes will be inserted or deleted from the
file but when in Overwrite mode, null bytes will be written to the file so that the file size does not
change.
Unicode - Displays a null-terminated Unicode character string (limit of 128 characters). Strings are
edited in a similar manner to the String data type.
DOSDATE - 16-bit value representing the date in DOS using the format 'MM/dd/yyyy' (note that M
means month, d means day, and y means year)
DOSTIME - 16-bit value representing the time in DOS using the format 'hh:mm:ss' (note that h means
hour, m means minute, and s means second)
FILETIME - 64-bit value representing date and time in Windows using the format 'MM/dd/yyyy
hh:mm:ss'. FILETIME is a 64-bit integer representing the number of 100-nanosecond intervals since
01/01/1601 12:00 AM.
OLETIME - 64-bit value representing date and time in OLE and Delphi using the format 'MM/dd/yyyy
hh:mm:ss'. OLETIME is a 64-bit double representing the number of days since 12/30/1899 12:00 AM.
TIME_T - 32-bit value representing date and time in C using the format 'MM/dd/yyyy hh:mm:ss'.
time_t is a 32-bit integer representing the number of seconds since 01/01/1970 12:00 AM.

To edit a value, left-click the number with the mouse or press the Enter key. Edit the value (see Introduction to
Number Systems for a list of supported formats) and press Enter to commit the change or Esc to cancel. Note
that changed bytes will be displayed as orange when editing data using the Hex Editor Window. The 'Edit > Undo'
or 'Edit > Redo' commands can be used to undo and redo changes made with the Inspector.
The different data types in Auto Inspector may be reordered or deleted, or your own custom data formats may be
added. To customize the Auto tab, right-click on the table and click the 'Customize...' menu option or see the
Inspector Options dialog.

Variables Tab

The Variables tab displays variables that were generated by running a Script or a Binary Template on a file (see
Introduction to Templates and Scripts for more information). Usually, the variables generated by a template are
edited in the Template Results panel (see Working with Template Results) but this tab provides an alternate place
to view and edit variables. The functionality of this tab is the same as the Template Results panel and is
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discussed in the Working with Template Results help topic. This tab can also be used to view the variables that
were generated by a script.

Bookmarks Tab
The Bookmarks tab displays a list of all bookmarks for the current file (see Using Bookmarks). Bookmarks are
displayed and edited similar to the Template Results panel mentioned above. The Name column displays a
combination of the Name and Type fields in the Add/Edit Bookmark dialog. The Value column shows the bytes of
the bookmark interpreted according to the data type. The Start and Size columns display the position of the
bookmark, and the Color column shows the Foreground (Fg:) and Background (Bg:) colors from the dialog.
To edit a bookmark, select a bookmark from the list, and select the 'Edit Bookmark' menu option from the rightclick menu. Selecting the 'Remove Bookmark' menu option from the right-click menu will delete the bookmark.

Functions Tab

The Functions tab lists all built-in functions that can be used when writing 010 Editor Scripts or Binary Templates
(see Introduction to Templates and Scripts). All functions are sorted into five categories: Interface Functions, I/O
Functions, String Functions, Math Functions, and Tool Functions. Click the '+' beside each function group to list all
functions in that group. The All group lists every function in alphabetical order. Double-clicking on a function
name will insert that function into the text editor at the cursor position. Click a function and press the F1 key to
view help on that function.
NOTE: The Inspector is a dockable window. By clicking and dragging on the title bar of the Inspector, the window
can be moved to other locations in the interface. Right-click the window and deselect the 'Allow Docking' toggle
to prevent the window from docking.

Related Topics:
Inspector Options
Interface Functions
Introduction to Number Systems
Introduction to Templates and Scripts
Using Bookmarks
Using the Hex Editor
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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Using Bookmarks
A Bookmark is a set of bytes in a file that are marked as having special significance. There are two types of
bookmarks in 010 Editor: Quick Bookmarks and Advanced Bookmarks. A Quick Bookmark just marks a position
at a particular byte but an Advanced Bookmark may be given a name and may be interpreted as any of the
standard data types or data types defined in a Binary Template. All bookmarks are persistent, meaning that
created bookmarks will still exist after exiting and restarting 010 Editor. The bookmarks for the current file will be
displayed in the Bookmarks tab of the Inspector (see Using the Inspector).

Adding Quick Bookmarks
Quick bookmarks provide an easy way to mark an important position or range in a file. To set a quick bookmark,
move the cursor to the position to mark or make a selection and then press Ctrl+F2 or click the 'Search > Toggle
Bookmark' menu option. The marked byte or selection will be displayed in a different color (by default light blue).
To move the cursor to a bookmark, press the F2 or Shift+F2 keys (see the Searching for Bookmarks section
below for more information). To remove a bookmark move the cursor to the bookmark you want to delete and
press Ctrl+F2 or click the 'Search > Toggle Bookmark' menu option again (see the Removing Bookmarks section
below for more information).

Adding Advanced Bookmarks

To add an advanced bookmark, click the 'Search > Add/Edit Bookmark' menu option, or press Ctrl+B. The 'Add
Bookmark' dialog will be displayed, which lists the attributes for the bookmark to create. To keep track of
different bookmarks, a name can be assigned using the Name field, but this field is optional. Select the data type
to interpret the bytes of the bookmark using the Type drop-down list. If a Binary Template has been run on the
current file, the Type drop-down list will also include custom data types defined in the template (note that all
bookmarks for a file using custom data types must come from the same Binary Template). If the bookmark to
create is not an array, enter '(none)' or nothing in the Array Size field. To interpret the bookmark bytes as an
array, enter the size in the Array Size field (note that a list of previously used sizes can be accessed by clicking
the down arrow to the right of field). Select which endian should be used when interpreting the data (see
Introduction to Byte Ordering) using the Little or Big toggles. By default, the endian will be the same endian as
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the file. If the Move Bookmark with Cursor toggle is enabled, the bookmark will move to the current cursor
position every time the Editor Window is clicked with the mouse or the cursor is moved with the cursor keys. This
feature is useful to apply structures from a Binary Template to a file when the exact file format is not known.
The foreground color (text color), or background color of the bookmark can be chosen by clicking the color
rectangles to the right of the Foreground or Background labels respectively. Clicking the color rectangle shows a
drop-down list of colors. A new color for the bookmark can be chosen by clicking one of the colors in the list.
Selecting None from the list means that the bookmark will not change the color. Click the More Colors... button
from the drop-down list to select a different color using a standard color selection dialog.
The start address and size of bookmark to be created will be listed beside the Start Address and Size labels
respectively. If no bytes were selected in the file when the 'Add Bookmark' dialog was opened, the Start Address
will be the cursor position in the file, and the Size will be calculated from the Type and Array Size. If a selection
was made when opening the dialog, the Start Address will be the start of the selection, and the Size will be the
size of the selection (note that the Array Size will be adjusted automatically to try to fit inside the selection).
When defining a bookmark using a custom data type from a Binary Template, sometimes the size cannot be
calculated so the size will be displayed as '???'.
Click the Add button to create the bookmark, or the Cancel button to dismiss the dialog. The generated
bookmarks will color the current file and be displayed in the Bookmarks tab of the Inspector. Note that when
bookmarks are added to a file, that file will be displayed in the Bookmarked Files list in the Workspace (see Using
the Workspace).

Editing Bookmarks
To edit a bookmark, position the cursor over a bookmark in a file, or select the bookmark from the Bookmarks
tab of the Inspector. Clicking the 'Search > Add/Edit Bookmark' menu option or pressing Ctrl+B will display the
above dialog with all the values from the selected bookmark. Change any values and click Update to apply the
changes or Cancel to ignore the changes.

Searching for Bookmarks
To search for the next bookmark after the current cursor position, click the 'Search > Next Bookmark' menu
option or press F2. If a bookmark is found it will be selected in the file. The search will wrap to the beginning of
the file if no more bookmarks are found. Similarly, to search for the previous bookmark before the current cursor
position, click the 'Search > Previous Bookmark' menu option or press Shift+F2.

Removing Bookmarks
To remove a bookmark, place the cursor over the bookmark in the file or select the bookmark from the
Bookmarks tab of the Inspector. Click the 'Search > Toggle Bookmark' menu option or press Ctrl+F2 to remove
the bookmark from the file. Alternately, all bookmarks can be removed from the file at once by clicking the
'Search > Clear All Bookmarks' menu option.

Related Topics:
Introduction to Byte Ordering
Using the Inspector
Using the Workspace
010 Editor v7.0 Manual - Windows Edition
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Using Column Mode

Column Mode is a special editing mode when using the Text Editor or Hex Editor where columns of data are
selected instead of a contiguous set of bytes (see the image above for an example). To enter Column Mode click
the 'View > Linefeeds > Column Mode' menu option, type Alt+3, or click the Column Mode icon in the Toolbar.
Column selections can also be made without entering Column Mode by holding down the Ctrl key while dragging
the mouse.

Columns Selections and the Clipboard
Once a column selection is made in the Text Editor, use the regular clipboard operations to manipulate the data.
For example, Ctrl+C will copy the column selection to the clipboard and the Delete key will delete the column
selection. When a column selection has been copied to the clipboard and Paste is used, the data is pasted as
columns even if the editor is not in Column Mode (this is useful so that Ctrl plus dragging can be used to make a
column selection and the selection can be copied and pasted all without entering Column Mode). Pasting a
column selection has a few different possibilities:

56



If a column selection is on the clipboard and Paste is used, the columns will be inserted into the file and
spaces will be inserted into the file so that the columns line up properly. The following image shows an
example of selecting a set of columns, cutting them to the clipboard and pasting them to the right 5
columns:



If only a single line of text data containing no linefeeds is on the clipboard and either a column selection
has been made or a Column Insert Line has been drawn (see Typing with Column Selections below),
pasting will cause the clipboard contents to be pasted on each line. For example, the following image
shows the result of pasting the text "<LI>" when a Column Insert Line has been made:

Copyright © 2003-2016 SweetScape Software

010 Editor - Reference Manual



If multiple lines of text data (not a column selection) are on the clipboard and either the editor is in
Column Mode or a column selection is currently made, the text data will be inserted line-by-line into the
editor (note in this case the columns may not line up properly). The following figure is an example of
pasting a text file containing a list of months into a file in Column Mode:

Note that when pasting and a column selection has been made, the column selection will be deleted before the
paste occurs.

Typing with Column Selections
010 Editor has a special Column Insert Line which can be created by clicking and dragging straight down when in
Column Mode or when the Ctrl key is held down. The Column Insert Line is displayed as a vertical blue line as
shown in the figure below left. When a Column Insert Line exists and a key is typed on the keyboard, that key
will be inserted onto each line at the same time. The following figure shows an example of typing the characters
'{' and ' ' when a Column Selection Line is made:

This technique also works when regular column selections are made and keys are typed on the keyboard, except
in this case the typed keys are written over the column selection until the cursor reaches the right side of the
column selection. Typing additional keys when the cursor is at the right side of the column selection will insert
that key on each line. For example, the following image shows making a column selection and then typing the
characters 'DECL' on the keyboard (note the position of the cursor on the right-hand image):
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Hex Editor and Column Mode

Column mode also works with the Hex Editor except all selections are made by byte as shown above. Note that
deleting a column selection in the Hex Editor can cause columns to be unsynchronized. Pasting works similar to
the Text Editor Column Mode except that if a column selection exists while pasting, the selection will not be
deleted before the paste occurs. Typing on a Column Selection works the same way as indicated above and
typing 0's is a quick way to blank out a column selection.

Related Topics:
Using the Clipboard
Using the Hex Editor
Using the Text Editor
010 Editor v7.0 Manual - Windows Edition
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Using Find
The Find Bar can be used to find a string, a set of hex bytes, or a number of different data types within a file. The
Find Bar can be accessed from the 'Search > Find...' menu option, the Tool Bar, or by pressing Ctrl+F.

Find Bar

When performing a search, the Find Bar will be displayed at the bottom of the editor. Different data types may be
searched by clicking the type name to the right of the Find label and choosing from the popup list. The following
types are supported:



















Text (t) - searches for a string using the character set of the current file (see File Interfaces). Can be
used to search for ASCII strings, Unicode strings, UTF-8 strings, etc.
Hex Bytes (h) - searches for a set of hex bytes (for example: 'FF 00 CB').
ASCII String (a) - searches for an ASCII+ANSI string.
Unicode String (u)
EBCDIC String (e)
Signed Byte (i8)
Unsigned Byte (ui8)
Signed Short (i16)
Unsigned Short (ui16)
Signed Int (i32)
Unsigned Int (ui32)
Signed Quad (i64)
Unsigned Quad (ui64)
Float (f)
Double (lf)
Variable Name (n) - see Finding Variables below
Variable Value (v) - see Finding Variables below

The value in brackets is the type specifier and can be used as a quick way to search for different data types (see
the Type Specifiers section below). Enter a string, value, or hex bytes to search for in the text field and the field
will automatically be converted to hexadecimal bytes and displayed to the right of the Options button. Note that
when converting numbers or Unicode strings, the endian of the current file is used (see Introduction to Byte
Ordering). Note also that the text field can be resized by dragging the line to the right of the Options button.
Clicking the
icon will find the next occurrence of the value in the current file or clicking the
icon will find the
previous occurrence. Clicking the All button will find all instances of the target value in the file and display the
results in the Output Window (see below). Pressing the Enter key in the text field has three different possible
outcomes depending upon which options are set in the Options dialog: If the Find All Occurrences toggle is set,
pressing Enter will perform a Find All operation but if it is not set, pressing Enter will either find the next
occurrence of the find value if the Down toggle is selected, or find the previous occurrence if the Up toggle is
selected. If no occurrences of the find value could be found, the find text field will be displayed in an orange
color. Press the Esc key to hide the Find Bar and return to editing the file.
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Find Options

Different options for the dialog can be displayed by clicking the Options button. When the Find All Occurrences
toggle is set, pressing the Enter key in the text field will find all occurrences of the target value. When this toggle
is not set, pressing the Enter key will either search for the next or previous occurrence of the target value
depending upon if the Down or Up toggle is set in the Direction box.
By default all find operations search the entire file but it is possible to limit finding to one part of the file by using
the Range box. To limit the find, first select some bytes in the file and then click the Options button and then the
Lock to Selection button. The Lock to Selection button will be disabled if no selection exists. After this button is
clicked, all subsequent find operations will be limited to the selection and the limited area will be highlighted
brown in the editor (see Color Options to change the color). To return to searching the whole file, click the Unlock
Selection button or the

icon.

When searching for strings, two options are available: If the Match Case toggle is enabled, the target string will
only match if the bytes match exactly. When the toggle is disabled, characters that are not the same case will
match. If the Match Whole Word toggle is set, the target string will not match partial words. When Match Case is
enabled, the Options button will contain the 'C' character in brackets and when the Match Whole Word toggle is
enabled, the Options button will contain the 'W' character in brackets.
To search for regular expressions enable the Search with Regular Expressions toggle and see the separate
Regular Expressions help topic. When regular expression searching is turned on the Options button will contain
the 'R' character in brackets. When searching for strings or hex bytes, enable the Search with Wildcards toggle to
allow the characters '*' and '?' to be used as wildcards in the text field. The '?' wildcard must match exactly one
byte, and the '*' wildcard can match zero up to a certain maximum number of bytes. For example, the value
'adv*e?' would match both the strings 'advantages' and 'advised'. The maximum number of bytes for a match
can be specified using the Advanced Options section as described below. When the Search with Wildcards toggle
is turned on, the special syntax '\*' and '\?' can be used to literally search for the characters '*' (ASCII code
0x2A) or '?' (ASCII code 0x3F).
When searching for floats or doubles, the Float Find Tolerance field will be displayed. This field can be used to
search for numbers that are very close to other numbers. Because of numerical precision, sometimes floatingpoint numbers are stored as 2.00000001 instead of 2. Enter a tolerance value in the Float Find Tolerance field.
Numbers that are within the tolerance above or below the target value will match.
If the Allow Multiple Find Ranges toggle is enabled, 010 Editor can store the search results from a number of
different queries and can optionally color each query by a different color in the Editor Window. When this toggle
is enabled, each query that is performed will add another section of results to the Find tab of the Output Window
(see Output Window below for more information). Also, the coloring of the file can be controlled with the
Advanced Options section as discussed below.
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Click the Advanced Options section to display further options for the find tool. By default, when searching for the
next occurrence of a find value and no values are found, the search will start over at the beginning of the file or
when searching up and no values are found, the search will start again at the bottom of the file. This is called
wrapping and can be disabled by turning off the Allow Wrapping toggle. Clicking the Allow Type Specifiers toggle
allows turning off the use of type specifiers (see the Type Specifiers section below). If the Hide Find Bar after
Search toggle is enabled the Find Bar will be hidden after a Find All operation, but if this toggle is turned off the
Find Bar will remained focused after a search.
By default, after a find is executed the found values are colored in the main Editor Window according to the Find
color listed in the Color Options dialog. To override this coloring enable the Use Custom Color toggle and enter a
new color using the Fore and Back color boxes. The Fore color indicates the text color to be displayed, and the
Back color indicates the background color behind the text. Specifying custom colors is useful with using Allow
Multiple Find Ranges to color different ranges different colors.
When finding a large number of find values it is possible to run out of memory. To prevent this 010 Editor by
default has a limit of 10000000 find occurrences (10000000 occurrences uses approximately 1 GB of storage).
This limit can be disabled by turning off the Limit Find Occurrences toggle or the limit can be changed using the
field to the right of the toggle. If more find occurrences are found than the limit, the text "Too many to display"
will be displayed at the bottom of the Find results. When the Search with Wildcards toggle is enabled, specify the
maximum number of bytes that the wildcard character '*' can match in the Maximum Wildcard Match Length'
(default of 24).

Output Window

When searching for all occurrences of a target value using the Find All button, the results are displayed in the
Output Window. The top row will be a dark gray header line that indicates the search target and number of
occurrences found. Each row of the table indicates a match with the target value. The starting address and value
searched for are displayed in the Address and Value fields respectively. When searching within text files, the full
line where the find occurrence was found is displayed in the Value field with the found value marked in bold. On
the left side of the Output Window is a graph representing the file. Blue lines indicate the position of matches in
the file. When a row is selected in the table, the corresponding line in the graph will be displayed as a yellow line.
The number displayed below the graph indicates the number of matches that were found. Bytes in the main
Editor Window will be colored blue if those bytes are part of a match. Selecting a row in the table will also select
the bytes in the editor.
The display format for each column can be set to hexadecimal or decimal by right-clicking on the Output Window
and selecting 'Column Display Format'. The Size column, which displays the size of each find occurrence is hidden
by default but can displayed by right-clicking on the table and selecting Show Size Column. Data can be exported
or imported from the table in CSV format by right-clicking and selecting either Export CSV or Import from the
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menu. Right-click the table and select 'Clear' to clear all find results, or press the Esc key to hide the Output
Window.
If multiple searches were performed and the Allow Multiple Find Ranges toggle is enabled, each search will be
displayed in the Output Window in a different section of the table separated by a dark gray header line. Click the
'+' or '-' buttons beside the header, or double-click the header to hide or show the results from that search.
Right-click the table and click the 'Expand All' or 'Shrink All' menu options to show or hide the search results for
all queries.

Find Next/Find Previous
After a search has been made, the 'Find > Find Next' or 'Find > Find Previous' menu options can be used to step
through the file, searching for the next or previous occurrences of the target value even when the Find Bar is not
displayed.

Type Specifiers
A quick way exists in the find field to specify different find types without using the popup list of types. This can be
done by placing a comma followed by a type specifier at the end of the value to find in the text field. For
example, the value "453f,h" would search for the hex bytes 0x45 and 0x3f, the value "0x100,i32" would search
for the integer 256, or the value "2.5,lf" would search for the double '2.5'. The full list of type specifiers is shown
in the list at the top of this section. To disable the use of type specifiers, click the Allow Type Specifiers toggle in
the Advanced Options section.

Finding Variables
The Find Bar can also be used to find variable names or values within the Template Results panel. Set the type to
search for as Variable Name or Variable Value to search for variables. When a variable is found that matches
either the Name or Value, that variable will be highlighted within the Template Results. Note that find all and
replace operations are not supported with finding variables.
NOTE: The Find Bar will be hidden automatically after a period of inactivity. To control the length of the period of
inactivity before hiding see the General Options dialog.

Related Topics:
Color Options
Introduction to Byte Ordering
Using Find In Files
Using Regular Expressions
Using Replace
Using Replace In Files
Working with File Interfaces
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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Using Replace
The Replace Bar is used to search and replace a set of bytes within a file. Access the Replace Bar from the
'Search > Replace...' menu option, the Tool Bar, or by pressing Ctrl+R.

Replace Bar

Specify the data to find in the Find Bar at the bottom of the editor. The functionality of this bar is documented in
the Using Find help topic. Enter the value to replace in the Replace text field and choose the data type to replace
with the popup list to the right of the Replace label (see Using Find for more information). The replace value will
be converted to a set of hex bytes and displayed to the right of the Replace All button.
Click the Find buttons

or

to scan through the file without making any replacements. Clicking the Replace

buttons
or
has two possible effects: If no occurrence of the Find value has been found yet, these buttons
function just like the Find buttons and search for either the next or the previous occurrence of the Find value and
set the selection to the result. If, however, a Find occurrence has been found (as indicated by the selection),
clicking either of these buttons will replace the current selection with the Replace value and then search for
another occurrence of the Find value. Pressing the Enter key while in the Replace text field will replace the value
and find either the next or the previous occurrence depending upon if the Down or Up toggle is set in the Options
dialog. Clicking the Replace All button automatically replaces all occurrences of the target value in the file.

All options when performing a Replace operation are identical to the Find Bar except for the Show All
Replacements toggle and the Pad With Zeros toggle. When the Show All Replacements toggle is set and a
Replace All operation is done, all the replacements will be shown in the Output Window (see Using Find for more
information). When the Pad With Zeros toggle is enabled, a set of zero bytes will be appended to the replaced
hex bytes until the length is the same as the find hex bytes. This feature is useful to replace a string with a
shorter string without changing the file length. The Range box is similar in functionality to the Range box of the
Find Bar. The Advanced Options are also documented in the Using Find help topic.
When replacing a large number of values (more than the Limit Find Occurrences setting in the Advanced Options)
and Show All Replacements is turned on, the text "Too many to display" will appear at the bottom of the Replace
results. Note that all the replacements will be done but not all the replacements will be listed in the Replace
results.
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Replace Next/Replace Previous
After a replacement has been performed, clicking the 'Search > Replace Next' menu option or the 'Search >
Replace Previous' menu option will perform the replacement again. These commands, along with the 'Search >
Find Next' and 'Search > Find Previous' menu options can be used to step through a file making replacements
even when the Replace Bar is hidden.
NOTE: The Replace Bar will be hidden automatically after a period of inactivity. To control the length of the period
of inactivity before hiding see the General Options dialog.

Related Topics:
Using Find
010 Editor v7.0 Manual - Windows Edition
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Using Find in Files
The Find in Files Bar is used to search for a set of bytes across multiple files. Open the Find in Files Bar by using
the 'Search > Find in Files...' menu option, the Tool Bar, or by pressing Ctrl+Shift+F.

Find in Files Bar

When searching for a set of bytes across files, the Find in Files Bar is displayed at the bottom of the editor. The
top portion of the bar, the Find Bar, is used to specify what bytes to search for and is identical to the normal Find
Bar (see Using Find for more information).
The in Files area is used to indicate which files should be searched. To search a directory enter a directory in the
text field to the right of the in Files label or choose a directory by clicking the browse button to the right of the
field. To search only files that are currently open in the interface, click the arrow icon on the right side of the text
field and select All Open Files from the popup list. Enter a file name mask in the File Types field using the
characters '*' and '?' to indicate wildcards. Multiple file masks can be entered in the field by separating them by
commas or semi-colons (for example: "*.exe,*.dll"). If the Include Subdirectories toggle is enabled in the
Options section, then the subdirectories of the specified directory are recursively searched as well.

Other options for the search can be set by clicking the Options button. Consult the Using Find help topic for
information on the Match Case, Match Whole Words, Search with Regular Expressions and Search with Wildcards
toggles. When a Find in Files operation is performed the results are displayed in the Output Window. By default,
only those files that contain 1 or more occurrence of the find value are listed; however, all files that were
searched can be listed in the Output Window by enabling the List All Files toggle.
Click the Find in Files button to start the Find in Files search and note that the Esc key can be used to cancel a
long search. Note also that the text fields in the in Files section can be resized by dragging the line to the right of
the Browse button or the line to the right of the File Types field.

Output Window
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When some occurrences of the search string are located in a file, the results are displayed in the Find in Files tab
of the Output Window. For each file which contains a match of the search string, a dark gray header line will be
displayed in the Output Window indicating the name of the file and the number of occurrences found. All search
occurrences for the file will be listed below the dark gray header, one per row of the table. Click the '+' or '-'
button beside the header, or double-click on the header to hide or show all search results for that file.
Alternately, all headers can be closed by right-clicking on the table and selecting the 'Shrink All' menu option, or
all headers can be opened by right-clicking and selecting the 'Expand All' menu option. Each search result lists
the File, Address, and Value and where the search occurrence was found (note that the Size column can be
shown by right-clicking on the table and choosing 'Show Size Column').
Along the left side of the dialog is a graph indicating where the search occurrences were found. The graph will
display information for the file the currently selected search occurrence is in. The selected search occurrence will
be highlighted as a yellow line and the other occurrences will be displayed as blue lines. The number below the
graph indicates the total number of occurrences that were found in all files. The display format for each column
can be set to hexadecimal or decimal by right-clicking on the Output Window and selecting 'Column Display
Format'. Press the Enter key while a find occurrence is highlighted to load that file and move the cursor to the
address of the occurrence. Pressing Ctrl+Enter will perform a similar operation as pressing Enter, but the
application focus will remain on the Output Window. The search results can be exported or imported from the
table in CSV format by right-clicking on the results and choosing either Export CSV or Import from the right-click
menu. Right-click the table and select 'Clear' to clear all find in files results, or press the Esc key to hide the
Output Window.
NOTE: The Find in Files Bar will be hidden automatically after a period of inactivity. To control the length of the
period of inactivity before hiding see the General Options dialog.

Related Topics:
Using Find
010 Editor v7.0 Manual - Windows Edition
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Using Replace in Files
Use the Replace in Files Bar to search and replace a set of bytes across a whole range of files at a single time.
The Replace in Files Bar may be accessed by the 'Search > Replace in Files...' menu option. Note that undo is not
currently supported after doing a Replace in Files operation so use this tool with caution.

Replace in Files Bar

Indicate which data to find using the Find Bar located at the bottom of the editor (see Using Find for more
information). In a similar manner, enter the bytes to replace in the Replace Bar (see Using Replace for more
information). Choose which files should be searched using the in Files Bar. The functionality of this box is the
same as with the Find in Files Bar (see Using Find in Files).

Options for the bar can be controlled by clicking the Options button. See the Replace Bar for information on the
Pad With Zeros toggle or the Find Bar for information on the Match Case, Match Whole Word, Search with Regular
Expressions, or Search with Wildcards toggles. See the Find in Files Bar for information on the List All Files or
Include Subdirectories toggles.
Click the Replace in Files button to search all files indicated by the in Files Bar and make the indicated
replacements.

Output Window
After a Replace in Files operation, the Find in Files tab of the Output Window changes to Replace in Files and a list
of all replacements is displayed in the window. See Using Find in Files for more information on how to use the
Output Window.
NOTE: The Replace in Files Bar will be hidden automatically after a period of inactivity. To control the length of
the period of inactivity before hiding see the General Options dialog.
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Related Topics:
Using Find
Using Find in Files
Using Replace
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Using Regular Expressions
Regular Expressions are a powerful syntax for finding string patterns within a file. Many different flavors of
regular expressions exist and 010 Editor uses a syntax similar to Ruby/Perl. To search for a regular expression,
click the Options button in the Find Bar and enable the Search with Regular Expressions toggle (see the image
below). Regular expressions can be used when performing a Find, Replace, Find In Files, or Replace In Files
operation. Note that the letter 'R' will appear beside the word Options when regular expressions are enabled. The
full syntax of regular expressions are beyond the scope of this document but the following contains an
introduction to the major features of regular expressions. Warning: Some regular expressions can be very
complex and using certain regular expressions containing lots of repetition operators can cause searches to be
performed very slowly.

Matching Characters
Regular expressions look just like regular Find strings. For example, to find a string such as 'Green' just use the
regular expression:

Green
Regular expressions use a number of special control characters to control how the searches are done and the
special characters are: ".[]^$()/\*{}?+|". To search for any of these control characters include an extra '\'
character before the control character. For example, to search for the string "5+6" use the regular expression:

5\+6
A number of special codes can be used to match characters:
















. - any character (except linefeeds)
\w - a word character include letters, numbers, '_' and unicode characters
\W - a non word character
\s - a whitespace character includes tabs and spaces
\S - a non whitespace chararacter
\d - a decimal digit chararacter [0-9]
\D - a non decimal digit character
\h - a hexadecimal character [0-9a-fA-F]
\H - a non hexadecimal character
\t - horizontal tab (0x09)
\n - newline (0x0A)
\r - return (0x0D)
\a - bell (0x07)
\e - escape (0x1B)
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\f - form feed (0x0C)
\v - vertical tab (0x0B)
\nnn - octal character
\xHH - hexadecimal character

For example, to search for all phone numbers in the form 555-5555 use the regular expression:

\d\d\d-\d\d\d\d
Note that the case-sensitivity of regular expressions is controlled by the Match Case toggle in the Find Bar
Options.

Character Classes
A Character Class or Character Set provides a way to give a number of different options that a single character
can match. Character Classes are denoted with '[' and ']' brackets where each character inside the brackets can
match. For example, the regular expression:

defen[cs]e
will match both the words 'defence' and 'defense'. Inside of a character class, only the characters "]\-^" are
considered control characters. The '-' character can be used to indicate a range of characters. For example the
character class:

[0-9a-fA-F]
will match any of the hexadecimal characters. Using the '^' character at the beginning of a character class
indicates a negated character class, meaning the regular expression will match any characters that are not in the
character class. For example, the character class:

[^abc]
will match any characters that are not a, b, or c.

Anchors
All matching so far has worked by matching a particular character. Regular expressions also support anchors
which work by matching a position within a file. The following anchors are supported:






^ - beginning of the line
$ - end of the line
\b - word boundary
\B - non word boundary

For example, the regular expression:

^\d\d:\d\d:\d\d
will match a timestamp only if it exists at the beginning of a line. The '\b' anchor can be used to ensure a regular
expression matches a whole word. For example the regular expression 'Al' would match both the words 'Al' and
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'Alpha' but the regular expression:

\bAl\B
would match 'Al' but not 'Alpha'. The Match Whole Word toggle in the Find Bar Options can be enabled as another
way to limit regular expressions to matching whole words only.

Repetition
To match multiple characters in a row, a number of different operators can be used. Some operators are greedy
meaning they match the largest number of characters they can, or lazy meaning they match as few characters as
they can. The following operators are supported and are by default greedy:









? - 1 or 0 times
* - 0 or more times
+ - 1 or more times
{n,m} - at least n but not more than m times
{n,} - at least n times
{,n} - at least 0 but not more than n times
{n} - exactly n times

To convert a greedy operator to a lazy operator include an additional '?' after the operator (for example, '??', '*?',
or '{n,m}?'. In our phone number example from above for a number such as 555-5555 we could now use:

\d{3}-\d{4}
To match both the strings 'color' and 'colour' use the regular expressions:

colou?r
For another example, to match a simple XML tag use:

<[A-Za-z0-9_/]+>
This regular expression matches one or more alphanumeric characters inside '<' and '>' brackets. Repetition
operations can also be used with the '(' and ')' brackets to indicate what is repeating. For example:

reg(ular)? ex(pression)?
matches both the strings 'regular expression' and 'reg ex'. Warning: Using certain combinations of repetition
operators can cause searches to be performed very slowly.

Alternation
The alternation operator '|' allows matching one out of several possible regular expressions. For example to
search for the colors red, green or blue, use:

red|green|blue
Alternation can be combined with the '(' and ')' brackets to make more complex statements. For example to
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search for 'const int' or 'const char' use:

const (int|char)

Matching Hex Bytes
When searching for hex bytes use the syntax '\xHH' to denote a hex byte where HH is the byte to find. This
syntax must be used for regular expressions even when the Find type is set to Hex Bytes in the Find Bar. For
example, to search for the bytes '3F 4D ?? 0F' use the regular expression:

\x3F\x4D.\x0F
Hex bytes can also be used in character classes. For example to search for the first non-zero byte use:

[^\x00]
When regular expressions are enabled, the Find type is set to Hex Bytes and no regular expression is being
editing in the Find Bar, pressing Ctrl+F on the keyboard will copy the currently selected hex bytes to the Find Bar
using the \x notation.

Functions
Regular expressions can be used in scripts using the FindAll, FindFirst, FindInFiles or ReplaceAll functions and the
'method=FINDMETHOD_REGEX' parameter. Regular expressions can also be used to search within strings using
the RegExMatch or RegExSearch functions.

Backreferences
Backreferences are currently not supported when performing replacement operations.

Related Topics:
String Functions
Tool Functions
Using Find
Using Find In Files
Using Replace
Using Replace In Files
010 Editor v7.0 Manual - Windows Edition
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Using Find Strings

The Find Strings dialog can be used to discover the location of strings within a binary file. Access the Find Strings
dialog using the 'Search > Find Strings...' menu option and note that this tool is generally not useful for text files
because a text file consists entirely of a set of strings.
Use the Find Strings dialog by specifying the minimum number of characters for each string in the Minimum
String Length field. Choose whether to search for ASCII strings, Unicode strings, or both ASCII and Unicode
strings using the String Type field. By default, the search will take place over the whole file (Entire File will be
selected in the Range group), but the search can be limited to an area of the file by making a selection before
opening the Find Strings dialog and then choosing the Selection toggle. Click the Find button to search through
the file and list all strings that were found and see the Output Window below. Clicking Cancel or pressing the Esc
key will dismiss the dialog without performing a search.

Other options are available for the Find Strings dialog by clicking the Advanced Options section. If the Require
Null After String toggle is set, only those strings that have a null (zero) character immediately following the string
will be listed in the Output Window. The Matching Characters box can be used to customize exactly which
characters are considered when searching for strings. Characters are divided into a number of different groups
which can be enabled or disabled by clicking the toggles. For example, if Letters A..Z is selected then all letters
(including uppercase and lowercase) will be considered part of a string. A list of custom characters can be
specified in the Custom field and the sequence ".." can be used to indicate a range of characters. For example, to
search just for letters or the characters $, & and @, disable all toggles except the Custom toggle and enter
"A..Za..z$&@" in the Custom field.

Output Window
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After the search is performed, all strings that were found will be displayed in the Find tab of the Output Window.
The top line lists how many strings were found and clicking on a string name will highlight that string in the
editor. The figure above shows an example of finding strings in the 'notepad.exe' file. A graph of where the
strings were found in the file is located to the left of the list of strings. Different formats for the Address column
can be chosen by right-clicking on a cell in the column and selecting Column Display Format from the popup
menu. Right-click the table and select 'Clear' to clear all the results or press the Esc key to hide the Output
Window.

Related Topics:
Using Find
010 Editor v7.0 Manual - Windows Edition
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Using Goto
The Goto Bar can be used to jump to any address, line, sector, or short in the current file. Access the Goto Bar by
using the 'Search > Goto...' menu option, the Tool Bar, or by pressing Ctrl+G.

Goto Bar

When using the Goto Bar, select what type of value to jump to using the popup list to the right of the Goto label.
The following 4 options are available:






Byte - Use this setting to seek to a particular byte address in the file. Entering ',b' after a value will
force the goto to jump to an address even if one of the other options is chosen in the list.
Line - When Line is chosen, the Goto Bar is used to jump to a line in the file. Enter ',l' after a value to
force the Goto Bar to jump to a line.
Sector - Choose Sector to jump to a sector in a file or drive (see Editing Drives for more information on
sectors). Enter ',s' after a value to jump to a particular sector.
Short - A Short is a group of two bytes within a hex file. Selecting Short from the list will jump to the
chosen short. Enter ',w' after a value to force the Goto Bar to jump to a short.

Enter a numeric value in the text field in the bar. Switch between Decimal and Hex numeric format by clicking the
area just to the right of the text field, or use any of the formats described in the Introduction to Number Systems
section. The position to seek will be calculated using an origin. The origin can be controlled by clicking the
Options button and using the Direction radio buttons:





From Beginning of File - Origin is at the beginning of the file.
From Current Position - Origin is the current position and plus or minus are used to move forward or
backward. For example, use '+10,l' to skip forward 10 lines or '-16,b' to skip backward 16 bytes.
From End of File - Origin is at the end of the file. For example, use '<16' to jump to the 16th byte
from the end of the file.

Press the Enter key or click the Goto icon to the right of the text field to move the cursor to the new position.
Pressing the Esc key will hide the Goto Bar and a list of the recent Goto commands can be accessed by clicking
the small up arrow to the right of the text field.

Goto Again
Once the Goto tool has been used, clicking 'Search > Goto Again' or pressing Ctrl+Shift+G will jump to the
address again. If the address was relative to the current position, the cursor will be moved again in the same
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direction. For example, enter '+48,b' in the Goto Bar and press Enter. Then press Ctrl+Shift+G multiple times to
step through the file by 48 bytes.
NOTE: The Goto Bar will be hidden automatically after a period of inactivity. To control the length of the period of
inactivity before hiding see the General Options dialog.

Related Topics:
Editing Drives
Selecting a Range
010 Editor v7.0 Manual - Windows Edition
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Using Paste Special

Many applications copy data to the clipboard in a variety of different formats. The Paste Special command allows
inserting of data into the current document in any of the available formats. This command can be accessed from
the 'Edit > Paste Special...' menu option. For more information on how pasting works in general, see the Using
the Clipboard topic.
Clicking the Paste Special command displays the Paste Special dialog show above. A list of all available data
formats is displayed in the center of the dialog. Click a format name and press the Paste button to paste data in
the selected format. Data can also be pasted by double-clicking a format name. Click the Cancel button to
dismiss the dialog without inserting any data.

Related Topics:
Using the Clipboard
010 Editor v7.0 Manual - Windows Edition
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Selecting a Range

The Select Bar can be used to select a set of continuous bytes in a file by specifying a starting address and a
number of bytes, or a start address and an end address. To open the Select Bar, click the 'Edit > Select Range...'
menu option or press Ctrl+Shift+A. If the Select Bar is opened when a selection is already made, the bar will
display the start address and size (or end address) of the current selection. Note that when the Select Bar is
displayed and the selection changes in a file, the Select bar will update to display the current selection.
By default, the Select Bar specifies selections using a Start and a Size field. The Start field of the bar displays the
address of the first byte of the selection. If no selection is made, the address will be the current cursor position.
The Size field displays the number of selected bytes. If no bytes are currently selected, this field shows the last
number of bytes selected with this bar. Choose the numeric format for the fields by clicking either Hex or Decimal
to the right of the size field, or use any of the formats described in the Introduction to Number Systems section.
Press the Enter key to make a selection or the Esc key to hide the bar.

Alternately, selections can be controlled using a Start address and an End address. To enable this mode, click the
Options button and enable the Specify Range using Start Address + End Address toggle. Enter the address of the
end of the selection in the End field (note that the Size field disappears). For example, entering a Start address of
1000 and an End address of 1005 would select 5 bytes (the byte at the end address is not selected).
When a selection is made, the start address and size of the selection are displayed in the status bar. See the
Status Bar help topic for more information.
NOTE: The Select Bar will be hidden automatically after a period of inactivity. To control the length of the period
of inactivity before hiding see the General Options dialog.

Related Topics:
Introduction to Number Systems
Selecting Bytes
Status Bar
Using the Clipboard
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Inserting or Overwriting Bytes
Two tools are included with 010 Editor that make inserting or overwriting blocks of bytes easy (for example, if
you want to insert a row of eighty '*' characters these tools make this operation simple).

Click the 'Edit > Insert/Overwrite > Insert Bytes...' menu option to access the Insert Bytes tool. The current
cursor address will be displayed in the Start Address field. Enter the number of bytes to insert in the Size field.
The address and size can be displayed in decimal or hex formats by clicking on the Decimal or Hex radio buttons.
Usually the range of bytes to insert is specified using the Size field but the range can also be specified using an
End Address by clicking the Options button and enabling the Specify Range using Start Address + End Address
toggle (note that the range does not include the byte at the end address).
The value of the bytes to be inserted can be controlled in the Byte Value box by entering a value in the Char, Hex
or Decimal fields. Note that the value is automatically converted between the different formats as a number is
entered in either field (the Char field will be left blank if there is no printable character that corresponds to the
byte value). Click the OK button to insert the bytes, or the Cancel button to close the dialog without making
changes. Note that bytes cannot be inserted into a drive or a process.

Click the 'Edit > Insert/Overwrite > Overwrite Bytes...' menu option to access the Overwrite Bytes tool. If any
bytes are selected in the editor, the starting address of the selection will be displayed in the Start Address field
and the number of bytes selected will be displayed in the Size field; otherwise, the current cursor position will be
listed in the Start Address field and the last number of filled bytes will be listed in the Size field. The range of
bytes to overwrite can also be specified by using a start address and end address (see the Insert Bytes dialog
above for more information). A Byte Value can be entered as when using the Insert Bytes tool. Click OK to set all
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the bytes specified by the Range to the given Byte Value. The Cancel button will close the dialog with no changes.

Related Topics:
Inserting Files
Selecting Bytes
Setting the File Size
Using the Hex Editor
010 Editor v7.0 Manual - Windows Edition
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Inserting or Overwriting Files
A file can easily be inserted into another file using the Insert File or Overwrite File tools. The Insert File tool
inserts the bytes from another file into the current file at the current cursor position whereas the Overwrite File
overwrites any bytes in the current file with another file starting at the current cursor position. Access the Insert
File tool by clicking the 'Edit > Insert/Overwrite > Insert File...' menu option or pressing Ctrl+I. Access the
Overwrite File using the 'Edit > Insert/Overwrite > Overwrite File...' menu option.
Position the cursor at the address to insert or overwrite the file and activate the desired tool. Select any file with
the file dialog box that is shown and click the Open button. Note that files cannot be inserted into drives or
processes since the file size of drives and processes is always fixed (but data can be overwritten using the
Overwrite File tool).
NOTE: 010 Editor employs a read-on-demand data engine that allows even huge files to be instantly inserted or
overwritten. As a result, the inserted file should not be deleted until the edits have been saved to disk (see
Introduction to the Data Engine for more information).

Related Topics:
Inserting or Overwriting Bytes
Introduction to the Data Engine
010 Editor v7.0 Manual - Windows Edition
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Setting the File Size

010 Editor contains a useful tool for setting the number of bytes in the current file. Note that the size of drives
and processes is fixed and cannot be edited with this tool. Click the 'Edit > Set File Size...' menu option to display
the Set File Size dialog. Enter the desired file size in the Size field. Note that either hex or decimal formats can be
used, depending on the Hex and Decimal radio buttons. If the new file size is larger than the current file size, a
number of bytes will be appended to the file. The value of the inserted bytes can be controlled using the Hex,
Decimal, and Char fields in the Byte Value box. Note that when typing a value in one field, the other fields will
automatically display the converted value (the Char field is empty in the above screenshot because the byte
value 0 cannot be converted to a printable character). If the new file size is less than the current size, bytes will
be deleted from the end of the file. Click OK to perform the operation or Cancel to close the dialog.

Related Topics:
Inserting or Filling Bytes
010 Editor v7.0 Manual - Windows Edition
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File Properties
The File Properties dialog displays useful information about the current file. This dialog can be accessed from the
'Edit > File Properties...' menu option or by pressing Alt+Enter. The Properties dialog will display different
information if the current file is a logical drive, physical drive, or process. See below for the information
displayed.

The File Properties dialog displays the current File, Location, and Size in both hex and decimal formats. The
Created, Modified, and Accessed fields display the time and date when the file was created, last changed on disk,
and accessed from disk respectively. Note that on some operating systems, these dates are not always 100%
accurate.
The Attributes area shows the Read Only, Hidden, Archive, and System file flags from the operating system. Note
that these toggles can be clicked on to change the attributes of the file on disk.
Click the OK button to accept any file attributes changes, or the Cancel button to dismiss the File Properties
dialog without making any changes.

Logical Drive Properties
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The Drive Properties dialog display information about a logical drive (for example, 'C:' or 'D:'). The dialog lists the
current File System (NTFS, FAT, CDFS, etc.) plus the Serial Number of the drive.
Each drive is divided into a number of sectors and clusters (see Editing Drives for more information). The middle
section of the dialog gives the size of each sector and cluster, plus the number of free and total sectors and
clusters.
The bottom section of the dialog displays the total number of bytes in the drive, the number of bytes used, and
the number of free bytes. As well a graph indicates what percentage of the drive is full (yellow indicates used
bytes and blue indicates unused bytes).
Click the OK button to dismiss the Drive Properties dialog.

Physical Drive Properties

When editing a physical drive, the properties dialog will display a different set of information about the drive than
a logical drive (see above). For information on the difference between a logical and a physical drive, see Editing
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Drives.
A physical drive is made up of a number of sectors, tracks, and cylinders (see Editing Drives). The middle section
of the dialog lists the number of bytes per sector, track, and cylinder, as well as the total number of each on the
drive (the number of tracks and cylinders is not available on all devices). The bottom part of the dialog displays
the total number of bytes available on the drive. Note that information on how much of the drive is free or in use
is not available for physical drives.
Click the OK button to dismiss the Physical Drive Properties dialog.

Process Properties

If the current file is a process, then the Process Properties dialog will be displayed that contains information on
the current process. The top portion of the dialog lists the Process Name, and the number of Heaps and number
of Modules of the process (see Editing Processes for more information).
The bottom portion of the dialog displays the number of bytes that do not belong to the process (Unallocated
Bytes) and the number of bytes that are allocated by cannot be accessed (No Access Bytes). As well the total
number of bytes that are marked as read only is displayed (Read Only Bytes), the number of bytes that are
marked for reading and writing (Read/Write Bytes), and the total number of readable bytes (Total Readable
Bytes).
Click the OK button to dismiss the Process Properties dialog.

Related Topics:
Editing Drives
Editing Processes
Using the Workspace
010 Editor v7.0 Manual - Windows Edition
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Importing/Exporting Files
Importing and Exporting allows conversion between a binary file and a number of supported formats. When
importing or exporting files, the following formats are supported:














Hex Text - Stores a binary file as a text file containing a series of bytes in hexadecimal format. For
example, the hex bytes 0x3F and 0x61 would be stored as the characters "3F 61"
Decimal Text - Stores a binary file as a text file where each byte is converted to a decimal number.
For example, the hex byte 0xFF would be stored as the characters "255".
Binary Text - Stores a binary file as a text file where each byte is converted to a binary number. For
example, the binary byte 0x6F would be stored as the characters "01101111".
C Code or Java Code - Converts a binary file to an array of bytes that could be included in a C/C++ or
Java program. (When importing data, specify the import type as 'Source Code' and 010 Editor will
automatically detect whether the data is C or Java code).
Intel 8, 16, or 32-Bit Hex Code - Stores a binary file in the Intel Hex format. A number of different
variations of the format exist, including 8-bit, 16-bit, and 32-bit. The Intel Hex format is used in a
number of different applications and is commonly used with EPROMs.
Motorola S19, S28, or S37 Records - Motorola S-Record format is used for transferring binary files
and is commonly used with EPROMs.
Text Area - Stores the currently selected bytes as text exactly how they are displayed in the hex
editor, including addresses and both the left and right areas. For example:

0030h: 3031
0123456789:;<=>?
0040h: 4041
@ABCDEFGHIJKLMNO
0050h: 5051
PQRSTUVWXYZ[\]^_
0060h: 6061
`abcdefghijklmno
0070h: 7071
pqrstuvwxyz{|}~•

3233 3435 3637 3839 3A3B 3C3D 3E3F
4243 4445 4647 4849 4A4B 4C4D 4E4F
5253 5455 5657 5859 5A5B 5C5D 5E5F
6263 6465 6667 6869 6A6B 6C6D 6E6F
7273 7475 7677 7879 7A7B 7C7D 7E7F

Note that importing from this format is not supported.
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Web Page (HTML) - Similar to the Text Area option above except that the data is stored in HTML
format suitable for being placed on a webpage. Any coloring of the data is also recorded in the HTML
data. Note that data can only be exported into HTML format (importing is not supported).
Rich Text Format (RTF) - Similar to the Text Area option above except the data is stored in Rich Text
Format (also called RTF). This format is used by a number of word processors including Microsoft Word.
010 Editor includes all foreground and background coloring information with the RTF but note that some
programs such as Microsoft Word do not support having background colors in RTF data. Exporting to
HTML will retain both the foreground and background colors more reliably. Only export is supported for
this format.
Base64 - Base64 is a method of encoding binary data so that it may be transferred between different
systems without losing any special characters. This format is used when transferring attachments over
email and other applications on the internet. Both importing and exporting are supported for Base64
data.
Uuencoding - Uuencoding is a method of encoding data similar to Base64 but with different
parameters. Uuencoding is used for transferring attachments over email or newsgroups, as well as
other applications. Importing and exporting are both supported for uuencoded data.
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Importing Files
Files may be imported by clicking the 'File > Import Hex...' menu option. Select a file to import using the
displayed file dialog box. By default, all files that can be imported will be displayed and the file type will be set to
'All Supported Import Types' but the file type can be changed to only display files of one type. Once the file is
imported, it will be converted to a binary file and opened as a new file in the editor. Any of the above formats can
be imported into 010 Editor except where indicated. 010 Editor contains some special functionality for importing
Intel Hex or Motorola S-Records (see Opening Files for more information). The Directory Options dialog can be
used to control the initial directory when the file dialog box is displayed.
When importing a file, any bytes that are skipped are set to zero value by default; however, this value can be
changed using the Default Import Byte option in the Importing Options.
In some special Intel Hex files, the addresses specified in the file indicate the position of the Word where the data
exists. To convert from this Word-based addressing system to a Byte-based addressing system, enable the
Words toggle in the Importing Options dialog (internally, the addresses are multiplied by two). Note that leaving
this toggle enabled when the import file does not use Word-based addresses will cause undefined results.

Exporting Files
To export the current file to one of the above formats, open the file and click the 'File > Export Hex...' menu
option. The Export Hex dialog will be displayed.

Choose a file name for the exported file in the Export File field. A file name can also be chosen by clicking the
Browse button to the right of the field. The default directory for the file to export can be controlled using the
Directory Options dialog. Select which type of file to export using the Export Type drop-down list. Note that
changing the export type automatically modifies the extension of the file to save. The number of bytes per line in
the output file can be adjusted using the Bytes Per Row field.
To view advanced options for the file to export, click the Options button. Choose the Entire File radio button to
export all the bytes from the current file or if a selection is made, choose the Selection toggle button to only
export the selected bytes.
The Intel Hex and Motorola S-Records formats support specifying a starting address of the data. When the
Always Zero toggle is selected, the address will always be written as zero. If the Start of Range toggle is
selected, the starting address of the exported bytes will be written (this is usually zero unless a selection is
exported using the Selection toggle). A custom address can also be specified by selecting the Custom toggle and
entering a number in the corresponding text field.
When exporting Intel Hex files, the output addresses can set set to Byte-based addresses by selecting the Bytes
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toggle (the default) or to Word-based addresses by clicking the Words toggle. See the Importing Files section
above for more information on Word-based addresses. If the Words toggle is enabled, the addresses will be
divided by two when exporting.
Click the Export button to create the exported file, or the Cancel button to dismiss the dialog without exporting.

Importing or Exporting Data Through the Clipboard
A quick way of importing or exporting data exists in 010 Editor by using the clipboard. To quickly export data,
select the bytes to export and click 'Edit > Copy As' and then select the type of data to export. The data will be
exported and the results copied to the clipboard. Then the data can be pasted to another application (for
example, copy data to the clipboard using 'Edit > Copy As > Copy As Web Page (HTML)' and paste the data into
an HTML editor such as Microsoft Word). The data will be exporting using the same options as when the selected
format was last exported using the 'File > Export Hex...' menu option.
Data can be imported quickly into 010 Editor by copying the data to import to the clipboard, then clicking 'Edit >
Paste From' and choosing which format to import. The data will be imported and inserted into the file at the
current cursor position.

Related Topics:
Converting Files
Directory Options
Edit Menu
Importing Options
Opening Files
010 Editor v7.0 Manual - Windows Edition
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Command Line Parameters
-close -compare -drive -exit -exitnoerrors -goto -h -import -line -noui -nowarnings process
-replace -reset -resetall -save -saveall -script -select -readonly -readonlyall -template

Opening Files
A set of files to load can be specified on the command line when starting 010 Editor. Each file to load should be
separated by a space. For example, to load two files use:

010editor file1.dat file2.dat
Multiple files can be loaded on the command line by using the wildcards '*' and '?'. For example:

010editor *.bin file???.dat
By default, when 010 Editor is installed it is placed in the system path. This means that 010 Editor can be run
from any command line by entering '010editor' (no directory needs to be specified). This command line syntax
can be used to load files even if 010 Editor is already running. To not place 010 Editor in the path, disable the
'Add 010 Editor to the system path' toggle in the install program.

Opening Drives
Drives can be opened from the command line by using the -drive: command, followed by either a drive label or a
drive number. If a drive label is specified, a logical drive is opened and if a drive number is specified, a physical
drive is specified (see Editing Drives for more information). For example:

010editor -drive:C -drive:1
would open logical drive C: and physical drive 1.

Opening Processes
Processes can be opened using the -process: command, followed by either a process identification number or a
name of a process. For more information on working with processes, see the Editing Processes help topic. For
example, to open two processes from the command line use:

010editor -process:cmd.exe -process:1074
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Importing Files
To import any of the available file formats, use the -import: command, followed by the file to load. Any of the
accepted import or export types are accepted and the type used will be based from the file extension (see
Importing/Exporting Files for more information). For example, to import a C file use:

010editor -import:array.c
The wildcard characters '*' and '?' can also be used to import multiple files at the same time.

Position the Cursor
The cursor can automatically be positioned within a file using the -line: or -goto: commands. Specify -line:
followed by a number to jump to that line within the file. For example:

010editor file1.txt -line:100
To jump to a specific address within a file use the -goto: command followed by a number and the number may
be in any of the supported numeric formats. For example:

010editor file1.dat -goto:0x20
All the options from the Goto Bar are available, including using '+' or '-' to jump relative the current location or
'<' to jump relative the end of the file. For example, to skip over 32 bytes use:

010editor -goto:+32
Using -goto: to jump to a line, sector or word is also possible by including either ',l', ',s' or ',w' at the end of the
command respectively. For example, to jump to sector 0x100 in a file use:

010editor -goto:0x100,s
Note that versions of 010 Editor before version 6 could use '@' to jump to a location. This syntax is still allowed in
version 6 but will be deprecated in future versions.

Making Selections
Selections can be made in a file using the command -goto:<start>:<size>. Note that start and size refer to
bytes and any of the standard numeric formats are accepted. For example, to select 4 bytes starting from
address 16 use:

010editor -select:16:4
If start is empty, the selection is started from the current cursor position which can be controlled with the -goto
command. For example, to select 0x200 bytes starting from the cursor position use:

010editor -select::0x200
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Opening Scripts or Templates
Scripts or Templates can be run from the command line using the -script: or -template: command respectively.
See Introduction to Templates and Scripts for more information on Templates and Scripts. To run the script
IsASCII for example, use:

010editor -script:IsASCII.1sc
The file to run must exist in either the current directory, the current 'Scripts' directory if running a script, or the
current 'Templates' directory if running a template (these directories can be modified in the Compiling Options).
To open the Script or Template in the interface without running the file, specify a '@' symbol and a line number
after the filename. For example, to open the ZIPTemplate.bt file and position the cursor on the 3rd line, use:

010editor -template:ZIPTemplate.bt@3
Command line arguments can be passed to a script or template by using the syntax
:(<arg1>,<arg2>,...,<argN>) after the script or template command. For example:

010editor -script:MyScript.1sc:(15,Test)
would pass the two arguments "15" and "Test" to the MyScript.1sc script. To include spaces in any of the
arguments, place double quotes around the whole command. The arguments can be retrieved in the script or
template using the GetNumArgs, GetArg and GetArgW functions.

Saving and Closing Files
The current open file can be saved to disk by using the -save command. To save a file to a different file name,
use the command -save:<filename>. For example:

010editor temp.txt -save:temp.txt.bak
To save all modified files use the -saveall command or to close the current file, use the -close command.

Replacing Strings or Bytes
A string or a set of bytes can be replaced from the command line using the replace:<find_value>:<replace_value> command. For example:

010editor temp.txt -replace:apple:orange
would replace all occurrences of apple with orange in the file temp.txt. Note that if there are spaces in any of the
replace strings, surround the whole -replace command with double quotes. The replacement options can be
controlled, and special characters can be inserted into strings through the use of escape codes which start with
the character '\'. The following special escape codes can be used:
\m = match case
\w = match whole word
\p = pad with zeros
\a = perform replacement on all open files
\* = search with wildcards
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\\ = insert a '\' character
\: = insert a colon
\' = insert double quotes "
For example, to replace the string 'first' with 'second' using the match case and whole word options, use:

010editor -replace:first:second\m\w
Different data types can be indicated using a comma and type specifier after the value (e.g. ',h' indicates
hexidecimal bytes). For example, use

010editor -replace:0D0A,h:0A,h
to replace Windows linefeeds with Unix linefeeds. See the Find dialog for a list of type specifiers.

Comparing Files
Two files can be compared from the command line using the -compare:<fileA>::<fileB> or the compare:<fileA>::<fileB>::<options> command. For example:

010editor -compare:c:\01.dat::c:\02.dat
would run a regular binary comparison on the two given files. Notice the double-colon '::' between the file names
and if there are spaces in either file name, surround the whole -compare command with double quotes. To
specify options for the comparison, use another double-colon '::' after the second file name and specify one or
more of the following special escape codes (note that 'XXX' indicates a number):
\b = byte by byte comparison
\i = ignore case
\e = enable synchronized scrolling
\xXXX = max look-a-head
\nXXX = min match length
\qXXX = quick match length
\saXXX = limit start for file A
\sbXXX = limit start for file B
\zaXXX = limit size for file A
\zbXXX = limit size for file B
For example, to compare two files and ignore the case, use:

010editor -compare:c:\01.dat::c:\02.dat::\i
or to limit the comparison to the first 16 bytes of each file, use:

010editor -compare:c:\01.dat::c:\02.dat::\i\za16\zb16
See Comparing Files for an explanation of the different options for comparisons. Note that if a Max Look-a-head,
Min Match Length, or Quick Match is not specified the values from the last time the Compare dialog was run will
be used. Running '010editor -compare:' will give a list of all comparison options.

Running 010 Editor in Batch Files
If running 010 Editor from a batch file, it is possible to pass error level codes from a script or template back to
the batch file. First, in a script or template call the function Exit with an error code (e.g. 'Exit(95);'). Next, in a
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batch file start 010 Editor by using the syntax 'start /wait 010editor ...'. Afterwards the error code can be
accessed in the batch file using the variable %ERRORLEVEL%. For example:

start /wait 010editor test.txt -template:test.bt -exit
echo %ERRORLEVEL%

Running 010 Editor without a User Interface
When running 010 Editor from the command line, the software can be executed without a user interface by
specifying the -noui command. In this mode, the splash screen and main window of 010 Editor are not displayed
and the program will exit automatically when all the command line options are executed. Note that in this mode,
messages boxes may still be displayed on error messages and this may stop program execution until the
message box is cleared by the user. To disable the display of any message boxes, include the -nowarnings
option on the command line. The -noui command line option is very useful when running 010 Editor from a batch
file (see above).

Resetting the Application
Options for 010 Editor can be reset by using the command line. Specify the -reset command on startup to reset
just the docking panel positions. Specify -resetall to revert all application settings to their defaults. If 010 Editor
will not startup, specifying -reset or -resetall will usually fix the problem.

Exiting the Application
Use the -exit command to shut down 010 Editor from the command line (all unsaved modifications will be lost).
Alternately the -exitnoerrors command can be used to shut down 010 Editor only if no errors occurred. Here an
error is defined to be a Script or Template that did not compile or execute properly, or a Script or Template that
was halted using the Exit function with a negative error code.

Other Command Line Parameters
The -readonly command can be used to set the last opened file, drive, or process to Read Only and the readonlyall command sets all open files as Read Only. The -h command will display this manual page.
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Related Topics:
Compiling Options
Editing Drives
Editing Processes
Interface Functions
Introduction to Templates and Scripts
Importing/Exporting Files
Opening Files
Using Find
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Using Tool Bars

The Tool Bars are a set of icons along the top of the screen and most icons are associated with a command on
the main menu (the icon will appear to the left of the menu option when browsing the main menu). Some icons
have a small down arrow in the lower-right corner that indicates the icon will drop down a list of items when
clicked. Placing the mouse over an icon for a second will display a hint containing the name of the icon and the
keyboard shortcut.
Five different icons in the tool bar may be highlighted (pressed in) depending upon the current file. The Toggle
Hex Interface icon will be highlighted when the current file uses a hex-based File Interface, the Word Wrap icon
will be highlighted when the current text file is in Word Wrap mode, the Show Whitespace icon will be highlighted
when whitespace is visible in the file, the Column Mode icon will be highlighted when the current file is in column
mode, and the Toggle Endian icon will be highlighted when the current file is in big-endian mode (see Byte
Ordering for more information).
Right-click on the Tool Bar background to display a popup menu with a list of all Tool Bars. Click on a Tool Bar
name in the list to either show or hide that Tool Bar and this list can also be accessed from the View Menu. Tool
Bars can be customized by selecting Customize... from the right-click menu or clicking 'Tools > Options...' and
selecting Toolbars from the list (see Toolbar Options for more information).

Related Topics:
Edit Menu
File Menu
Introduction to Byte Ordering
Toolbar Options
Tools Menu
Using the Text Editor
View Menu
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
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Printing
010 Editor contains a powerful printing tool, complete with print preview, headers, footers, and margins. To
configure the display of the current page, see the Page Setup Dialog. To obtain a preview of how the document
will appear when printed, see the Print Preview Dialog. Once the document is configured properly, click the 'File >
Print...' menu option to open the Print Dialog (note that the Print Dialog may appear slightly different than below
depending on the operating system).

Select the output printer from the Select Printer list box. Printer-specific options can be edited by clicking the
Preferences button.
Select which pages to print using the Print Range options. All prints the whole document. The Pages radio button
can be used to print a range of pages. If a selection is made in the current document, the Selection radio toggle
can be selected to print just the selected bytes.
More that one copy of the current document can be printed by entering a number into the Number of copies field.
When printing documents of more than one page, the copies can be collated or uncollated by clicking the Collate
toggle (if your printer supports this option). For example, if 2 copies of a document of 3 pages are printed, the
page order when collated would be 1, 2, 3, 1, 2, 3, and the page order when uncollated would be 1, 1, 2, 2, 3, 3.
Click the Print button to send the document to the printer, or the Cancel button to close the dialog.

Related Topics:
Page Setup
Print Preview
010 Editor v7.0 Manual - Windows Edition
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Print Preview
The Print Preview dialog shows an image representing how the current document would appear if printed. This
dialog shows a series of pages, complete with margins, header, and footer. The 'File > Print Preview...' menu
option can be used to access the Print Preview dialog.

When the mouse cursor is positioned over the document, the cursor will change to a magnifying glass. Click the
left mouse button to zoom into medium-resolution mode and click again to zoom into high-resolution mode.
Clicking the mouse a third time will return to low-resolution mode. Note that the Zoom In and Zoom Out icons
(located at the top-right of the dialog) can also be used to change the zoom factor.
A text field at the top of the dialog shows the current page number and the total number of pages (indicated as
'Page <current> of <total>'). A value can be typed into the page number text field to jump to a particular page.
Clicking the Next Page or Previous Page icons (the left and right arrows) will view the next or previous page in
the document respectively. The First Page or Last Page icons (the left and right arrows with a vertical bar) will
view the first or last page in the document respectively. The mouse wheel can also be used to scan through the
pages to print.
Clicking the 'Print...' button will show the Print Dialog that can be used to send the document to the printer (see
Printing for more information). The Cancel button will close the current dialog. Finally, the Page Setup... button
will display the Page Setup dialog that is used to configure the margins, font, headers, and orientation for the
document (see Page Setup for more information).

Related Topics:
Page Setup
Printing
010 Editor v7.0 Manual - Windows Edition
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Page Setup
The Page Setup dialog controls how the page appears when printing. Use the Page Setup dialog to set margins,
headers and footers, fonts, and paper orientation for printing. Click the 'File > Page Setup...' menu option to
open the dialog.

When printing a file, most of the options from the current File Interface are used, except for the font and number
of bytes per row (when printing hex data). Click the Font button to set the font to use for the printer. Use the
Bytes Per Row field to control how many bytes are printed on each line of the output.
The Header and Footer fields control the text displayed in the top and bottom margins respectively. Text entered
into either of the Left fields will appear left-justified and text entered into either of the Right fields will appear
right-justified. Similarly, text in the Center fields will appear in the center of the page. Each field can contain a
combination of regular text and special codes, indicated by a '%' symbol followed by one or two characters. Click
the Insert > button to see a full list of available codes and click one of the codes from the list to enter it into the
current text field. When the page is printed, the special codes will be replaced with the required information. The
following is a list of available codes:














File Name (%f) - The name of the file to be printed without path.
File Path (%F) - The name of the file to be printed included path.
Current Page (%p) - Current page number being printed.
Total Pages (%P) - Total number of pages in document.
File Time - AM/PM (%t) - Last modified time for the file, displayed with am/pm indictor.
File Time - 24 Hour (%T) - Last modified time for the file, displayed in 24-hour format.
File Date - Short (%d) - Last modified date for the file, displayed in 'MM/DD/YY' format.
File Date - Long (%D) - Last modified date for the file, displayed in 'Weekday, Month DD, YYYY'
format.
Current Time - AM/PM (%ct) - Current time, displayed with am/pm indictor.
Current Time - 24 Hour (%cT) - Current time, displayed in 24-hour format.
Current Date - Short (%cd) - Current date, displayed in 'MM/DD/YY' format.
Current Date - Long (%cD) - Current date, displayed in 'Weekday, Month DD, YYYY' format.

The Margin fields indicate how much space is required from the edge of the paper to the start of the hex printout.
Note that the Header and Footer are printed in the margins. Enter a value in the Top, Right, Bottom, or Left fields
to control the margin size in either of those directions. If the Units radio buttons is set to inches, the fields will be
displayed in number of inches. If the Units radio button is set to cm, the fields will be displayed in centimeters.
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Print Setup
Click the Print Setup button to show the Print Setup dialog. The dialog may be used to choose the printer used
when printing. Also, the size or source of the paper can be chosen. Click the Portrait radio button to print in
portrait (upright) format, or the Landscape button to print in landscape (sideways) format.

Click the Print Preview button in the Page Setup dialog to close the dialog and display the Print Preview (see Print
Preview). Clicking the Print button will close the dialog and open the Print dialog (see Printing). Press the OK
button to close the dialog with the current changes made or the Cancel button to discard all changes.

Related Topics:
Print Preview
Printing
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
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Calculator
The Calculator provided with 010 Editor is a full expression calculator using a syntax similar to C. The calculator
can be loaded by clicking the 'Tools > Calculator...' menu option or pressing F8.

Enter values into the calculator by clicking the buttons at the bottom of the calculator or by typing on the
keyboard. Note that many common letters, numbers, and symbols can be entered by clicking the calculator
buttons but some of the advanced features of the calculator are accessible only by typing commands on the
keyboard.
Click the Backspace button to delete the character to the left of the current cursor position or press the Clear
button to delete all information in the calculator. Clicking the Copy button copies the last result to the Windows
clipboard and clicking the Run or '=' button will evaluate the current expression and display the result in the
calculator window.

Expressions
For evaluating simple expressions, enter an expression in the calculator with no semi-colon (';') at the end of the
line. Note that when entering hexadecimal numbers, place an 'h' after the number (for example '2Fh'). Because
the calculator uses C-syntax, make sure to place a '0' before any hexadecimal numbers that begin with a letter
(for example, you must use '0FFh' instead of just 'FFh'). Click the Run button or press F8 again to display the
results in the calculator. For example:

1000h+512*123
will display the result '67072 [10600h]'. If a semi-colon is included at the end of the line, the expression is
treated as a C program and to display results the return keyword must be used. For example:

return 0x1000 + 512*123;
All standard C operators are supported including +, -, *, /, ~, ^, &, %, |, <<, >>, ?:, brackets, etc. Decimal,
hex, octal, and binary number formats are supported. For example:
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(312 + 013) * (0x1000 | 0b10)
See Script Basics and Expressions for more information on expressions.

Variables
Variables can also be declared and used in the calculator using C syntax. For example:

int x = 0x4210 + 512;
int y = (x << 16) + x;
return y;
A variable declared in the calculator will be displayed in the Variables tab of the Inspector. Strings and arrays are
also supported. See Data Types for a full list of supported data types.

Functions
010 Editor includes a number of functions for math operations, editing files, editing strings, and interacting with
the interface. Most functions are similar to their C counterparts but have a capital first letter. The Printf function
is supported and can be used for displaying text in the Output tab of the Output panel. For example:

Printf( "Integer result = %d, String result = '%s'\n",
0x24 << 3, "Test" );
See Interface Functions, I/O Functions, String Functions, Math Functions, or Tool Functions for a full list of
functions.

Related Topics:
Data Types
Expressions
Introduction to Templates and Scripts
Interface Functions
I/O Functions
Math Functions
Script Basics
String Functions
Tool Functions
010 Editor v7.0 Manual - Windows Edition
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Comparing Files
The Compare Files tool allows the binary comparison of two files or two blocks of data for byte-by-byte
differences. Note that this comparison is different that most text editors which only compare line-by-line. Access
the Compare Files tool by clicking the 'Tools > Compare Files...' menu option.

Compare Dialog

Enter the two files to compare in the File A and File B fields. Each field contains a drop-down list of all open and
recent files. Click the browse button beside either field to use a file dialog box to select a file. Note that if exactly
two files are open in the main Tab Group in 010 Editor, the file names for those two files will be automatically
entered in these fields.
The Comparison tool supports two different algorithms: Binary and Byte by Byte. The Byte by Byte algorithm
compares corresponding bytes between the two files (e.g. each byte at address n of file A is compared only
against the byte at address n of file B) and will usually run quickly. The Binary algorithm tries to identify blocks
within the files that match. This algorithm is fast when the number of differences is low between the files, but
slows down if a number of differences exist (the algorithm is O(d2) where d is the number of differences). Select
which algorithm to use in the Comparison Type box.
Two options exist for running comparisons in the Options box. If the Match Case toggle is enabled, then ASCII
strings must match exactly, otherwise strings with a mixture of upper and lowercase letters will match. If the
Enable Synchronized Scrolling toggle is enabled then after the comparison, scrolling one of the files will cause the
other file to scroll as well. Synchronized scrolling can be turned off using the 'Window > Synchronize Scrolling'
menu option (see the Window Menu for more information).
Other advanced options can be viewed by clicking the Advanced Options button. The display of the files after the
comparison is determined by the Display Files box. If the Tile Horizontal toggle is set, the two files will be stacked
one on top of the other. If the Tile Vertically toggle is selected, the files will be stacked side-by-side. The files will
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not be moved if the Do Not Tile toggle is selected.
For the Binary algorithm, a limit can be put on the number of bytes the algorithm searches forward by entering a
value in the Max Look-a-head field. The higher the value, the slower the algorithm may run. The Min Match
Length field indicates the minimum number of consecutive bytes that must match to display a match in the final
output. For higher values, random data is less likely to match, but for lower values, small matches might be
ignored. The algorithm contains a heuristic that allows it to quickly accept matches of a certain size. Enter a valid
in the Quick Match field to indicate the minimum number of bytes that must match for the heuristic. The lower
the value, the faster the algorithm will run but the results may be less accurate.
Click the Compare button to run the algorithm and display the results in the Output Window. The Cancel button
will dismiss the dialog when pressed.

Comparing Blocks of Data
The binary comparison tool can also compare two blocks of data in two different files, or two blocks of data in the
same file. Blocks to compare are specified in the Limit Comparison box. To compare only part of file A, click the
File A toggle and enter the starting address of the block and number of bytes in the block in the Start and Size
fields respectively. If the set of bytes to compare has been selected in the file, click the Get Selection icon to copy
the start and size of the current selection into the proper fields. If the File A toggle is disabled, then the
comparison will use the entire file A. Similarly, to limit the bytes compared in file B, enable the File B toggle and
enter values in the Start and Size fields.
To compare two blocks of data in the same file, set the file name for File A and File B to be the same file name.
Then specify which blocks of data to compare in the Limit Comparison box. Clicking the Compare button will
cause two views of the file to be opened as could be done with the 'Window > Duplicate Window' menu option.

Output Window
The Output Window will appear after a comparison is run. This window displays a list of all matches and
differences, plus a graphical representation of how the files match.

The Result field can indicate a Difference, a Match, or may say Only In A or Only In B if a block exists only in one
of the two files. Address A and Start A indicate the start and size of the block in the first file, and Address B and
Start B indicate the start and size of the block in the second file. Selecting an entry from the list will highlight the
block in both files and also highlight the block in the graph. The display format for each column can be set to
hexadecimal or decimal by right-clicking on the Output Window and selecting 'Column Display Format'. Data can
be sorted in the display by clicking on one of the column headers. For example, to see all the matches and
differences grouped together, click on the Result column header.
The graph contains a representation of both files, side by side. Matched areas are shown in gray, differences are
shown as red, and blocks that are only in one file are displayed as yellow. When a range is selected, a white box
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is drawn around the range in the graph. Below the graph is a number indicating the number of ranges in the
comparison.
After the comparison is run, the files will be colored according to which bytes match. Bytes that are different will
be displayed as light red and bytes that are only in one file will be displayed as light yellow (see Color Options to
change the colors). Right-click the Output Window and select 'Clear' to clear the results from the comparison.
Press the Esc key in the Output Window to hide the window.

Related Topics:
Color Options
Window Menu
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Hex Operations
The Hex Operations tool provides any easy way to apply mathematical operations to a set of bytes. Open the Hex
Operations dialog by clicking the 'Tools > Hex Operations' menu option and selecting an operation from the list.

All hex operations treat the bytes in the file as an array. Select the data type of the array by choosing a type
from the Treat Data As drop-down list. Enter a number in the Operand field using any of the formats described in
the Introduction to Number Systems. Note that the operand is assumed to be hex if the Hex toggle is set, or
decimal if the Decimal toggle is set. How the Operand is applied to the data is dependant upon which operation is
selected. The following list describes each operation in C notation, assuming that X[i] represents each value in
the file to be modified.
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Assign: X[i] = Operand
Add: X[i] += Operand (this is equivalent to X[i] = X[i] + Operand)
Subtract: X[i] -= Operand (this is equivalent to X[i] = X[i] - Operand)
Multiply: X[i] *= Operand (this is equivalent to X[i] = X[i] * Operand)
Divide: X[i] /= Operand (this is equivalent to X[i] = X[i] / Operand)
Negate: X[i] = -X[i]
Modulus: X[i] = X[i] % Operand (the modulus operator % computes the remainder after dividing X[i]
by the Operand)
Set Minimum: Sets a minimum limit for X[i]. If X[i] is less than the Operand, X[i] is set to the
Operand.
Set Maximum: Sets a maximum limit for X[i]. If X[i] is greater than the Operand, X[i] is set to the
Operand.
Swap Bytes: Swap the bytes of X[i]
Binary And: X[i] &= Operand
Binary Or: X[i] |= Operand
Binary Xor: X[i] ^= Operand
Binary Invert: X[i] = ~X[i]
Shift Left: X[i] <<= Operand
Shift Right: X[i] >>= Operand
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Block Shift Left: Similar to Shift Left except data is treated as one long block. Bytes shifted off of
X[i+1] will be shifted onto X[i].
Block Shift Right: Similar to Shift Right except data is treated as one long block. Bytes shifted off of
X[i] will be shifted onto X[i+1].
Rotate Left: Similar to Shift Left except that bytes shifted off of X[i] will be added to the right side of
X[i].
Rotate Right: Similar to Shift Right except that bytes shifted off of X[i] will be added to the left side of
X[i].

Note that the Operand is not used for some operations and some operations can only be used on certain data
types. A description of the selected operation is shown in the Description box and further options for the dialog
can be controlled by clicking the Options button.
If no bytes are selected in the file, the Operation will be applied to the whole file. If a selection is made, the
Operation will be applied to the selected bytes if the Selection toggle is set, or the whole file if the Entire File
toggle is set. By default, the data for the operation will be assumed to have the same endian as the file (see
Introduction to Byte Ordering for more information). To change the endian of the operation, click the Little Endian
or the Big Endian toggle.
The Advanced box contains two fields: Operand Step and Skip Bytes. If a value is entered in Operand Step, that
value will be added to the Operand after modifying each value in the file. The Operand Step can be used to easily
perform a number of complex operations, including building arrays. For example, select 256 bytes in a file and
perform an Assign operation on the bytes with an Operand of '0' and an Operand Step of '1'. The result will be an
array with the values 0 up to 255.
If a value is entered in the Skip Bytes field, that number of bytes will be skipped after each value is modified in
the file. This feature can be used to skip over bytes that should not be modified. For example, if a binary file
contains a series of employee records containing an integer ID number followed by a 40 character Name, the
Skip Bytes field can be used to modify the ID number without modifying the Name. Use an Add operation on
integers with '1' as the Operand and '40' as the Skip Bytes value.
For more complex operations, scripts can be used. See Introduction to Templates and Scripts for more
information.

Related Topics:
Introduction to Byte Ordering
Introduction to Number Systems
Introduction to Templates and Scripts
010 Editor v7.0 Manual - Windows Edition
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Converting Files
The conversion tool supplied with 010 Editor can be used to convert bytes from one character set to another and
can also transform linefeeds from one type to another. Select 'Tools > Convert' or press Ctrl+T to open the
Convert Dialog.

In the Convert dialog choose which character set to convert from using the Source Character Set drop-down list.
The source character set will automatically be filled from the current File Interface. Next select which character
set to convert to using the Target Character Set list (by default the target character set is the same as the
source). To not apply any special conversions to the linefeeds of a text file, leave the Target Linefeeds list set to
'(No Change)'. Selecting a linefeed type from the Target Linefeeds list will transform all linefeeds found in the file
to the indicated type. The Convert dialog can be used to only modify only the linefeeds by leaving the source and
the target character set the same. See Working with File Interfaces for more information on character sets and
linefeeds.
Some text files contain a sequence of bytes at the beginning of the file to indicate which character set is used in
the file and this is called a Byte-Order Mark or BOM. Byte-Order Marks are only currently used for Unicode or
UTF-8 files. When the Convert dialog is opened for a Unicode or UTF-8 text file that contains a BOM, the Include
Byte Order Mark (BOM) toggle will be set and the text '(currently exists)' will be included after the toggle. When
converting a Unicode or UTF-8 file that does not contain a BOM, the Include Byte Order Mark (BOM) will be
unchecked and the text '(not present)' will be shown. When the Target Character Set is Unicode or UTF-8, set the
Include Byte Order Mark (BOM) toggle to add a BOM to the file or uncheck the toggle to remove the BOM. The
toggle will be disabled when the Target Character Set is not Unicode or UTF-8. See Byte-Order Marks for more
information on using BOMs with the editor.
If no bytes are selected in the file when the conversion is performed, the conversion will be applied to every byte
in the file. If a selection is made the Conversion may be applied to just the selected bytes by clicking the Options
button and choosing the Selection toggle (the default). Alternately, select the Entire File toggle to convert the
whole file. Sometimes there is no equivalent character when converting data from one character set to another
(for example when converting Unicode to ASCII). Any characters that the dialog cannot convert will be assigned
the byte value listed in the Replace Invalid Characters With box (the default is the space character 0x20).
Clicking Convert will perform the conversion or clicking Cancel will close the dialog. Double-clicking on an item in
the Target Character Set or Target Linefeeds list will also perform the conversion. Note that if converting a whole
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text file, 010 Editor may automatically change the current File Interface.
Files can also be converted to other formats using the 'File > Import Hex...' or 'File > Export Hex...' tools (see
Importing/Exporting Files for more information).

Related Topics:
Importing/Exporting Files
Introduction to Byte Ordering
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Histograms
A histogram is a graph which indicates how often certain data values occur in a file. Click the 'Tools > Histogram'
menu option to calculate and display the histogram for the current file.

A histogram is calculated by first interpreting the file as an array of data. Select the data type for the array by
selecting a value from the Treat Data As drop-down list (see Using the Inspector for more information on
different data types). Then the histogram generates a number of buckets and places each value into a bucket
depending upon its value. For example, the most common histogram treats the data as unsigned bytes and uses
256 buckets. Bytes in the file with value 0 are placed into the first bucket, bytes with value 1 are placed into the
second bucket, etc. The graph generated indicates how many values were placed into each bucket.
Click the Options button to control the range and bucket configuration for the histogram. By default, 010 Editor
generates 256 buckets to place values but the number of buckets can be modified using the Number of Buckets
field. The minimum and maximum accepted values can be edited by modifying the Minimum Value and Maximum
Value fields respectively. The values that each bucket holds is calculated by dividing the range specified by the
minimum and maximum values into Number of Buckets equal intervals. Any values in the file outside the
minimum and maximum values are ignored in the histogram calculation.
If no selection is made on the file, the Histogram will be run on the entire file. If a selection is made, select the
Selection toggle to calculate the histogram based only on the selected bytes (the default), or select Entire File to
calculate the histogram on all bytes in the file.

Output Window

The result of the histogram will be shown in the Output Window. On the right side of the window is a table of all
the different buckets (see above for an explanation of the buckets). The Dec, Hex, and Char fields indicate the
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values in a particular bucket in different formats. The Count field indicates the number times a value was placed
into a bucket and the Percent field indicates the percentage of all the values that were placed into the bucket.
Note that the Char field will display characters using the character set of the current file if the file is using a
simple character set; however, if the file is using a more complex multi-byte character set such as UTF-16, UTF8, or Chinese, this field will just display ASCII values. The table can be sorted by clicking on one of the field
headings.
A graph is displayed in the left area with percentage running along the vertical axis and value running along the
horizontal axis. A blue bar indicates the percentage of each value. Selecting a bucket in the output table will
highlight the corresponding bar as yellow in the graph. To clear the histogram, right click on the Output Window
and select 'Clear'. Press the Esc key in the Output Window to hide the window.

Related Topics:
Using the Inspector
010 Editor v7.0 Manual - Windows Edition
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Check Sum/Hash Algorithms
The Check Sum tool can be used to apply a number of Check Sum or Hash Algorithms to the current file. Run the
Check Sum tool by clicking the 'Tools > Check Sum...' menu option or press Ctrl+K.

Select which Check Sum algorithms to perform on the file by checking or unchecking the algorithm name in the
Algorithms list. Note that all algorithms can be selected or deselected at once by clicking the box beside the
Algorithms label. The following algorithms are supported:





















Checksum - UByte (8 bit)
Checksum - UShort (16 bit) - Little Endian
Checksum - UShort (16 bit) - Big Endian
Checksum - UInt (32 bit) - Little Endian
Checksum - UInt (32 bit) - Big Endian
Checksum - UInt64 (64 bit) - Little Endian
Checksum - UInt64 (64 bit) - Big Endian
CRC-16
CRC-16/CCITT
CRC-32
Adler32
MD2
MD4
MD5
RIPEMD160
SHA-1
SHA-256
SHA-512
TIGER

Most checksum algorithms treat the data file as a list of unsigned bytes and then sum the values of those bytes
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(this type of algorithm can be performed by selecting the Checkum - UByte algorithm). However, some checksum
algorithms need to treat the data file as a list of unsigned shorts, ints, or int64s (see Using the Inspector for
more information on different data types). These type of checksums can be calculated by selecting the Checksum
- UShort, Checksum - UInt, or Checksum - UInt64 algorithms respectively. Note that there are two versions of
these algorithms, one where the file is treated as Little Endian and one where the file is treated as Big Endian
(see Introduction to Byte Ordering for more information on endianness). For unsigned short, int, or int64
checksum algorithms the data will be padded with zeros if the data size is not a multiple of the data type size.
The details of the other algorithms are beyond the scope of this help file.

Some advanced options can be controlled by clicking the Options button. If no bytes are selected in the file when
the Check Sum tool is run, the algorithms will be applied to all bytes in the file. When a selection is made, select
the Selection toggle in the dialog box to apply the algorithms to only the selected bytes (the default), or the
Entire File toggle to apply the algorithms to all bytes.
Besides limiting the checksum to the selected bytes, explicitly excluding certain byte ranges is possible by
enabling the Ignore Byte Ranges toggle and entered ranges in the associated field. Multiple addresses can be
indicated using commas, and a range of addresses can be indicated using '..' between two addresses (the range
is inclusive). Any of the standard numeric formats can be used in the field. For example, entering the ranges
'512..515,0x1000' would ignore the 4 bytes starting at position 512, and the single byte at 0x1000. This feature
is useful to calculate the checksums for files where the actual checksum is stored in the file and thus should be
excluded from the calculation.
The CRC-16, CRC-16/CCITT and CRC-32 algorithms can be customized by clicking the Options button and using
the Custom Polynomials section. Enable the toggle beside the name of the algorithm to customize, and then
enter the starting value for the CRC in the Initial Value field and the polynomial for the algorithm in the
Polynomial field. Clicking the Reset button to the right of an algorithm resets all values for that algorithm to their
default values. Note that different polynomials exist for some algorithms depending upon how the algorithm is
implemented internally and this dialog lists the default polynomials for how 010 Editor has implemented the
algorithms.
Click the OK button to perform the calculation or click the Cancel button to dismiss the dialog.

Output Window
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The results of the different algorithms are displayed in the Output Window. The algorithm name is listed under
the Algorithm column and the result is displayed in the Check Sum/Digest column. The result can be copied to
the clipboard by right-clicking the Output Window and selecting 'Copy'.
By default, all checksums will be displayed as a 64-bit number in hex notation where the first 32 bits and the last
32 bits are separated by a space (for example, "00000000 00007F80"). The checksums can be configured to only
display 32, 16, or 8 bits instead of 64 by right-clicking on the Checksum/Digest column and selecting the
Checksum Precision menu option. Also, the results can be displayed in decimal notation by right-clicking on the
Checksum/Digest column and selecting the Column Display Format menu option. Select 'Clear' from the rightclick menu to clear all of the results. Press the Esc key in the Output Window to hide the window.

Related Topics:
Introduction to Byte Ordering
Using the Inspector
010 Editor v7.0 Manual - Windows Edition
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Base Converter
The Base Converter is an easy-to-use tool for converting between decimal, hexadecimal, octal, and binary
numeric formats, plus a number of floating point and string formats. Click the 'Tools > Base Converter...' menu
option to display the Base Converter window.

Type a number into either the Decimal, Hex, Octal, or Binary field. The number will be converted into the other
three formats and displayed in the corresponding fields. If an invalid number is entered, the other fields will be
cleared. See the Introduction to Number Systems for more information on numeric formats.
If a number is entered into the Float or Double fields, the number will be converted from its floating point value
to a binary encoding (4 bytes for a Float and 8 bytes for a Double). The binary data will be displayed as a set of 4
or 8 numbers in the Decimal, Hex, Octal, and Binary fields. Note that the endianness of the binary data can be
controlled with the Little Endian and Big Endian toggles at the bottom of the dialog (see Introduction to Byte
Ordering).
If a string or character is entered in the ASCII, EBCDIC, or UNICODE fields, the string will be converted to a set
of binary bytes. These bytes will be displayed as a set of numbers in the Hex, Octal, and Binary fields. Note that
UNICODE strings have 2 bytes per character and the endianness of the UNICODE data can be controlled using the
Little Endian and Big Endian toggles at the bottom of the dialog.
The Base Converter dialog can be left open while working in other windows in the editor and the window can be
resized horizontally to enlarge or shrink the fields. Click the Close button to dismiss the dialog.

Related Topics:
Introduction to Byte Ordering
Introduction to Number Systems
010 Editor v7.0 Manual - Windows Edition
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Introduction to Templates and Scripts
One of the most powerful features of 010 Editor is the ability to run Binary Templates and Scripts. A Binary
Template allows a binary file to be understood by parsing the file into a hierarchical structure. Templates have a
similar syntax to C/C++ structs but they are run as a program. Every time a variable is declared in the Template,
the variable is mapped to a set of bytes in the current file. For example, the following is a simple Template:

struct FILE {
struct HEADER {
char
type[4];
int
version;
int
numRecords;
} header;
struct RECORD {
int
employeeId;
char
name[40];
float
salary;
} record[ header.numRecords ];
} file;
The variable type is mapped to the bytes 0 to 3 in the file, version is mapped to the bytes 4 to 7, and
numRecords is mapped to the bytes 8 to 11. Any time a variable is accessed, its value is read from the file, and
any time the variable is assigned, its value is written to the file. These structures are different from regular C
since they can contain control statements such as if, for, or while. Templates are executed in a similar fashion to
an interpreter, where each line is executing starting from the top of the file.
A Script file also has a similar syntax to C and can be used to edit variables defined in a Template. For example,
the Script:

int i;
for( i = 0; i < file.header.numRecords; i++ )
file.record[i].salary *= 2.0;
can be used to double every employee's salary using the Template. Scripts can be used with Templates, or on
their own to edit files or interact with the 010 Editor program. Scripts can also be used as macros to simplify
repetitive tasks.
For an example of using Templates to parse files, open a ZIP, BMP, or BMP file and look at the Template Results
panel below the Hex Editor Window. For more information see:



Working with Template Results

Binary Templates are stored as text files with extension ".bt" and Scripts are stored as text files with extension
".1sc". For information on executing Scripts or Templates see:
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For an introduction to writing Templates see:



Template Basics

For information on writing Scripts see:



Script Basics

Binary Templates and Scripts others have created can easily be downloaded and installed from the 010 Editor
Repository. See:



Introduction to the Repository

Although Templates are initially compiled, they are executed similar to an interpreter. The execution starts at the
first line of Template and continues line by line, obeying any control statements encountered.

Related Topics:
Introduction to the Repository
Script Basics
Template Basics
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com

Copyright © 2003-2016 SweetScape Software

117

010 Editor - Reference Manual

Running Templates and Scripts
Running Templates
A number of ways exist to run a Binary Template. The easiest is simply to open a file and if 010 Editor has a
Binary Template installed for that type of file the Template will be run automatically. 010 Editor comes
preinstalled with Binary Templates for BMP, WAV, and ZIP files but other Templates can be installed (see
Template Options or the Repository Dialog for more information). Templates can also be run by clicking on the
name of a Template in the 'Templates' menu (Templates can be installed on this menu using the Template
Options dialog or the Repository Dialog).

Another method of running Binary Templates is to use the File Bar above each editor. When editing a data file
(i.e. a file that is not a Template or Script), the File Bar will contain sections marked Run Script and Run
Template as shown above. Click the Run Template area to display a drop-down list of Installed Templates, Open
Templates, and Recent Templates. Click on a Template name in the list to execute that Template on the current
file. Once a Template has been selected for a file, the Run Template area will indicate Run Template:
<template_name> followed by the icon . Click this icon or press F5 to rerun the template.
At the bottom of the drop-down list are four icons which can be used for creating a new Template, opening a
Template, editing the Template associated to this file, or editing the list of Installed Templates, respectively. Note
that the drop-down list can be resized by clicking and dragging the handle at the bottom-right corner of the list
and 010 Editor will remember the chosen size.

When editing a Template (the Edit As area will display Edit As: Template) the File Bar will now contain the section
Run on File as shown above. Clicking the Run on File area will display a list of all files currently open, but will not
include any Scripts or Templates. Click a file in the drop-down list to run the current Template on that file. Once a
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file has been selected, this area will indicate Run on File: <file_name> and clicking the icon or pressing F5 will
rerun the current Template. Clicking the Open icon at the bottom of the drop-down list allows opening a file and
then immediately running the current Template on that file. The Repository section of the File Bar is discussed in
the Repository Menu help topic.
If an error occurs while running a Template, an error message will be displayed in the Output tab of the Output
Window. Double-clicking on an error message will move the cursor to the line where the error occurred.
Templates can also be run using the Command Line. Once a Template has been run the Working with Template
Results help topic describes how to use the results.

Running Scripts
Similar to running Templates, Scripts can be run by clicking on a script name in the 'Scripts' menu (see the Script
Options dialog for information on placing a Script on this menu plus a list of all available scripts). Also, through
the same dialog Scripts can be set to run when a certain file type is opened or can be set to run automatically on
application startup or shutdown. See the Repository Dialog for information on installing Scripts that other people
have submitted to the repository.

Alternately, Scripts can be run using the File Bar at the top of each editor. When editing a file that is not a Script
or Template, the File Bar will contain two sections marked Run Script and Run Template. Click the Run Script
area and select a script from the list of Installed Scripts, Open Scripts, or Recent Scripts to run that script on the
current file. After a Script has been selected for a file, the Run Script area will display Run Script: <script_name>
followed by the icon . Click this icon or press F7 to run the script again.
At the bottom of the drop-down list four icons exist. These icons can be used for creating a new Script, opening a
Script, editing the Script associated with this file, or editing the list of Installed Scripts. The drop-down list can
also be resized by clicking and dragging the handle at the bottom-right corner of the list.

If the current file being edited is a Script (the Edit As area will display Edit As: Script) the File Bar will now display
a section Run on File. Click the Run on File section and select a file from the drop-down list of all open files to run
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the current Script on that file. Some Scripts may be run without a target file by clicking the icon or by selecting
'(none)' from the drop-down list. After a file has been chosen, this area will show Run on File: <file_name> and
clicking the icon or pressing F7 will rerun the current Script on the selected file. The Open icon at the bottom of
the drop-down list can be used to open a file and immediately run the current Script on that file.
If an error occurs while running a Script, an error message will be displayed in the Output tab of the Output
Window. Double-click an error message to view the line where the error occurred. Scripts can be run using the
Command Line as well. After a Script has been run (and assuming the Script is loaded in the interface) select the
Script and click on the Variables tab of the Inspector to view the variables created by the Script.

Related Topics:
Command Line Parameters
Script Options
Template Basics
Template Options
Using the Inspector
Using the Repository Dialog
Using the Repository Menu
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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Working with Template Results

The Template Results panel displays variables that were generated by running a Binary Template on a file (see
Introduction to Templates and Scripts) and this panel is shown by default attached to the bottom of the Hex
Editor Window (see Using the Hex Editor). To hide the Template Results panel click on the 'x' icon to the right of
the Template Results title or click the 'View > Template Results' menu option when a file is opened. If the
Template Results panel is hidden, it can be shown by clicking the 'View > Template Results' menu option or by
clicking the button underneath the vertical scroll bar and dragging upwards (see the diagram at the bottom of
this page). The Template Results can be attached to the right side of the Hex Editor Window by right-clicking on
the Template Results and choosing the Template Results Position menu option. Alternately, the Template
variables can be viewed by clicking on the Variables tab of the Inspector. To see an example of a Template open
any ZIP, BMP, or WAV file on your computer and a Binary Template will automatically be run and the results
displayed.
All variables are displayed in a hierarchal list. If a variable in the list has a '+' beside it that variable is either a
structure or array. Clicking the plus or double-clicking the variable will show all members within that variable. If a
variable has a '-' beside it click the minus or double-click the variable to hide all members. A variable can also be
opened using the Ctrl+Right Arrow key combination or the Right Arrow key while the cursor is in the right-most
column. A variable can be closed using the Ctrl+Left Arrow key combination or by pressing the Left Arrow when
the cursor is in the left-most column. When a variable is selected, the bytes that correspond to that variable are
selected in the file.
To open the entire sub-tree below a variable, right-click on a variable with the mouse and select the Expand All
Children of Node menu option, or right-click on a variable and select Expand All Nodes to open all children of all
nodes in the tree (note that the syntax '<open=suppress>' can be used after a variable to prevent it from being
opened in an Expand All operation). To locate a variable in the list that corresponds to a byte position in the file,
position the cursor over a byte in the Hex Editor Window and then use the 'Search > Jump to Template Variable'
menu option to try to locate the variable (see Search Menu). Variables can also be located by string value using
the Find Bar.
The Template Results panel displays 6 different columns: The Name column lists the data type and the name of
the variable, and will also include any array indices. The Value column displays the value of the current variable
as read from the file. The Start column lists the starting address of the variable and the Size column lists the size
in bytes of the data. The Color column lists the foreground color (Fg:) and background color (Bg:) of the variable
(this can be modified by the SetForeColor, SetBackColor, or SetColor functions as listed in Interface Functions).
The Comment column displays a string that can be set after a variable is declared using the syntax
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'<comment="<string>">' or '<comment=<function_name>>' (see Declaring Template Variables).
If the value for a variable displayed in the Value column is a hex or decimal number, right-click on the variable
and select 'Goto > Goto Address <number>' or 'Goto > Goto Sector <number>' from the popup menu to jump to
that byte address or sector within the file. For example, if a variable has the value '10324', right-click on the
variable and choose 'Goto > Goto Address 10324' to jump to address 10324.
The display format for the different columns can be changed by right-clicking on the window and selecting the
'Column Display Format' option from the menu. For the Value column, if the 'Default' option is chosen from the
'Column Display Format' menu, then the display format is determined when running the Template from the
functions DisplayFormatHex, DisplayFormatDecimal, DisplayFormatOctal, DisplayFormatBinary, or by using
'<format=hex|decimal|octal|binary>'. The 'Column Display Format' for the first column can be set to 'Type and
Name' to show both the variable type and name, or set to 'Name' to just display the variable name. Through the
right-click menu the address display for the Start column can be set to either 'Global' or 'Local' using the 'Start
Addresses' menu option. In 'Global' mode, the addresses are displayed as regular addresses from the beginning
of the file but the 'Local' addresses option displays a variable's address as the offset from its parent variable.
To edit the value of a variable, click the value or press the Enter key while a cell in the Value column is selected
(the current cell is indicated by a dashed box and can be moved using the cursor keys). Modify the value and
press Enter to commit the change or Esc to cancel. Editing is performed similar to the Auto Inspector. If no value
is displayed in the Value column, this means that the variable cannot be edited. To clear the template results,
right-click the Template Results panel or the Variables tab of the Inspector and click the 'Clear' menu option.
By default, the Template Results does not display any local variables (see Declaring Template Variables for more
information on local variables). To enable the display of local variables right-click on the panel and select the
Show Local Variables menu option from the menu. Many of the menu options on the right-click menu are similar
to the Inspector. See the Inspector help topic for information on the 'Copy', 'Copy Row', 'Copy Column', 'Copy
Table', and 'Export CSV' options. Use the 'Export XML' menu option to export data from the Template Results in
XML format (note that XML files are written in UTF-8 format).

Mouse Over and Hints
After a Template has been run on a file, 010 Editor has an easy way to view the Template variables. Just position
the mouse over bytes in the Hex Editor Window for a second and a Hint will popup displaying the value of the
variable that uses those bytes. Brackets are also displayed on the Hex Editor Window to indicate which bytes the
variable uses. The brackets and hint display can be turned off through the Hex Editor Options dialog.

Related Topics:
Declaring Template Variables
Hex Editor Options
Inspector
Introduction to Templates and Scripts
Search Menu
Using Find
Using the Hex Editor
010 Editor v7.0 Manual - Windows Edition
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Script Basics
010 Editor has a powerful scripting engine that allows many tasks to be automated. Script files have the
extension '.1sc' and are very similar in syntax to C. All scripts are executed similar to how an interpreter would
run the file, starting at the first line of the program and progressing downwards (there is no need to write a
'main' function as in ANSI C). Scripts can be used to perform editing operations on files, manipulate files on disk,
or even perform complex operations like file comparisons, checksums, and find in files. To open or run a script
see the Scripts Menu or Running Templates and Scripts. A repository of scripts can be accessed by clicking the
'Scripts > Script Repository' menu option (see the Repository Dialog). Scripts can be configured to run on
startup, shutdown, or when files are opened, and scripts can also be added to the 'Scripts' menu (see Script
Options).
View the following topics for more information on the syntax used when writing Scripts:












Expressions
Declaring Script Variables
Data Types, Typedefs, and Enums
Arrays and Strings
Control Statements
Functions
Special Keywords
Preprocessor
Includes
Script Limitations

A large number of functions are available when writing Scripts. The available functions are described in:







Interface Functions
I/O Functions
String Functions
Math Functions
Tool Functions

Binary Templates have a syntax similar to scripts, but allow a file to be parsed into a number of variables. Scripts
can be used to modify the variables that are defined in Templates. See Template Basics for an introduction to
using Templates.

Related Topics:
Arrays and Strings
Control Statements
Data Types, Typedefs, and Enums
Declaring Script Variables
Expressions
Functions
Includes
Interface Functions
I/O Functions
Math Functions
Preprocessor
Script Limitations
Special Keywords
String Functions
Template Basics
Tool Functions
010 Editor v7.0 Manual - Windows Edition
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Expressions
Expressions in Scripts or Templates can contain any of the standard C operators:
















+ (addition)
- (subtraction)
* (multiplication)
/ (division)
~ (binary invert)
^ (binary xor)
& (binary and)
| (binary or)
% (modulus)
++ (increment)
-- (decrement)
?: (ternary)
<< (shift left)
>> (shift right)

Brackets '(' or ')' can be used to group expressions. For example:

(45 + 123) * (456 ^ 16)
is a valid expression. The following comparison operators can be used:









< (less than)
> (greater than)
<= (less than or equal)
>= (greater than or equal)
== (equal)
!= (not equal)
! (not)

For example,

(45 > 32)
would return the value 1. Any of the assignment operators +=, -=, *=, /=, &=, ^=, %=, |=, <<=, or >>= can
also be used. A number of addition Special Keywords including sizeof can be used in expressions.

Boolean Operators
The following boolean operators can be used in expressions:
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&& (AND)
|| (OR)
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! (NOT - takes one operator only)

For example, to perform an operation if A and B are true or if C is not true, use:

if( (A && B) || !C ) ...
Brackets can be used to indicate which order the operations should be performed.

Numbers
Numbers may be entered in a number of different formats (see Introduction to Number Systems):






Decimal - 456
Hexadecimal - 0xff, 25h, 0EFh
Octal - 013 (with a zero before any numbers)
Binary - 0b011

The 'u' character can be used after a number to indicate an unsigned value (e.g. '12u'), or 'L' can be used to
indicate an 8-byte int64 value (e.g. '-1L'). Floating-point numbers may contain 'e' for an exponent (e.g. 1e10). A
floating-point number is automatically assumed to be an 8-byte double unless an 'f' character is located after the
name (e.g. 2.0f), in which case the number is assumed to be a 4-byte float.

Related Topics:
Introduction to Number Systems
Script Basics
Special Keywords
010 Editor v7.0 Manual - Windows Edition
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Declaring Script Variables
A variable can be declared using the syntax '<data type> <variable name>;' Use an '=' to assign a value to the
variable. Multiple variables can also be declared using the ',' operator. For example:

int x;
float a = 3.5f;
unsigned int myVar1, myVar2;
For a complete list of types allowed, see Data Types. Any variables declared in a Script will be displayed in the
Variables tab of the Inspector. Arrays of variables can also be declared (see Arrays and Strings). Declaring
variables is the main way of building Templates (see Declaring Template Variables for more information).

Constants
Constants can be declared using the keyword 'const' before a variable declaration. For example:

const int TAG_EOF = 0x3545;
This syntax is generally better for defining constants than using the '#define' preprocessor directive. A number of
constants are built into 010 Editor, including true, false, TRUE, FALSE, M_PI, and PI. See Interface Functions for a
list of other constants used for coloring or Tool Functions for a list of constants used when calling tool functions.

Related Topics:
Arrays and Strings
Data Types, Typedefs, and Enums
Declaring Template Variables
Interface Functions
Script Basics
Script Limitations
Tool Functions
Using the Inspector
010 Editor v7.0 Manual - Windows Edition
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Data Types, Typedefs, and Enums
Support for a number of different data types is built into 010 Editor. These data types are used when writing a
Template (see Declaring Template Variables) or when declaring variables in a Script (see Declaring Script
Variables). Commonly, a number of different names refer to the same data type (for example, 'ushort' and
'WORD' usually refer to a 16-bit unsigned integer). The following lists each of the data types and all of the names
currently supported for that type:














8-Bit Signed Integer - char, byte, CHAR, BYTE
8-Bit Unsigned Integer - uchar, ubyte, UCHAR, UBYTE
16-Bit Signed Integer - short, int16, SHORT, INT16
16-Bit Unsigned Integer - ushort, uint16, USHORT, UINT16, WORD
32-Bit Signed Integer - int, int32, long, INT, INT32, LONG
32-Bit Unsigned Integer - uint, uint32, ulong, UINT, UINT32, ULONG, DWORD
64-Bit Signed Integer - int64, quad, QUAD, INT64, __int64
64-Bit Unsigned Integer - uint64, uquad, UQUAD, UINT64, QWORD, __uint64
32-Bit Floating Point Number - float, FLOAT
64-Bit Floating Point Number - double, DOUBLE
16-Bit Floating Point Number - hfloat, HFLOAT
Date Types - DOSDATE, DOSTIME, FILETIME, OLETIME, time_t (for more information on date types,
see Using the Inspector)

Note that date types can be used in Templates, but they must be cast to an int or float before any operations can
be performed on them. 010 Editor also has support for a special string type.

Typedefs
Other data types can be created using the 'typedef' keyword. The syntax for creating new types is 'typedef
<data_type> <new_type_name>'. For example,

typedef unsigned int myInt;
would generate a new data type myInt for unsigned integers. Typedefs can also be used with arrays (see Arrays
and Strings) using the syntax 'typedef <data_type> <new_type_name> [ <array_size> ]'. Note that the array
size must be a constant in this case. For example, to generate a new string type with 15 characters use:

typedef char myString[15];
myString s = "Test";
Note that typedefs cannot be used to create multi-dimensional arrays (see Template Limitations). Typedefs can
also be used with structs (see Structs and Unions).

Enums
Use the enum keyword to specify a number of constants for a variable. An enum data type can be created using
the C syntax 'enum <type_name> { <constant_name> [ = expression ], ... } <variable_list>'. If no expression
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is given for the first constant, it is assumed to be zero. If no expression is given for any other constant, its value
is assumed to be the previous constant plus one. For example,

enum MYENUM { COMP_1, COMP_2 = 5, COMP_3 } var1;
would declare the constants COMP_1 equal to 0, COMP_2 equal to 5, and COMP_3 equal to 6. By default, enums
are the same type as an integer, but the type can be changed by placing '<' type_name '>' after the enum
keyword. For example,

enum <ushort> MYENUM { COMP_1, COMP_2 = 5, COMP_3 } var1;
would declare the same variable but as an unsigned short. Enums can be useful when writing Templates (see
Declaring Template Variables).

Related Topics:
Arrays and Strings
Declaring Script Variables
Declaring Template Variables
Structs and Unions
Using the Inspector
Template Limitations
010 Editor v7.0 Manual - Windows Edition
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Arrays and Strings
Arrays
An array of variables can be defined using the syntax '<data type> <variable name> [ <expression> ]'. Any of
the types in the Data Types list can be used. For example:

int myArray[15];
Note that unlike ANSI C, the size of the array can be any expression including variables, functions, or operators.
For example

int myArray[ FileSize() - myInt * 0x10 + (17 << 5) ];
The individual elements of the array can be accessed using the '[ ]' operator. For example:

for( i = 0; i < 15; i++ )
myArray[i] = i;
If an array is declared with size zero a warning will be printed out and no variable will be created, but no error
will be generated.

Strings
An array of characters is treated as a special string type. The keyword 'string' can also be used to declare a
string. The operators '=', '+', '+=', and comparison operators can be used on strings as if they were a separate
data type. For example:

char str[15] = "First";
string s = "Second";
string r1 = str + s;
string r2 = str;
r2 += s;
return (r1 == r2);
Strings will automatically resize if assigned too many characters, and a warning will be displayed in the Output
text area. All strings are assumed to be null-terminated. For a list of functions that can be used when working
with strings, see String Functions.

Wide Strings (Unicode Strings)
Regular strings above assume each character can be stored in 8-bits; however this character size is not
appropriate for many languages so 010 Editor also supports wide strings (also called Unicode strings) where each
character is a 16-bit unsigned short. Use the special 'wstring' type to define a wide string and each character of a
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wstring is assumed to be of type 'wchar_t' (a wchar_t is equivalent to an unsigned short).
The same operators '=', '+' and '+=' are supported for wstrings as for strings and a wide string constant can be
declared by placing a 'L' character before a string or character constant. For example:

wchar_t str1[15] = L"How now";
wstring str2 = "brown cow";
wstring str3 = str1 + L' ' + str2 + L'?';
Extended characters can be placed in string constants using the UTF-8 character encoding. Wide strings are
assumed to be null-terminated and a list of functions available for working with wide strings is available in the
String Functions help topic. Wide strings can be converted to regular strings using the WStringToString or
StringToWString functions, or by casting.

Related Topics:
Data Types, Typedefs, and Enums
String Functions
010 Editor v7.0 Manual - Windows Edition
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Control Statements
if Statements
Statements may be grouped by '{' or '}' and may contain the regular C if statement, or the if-else statement in
the form 'if( <condition> ) then <statement> [else <statement>]'. For example:

if( x < 5 )
x = 0;
or

if( y >
max
else
{
max
y =
}

x )
= y;
= x;
0;

for Statements
The standard C for statement can be used in any Script or Template in the form 'for( <initialization>;
<condition>; <increment> ) <statement>'. For example:

for( i = 0, x = 0; i < 15; i++ )
{
x += i;
}

while Statements
The while and do-while statements can also be used in the form 'while( <condition> ) <statement>' or 'do
<statement> while( <condition> )'. For example:

while( myVar < 15 )
{
x *= myVar;
myVar += 2;
}
or

do
{
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x *= myVar;
myVar += 2;
}
while( myVar < 23 );

switch statements
A switch statement can be used to compare a variable with a number of values and perform different operations
depending on the result. switch statements are of the form:

switch( <variable> )
{
case <expression>: <statement>; [break;]
.
.
.
default : <statement>;
}
For example:

switch( value
{
case 2 :
case 4 :
case 8 :
case 16 :
default :
}

)
result
result
result
result
result

=
=
=
=
=

1; break;
2; break;
3; break;
4; break;
-1;

break and continue
break or continue can be used in a Script or Template using the syntax 'break;' or 'continue;'. Use break to exit
out of the current for, switch, while, or do block and transfer program control to the first statement after the
block. break can also be used to break out of structs when writing Templates. Use continue to jump to the end
brace of any for or while loop and continue execution of the loop.

return
At any point during program execution the statement 'return <expression>;' can be used to stop execution. The
returned value will be displayed in the Output tab of the Output window which can be displayed by pressing
Alt+3. For example:

return 45 + 0x10;
would display 61 in the Output area. return is also used to return a value when defining custom functions (see
Functions).

Related Topics:
Script Basics
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Functions
A large number of functions are built into 010 Editor. Many of the standard C functions are available, but have a
uppercase first letter to differentiate them. Functions are called using the typical C syntax '<function name> (
<argument_list> )'. For example:

string str = "Apple";
return Strlen( str );
would return 5. Some functions can have a variable number of arguments. For example:

Printf( "string='%s' length='%d'\n", str, Strlen( str ) );
would display "string='Apple' length='5'" in the Output tab of the Output Window. See Interface Functions, I/O
Functions, String Functions, Math Functions, Tool Functions for a list of all functions.

Custom Functions
Custom functions can be defined with the regular C syntax '<return type> <function name> ( <argument_list> )
{ <statements> }'. The return type can be void or any of the supported data types. For example:

void OutputInt( int d )
{
Printf( "%d\n", d );
}
OutputInt( 5 );
Arguments are usually passed by value, but can be passed by reference using the '&' character before the
argument name. Array arguments can be indicated using the characters '[]' after the argument name. Array
arguments are passed by reference if possible, or by value if not. For example:

char[] GetExtension( char filename[], int &extLength )
{
int pos = Strchr( filename, '.' );
if( pos == -1 )
{
extLength = 0;
return "";
}
else
{
extLength = Strlen( filename ) - pos - 1;
return SubStr( filename, pos + 1 );
}
}
Prototypes can also be used on functions by replacing the statements with a semi-colon ';' after the argument
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list. Full recursion is supported on custom functions. Note that unlike regular C, the function 'main' is not required
and execution begins from the first line of the Script or Template. Note that if a Script is run on a file after a
Template has been run on that same file, the functions in the Template can be called from the Script.

Related Topics:
Data Types, Typedefs, and Enums
Interface Functions
I/O Functions
Math Functions
String Functions
Tool Functions
010 Editor v7.0 Manual - Windows Edition
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Special Keywords
sizeof
The sizeof operator can be used to calculate the size in bytes of one of the basic types or a variable that has been
declared. For example,

sizeof(double)
would return 8. The sizeof operator can also compute the size of simple structs or unions (see Structs and
Unions). A simple struct is one that does not contain if statements or other statements that may change its size
when declared. Attempting to compute the size of a non-simple struct or union will generate an error.

startof
The special keyword startof can be used on a variable that has been declared in a Template to calculate the
starting address of the bytes the variable is mapped to in the file. For example, after opening a BMP file, use the
following command in a script to position the cursor at the beginning of the first line of bitmap data:

SetCursorPos( startof( lines[0] ) );

exists
The special exists operator can be used to determine if a variable has been declared. The operator will return 1 if
the given variable exists, or 0 if it does not. For example, after opening a ZIP file, the following command in a
script will output all file names:

int i;
string s;
while( exists( file[i] ) )
{
s = file[i].frFileName;
Printf( "%s\n", s );
i++;
}

function_exists
The function_exists operator can be used to test if a particular function is defined either as a user-defined
function or a built-in function (see Functions for more information). The operator returns 1 if the function exists
or 0 if it does not. For example:

if( function_exists(CopyStringToClipboard) )
{
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...
}
Requires 010 Editor v3.1 or higher.

this
The this keyword can be used to access the variable representing the current structure being defined (see Structs
and Unions). For example:

void PrintHeader( struct HEADER &h )
{
Printf( "ID1 = %d\n", h.ID1 );
Printf( "ID2 = %d\n", h.ID2 );
}
struct HEADER
{
int ID1;
int ID2;
PrintHeader( this );
} h1;
If no current structure is currently being defined, this is NULL.
Requires 010 Editor v3.1 or higher.

parentof
The parentof keyword can be used to access the struct or union that contains a given variable. For example:

void PrintHeader( struct HEADER &h )
{
Printf( "ID1 = %d\n", h.ID1 );
Printf( "ID2 = %d\n", h.ID2 );
}
struct HEADER
{
int ID1;
int ID2;
struct SUBITEM
{
int data1;
int data2;
PrintHeader( parentof(this) );
} item1;
PrintHeader( parentof(item1) );
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} h1;
If the given variable is not inside a struct or union an error will be generated.
Requires 010 Editor v3.1 or higher.

Related Topics:
Data Types, Typedefs, and Enums
Functions
Structs and Unions
010 Editor v7.0 Manual - Windows Edition
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Preprocessor
When a Script or Template is executed, a special preprocessor stage is run before the main compilation of the file
begins. In the preprocessor stage, the software finds any preprocessor directives (e.g. #include, #ifdef, #define,
etc.) and uses them to modify the text of the original source code. Each preprocessor directive must start with a
'#' character and the '#' character must be the first non-whitespace character on a line.

Defines
Special preprocessor constants can be defined using the syntax '#define <constant_name> [ <text_value> ]'.
For example:

#define PI 3.14159265
Note that a semi-colon is not required after the statement. When any occurrence of the defined constant name is
encountered in the rest of the source code (except inside of a string), it will be textually replaced with the defined
value of the constant. For example:

Printf( "ToRadians=%lf\n", 90.0 * (PI/180.0) );
When defining a constant, a value is not required after the constant name in which case a constant is still defined
but it will have an empty value. The constant value can be any text string and multi-line values can be defined by
placing a '\' character as the last character of a value line. For example:

#define CHECK_VALUE if( value > 5) { \
Printf( "Invalid value %d\n", value ); \
Exit(-1); }
int value = 4;
CHECK_VALUE;
value = 10;
CHECK_VALUE;
Constants created with #define can also include other constants that have previously been created with #define.
For example:

#define FILE_ICON
12
#define FOLDER_ICON (FILE_ICON+100)
Any constants that are defined can be undefined later using the syntax '#undef <constant_name>'. Note that
some preprocessors support macros with #define statements but this is not currently supported in 010 Editor.

Built-in Constants
The following constants are defined automatically in 010 Editor depending upon which version of 010 Editor is
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being run:







_010EDITOR - always defined when running 010 Editor.
_010_WIN - defined if running the Windows version of 010 Editor.
_010_MAC - defined if running the Macintosh version of 010 Editor.
_010_LINUX - defined if running a Linux version of 010 Editor.
_010_64BIT - defined if 010 Editor is being run in 64-bit mode.

Conditional Compilation
The preprocessor directives #ifdef and #ifndef can be used to compile or ignore whole sections of source code
depending on if certain constants were defined with the #define directive above. The syntax for these commands
is:

#ifdef | #ifndef <constant_name>
(...)
[ #else ]
(...)
#endif
A common usage of this syntax is to place code such as:

#ifndef CONSTANTS_H
#define CONSTANTS_H
at the beginning of a header file (e.g. constants.h) and then an '#endif' statement at the end of the header file.
Then, if this header file is included twice into the source code with #include (see below), the code inside the
header file will only be compiled once (the second time the file is included the constant CONSTANTS_H is already
defined so the #ifndef statement skips the rest of the code). Note that multiple #ifdef or #ifndef statements can
be nested inside of each other, but make sure the #endif statements properly line up with the #ifdef/#ifndef
statements.

Warnings and Errors
The preprocessor directive #warning can be used to output a message to the Output tab of the Output Window
during compilation with the syntax '#warning "<message>"'. For example:

#ifdef NUMBITS
value = value + NUMBITS;
#else
#warning "NUMBITS not defined!"
#endif
The #error directive is similar to the #warning directive except compilation will stop once an #error directive is
reached. For example:

#ifndef CURRENT_OS
#error "CURRENT_OS must be defined. Compilation stopped."
#endif
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Includes
The #include directive is supported to insert additional text files into the current file. This directive is discussed in
the separate Includes help topic.

Related Topics:
Compiling Options
Includes
Script Basics
010 Editor v7.0 Manual - Windows Edition
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Includes
Additional source code files can be inserted into the current script or template using the syntax '#include
"filename"'. For example:

#include "Vector.bt"
Note that a semi-colon is not required after the statement. The angle brackets '<' and '>' can be used around the
file name instead of quotes (as in regular C), but the semantics are the same. The indicated file will be inserted
into the script or template and the code will be executed as if it were one long file.
When a file is included, it will be searched for in the following directories in the following order:









Current Working Directory - If 010 Editor was started from the command line, the current working
directory would be the directory where 010 Editor was started from, else the current working directory
is usually the directory where 010 Editor was installed ('C:\Program Files\010 Editor\' by default).
File Directory - The directory where the file that contains the include statement currently resides.
Template Directory - The default Template directory specified using the Directory Options.
Script Directory - The default Script directory specified using the Directory Options.
Template Repository Directory - The directory where Templates from the Repository are installed
(see Directory Options).
Script Repository Directory - The directory where Scripts from the Repository are installed (see
Directory Options).
Additional Include Directories - Any additional directories specified using the Compiling Options
dialog.

Include files can be nested as in regular C. Note that during execution, if an error occurs inside an include file,
you will be asked if you want to load the include file in the interface.

Related Topics:
Compiling Options
Directory Options
Preprocessor
Script Basics
010 Editor v7.0 Manual - Windows Edition
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Script Limitations
Scripts have a syntax similar to C; however, the software was designed for parsing binary files and is not meant
to be fully ANSI compliant. This section lists most of the important differences between ANSI C and 010 Editor
when writing code:






Pointers - No pointers are currently allowed using '*'. References using '&' are only allowed when
passing arguments to custom functions (see Functions).
Preprocessor - Most preprocessor directives are supported including #define, #ifdef, #ifndef, etc.
However, the #if directive is not currently supported and defining macros using the #define directive is
not currently supported.
Multi-dimensional Arrays - Multi-dimensional arrays are currently not supported. See Template
Limitations for an alternate way of declaring multi-dimensional arrays in Templates.
Control statements - The goto statement is not supported.

Related Topics:
Declaring Script Variables
Functions
Includes
Template Limitations
010 Editor v7.0 Manual - Windows Edition
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Template Basics
Binary Templates, one of the most powerful features of 010 Editor, allow virtually any binary file to be parsed
into a series of variables. Templates allow binary files to be understood and edited in a much easier fashion than
typical hex editors. Each Template is stored as a text file with the extension ".bt" and can be edited directly in
010 Editor (see the Templates Menu). Templates are executed as an interpreter would run, starting from the first
line in the file and progressing downwards. When a Template is executed the file is parsed into a number of
variables and the variables are displayed in the Template Results panel (see Template Results for more
information). Templates can be configured to automatically load and execute each time a file is opened (see
Template Options). For an example of how Templates work open any ZIP, BMP, or WAV file on your computer
and see the Repository Dialog for information on installing Templates from the Repository.
The syntax of Binary Templates is similar to that of scripts. The following topics describe the syntax specifically
used when writing Binary Templates:

















Declaring Template Variables
Data Types, Typedefs, and Enums
Structs and Unions
Arrays, Duplicates, and Optimizing
Bitfields
Expressions
Control Statements
Functions
Special Keywords
Preprocessor
Includes
Editing with Scripts
Custom Variables
On-Demand Structures
Template Limitations

A large number of functions are available when writing Templates. The following topics list all available functions:







Interface Functions
I/O Functions
String Functions
Math Functions
Tool Functions

Scripts can be used to modify variables defined in a Template. See Script Basics for more information on Scripts
and Editing with Scripts for information on using Scripts and Templates together.

Related Topics:
Arrays, Duplicates, and Optimizing
Bitfields
Custom Variables
Declaring Template Variables
Editing with Scripts
Interface Functions
Introduction to Templates and Scripts
I/O Functions
Math Functions
On-Demand Structures
Preprocessor
Script Basics
String Functions
Structs and Unions
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Template Limitations
Tool Functions
Working with Template Results
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Declaring Template Variables
Declaring variables in templates is performed similar to ANSI C and Scripts, but with an important difference:
every time a variable is declared in the Template, that variable is mapped to a set of bytes in a file. For example,
running the template:

char
int

header[4];
numRecords;

Would create the character array header, which is mapped to the first 4 bytes of the current file, and the integer
numRecords, which is mapped to the next 4 bytes of the file. Both variables will be displayed in the Template
Results panel and can be used for editing the file. Variables can also be edited using Scripts (see Editing with
Scripts). The main way of grouping Template variables together is to declare structs or unions. See the Structs
and Unions help topic for more information.

Special Attributes
One or more special attributes can be specified after a variable inside '<' and '>' brackets. The following
attributes are supported:

< format=hex|decimal|octal|binary,
fgcolor=<color>,
bgcolor=<color>,
comment="<string>"|<function_name>,
name="<string>"|<function_name>,
open=true|false|suppress,
hidden=true|false,
read=<function_name>,
write=<function_name>
size=<number>|<function_name> >
All attributes are discussed below except for the read and write attributes which can be used to create special
Custom Variables (see Custom Variables) and the size attribute which can be used to create on-demand
structures (see On-Demand Structures).

Display Format
By default, all variables declared will be displayed in the Template Results panel in decimal format. To switch
between hexadecimal, decimal, octal, or binary display formats, see the functions DisplayFormatDecimal,
DisplayFormatHex, DisplayFormatBinary, and DisplayFormatOctal in Interface Functions.
An alternate way of specifying the format for a variable is to use the syntax '<format=hex|decimal|octal|binary>'
after a variable declaration or a typedef. For example:

int id;
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int crc <format=hex>;
int flags <format=binary>;

Colors
When parsing a file, different colors can be applied to variables by using a Template. For example, the header
bytes of a file could be colored differently than the rest of the file. There are two ways to control the color of
variables. If you just wish to set the color of a single variable, the syntax '<fgcolor=???>' or '<bgcolor=???>' can
be used after a variable to set the foreground or background color respectively. Here '???' can indicate either a
built-in color constant (see SetBackColor for a list) or a number constant in the format '0xBBGGRR' (e.g.
0xFF0000 is blue). For example:

int id <fgcolor=cBlack, bgcolor=0x0000FF>;
The second way of coloring variables is to use the SetForeColor, SetBackColor, or SetColor functions to set the
default color. Every variable defined after a call to one of these functions will be assigned the default color. The
special color constant 'cNone' can be used to turn off coloring. For example:

SetForeColor( cRed );
int first; // will be colored red
int second; // will be colored red
SetForeColor( cNone );
int third; // will not be colored
See the functions in Interface Functions for more information. Note that the fgcolor and bgcolor syntax requires
010 Editor version 3.1 or higher.

Endian
Any data written or read from a file depends upon the endian of the file (see Introduction to Byte Ordering). By
default, all variables declared will have the same endian as the file, but the endian can be modified by using the
functions BigEndian or LittleEndian (see I/O Functions). Using this technique, the same file can contain both little
and big endian data.

Comments
A comment can be attached to a variable using the syntax '<comment="<string>">'. For example:

int machineStatus <comment="This should be greater than 15.">;
This comment will be displayed in the Comment column of the Template Results. Alternately, a comment can be
provided using a custom function using the syntax '<comment=<function_name>>'. The comment function
takes as arguments a variable and returns a string to be displayed in the Comment column. For example:

int machineStatus <comment=MachineStatusComment>;
string MachineStatusComment( int status )
{
if( status <= 15 )
return "*** Invalid machine status";
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else
return "Valid machine status";
}
Note that extended characters can be included in string constants when a Template file uses the UTF-8 character
set. Comments with strings are only available in version 3.1 of 010 Editor or higher and comments with custom
functions are only available in version 4.0 of 010 Editor or higher.

Names
The name attribute can be used to override the text displayed in the Name column of the Template Results.
Similar to the comment attribute above, the name attribute can be given a string with the syntax
'<name="<string>">' or can be given a function with the syntax '<name=<function_name>>'. A name function
is similar to a comment function and takes as arguments a variable and returns a string. The following is an
example of using the name attribute with a string:

byte _si8 <name="Signed Byte">;
The above statement would display "Signed Byte" in the Name column of the Template Results instead of the
string "byte _si8". Note that if the variable is part of an array, the array indices will be automatically appended to
the name. The name attribute is only available in version 4.0 of 010 Editor or higher.

Order
After each Template variable is declared, the current file position is moved forward. The current file position can
be examined using the function FTell. By using the functions FSeek or FSkip, the current position can be moved
around the file. This technique allows a file to be parsed out of order. Note that to read from a file without
defining a variable, the functions ReadByte, ReadShort, ReadInt, etc. can be used (see I/O Functions).

Local Variables
In some instances, a variable may be required which is not mapped to a file and not displayed in the Template
Results (i.e. a regular C/C++ variable). In this case, the special keyword 'local' can be used before the
declaration. For example:

local int i, total = 0;
int
recordCounts[5];
for( i = 0; i < 5; i++ )
total += recordCounts[i];
double records[ total ];
In this example, i and total are not added to the Template Results panel by default; however, the display of local
variables in the Template Results panel can be enabled by right-clicking on the Template Results panel and
clicking Show Local Variables.
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Open Status of Variables
When a Template is run, all the created variables are displayed in a tree format in the Template Results. By
default all arrays and structs will be closed in the tree and can be opened by clicking the small '+' or arrow beside
each item; however, sometimes it is useful to have an array or struct open by default which makes viewing
important data easier. To open an array or struct by default use the syntax '<open=true>' after a variable. The
syntax '<open=false>' can also be used to set an array or struct closed after the template is run (this is the
default behavior).
When the Expand All Children of Node operation is run on the Template Results tree (this is performed by rightclicking on the Template Results), all arrays or structs under the selected variable are opened. Alternately, all
nodes in the Template Results can be recursively opened by right-clicking on the tree and selecting Expand All
Nodes. To prevent an array or struct from being opened during an Expand All operation, use the syntax
'<open=suppress>' after the variable. Controlling the open status of variables is only available in version 3.1 of
010 Editor or higher.

Strings
Null-terminated strings are commonly defined in binary files. 010 Editor allows the special syntax in a template to
read a null-terminated string:

char str[];
or

string str;
will both read a string until a 0 byte is encountered. Unicode strings (wide strings) can be read using:

wchar_t str[];
or

wstring str;
See Arrays and Strings for more information on strings.

Enums
Enums are useful when writing Templates (see Data Types, Typedefs, and Enums for information on declaring
enum types). When an enum variable is declared and the variable is selected in the Template Results, a down
arrow will appear to the right of the text field. Clicking on the down arrow displays a drop-down list of all
constants defined for the enum. Selecting an item from the drop-down list, or entering a constant in the edit field
and pressing Enter will assign the variable to a new value. Enums may also be used with bitfields.

Hidden Variables
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The syntax '<hidden=true>' can be used to hide the display of variables in the Template Results. This syntax can
also be used with typedefs and '<hidden=false>' can be used to re-enable the display of a variable. Hidden
variables are only available in version 3.1 of 010 Editor or higher.

Related Topics:
Arrays and Strings
Bitfields
Custom Variables
Data Types, Typedefs, and Enums
Declaring Script Variables
Editing with Scripts
Interface Functions
Introduction to Byte Ordering
I/O Functions
On-Demand Structures
Structs and Unions
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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Structs and Unions
The C keyword 'struct' can be used to define a hierarchical data structure when parsing a file. Structures can be
defined using C/C++ syntax. For example:

struct myStruct {
int a;
int b;
int c;
};
See Declaring Template Variables for information on declaring the variables within a struct. Note the semi-colon
after the struct definition is required. This syntax would actually generate a new type myStruct, but would not
declare any variables until an instance of type myStruct is declared:

myStruct s;
After this declaration, the Template Results would have an entry 'myStruct s' with a '+' beside it. Clicking the '+'
would display the variables a, b, and c beneath.
Instances of structures can be declared at the same time the structure is defined. For example:

struct myStruct {
int a;
int b;
int c;
} s1, s2;
would generate two instances of myStruct. s1 would cover the first 12 bytes of the file (4 bytes for each of the 3
integers) and s2 would cover the next 12 bytes of the file.
These structs are more powerful than typical C structs since they may contain control statements such as if, for,
or while. For example:

struct myIfStruct {
int a;
if( a > 5 )
int b;
else
int c;
} s;
In this example, when s is declared only two variables are generated: a, and one of b or c. Remember that
templates are executed as an interpreter would, evaluating each line before stepping to the next. The value of a
is read directly from the current file.
Structures can be nested and array of structures can also be declared. For example:

struct {
int width;
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struct COLOR {
uchar r, g, b;
} colors[width];
} line1;
Note that forward-declared structs are supported and structs can even be nested recursively. Typedefs can be
used with structs as an alternate way to define a structure. For example:

typedef struct {
ushort id;
int
size;
}
myData;

Unions
A union can be declared using the same syntax as structs except that the keyword 'union' is used instead of
'struct'. In a union, all the variables start at the same position and the size of the union is just large enough to
contain the largest variable. For example, for the union:

union myUnion {
ushort s;
double d;
int
i;
} u;
all three variables would be read starting from the same position and the size of the union would be 8 bytes to
contain the double.

Structs with Arguments
A list of arguments can be specified after the 'struct' or 'union' keyword when defining a structure or union. This
is a powerful way of working with complex structures and the argument list is defined in a similar manner to
Functions. For example:

struct VarSizeStruct (int arraySize)
{
int id;
int array[arraySize];
};
Then, when instances of this struct are declared the proper parameters must be passed to the struct in brackets.
For example:

VarSizeStruct s1(5);
VarSizeStruct s2(7);
Arguments can also be used with structs or unions defined using typedefs. For example:

typedef struct (int arraySize)
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{
int id;
int array[arraySize];
} VarSizeStruct;

Related Topics:
Data Types, Typedefs, and Enums
Declaring Template Variables
On-Demand Structures
010 Editor v7.0 Manual - Windows Edition
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Arrays, Duplicates, and Optimizing
Arrays and Duplicates
When writing a template, regular arrays can be declaring using the same syntax as scripts (see Arrays and
Strings). However, 010 Editor has a syntax that allows arrays to be built in a special way. When declaring
template variables, multiple copies of the same variable can be declared. For example:

int x;
int y;
int x;
010 Editor allows you to treat the multiple declarations of the variable as an array (this is called a Duplicate
Array). In this example, x[0] could be used to reference the first occurrence of x and x[1] could be used to
reference the second occurrence of x. Duplicate arrays can even be defined with for or while loops. For example:

local int i;
for( i = 0; i < 5; i++ )
int x;
For another example, see the 'ZIPTemplate.bt' file that uses duplicate arrays to parse ZIP files. Duplicate arrays
are also useful because of how 010 Editor deals with arrays of structs.

Optimizing Structs
010 Editor contains an optimization that allows it to generate arrays of structures with millions and millions of
elements. The optimization calculates the size of the first element of the array and assumes all elements of the
array are the same size. This optimization will cause incorrect results if the elements can be variable size (010
Editor will display a warning in the Output text area if it detects this may be happening). To turn the optimization
off, use the syntax '<optimize=false>' after the array declaration. For example:

typedef struct {
int
id;
int
length;
uchar data[ length ];
} RECORD;
RECORD record[5] <optimize=false>;
If 010 Editor displays a warning in the Output text area, but you would still like to use the optimization, use the
syntax '<optimize=true>' to turn off display of the warning. The '<optimize=false>' syntax can also be used with
struct typedefs to indicate that optimization should not be used on any arrays using that structure. Unoptimized
arrays can also be rewritten as duplicate arrays (see above) since the elements of duplicate arrays can have
different sizes.

Related Topics:
Arrays and Strings
Structs and Unions
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Bitfields
A bitfield allows structures to be subdivided into groups of bits. This process allows multiple variables to be
packed into a single block of memory. The syntax for defining a bitfield is 'type_name <variable_name> :
number_of_bits'. The type can be char, short, int, or int64 (unsigned or signed) or any of the equivalent types. If
the variable name is omitted, the given number of bits will be skipped. For example,

int alpha : 5;
int
: 12;
int beta : 15;
would pack alpha and beta into one 32-bit value, but skip 12 bits in the middle. 010 Editor has two special bitfield
modes that determine how the bits are packed into variables: padded bitfields and unpadded bitfields.

Padded Bitfields
With padded bitfields (the default), how the bits are packed into a variable depends upon the current endianness.
By default, bits are packed right-to-left for little endian files, and left-to-right for big endian files. For example,
for the bitfields:

ushort a : 4;
ushort b : 7;
ushort c : 5;
In little endian mode, this structure would be stored as the bits:

cccccbbb bbbbaaaa
(and stored on disk as bbbbaaaa cccccbbb). In big endian mode, this structure would be stored as the bits:

aaaabbbb bbbccccc
(and stored on disk as aaaabbbb bbbccccc). Whether the bits are packed left-to-right or right-to-left can be
controlled by the functions BitfieldLeftToRight, and BitfieldRightToLeft (see I/O Functions).
In this mode, the program will automatically add padding bits when needed. If the size of the type being defined
changes, padding will be added so the bitfield will be defined on the next variable boundary. Also, if the specified
bitfield would step across the boundary of a variable, padding is added so the bitfield starts at the next variable.
For example:

int
int
int
int
short

apple
orange
banana
peach
grape

:
:
:
:
:

10;
20;
10;
12;
4;

The bitfields apple and orange would be packed into one 32 bit value. However, banana steps over the variable
boundary, so 2 bits of padding are added so that it starts at the next 32 bit value. Banana and peach are packed
into another 32-bit value, but because the size of the type changes with grape, an extra 10 bits of padding is
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added before grape is defined.

Unpadded Bitfields
010 Editor includes a special unpadded bitfield mode that treats the file as one long bit stream. No padding bits
are added if the variable type changes or if the bits cannot be packed into a single variable. The unpadded mode
can be entered by calling the function BitfieldDisablePadding (padding can be turned back on by calling
BitfieldEnablePadding).
In unpadded bitfield mode, each variable defined reads some bits from the bitstream. For example:

BitfieldDisablePadding();
short a : 10;
int
b : 20;
short c : 10;
Here a reads the first 10 bits from the file, b reads the next 20 bits from the file, and so on. If the bitfields are
defined as reading from right to left (this is the default for little endian data and can enabled using the function
BitfieldRightToLeft), the variables would be stored as the bits:

aaaaaaaa bbbbbbaa bbbbbbbb ccbbbbbb cccccccc
If the bitfields are defined as reading from left to right (this is the default for big endian data and can enabled
using the function BitfieldLeftToRight), the variables would be stored as the bits:

aaaaaaaa aabbbbbb bbbbbbbb bbbbbbcc cccccccc
When declaring structures containing unpadded bitfields, no extra padding bits are added between the structures.
(Note that internally, any unpadded right-to-left bitfield is forced to be declared in little endian mode and any
unpadded left-to-right bitfield is forced to be declared in big endian mode.)

Bitfields and Enums
Bitfields may be combined with enums by placing a colon and a number of bits after the enum definition. For
example, to pack two enums into a single ushort, the following may be used:

enum <ushort> ENUM1 { VAL1_1=25, VAL1_2=29, VAL1_3=7 } var1 : 12;
enum <ushort> ENUM2 { VAL2_1=5, VAL2_2=6 }
var2 : 4;

Related Topics:
Declaring Template Variables
I/O Functions
010 Editor v7.0 Manual - Windows Edition
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Editing with Scripts
Templates are meant only to parse a binary file and cannot modify the data file they are run on (however,
Templates can be allowed to read from or write to other files using Permissions). To edit the variables defined
from the template, use either the Template Results panel or a script. When a variable is declared in a Template,
it is mapped to a set of bytes in the file. Reading the variable causes bytes in the file to be read, and assigning to
the variable causes the bytes of the file to be modified.
Scripts have access to any of the variables declared in the Template and can use '.' to access data in structures.
For example, using the template:

struct myStruct {
int a;
int b;
int c;
} s1, s2;
a script could be written to swap the a variables:

int temp;
temp = s1.a;
s1.a = s2.a;
s2.a = temp;
Note that there is no special syntax to use; a Script can automatically access any Template variable if the Script
is run after the Template is run. For a list of other special keywords that can be used while editing Template
variables with a Script, see Special Keywords. Using a combination of Templates and Scripts provides a powerful
method of editing binary files.

Related Topics:
Permission Options
Special Keywords
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com

158

Copyright © 2003-2016 SweetScape Software

010 Editor - Reference Manual

Custom Variables
Some binary file formats use variable types that are different from the regular Data Types. 010 Editor has a
powerful syntax for letting you define custom variables in practically any format. To build a custom variable, write
a custom function that converts a variable into a string. This string will be displayed in the Template Results
panel as the value for the variable (this custom function is called a read function). Optionally, a write function can
be written that converts a string in the Template Results panel back to the variable when the variable is edited
and Enter is pressed. To assign a read and write function to a variable, use the syntax '<read= <function_name>
[, write= <function_name> ] >'after a typedef. A read function takes as arguments a variable and returns a
string. A write function takes as arguments a reference to a variable and a string. For example, to define a fixed
point data type that uses 16 bits (the 8 high bits define the whole part and the 8 low bits define the fractional
part), use:

typedef ushort FIXEDPT <read=FIXEDPTRead, write=FIXEDPTWrite>;
string FIXEDPTRead( FIXEDPT f )
{
string s;
SPrintf( s, "%lg", f / 256.0 );
return s;
}
void FIXEDPTWrite( FIXEDPT &f, string s )
{
f = (FIXEDPT)( Atof( s ) * 256 );
}
In this example, the FIXEDPT variable could be defined without a write function using '<read=FIXEDPTRead>',
but the variable will be read-only in the Template Results panel. Note that the typedef must be defined before the
functions in the source file. If an error can occur when a write function is called, change the return value to int
and return 0 on success or -1 on failure.
If a run-time error occurs inside a read function, 010 Editor will display "(error)" in the Template Results panel
and then display "(error)" every time the read function was to be called (010 Editor will not repeatedly call
functions which cause run-time errors because of performance issues). Fix the error within the read function and
then re-run the template to use the read function again.
When displaying arrays in the Template Results panel, usually no value is displayed for an array until the array is
opened up. To specify a value beside the array, a custom variable can be defined. For example:

typedef float VEC3F[3] <read=Vec3FRead, write=Vec3FWrite>;
string Vec3FRead( VEC3F v )
{
string s;
SPrintf( s, "(%f %f %f)", v[0], v[1], v[2] );
return s;
}
void Vec3FWrite( VEC3F &v, string s )
{
SScanf( s, "(%f %f %f)", v[0], v[1], v[2] );
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}
Note that currently, read/write functions cannot be declared simultaneously for an array of elements and for each
element of the array. The same process can be used to display a value for a struct in the Template Results panel.
For an example, see the 'ZIPTemplate.bt' file that uses a read function to display the file name beside each
structure.

Related Topics:
Arrays and Strings
Data Types, Typedefs, and Enums
Functions
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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On-Demand Structures
Some 010 Editor templates that define a large number of variables may use a significant amount of system
memory. To get around this issue, templates may use On-Demand Structures. With On-Demand Structures the
code which defines the variables inside a struct or union is not executed until it is needed (either the structure is
opened in the Template Results or a Script or Template accesses a member variable of the struct or union). In
order to use on-demand structures, 010 Editor must know the size of the struct or union so that it knows where
the next variable exists within the file. To enable on-demand parsing for a struct or union, use the syntax
'<size=<number>|<function name>' after a typedef.
If the size of a struct or union is always fixed, a number can be passed to the size attribute (note that sizes are
always in number of bytes). For example:

typedef struct
{
int header;
int value1;
int value2;
} MyStruct <size=12>;
In this case, anytime a struct of type MyStruct is defined the variables header, value1, and value2 are not
defined until they are needed.
If the size of struct or union is not fixed, a custom size function can be specified. The size function takes as
arguments a variable and returns an int or int64. If data needs to be read from the disk inside a size function the
Read<data_type> functions must be used (see I/O Functions). The member variables of the struct or union
cannot be accessed inside the size function because they do not exist until after the size function is called. For an
example of a size function, in the ZIPTemplate.bt file the ZIPFILERECORD struct could be converted to ondemand using this syntax:

typedef struct {
<...>
uint
frCompressedSize;
uint
frUncompressedSize;
ushort
frFileNameLength;
ushort
frExtraFieldLength;
if( frFileNameLength > 0 )
char
frFileName[ frFileNameLength ];
if( frExtraFieldLength > 0 )
uchar
frExtraField[ frExtraFieldLength ];
if( frCompressedSize > 0 )
uchar
frData[ frCompressedSize ];
} ZIPFILERECORD <size=SizeZIPFILERECORD>;
int SizeZIPFILERECORD( ZIPFILERECORD &r )
{
return 30 +
// base
ReadUInt(startof(r)+18) +
// size
ReadUShort(startof(r)+26) + // size
ReadUShort(startof(r)+28); // size

size of the struct
of the compressed data
of the file name
of the extra field
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}
Note that the size function should always return the size of a single element of the struct or union even if the
struct or union is defined as part of an array. Also note that applying colors to variables within on-demand
structures may not work as expected because the colors are not defined until the variables are created.

Related Topics:
I/O Functions
Structs and Unions
Working with Template Results
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Template Limitations
Binary Templates have a slightly different syntax than regular ANSI C files and are not meant to be fully ANSI
compliant. The following is a list of important differences between ANSI C and Binary Templates:














Pointers - See Script Limitations.
Preprocessor - See Script Limitations.
Multi-dimensional Arrays - When declaring arrays (see Arrays and Strings), multi-dimensional arrays
are not supported (this includes arrays of strings). When writing a Template, a combination of structs
and arrays can be used to simulate multi-dimensional arrays. For example, the array 'float matrix[4][4]'
could be defined as

typedef struct
{
float row[4];
}
MATRIX[4];
MATRIX m;
Control statements - See Script Limitations.

Related Topics:
Arrays and Strings
Script Limitations
Structs and Unions
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Interface Functions
The following is a list of functions for communicating with the 010 Editor program when writing a Template or
Script.

void AddBookmark(
int64 pos,
string name,
string typename,
int arraySize=-1,
int forecolor=cNone,
int backcolor=0xffffc4,
int moveWithCursor=false )
Creates a bookmark in the file on which the current Script or Template is being executed (not the actual Script or
Template). See Using Bookmarks for information on bookmarks and see Running Templates and Scripts for
information on controlling on which file a Script or Template is run.
pos indicates the file address where the bookmark will be generated and name gives the name of the bookmark
(this name can be empty). typename is a string giving the type of the bookmark to generate and this must be
one of the built-in types or a user-defined type. If the type is user-defined and the AddBookmark function is run
from a Template, that type must be defined in the current Template. If the type is user-defined and the
AddBookmark function is run from a Script, that type must be defined in a Template that has already been run on
the file (not in the current Script). Specify an array of variables using the arraySize argument or set arraySize to
-1 to just generate a single variable. The text color of the bookmark can be indicated using the forecolor
argument and the background color can be specified with the backcolor argument. If the moveWithCursor
argument is true, the bookmark will reposition itself to the cursor as the cursor moves around the file.
For example, after loading a ZIP file in 010 Editor (which will cause the 'ZIPTemplate.bt' Template to be run on
the file), create a new Script and run the following command on the file:

AddBookmark( GetCursorPos(), "endmarker",
"ZIPENDLOCATOR", -1, cRed );
Here the type "ZIPENDLOCATOR" type is defined in the 'ZIPTemplate.bt' file, not in the Script. The functions
GetNumBookmarks, GetBookmarkPos and GetBookmarkName can be used to query existing bookmarks and the
RemoveBookmark function can be used to erase bookmarks.
Requires 010 Editor v3.1 or higher.

void Assert( int value, const char msg[] = "" )
Stops execution of the script or template if the value is equal to zero. If execution is stopped, the text message
msg will be displayed in the Output tab of the Output Window (note that this is an optional argument). Because
conditional statements evaluate to 1 or 0 in C/C++, comparisons can be used in asserts. For example:

Assert( numRecords > 10,
"numRecords should be more than 10." );
Requires 010 Editor v3.1 or higher.

void ClearClipboard()
Removes any data that is on the currently active clipboard. See the SetClipboardIndex function to control which
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clipboard is active.
Requires 010 Editor v3.1 or higher.

void CopyBytesToClipboard( uchar buffer[], int size, int charset=CHARSET_ANSI, int bigendian=false
)
Copies size bytes from the array buffer and places them on the currently active clipboard. If the data being
copied represents a string, use the charset parameter to indicate which character set the string uses (see the
ConvertString function for a list of character sets). If copying Unicode data the bigendian parameter indicates if
the data is in big or little endian format, otherwise this parameter is ignored. See the SetClipboardIndex function
to control which clipboard is currently active.
Requires 010 Editor v5.0 or higher.

void CopyStringToClipboard( const char str[], int charset=CHARSET_ANSI )
Sets the currently active clipboard to contain the string passed in the str argument. The charset parameter tells
the clipboard what character encoding is used for the string (e.g. ANSI, UTF-8, etc.) and the list of possible
character sets is available in the ConvertString function. If copying hex bytes to the clipboard see the
CopyBytesToClipboard function and the active clipboard can be set using the SetClipboardIndex function.
Requires 010 Editor v3.1 or higher.

void CopyToClipboard()
Copies the currently selected bytes to the active clipboard. See SetSelection to change the selection or
SetClipboardIndex to set the active clipboard.

void CutToClipboard()
Copies the currently selected bytes to the active clipboard and deletes them from the file. See SetSelection to
change the selection or SetClipboardIndex to set the active clipboard.

int DeleteFile( char filename[] )
Deletes the file given by filename from disk. Note that the file should not be open in the editor or the delete will
fail. Returns a value less than zero on failure.

void DisableUndo()
Turns off undo support for a file. This function will speed up a script when writing a large number of changes to a
file. Undo is automatically turned on after the script is finished. Note that undo is automatically disabled for files
created with FileNew. See EnableUndo below.

void DisplayFormatBinary()
void DisplayFormatDecimal()
void DisplayFormatHex()
void DisplayFormatOctal()
Sets the display format of variables in the Inspector to binary, decimal, hexadecimal, or octal. Any variables
declared after this function is called will be displayed in the selected format. Note that the format can also be set
for one variable using the syntax <format=hex|decimal|octal|binary> after a declaration or typedef (see
Declaring Template Variables for more information).
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void EnableUndo()
Turns back on Undo support for a file after calling DisableUndo. Undo is automatically turned on after the script is
finished.

int Exec( const char program[], const char arguments[], int wait=false )
int Exec( const char program[], const char arguments[], int wait, int &errorCode )
Executes an external application using the given program and arguments. Returns 0 if successful or a negative
number if an error occurred. If the wait argument is true, this function waits for the external application to finish
processing before it returns. If wait is true and the errorCode parameter is given, the error code from the
executed program will be stored in the errorCode variable. Note that starting in 010 Editor version 3.1, this
function can no longer be called in a Template because of security issues.
Requires 010 Editor v3.1 or higher for the wait parameter.
Requires 010 Editor v6.0 or higher for the errorCode parameter.

void Exit( int errorcode )
Ends execution of the current script or template and displays the errorcode in the Output tab of the Output panel.
Note that usually the keyword return can be used to accomplish the same task unless execution is inside of a
custom function.
This function is special in that it can be used to return an ERRORLEVEL code to a batch file (see Command Line
Parameters for more information). The last errorcode that was passed to an Exit function, either from a script or
a template, will be returned as the global ERRORLEVEL when 010 Editor exits.

void ExpandAll()
Recursively opens all tree nodes in the Template Results panel. Variables that have the attribute
'<open=suppress>' set will not be opened. See Template Results for more information.
Requires 010 Editor v3.2 or higher.

void ExportCSV( const char filename[] )
Writes the contents of the Template Results panel to a file in a comma-delimited format which can be opened in
other programs such as Excel. The file is saved to the given filename and the ExpandAll function can be called
first to ensure all variables are included in the export. Alternately, the FPrintf function can be used to output
individual variables.
Requires 010 Editor v3.2 or higher.

void ExportXML( const char filename[] )
Similar to ExportCSV except the contents of the Template Results panel are written to a file in XML format. The
file to write is given by the filename paramater. Call the ExpandAll function first to ensure all variables are
included in the XML file.
Requires 010 Editor v6.0 or higher.

void FileClose()
Closes the current file. No file will be active after this function is called and use the FileSelect function to activate
another file. This function can also be used to close an open process or drive. Note that the user will not be asked
to save changes if the file is modified.
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int FileCount()
Returns the number of existing file handles. See FileSelect to set the current file.

int FileExists( const char filename[] )
Returns true if the given file name exists on disk, or false if it does not.

int FileNew( char interface[]="", int makeActive=true )
Creates a new file in the editor and returns the index of the created file (see GetFileNum). If the interface
parameter is not empty, the created file will be assigned that File Interface the same as using the
SetFileInterface function (for example, "Hex", "Text", or "Unicode"). If no interface is given, the default File
Interface is used from the Editor Options dialog.
If this function is run from a script and the makeActive parameter is true, the created file becomes the current
file. If this function is run from a template or the makeActive parameter is false, the current file does not change
(use the FPrintf function to write data to the returned file handle). Note that when new files are created, the undo
buffer is turned off by default, but will be turned on as soon as the script finishes.
Requires 010 Editor v4.0 or higher for the interface parameter.
Requires 010 Editor v5.0 or higher for the makeActive parameter.

int FileOpen( const char filename[], int runTemplate=false, char interface[]="", int
openDuplicate=false )
Opens the file specified by the UTF-8 encoded string filename into the editor. If runTemplate is true and a
Template is associated with that file (see Template Options), the Template will be run on the file. The opened file
will be assigned the File Interface interface (for example, "Hex", "Text", or "Unicode") and if interface is an empty
string, FileOpen will automatically choose an interface. If openDuplicate is true and the file to be opened is
already open in the editor, a duplicate copy of the file will be created but if openDuplicate is false, no action will
be taken. This function returns the file index of the opened file if the file could be loaded (see GetFileNum), the
file index of the already opened file if openDuplicate is false and the file is already open, or a negative number if
the file could not be opened (no error message is displayed if the file could not be found). FileOpen is usually
called in a Script but can be called in a Template if that Template is given special permission to read other files
(see Permissions).
Requires 010 Editor v3.1 or higher for the runTemplate parameter.
Requires 010 Editor v4.0 or higher for the interface or openDuplicate parameters.

int FileSave()
int FileSave( const char filename[] )
int FileSave( const wchar_t filename[] )
Saves the current file to the given file name. The file name can be either a UTF-8 string or a wide string. If
FileSave is called with no parameters, the file is saved to the current file name. See GetFileName or
GetFileNameW to retrieve the name of the current file. Returns a value less than zero on error. Note that when
using backslashes in Windows path names, two backslashes must be used in string constants. For example:

FileSave( "C:\\temp\\data.log" );
int FileSaveRange( const char filename[], int64 start, int64 size )
int FileSaveRange( const wchar_t filename[], int64 start, int64 size )
Similar to the FileSave function except that only part of the file is written to disk. size bytes starting from the
address start are written to the given filename and filename can be given in UTF-8 or Unicode format. Note that
filename must specify a different file than the current file name. Returns a negative value on error.
Requires 010 Editor v5.0 or higher.
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void FileSelect( int index )
Only one file can be active at a time and all of the Read/Write operations occur on that file. Use FileSelect to
select a different file to be the current file. The files are numbered from 0 up to FileCount()-1. See GetFileNum to
get the index of the current file.

int FindOpenFile( const char path[] )
int FindOpenFileW( const wchar_t path[] )
Searches through the list of all open files to see if the file indicated by path is currently open. If the file is open,
the index of the file is returned which can be used with the FileSelect function. If the file cannot be found, -1 is
returned. The FindOpenFileW operates similarly to the FindOpenFile function but takes as input a Unicode file
name.
Requires 010 Editor v4.0 or higher.

char[] GetArg( int index )
wchar_t[] GetArgW( int index )
Returns an argument passed to a script or a template from the command line. The GetArg function returns an
ASCII string and the GetArgW function returns a wide string. The index parameter must be a number between 0
and GetNumArgs()-1. If index is an invalid number an empty string is returned. See the GetNumArgs function or
the -script or -template parameter for more information on passing command line arguments.
Requires 010 Editor v3.2 or higher.

int GetBackColor()
Returns the currently active background color for template variables. See SetBackColor for more information.
Requires 010 Editor v6.0 or higher.

int GetBookmarkArraySize( int index )
If the bookmark specified by index is an array this function returns the number of elements in the array,
otherwise this function returns -1. index should be greater or equal to zero and less than the value returned by
GetNumBookmarks. See AddBookmark for more information.
Requires 010 Editor v5.0 or higher.

int GetBookmarkBackColor( int index )
This function returns an integer representing the background color of the bookmark specified by index. index
should be zero or greater and less than the number of bookmarks (see GetNumBookmarks). More information
about creating bookmarks can be found in the AddBookmark help topic.
Requires 010 Editor v5.0 or higher.

int GetBookmarkForeColor( int index )
Returns an integer representing the foreground (text) color of the bookmark indicated by the index parameter. A
return value of cNone means that the foreground color is not changed. index should be greater or equal to zero
and less that the total number of bookmarks. See GetNumBookmarks to retrieve the number of bookmarks and
AddBookmark for more information on adding bookmarks.
Requires 010 Editor v5.0 or higher.

int GetBookmarkMoveWithCursor( int index )
This function returns true if the bookmark specified by index is set to move around the file as the cursor moves
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(a floating bookmark). False is returned if this is not a floating bookmark. Bookmarks can be created to move
with the cursor using the AddBookmark function. Note that index should be greater or equal to zero and less that
the value returned by GetNumBookmarks.
Requires 010 Editor v5.0 or higher.

string GetBookmarkName( int index )
Returns a string which contains the name of a bookmark. index controls which bookmark name is returned and
the value of index should be greater or equal to zero, and less than the number of bookmarks (see
GetNumBookmarks). See AddBookmark for information on creating bookmarks.
Requires 010 Editor v3.1 or higher.

int64 GetBookmarkPos( int index )
Returns the starting address of a bookmark and the bookmark returned is specified using the index argument.
index should be greater or equal to zero, and less than the number of bookmarks (see GetNumBookmarks). See
AddBookmark for information on creating bookmarks.
Requires 010 Editor v3.1 or higher.

string GetBookmarkType( int index )
This function returns a string representing the type of data stored by the given bookmark (for example, "char" or
"int"). The index parameter must be greater or equal to zero and less than the value returned by
GetNumBookmarks. See the AddBookmark function for information about creating bookmarks.
Requires 010 Editor v5.0 or higher.

int GetBytesPerLine()
Returns the number of bytes displayed per line in the current Hex Editor Window. This value is by default 16, but
may change depending upon the current settings in the View Menu.

int GetClipboardBytes( uchar buffer[], int maxBytes )
Reads data from the currently active clipboard into the given buffer. At most maxBytes bytes will be read from
the clipboard and the buffer array must be large enough to hold maxBytes bytes. The return value is the number
of bytes written into the buffer, or 0 if no bytes could be read. Also see the GetClipboardString for reading strings
from the clipboard and the active clipboard can be set using the SetClipboardIndex function.
Requires 010 Editor v5.0 or higher.

int GetClipboardIndex()
Returns the index of the currently active clipboard. A return value of 0 means the standard system clipboard is
chosen and a value of 1 to 9 inclusive means a custom clipboard is chosen. All clipboard operations including
CopyToClipboard, CutToClipboard, PasteFromClipboard, CopyBytesToClipboard, CopyStringToClipboard,
GetClipboardBytes, GetClipboardString, and ClearClipboard operate on the currently selected clipboard. Use the
SetClipboardIndex function to select a different clipboard and see Using the Clipboard for more information on
using multiple clipboards. The currently active clipboard is indicated in the Status Bar.
Requires 010 Editor v5.0 or higher.

string GetClipboardString()
If the active clipboard currently contains a string, this string will be returned by the GetClipboardString function.
If the data on the clipboard cannot be converted to a string, an empty string will be returned. If the clipboard
contains hex data that may include null characters, use the GetClipboardBytes function instead. The active
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clipboard can be set using the SetClipboardIndex function.
Requires 010 Editor v3.1 or higher.

string GetCurrentTime( char format[] = "hh:mm:ss" )
Returns a string representing the current time in the format "hh:mm:ss" by default (note this is using the 24hour clock). For information on different formats that can be used see the GetCurrentDateTime function.
Requires 010 Editor v3.1 or higher.
Requires 010 Editor v4.0 or higher for the format parameter.

string GetCurrentDate( char format[] = "MM/dd/yyyy" )
Returns a string representing the current date in the format "MM/dd/yyyy" by default. For information on
different formats that can be used see the GetCurrentDateTime function.
Requires 010 Editor v3.1 or higher.
Requires 010 Editor v4.0 or higher for the format parameter.

string GetCurrentDateTime( char format[] = "MM/dd/yyyy hh:mm:ss" )
Returns a string representing the current date and time in the format "MM/dd/yyyy hh:mm:ss" by default (note
this is using the 24-hour clock). When specifying a custom format, the following characters can be used:




















h - hour without leading zero
hh - hour with leading zero
m - minute without leading zero
mm - minute with leading zero
s - second without leading zero
ss - second with leading zero
AP - either AM or PM
ap - either am or pm
d - day without leading zero
dd - day with leading zero
ddd - short day (e.g. 'Mon')
dddd - long day (e.g. 'Monday')
M - month without leading zero
MM - month with leading zero
MMM - short month (e.g. 'Jan')
MMMM - long month (e.g. 'January')
yy - 2-digit year
yyyy - 4-digit year

Functions such as StringToTimeT or StringToOleTime can be used to convert the resulting string to a date format.
Requires 010 Editor v3.1 or higher.
Requires 010 Editor v4.0 or higher for the format parameter.

int64 GetCursorPos()
Returns the address of the cursor in the file.

char[] GetEnv( const char str[] )
Attempts to locate the system environment variable indicated by str. If the environment variable is found, the
value of the environment variable is returned as a UTF-8 string and if it could not be found an empty string is
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returned.
Requires 010 Editor v4.0 or higher.

int GetFileAttributesUnix()
Returns the file attributes of a file on a Unix or Macintosh operating system as a bit flag. The resulting value has
nine different flags: read, write and execute for each of the areas user, group, and other. The following constants
can be used for testing the bits:











FILEATTR_READ_USER
FILEATTR_WRITE_USER
FILEATTR_EXE_USER
FILEATTR_READ_GROUP
FILEATTR_WRITE_GROUP
FILEATTR_EXE_GROUP
FILEATTR_READ_OTHER
FILEATTR_WRITE_OTHER
FILEATTR_EXE_OTHER

If the file is not a valid file or the file is not in a Unix or Macintosh operating system, the constant
FILEATTR_INVALID is returned. For example:

int flags = GetFileAttributesUnix();
if( (flags != FILEATTR_INVALID) && !(flags & FILEATTR_READ_USER) )
Printf( "File is read only.\n" );
See the SetFileAttributesUnix function to modify the attributes.
Requires 010 Editor v4.0 or higher.

int GetFileAttributesWin()
Returns the file attributes of a file on a Windows operating system as a bit flag. The resulting constants can be
used for testing the bits:






FILEATTR_ARCHIVE
FILEATTR_HIDDEN
FILEATTR_READONLY
FILEATTR_SYSTEM

If the file is not a valid file or the file is not in a Windows operating system, the constant FILEATTR_INVALID is
returned. For example:

int flags = GetFileAttributesWin();
if( (flags != FILEATTR_INVALID) && (flags & FILEATTR_READONLY) )
Printf( "File is read only.\n" );
See the SetFileAttributesWin function to modify the attributes.
Requires 010 Editor v4.0 or higher.

int GetFileCharSet()
Returns an integer representing the character set of the current file. The list of possible character sets is available
in the ConvertString function.
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Requires 010 Editor v4.0 or higher.

char[] GetFileInterface()
Returns a string representing the File Interface of the current file. The File Interface name is listed in the Edit As
section above each editor (for example: "Hex", "Text", or "Unicode"). See the SetFileInterface function to change
the interface of the current file.
Requires 010 Editor v4.0 or higher.

char[] GetFileName()
Returns a string representing the file name of the current file including the path. The string is returned in UTF-8
format.

wchar_t[] GetFileNameW()
Returns a wide string which contains the file name of the current file including the path.
Requires 010 Editor v3.2 or higher.

int GetFileNum()
Each open file is assigned a index from 0 up to FileCount()-1. This function returns the index of the current file.
Use the FileSelect function to make another file the active file.

int GetForeColor()
Returns the currently active foreground (text) color for template variables. See SetForeColor for more
information.
Requires 010 Editor v6.0 or higher.

int GetMouseWheelScrollSpeed()
Returns the number of lines that are scrolled every time a mouse scroll wheel is clicked ahead or back. The scroll
speed can be controlled with the Editor Options dialog or with the SetMouseWheelScrollSpeed function.
Requires 010 Editor v6.0 or higher.

int GetNumArgs()
Returns the number of arguments that were passed to this script or template from the command line. The
individual arguments can be accessed using the GetArg and GetArgW functions. For more information on how to
pass arguments see the -script and -template command line parameters.
Requires 010 Editor v3.2 or higher.

int GetNumBookmarks()
Returns the number of bookmarks set for the file that the current Script or Template is being run on (see
Running Templates and Scripts for more information on choosing which file to run a Template or Script on). See
the AddBookmark function for information on creating bookmarks.
Requires 010 Editor v3.1 or higher.

int GetReadOnly()
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Returns true if the file is marked as read-only, or false if the file can be modified.

char[] GetScriptName()
wchar_t[] GetScriptNameW()
These functions return the name of the script that is currently being executed. This name is calculated by taking
the full file name of the script and removing the path information. For example, if the script being run was
'H:\Scripts\Test.1sc', these functions would return 'Test.1sc'. GetScriptName returns a UTF-8 string and
GetScriptNameW returns a Unicode string.
Requires 010 Editor v4.0 or higher.

char[] GetScriptFileName()
wchar_t[] GetScriptFileNameW()
When a script is being executed, these functions return the full file name of the script being run.
GetScriptFileName returns a UTF-8 string and GetScriptFileNameW returns a Unicode string.
Requires 010 Editor v4.0 or higher.

int64 GetSelSize()
Returns the number of bytes that have been selected. Returns 0 if no selection is made.

int64 GetSelStart()
Returns the start address of the selection. Use GetSelSize to determine if a selection has been made.

string GetTempDirectory()
Returns a string representing the current temporary directory set using the Directory Options dialog. The temp
directory will contain a slash as the last character (e.g. "C:\temp\").
Requires 010 Editor v3.1 or higher.

char[] GetTempFileName()
Returns the full path of a file that can be used as a temporary file. The file will be in the current temporary
directory and will be guaranteed not to exist. The returned file name is in UTF-8 format.
Requires 010 Editor v4.0 or higher.

char[] GetTemplateName()
wchar_t[] GetTemplateNameW()
These functions operate by taking the full template file name as returned from the functions
GetTemplateFileName or GetTemplateFileNameW, removing the path information and returning the result. For
example, if the current Template being run was 'H:\Templates\Test.bt', these functions would return 'Test.bt'.
GetTemplateName returns a UTF-8 string and GetTemplateNameW returns a Unicode string.
Requires 010 Editor v4.0 or higher.

char[] GetTemplateFileName()
wchar_t[] GetTemplateFileNameW()
When run in a Template, these functions return the full file name of the Template that is being run. When run in
a Script, these functions return the full file name of the Template that has been associated with the target file, or
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an empty string if there is no associated Template. GetTemplateFileName returns a UTF-8 string and
GetTemplateFileNameW returns a Unicode string.
Requires 010 Editor v4.0 or higher.

char[] GetWorkingDirectory()
wchar_t[] GetWorkingDirectoryW()
Returns the full path of the current working directory for the application. The last character of the directory will
be a slash and the current working directory can be set using the SetWorkingDirectory and
SetWorkingDirectoryW functions. GetWorkingDirectory returns UTF-8 string and GetWorkingDirectoryW returns a
Unicode string.
Requires 010 Editor v4.0 or higher.

char[] InputDirectory( const char title[], const char defaultDir[]="" )
Allows the user to choose a directory using the standard system directory select dialog. The title string is
displayed in the title bar of the dialog. The defaultDir paramater allows setting the initial directory when the
dialog is first displayed and if this parameter is null, the last chosen directory will be used. The return value is the
directory name in UTF-8 format including a trailing slash, or an empty string if the dialog was cancelled.
Requires 010 Editor v5.0 or higher.

double InputFloat(
const char title[],
const char caption[],
const char defaultValue[] )
Opens up a dialog with a single edit box. The title displays in the title bar of the dialog and the caption displays
above the edit box. The defaultValue specifies the starting value in the edit box. This function returns the
floating-point value of the number entered in the edit box. If an invalid number is entered or Cancel is pressed,
the constant BAD_VALUE is returned.

int InputNumber(
const char title[],
const char caption[],
const char defaultValue[] )
Similar to InputFloat except an integer is returned instead of a float value. If an invalid number is entered or
Cancel is pressed, the constant BAD_VALUE is returned.

char[] InputOpenFileName(
char title[],
char filter[]="All files (*.*)",
char filename[]="" )
Shows a standard file open dialog box with the caption title. The filter controls which file masks are available in
the File Type drop-down list. Specify filters as an array of strings separated by the '|' character (the file masks
should be inside brackets). The filename gives the default file name of the file to open and may just contain a
directory to start the dialog in that directory. Only a single file may be selected with the file dialog box. The
returned value is the full chosen file name in UTF-8 format, or an empty string if cancel was pressed.

TOpenFileNames InputOpenFileNames(
char title[],
char filter[]="All files (*.*)",
char filename[]="" )
Similar to InputOpenFileName except that multiple files may be selected. The results are returned in a structure
TOpenFileNames that contains a count variable indicating the number of opened files (zero if cancel was
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pressed), and an array of file variables which each have a UTF-8 filename variable indicating the selected file. For
example:

int i;
TOpenFileNames f = InputOpenFileNames(
"Open File Test",
"C Files (*.c *.cpp)|All Files (*.*)" );
for( i = 0; i < f.count; i++ )
Printf( "%s\n", f.file[i].filename );
will print out all file names selected.

int InputRadioButtonBox(
const char title[],
const char caption[],
int defaultIndex,
const char str1[], const char str2[], const char str3[]="",
const char str4[]="", const char str5[]="", const char str6[]="",
const char str7[]="", const char str8[]="", const char str9[]="",
const char str10[]="", const char str11[]="", const char str12[]="",
const char str13[]="", const char str14[]="", const char str15[]="" )
Displays a dialog box containing a number of radio buttons which allows a user to pick one choice from a list of
options. The title string is displayed in the title bar and the caption string is displayed above the first radio
button. The list of options to be displayed is controlled using the str1 .. str15 parameters. Which radio button is
chosen by default is controlled with the defaultIndex parameter (use a value of -1 to not use a default and note
that 0 represents the first item). The return value of this function is the index of the chosen radio button (0 is the
first item, 1 the next, etc), or -1 is returned if the dialog was cancelled.
Requires 010 Editor v5.0 or higher.

char[] InputSaveFileName(
char title[],
char filter[]="All files (*.*)",
char filename[]="",
char extension[]="" )
Uses a standard file save dialog box to select a file name suitable to use when saving a file. The user will be
asked to overwrite a file if it already exists on disk. The title, filter and filename arguments are similar to the
InputOpenFileName function. If no extension is given for the file name, a period and the extension argument will
automatically be appended to the file name. The return value is the full chosen file name in UTF-8 format, or an
empty string if cancel was pressed.

char[] InputString(
const char title[],
const char caption[],
const char defaultValue[] )
Similar to InputFloat except that the string value of the edit box is returned instead of a float value. If Cancel is
pressed, an empty string is returned.

wstring InputWString(
const char title[],
const char caption[],
const wstring defaultValue )
Displays a dialog for the user to enter a wide string (unicode string). See the InputFloat function for an
explanation of the different arguments. If Cancel is pressed, an empty string is returned.
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Requires 010 Editor v3.1 or higher.

int InsertFile( const char filename[], int64 position )
Inserts all of the bytes in the file given by filename into the current file starting at position. A negative number is
returned if the file cannot be inserted.

int IsEditorFocused()
Returns true if a Editor Window is currently focused. This function is useful if you want to build a script that
controls the cursor of the Editor Window and only want the cursor to move when the window is focused.

int IsModified()
Returns true if any changes have been made to the file, or false otherwise.

int IsNoUIMode()
Returns true if 010 Editor is currently in -noui mode, or false otherwise. See Command Line Parameters for more
information on -noui mode.
Requires 010 Editor v3.2 or higher.

int MessageBox( int mask, const char title[], const char format[] [, argument, ... ] )
Displays a message box to the user with a number of buttons to press. The buttons displayed depend upon an OR
mask of four values. The Ok, Cancel, Yes, or No buttons can be displayed by using the constants idOk, idCancel,
idYes, or idNo respectively (note that not all possible combinations are supported). The title is display in the title
bar of the message box. The message to display is obtained using a syntax similar to printf (see Printf below).
The return value is one of the constants idOk, idCancel, idYes, or idNo depending upon which button was
pressed. For example, to display a message box with Yes and No buttons use:

if( MessageBox( idYes | idNo,
"Script",
"Save changes to '%s'?",
GetFileName() )
== idYes )
. . .
Note that extended characters can be displayed in the message box by passing strings in UTF-8 format.

void OutputPaneClear()
The Output Pane refers to the area where text from the Printf function is displayed (located in the Output tab of
the Output Window). When this function is called, all previous output in the Output Pane is cleared.
Requires 010 Editor v3.1 or higher.

int OutputPaneSave( const char filename[] )
Saves all text in the Output tab of the Output Window to a file on disk. The filename argument gives the name of
the target output file. This function returns 0 if the file was successfully written or a negative number if the file
could not be written.
Requires 010 Editor v3.1 or higher.
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void OutputPaneCopy()
Copies the text in the Output tab of the Output Window to the operating system clipboard.
Requires 010 Editor v3.1 or higher.

void PasteFromClipboard()
Inserts any bytes in the currently active clipboard into the file starting at the current cursor position. If a
selection has been made, the selected bytes will be deleted before the bytes are inserted. See the
SetClipboardIndex function to control which clipboard is active.

int Printf( const char format[] [, argument, ... ] )
Similar to the standard C printf function. Accepts a format specifier and a series of arguments. The results of the
Printf are displayed in the Output tab of the Output Window and the following codes can be used to specify
different data types:













%d, %i - signed integer
%u - unsigned integer
%x, %X - hex integer
%o - octal integer
%c - character
%s - string
%f, %e, %g - float
%lf - double
%Ld - signed int64
%Lu - unsigned int64
%Lx, %LX - hex int64

Width, precision, and justification characters are also supported (e.g. "%5.2lf", or "%-15s") and the newline
character can be specified with '\n'. This function is different than the standard C printf function because type
checking and casting are done on each of the arguments of the function. For example, in this function call the
number '5' is automatically cast to a double:

Printf( "Num = %d, Float = %lf, Str = '%s'\n", 15, 5, "Test" );
The above statement would display "Num = 15, Float = 5.000000, Str = 'Test'". Extended characters can be
printed in the Output Window by passing a string in UTF-8 format. Wide strings can be printed with Printf using
the regular '%s' specifier because they will automatically be cast to a UTF-8 string. Previous to version 4.0 of 010
Editor, the Printf function did some interpretation of basic HTML tags but this has been removed in version 4.0.
Consult documentation on the standard C printf function for more information on different specifiers that can be
used.
The Output Window is automatically shown when Printf is called in a Script but is not automatically shown when
Printf is called in a Template. This functionality can be controlled via the Compiling Options dialog.

int64 ProcessGetHeapLocalAddress( int index )
Each memory heap in a process is assigned a position in the current file. This function returns the starting local
file address for the heap given by index. index must be between 0 and ProcessGetNumHeaps()-1. If the current
file is not a process or if index does not refer to a valid heap, -1 is returned. See Editing Processes for more
information on processes and heaps.
Requires 010 Editor v3.2 or higher.
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wchar_t[] ProcessGetHeapModule( int index )
Returns the name of the module to which the given memory heap belongs. The module name is returned as a
wide string and index must be between 0 and ProcessGetNumHeaps()-1. If the current file is not a process or if
index does not refer to a valid heap or if the given heap is not associated with a module, an empty string is
returned. For more information on heaps and modules see Editing Processes.
Requires 010 Editor v3.2 or higher.

int ProcessGetHeapSize( int index )
Returns the size in number of bytes for the heap given by index. index must be between 0 and
ProcessGetNumHeaps()-1. If the current file is not a process or if index does not refer to a valid heap, -1 is
returned.
Requires 010 Editor v3.2 or higher.

int64 ProcessGetHeapStartAddress( int index )
Returns the starting address in memory for the heap given by index. index must be between 0 and
ProcessGetNumHeaps()-1. If the current file is not a process or if index does not refer to a valid heap, -1 is
returned.
Requires 010 Editor v3.2 or higher.

int ProcessGetNumHeaps()
Returns the number of memory heaps for the current process. If the current file is not a process, 0 is returned.
See Editing Processes for more information on processes and heaps.
Requires 010 Editor v3.2 or higher.

int64 ProcessHeapToLocalAddress( int64 memoryAddress )
Each heap in a process has two addresses: a memory address where the data actually exists in computer
memory and a local file address where the data is located for editing in 010 Editor. Given an address
memoryAddress in system memory, this function returns the equivalent address in the local file. See Editing
Processes for more information on processes and heaps.
Requires 010 Editor v3.2 or higher.

int64 ProcessLocalToHeapAddress( int64 localAddress )
Each heap in a process has two addresses: a memory address where the data actually exists in computer
memory and a local file address where the data is located for editing in 010 Editor. Given an address localAddress
in the local file, this function returns the equivalent address in system memory. See Editing Processes for more
information on processes and heaps.
Requires 010 Editor v3.2 or higher.

void RemoveBookmark( int index )
Removes a bookmark from the current file. The index argument specifies which bookmark to remove and its
value should be greater or equal to zero, and less than the number of bookmarks (see GetNumBookmarks). For
information on creating bookmarks see AddBookmark.
Requires 010 Editor v3.1 or higher.

int RenameFile( const char originalname[], const char newname[] )
Renames a file on disk from originalname to newname. Note that the file should not be open in the editor when it
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is renamed. A negative number if returned if the rename fails.

void RequiresFile()
Scripts can either be run with a target file or without a target file (select "(none)" in the Run on File section when
editing a Script to run it without a target file). If this function is called and the current script is being run without
a target file, a runtime error will be displayed and the script will be stopped. This function should not be called in
a Template because Templates must always have a target file.
Requires 010 Editor v4.0 or higher.

void RequiresVersion( int majorVer, int minorVer=0, int revision=0 )
Indicates what version of 010 Editor is required to execute the current script or template. The execution of the
script or template will stop if the current version of 010 Editor is less than the version number given by the
majorVer, minorVer, and reversion parameters. For example, with 010 Editor version '3.0.2', the '3' is the major
version, '0' is the minor version, and '2' is the revision number. Use this function to ensure that other people that
are running your scripts or templates are using the proper version of 010 Editor.

void RunTemplate( const char filename[]="", int clearOutput=false )
This function can be called in a Script to execute a Template on the current file. The filename argument indicates
which Template file to run and the filename can either be a full file path, or can be just the name of the file and
010 Editor will attempt to locate the Template using the same rules as locating Include files. For example,
'RunTemplate( "ZIPTemplate.bt" );' will attempt to locate the "ZIPTemplate.bt" file and execute it on the current
file. filename can also be an empty string in which case the Template which is associated with the current file will
be run (usually this is the last Template that was run on the file). If the Template cannot be located or if there is
an error executing the Template, program execution will be stopped. If clearOutput is true, the Output tab of the
Output Window will be cleared before the Template is started.
Requires 010 Editor v3.1 or higher.
Requires 010 Editor v4.0 or higher for the clearOutput parameter
or passing an empty filename.

void SetBackColor( int color )
void SetColor( int forecolor, int backcolor )
void SetForeColor( int color )
These functions are used when writing a Template to apply color to different variables. All variables defined after
calling one of these functions will be displayed in the given color. SetForeColor sets the foreground (text) color,
and SetBackColor sets the background color. Use SetColor to set both the foreground and background color at
the same time. A color is an integer made up of 3 hex bytes specifying the blue, green, and red components of
the color. The following constants are defined and may be used when setting colors:


















cBlack - 0x000000
cRed - 0x0000ff
cDkRed - 0x000080
cLtRed - 0x8080ff
cGreen - 0x00ff00
cDkGreen - 0x008000
cLtGreen - 0x80ff80
cBlue - 0xff0000
cDkBlue - 0x800000
cLtBlue - 0xff8080
cPurple - 0xff00ff
cDkPurple - 0x800080
cLtPurple - 0xffe0ff
cAqua - 0xffff00
cDkAqua - 0x808000
cLtAqua - 0xffffe0
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cYellow - 0x00ffff
cDkYellow - 0x008080
cLtYellow - 0x80ffff
cDkGray - 0x404040
cGray - 0x808080,
cSilver - 0xc0c0c0,
cLtGray - 0xe0e0e0
cWhite - 0xffffff
cNone - 0xffffffff

The cNone constant indicates that no color should be applied. See GetBackColor and GetForeColor to get the
value of the currently active color.

int SetClipboardIndex( int index )
Sets which clipboard is the currently active clipboard. An index value of 0 indicates the normal system clipboard
and a value of 1 through 9 indicates one of the custom clipboards. All clipboard functions including
CopyToClipboard, PasteFromClipboard, etc. operate on the currently active clipboard. See the GetClipboardIndex
function to retrieve which clipboard is active and see Using the Clipboard for more information on using multiple
clipboards. Note that setting the clipboard index effects the whole application and the selected clipboard will
remain active after the script has finished executing. See the Status Bar for a visual indication of which clipboard
is active.
Requires 010 Editor v5.0 or higher.

void SetCursorPos( int64 pos )
Sets the cursor position in the current file to pos. A flashing caret will visually indicate the cursor position in the
file.

int SetEnv( const char str[], const char value[] )
Attempts to set the system environment variable indicated by str to the given value (both str and value are UTF8 strings). Note that the environment variable changes are only local to the 010 Editor process, so when 010
Editor is closed the changes will be lost. Returns 0 on success or a negative number on failure.
Requires 010 Editor v5.0 or higher.

int SetFileAttributesUnix( int attributes )
Sets the file attributes of the current Unix or Macintosh file to attributes. The attributes are a bit flag composed of
the constants listed in the GetFileAttributesUnix function. This function returns true if the file is on a Unix or
Macintosh operating system and the attributes were set properly, or false otherwise. For example:

int flags = GetFileAttributesUnix();
if( flags != FILEATTR_INVALID )
SetFileAttributesUnix( flags & ~(FILEATTR_READ_USER) );
Requires 010 Editor v4.0 or higher.

int SetFileAttributesWin( int attributes )
Sets the file attributes of the current Windows file to the given attributes. The attributes are a bit flag made up of
the constants in the GetFileAttributesWin function. This function returns true if the file is a valid Windows file and
the attributes were set properly, or returns false otherwise. For example:

int flags = GetFileAttributesWin();
if( flags != FILEATTR_INVALID )
SetFileAttributesWin( flags | FILEATTR_READONLY );
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Requires 010 Editor v4.0 or higher.

int SetFileInterface( const char name[] )
Sets the File Interface of the current file to the interface with the given name. The current interface of the file can
be returned using the GetFileInterface function. The list of valid File Interfaces is found in the Edit As section of
the File Bar above each editor (for example: "Hex", "Text", or "Unicode"). This functions returns 0 if the change
was successful or a negative number if the Interface could not be found.
Requires 010 Editor v4.0 or higher.

void SetMouseWheelScrollSpeed( int speed )
Sets the number of lines that are scrolled each time a scroll wheel on a mouse is clicked forward or backward.
The scroll speed is also listed in the Editor Options dialog and the scroll speed can be investigated with the
GetMouseWheelScrollSpeed function.
Requires 010 Editor v6.0 or higher.

int SetReadOnly( int readonly )
Sets the read-only status of the current file to true or false. A negative number is returned if the read-only status
could not be changed.

void SetSelection( int64 start, int64 size )
Selects size bytes from the file starting at the address start. The selected bytes will appear blue in the main
window.

int SetWorkingDirectory( const char dir[] )
int SetWorkingDirectoryW( const wchar_t dir[] )
Sets the current working directory of the application to the directory dir. The current working directory can be
retrieved using the GetWorkingDirectory or GetWorkingDirectoryW functions. This functions returns 0 if the
directory is valid and could be set, or a negative number if the directory is not valid.
Requires 010 Editor v4.0 or higher.

void Sleep( int milliseconds )
Halts program execution for the given number of milliseconds. For example, 'Sleep(2000);' would cause a pause
of two seconds. Note that for sleeps of more than 1000 milliseconds the screen is automatically repainted before
the sleep occurs.
Requires 010 Editor v3.1 or higher.

void StatusMessage( const char format[] [, argument, ... ] )
Similar to the Printf function except the resulting string is displayed in the Status Bar of the application as a
normal status message. See also the Warning function.
Requires 010 Editor v4.0 or higher.

void Terminate( int force=true )
Exits out of the script and then shuts down 010 Editor. If force is true, all open files will be closed and any
unsaved modifications will be lost. If force is false and files are modified, the user will be asked if they want to
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save the files and optionally given a chance to cancel the shut down procedure.

void Warning( const char format[] [, argument, ... ] )
Similar to the Printf function except the resulting string is displayed in the Status Bar of the application and is
highlighted orange. This is useful to display an error that occurs in a Template. See also the StatusMessage
function.

Related Topics:
Declaring Template Variables
I/O Functions
Math Functions
Running Templates and Scripts
Status Bar
String Functions
Tool Functions
Using Bookmarks
Copyright © 2003-2013 SweetScape Software - www.sweetscape.com
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I/O Functions
The following is a list of input/output functions that can be used when writing Templates or Scripts.

void BigEndian()
Indicates that all subsequent reads and writes from the file should use big-endian byte order. This function can
be used in a Template to specify the byte order of variables.

void BitfieldDisablePadding()
void BitfieldEnablePadding()
These functions control how multiple bitfields are packed into a set of bits. See Bitfields more information on
bitfields. Padding is enabled by default.

void BitfieldLeftToRight()
void BitfieldRightToLeft()
These functions control how bitfields are packed into a variable. See Bitfields for an introduction to using bitfields.
The packing is different depending on if the Template is in big or little endian mode. In little endian mode the
default is right-to-left and in big endian mode the default is left-to-right.

double ConvertBytesToDouble( uchar byteArray[] )
float ConvertBytesToFloat( uchar byteArray[] )
hfloat ConvertBytesToHFloat( uchar byteArray[] )
These functions take as input an array of hex bytes byteArray and returns either the double, float, or hfloat that
is represented by those bytes. The byteArray parameter must contain at least 8 bytes for the
ConvertBytesToDouble function, 4 bytes for the ConvertBytesToFloat function, or 2 bytes for the
ConvertBytesToHFloat function. The conversion is performed using the endian for the current file, which can be
controlled using the BigEndian or LittleEndian functions. See the ConvertDataToBytes function to convert a
double, float, or hfloat to a set of bytes.
Requires 010 Editor v5.0 or higher.

int ConvertDataToBytes( data_type value, uchar byteArray[] )
Given a variable value that can be of any of the main data types (e.g. float, short, int, etc.), this function
converts the variable to a set of bytes as it would be written to a file and stores the results in the byteArray
variable. The return value is the number of bytes written to the array. Note that byteArray must be large enough
to hold the bytes from the conversion. The endian used for the conversion is taken from the current file endian,
which can be set using the BigEndian or LittleEndian functions.
Requires 010 Editor v3.1 or higher.

void DeleteBytes( int64 start, int64 size )
Deletes size bytes from the file, starting at address start.
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int DirectoryExists( string dir )
Returns true if the given directory exists on disk or false if it does not. dir should be the full path for a directory.

int FEof()
Returns true if the current read position is at the end of the file.

int64 FileSize()
Returns the size of the current file in bytes.

TFileList FindFiles( string dir, string filter )
This function scans the given directory dir and returns all files that match the filter. The filter can contain the
wildcard characters * and ? and can contain multiple filters separated by semi-colons (for example,
"*.cpp;*.c;*.h"). The results are returned in a TFileList structure which has a filecount variable indicating the
number of files that match the filter, and an array of file variables which each contain a string filename. The
TFileList also contains a list of sub-directories in the given directory. The dircount variable indicates how many
sub-directories exist and an array of dir variables contains a dirname string for each directory. For example:

TFileList fl = FindFiles( "C:\\temp\\", "*.zip" );
int i;
Printf( "Num files = %d\n", fl.filecount );
for( i = 0; i < fl.filecount; i++ )
{
Printf( " %s\n", fl.file[i].filename );
}
Printf( "\n" );
Printf( "Num dirs = %d\n", fl.dircount );
for( i = 0; i < fl.dircount; i++ )
{
Printf( " %s\n", fl.dir[i].dirname );
}
int FPrintf( int fileNum, char format[], ... )
Performs a Printf starting from format and writes the resulting string to the file with index fileNum. Use the
function GetFileNum to get the index of a file. The string is written at the current read/write position as given by
FSeek and then the read/write position is moved forward. Use this function to read data from one file and write
the results to another file. This function can also be used in a Template to write data to a different file as the
Template is being run (see Permissions). See Printf for more information on format specifiers.

int FSeek( int64 pos )
Sets the current read position to the address pos. The read position is used when defining variables in a
Template. Using this function, bytes can be processed in any order. Returns 0 if successful or -1 if the address
was out of range. Use the FTell function to query the current read position.

int FSkip( int64 offset )
Moves the current read position ahead by offset bytes. offset can also be negative to move the read position
backwards. The read position is used when defining variables in a template. Using this function, bytes can be
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processed in any order. Returns 0 if successful, or -1 if the address was out of range.

int64 FTell()
Returns the current read position of the file. This read position is used when defining variables in a Template.
Every time a variable is defined in a template, the read position moves ahead the number of bytes used by the
variable. See the FSeek and FSkip functions for another way to change the read position, and note that functions
like ReadByte do not affect the read position.

void InsertBytes( int64 start, int64 size, uchar value=0 )
Inserts size bytes into the file starting at address start. If start is at the end of the file, the file will be lengthened
by size bytes. The value of each inserted byte can be controlled using the value parameter. Note that this
function or any of the 'Write' functions can be used to lengthen a file. See also the OverwriteBytes function to
overwrite data in a file.
Requires 010 Editor v5.0 or higher for the value parameter.

int IsBigEndian()
Returns true if the file is being read in big-endian byte order, or false otherwise.

int IsLittleEndian()
Returns true if the file is being read in little-endian byte order, or false otherwise.

void LittleEndian()
Indicates that all subsequent reads and writes from the file should use little-endian byte order. This function can
be used in a Template to specify the byte order of variables.

int MakeDir( string dir )
Attempts to create the directory given by dir. If any of the parent directories of the given directory do not exist,
they will be created too. For example, MakeDir( "C:\\app\\data\\backup\\" ) will create the directories "C:\app\"
and "C:\app\data\" if necessary. Returns true if the functions succeeds or false otherwise.

void OverwriteBytes( int64 start, int64 size, uchar value=0 )
Overwrites size bytes in the file starting at address start. The value of each byte written is controlled by the value
parameter. If the overwrite goes past the end of the file, the file will automatically be lengthened. See also the
InsertBytes function to insert data into a file.
Requires 010 Editor v5.0 or higher.

char ReadByte( int64 pos=FTell() )
double ReadDouble( int64 pos=FTell() )
float ReadFloat( int64 pos=FTell() )
hfloat ReadHFloat( int64 pos=FTell() )
int ReadInt( int64 pos=FTell() )
int64 ReadInt64( int64 pos=FTell() )
int64 ReadQuad( int64 pos=FTell() )
short ReadShort( int64 pos=FTell() )
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uchar ReadUByte( int64 pos=FTell() )
uint ReadUInt( int64 pos=FTell() )
uint64 ReadUInt64( int64 pos=FTell() )
uint64 ReadUQuad( int64 pos=FTell() )
ushort ReadUShort( int64 pos=FTell() )
Returns data read from the file at address pos. If no pos is given, pos defaults to the current read position as
reported by FTell. These functions can be used in a Template to read data from a file without declaring a variable
and note that these functions do not affect the current read position.
Requires 010 Editor v5.0 or higher for the ReadHFloat function.
Requires 010 Editor v6.0 or higher for the default parameter.

char[] ReadLine( int64 pos, int maxLen=-1, int includeLinefeeds=true )
Reads a string from the file starting at address pos. Reads characters until a null-character or end-of-line
sequence is found. If maxLen is greater than zero, the returned string will have at most maxLen characters but if
maxLen is -1 the parameter will be ignored. If includeLinefeeds is true the linefeeds will be returned as part of
the string, otherwise the linefeed characters will not be included.
Requires 010 Editor v5.0 or higher for the maxLen parameter.
Requires 010 Editor v6.0 or higher for the includeLinefeeds parameter.

void ReadBytes( uchar buffer[], int64 pos, int n )
Reads n bytes starting from the address pos into the character array buffer. Note that char[] and uchar[] can be
used interchangeably.

char[] ReadString( int64 pos, int maxLen=-1 )
Reads a string from the file starting at address pos. Reads characters until a null-character is found or maxLen
characters are read. If maxLen equals -1, the maxLen parameter is ignored.
Requires 010 Editor v5.0 or higher for the maxLen parameter.

int ReadStringLength( int64 pos, int maxLen=-1 )
Returns the length of a null-terminated string if it were read at the address pos in the target file. In other words,
this function counts the number of bytes until a null-byte is encountered, starting from address pos. The returned
length includes space for the null-character. If maxLen is greater than zero, the returned string will have at most
maxLen bytes but if maxLen is -1, the file will be scanned until the end-of-file is reached.
Requires 010 Editor v4.0 or higher.

wstring ReadWLine( int64 pos, int maxLen=-1 )
Reads a wide (unicode) string from the file starting at address pos. The string is read until a null-character or
end-of-line sequence is encountered. If maxLen is greater than zero, the returned string will have at most
maxLen characters but if maxLen is -1 the parameter will be ignored. Note that the endian used for reading is
taken from the current file endian, which can be set using the BigEndian or LittleEndian functions.
Requires 010 Editor v3.1 or higher.
Requires 010 Editor v5.0 or higher for the maxLen parameter.

wstring ReadWString( int64 pos, int maxLen=-1 )
Reads a wide (unicode) string from the file starting at the address pos. The string is read until a null-character is
encountered or maxLen characters are read. If maxLen equals -1, the maxLen parameter is ignored. Note that
the endian used for reading is taken from the current file endian, which can be set using the BigEndian or
LittleEndian functions.
Requires 010 Editor v3.1 or higher.
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Requires 010 Editor v5.0 or higher for the maxLen parameter.

int ReadWStringLength( int64 pos, int maxLen=-1 )
Calculates the number of characters in a null-terminated Unicode string if it were read at byte position pos in the
target file. This is equivalent to counting the number of words (a word is a group of two hex bytes) in the file
until a word with zero value is encountered. The returned count includes the null-terminating word. By default
this function searches until it reaches the end of the file but can be limited to a set number of characters by
setting maxLen to a value greater than zero.
Requires 010 Editor v4.0 or higher.

int64 TextAddressToLine( int64 address )
Given address, the position of a byte within a text file, this function returns the number of the line that contains
that byte. Note that lines are numbered starting from 0. If the file is not a text file or the address is invalid, -1 is
returned. See TextLineToAddress for the inverse operation.
Requires 010 Editor v3.2 or higher.

int TextAddressToColumn( int64 address )
Given an address of a byte in a file, this function returns the text column where that byte is located. Note that a
column number is returned only when using a fixed-width font, otherwise -1 is returned. If the address does not
reference a valid byte or the file is not a text file, -1 is also returned.
Requires 010 Editor v3.2 or higher.

int64 TextColumnToAddress( int64 line, int column )
Given a line number line (note that line numbers start from 0) and a column, this function returns the byte
address of the character in that column. If the address cannot be determined -1 is returned or if the line contains
less than column number of columns, the address of the last character on the line is returned.
Requires 010 Editor v4.0 or higher.

int64 TextGetNumLines()
Returns the number of lines in the current text file. If the current file is a hex file, -1 is returned.
Requires 010 Editor v3.2 or higher.

int TextGetLineSize( int64 line, int includeLinefeeds=true )
Returns the number of bytes that the given line contains. The returned size includes the size of the linefeeds if
includeLinefeeds is true but does not include the size of the linefeeds if includeLinefeeds is false. Note that line
numbers start at 0 and if an invalid line is passed to this function, -1 is returned. If the current file is not a text
file, -1 is also returned.
Requires 010 Editor v3.2 or higher.
Requires 010 Editor v6.0 or higher for the includeLinefeeds parameter.

int64 TextLineToAddress( int64 line )
Given a line number, this function returns the address of the first byte of that line. Note that line numbers start
with 0. See TextAddressToLine for the inverse operation.
Requires 010 Editor v3.2 or higher.

int TextReadLine( char buffer[], int64 line, int maxsize, int includeLinefeeds=true )
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This function reads the byte data from line number line and places it into the string buffer. Up to maxsize bytes
will be read from the file and the number of bytes read is returned. If line is an invalid line an empty string will be
placed into the buffer. Note that the returned string will not include linefeed characters if includeLinefeeds is
false.
Requires 010 Editor v3.2 or higher.
Requires 010 Editor v6.0 or higher for the includeLinefeeds parameter.

int TextReadLineW( wchar_t buffer[], int64 line, int maxsize, int includeLinefeeds=true )
Reads bytes from the given line and places them into the wide string buffer. The full line, up to maxsize
characters will be read from the file and the number of characters read is returned. Use this function if the
current file is a Unicode file, otherwise use the TextReadLine function. The returned buffer will include linefeed
characters if includeLinefeeds is true and will not include linefeeds if includeLinefeeds is false.
Requires 010 Editor v3.2 or higher.
Requires 010 Editor v6.0 or higher for the includeLinefeeds parameter.

void TextWriteLine( const char buffer[], int64 line, int includeLinefeeds=true )
Writes the data from the buffer to the given line, replacing the existing data of that line. Note that line numbers
start at 0. If the line to write is longer or shorter than the existing line, the file will be automatically expanded or
contracted. If includeLinefeeds is true the data to write should contain a linefeed at the end of the line, and if
includeLinefeeds is false the data should not contain a linefeed.
Requires 010 Editor v3.2 or higher.
Requires 010 Editor v6.0 or higher for the includeLinefeeds parameter.

void TextWriteLineW( const wchar_t buffer[], int64 line, int includeLinefeeds=true )
This function writes the wide string from buffer to the given text file at line number line. Use this function if the
current file is a Unicode file, otherwise use the TextWriteLine function. Line numbers start at 0 and if the data to
write is longer or shorter than the existing line, the file will be automatically expanded or contracted. buffer
should contain a linefeed if includeLinefeeds is true and buffer should not contain linefeeds if includeLinefeeds is
false.
Requires 010 Editor v3.2 or higher.
Requires 010 Editor v6.0 or higher for the includeLinefeeds parameter.

void WriteByte( int64 pos, char value )
void WriteDouble( int64 pos, double value )
void WriteFloat( int64 pos, float value )
void WriteHFloat( int64 pos, float value )
void WriteInt( int64 pos, int value )
void WriteInt64( int64 pos, int64 value )
void WriteQuad( int64 pos, int64 value )
void WriteShort( int64 pos, short value )
void WriteUByte( int64 pos, uchar value )
void WriteUInt( int64 pos, uint value )
void WriteUInt64( int64 pos, uint64 value )
void WriteUQuad( int64 pos, uint64 value )
void WriteUShort( int64 pos, ushort value )
Writes the value to the current file at the address pos. Note that if bytes are written past the end of the file, the
file will automatically be expanded.
Requires 010 Editor v5.0 or higher for the WriteHFloat function.

void WriteBytes( const uchar buffer[], int64 pos, int n )
Writes n bytes from the array buffer to the file at the address pos. Note that char[] and uchar[] can be used
interchangeably. If bytes are written past the end of the file, the file will automatically be expanded.
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void WriteString( int64 pos, const char value[] )
Writes the string value to the current file at address pos. Stops when the null-character is reached.

void WriteWString( int64 pos, const wstring value )
Writes the wide string value to the current file at address pos and stops when the null-character is reached. Note
that the endian used for writing is taken from the current file endian, which can be set using the BigEndian or
LittleEndian functions.
Requires 010 Editor v3.1 or higher.

Related Topics:
Bitfields
Functions
Functions
Functions
Functions

Interface
Math
String
Tool
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String Functions
The following is a list of string functions that can be used when writing Templates or Scripts.

double Atof( const char s[] )
Converts a string to a floating-point number. Returns zero on error.

int Atoi( const char s[] )
Converts a string to an integer. Returns zero on error.

int64 BinaryStrToInt( const char s[] )
Converts a string containing a binary number s to an integer and returns the result. For example:

return BinaryStrToInt( "01001101" );
would return the number 77. If the string is not a valid binary string, zero is returned.
Requires 010 Editor v4.0 or higher.

char[] ConvertString( const char src[], int srcCharSet, int destCharSet )
Given a string src that uses the character set encoding srcCharSet, the string is converted to use the character
set encoding destCharSet and returned as a string. The following character set constants exist:
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CHARSET_ASCII
CHARSET_ANSI
CHARSET_OEM
CHARSET_EBCDIC
CHARSET_UNICODE
CHARSET_MAC
CHARSET_ARABIC
CHARSET_BALTIC
CHARSET_CHINESE_S
CHARSET_CHINESE_T
CHARSET_CYRILLIC
CHARSET_EASTEUROPE
CHARSET_GREEK
CHARSET_HEBREW
CHARSET_JAPANESE
CHARSET_KOREAN_J
CHARSET_KOREAN_W
CHARSET_THAI
CHARSET_TURKISH
CHARSET_VIETNAMESE
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CHARSET_UTF8

This function should not be used with Unicode character sets (CHARSET_UNICODE). To perform conversions with
Unicode strings see the StringToWString and WStringToString functions.
Requires 010 Editor v4.0 or higher.

string DosDateToString( DOSDATE d, char format[] = "MM/dd/yyyy" )
Converts the given DOSDATE into a string and returns the results. By default the date will be in the format
'MM/dd/yyyy' but other formats can be used as described in the GetCurrentDateTime function. Click here for
more information on the DOSDATE type and see the FileTimeToString function for an example of using SScanf to
parse the resulting string.
Requires 010 Editor v4.0 or higher for the format parameter.

string DosTimeToString( DOSTIME t, char format[] = "hh:mm:ss" )
Converts the given DOSTIME into a string and returns the results. By default the time will be in the format
'hh:mm:ss' but other formats can be used as described in the GetCurrentDateTime function. Click here for more
information on the DOSTIME type and see the FileTimeToString function for an example of using SScanf to parse
the resulting string.
Requires 010 Editor v4.0 or higher for the format parameter.

string EnumToString( enum e )
If the given variable e is an enum, the value is converted into the string which represents that enum value and
returned. The enum may be a constant or an enum variable. For example:

enum { FIRST, SECOND, THIRD } value;
string s1, s2;
value = SECOND;
s1 = EnumToString( THIRD ); //s1 = "THIRD"
s2 = EnumToString( value ); //s2 = "SECOND"
Note that if e is a valid enum but no string corresponds to that enum value, an empty string is returned.

char[] FileNameGetBase( const char path[], int includeExtension=true )
wchar_t[] FileNameGetBaseW( const wchar_t path[], int includeExtension=true )
When called with a full path name for a file in path, this function removes the path name and returns the
resulting string. If includeExtension is true, the file path will still contain any file extension if it exists, or if false
the file extension is removed. For example:

return FileNameGetBase( "C:\\temp\\file.dat" );
would return "file.dat", and

return FileNameGetBase( "C:\\temp\\file.dat", false );
would return "file". FileNameGetBaseW works in the same way except this function accepts a Unicode string and
returns a Unicode string.
Requires 010 Editor v4.0 or higher.

char[] FileNameGetExtension( const char path[] )
wchar_t[] FileNameGetExtensionW( const wchar_t path[] )
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Given a file name path, this function returns the extension for the file name including the '.'. For example:

return FileNameGetExtension( "C:\\temp\\file.dat" );
would return ".dat". FileNameGetExtensionW works the same way except the path is a Unicode string and a
Unicode string is returned.
Requires 010 Editor v4.0 or higher.

char[] FileNameGetPath( const char path[], int includeSlash=true )
wchar_t[] FileNameGetPathW( const wchar_t path[], int includeSlash=true )
Given a full file name path, this function returns just the path portion of the file name. If includeSlash is true, the
last character in the returned path will be a slash. For example:.

return FileNameGetPath( "C:\\temp\\file.dat" );
would return "C:\temp\", and

return FileNameGetBase( "C:\\temp\\file.dat", false );
would return "C:\temp". FileNameGetBaseW operates the same way but accepts a Unicode path and returns a
Unicode string.
Requires 010 Editor v4.0 or higher.

char[] FileNameSetExtension( const char path[], const char extension[] )
wchar_t[] FileNameSetExtensionW( const wchar_t path[], const wchar_t extension[] )
This function takes as input a file name path and an extension. The function then removes any existing extension
in path, appends the new extension and then returns the resulting string. Note that extension may or may not
start with a '.' character and the original path argument is not modified. For example:

return FileNameSetExtension( "C:\\temp\\file.dat", "bmp" );
would return "C:\temp\file.bmp". Similarly, FileNameSetExtensionW can be used on Unicode strings and a
Unicode string is returned.
Requires 010 Editor v4.0 or higher.

string FileTimeToString( FILETIME ft, char format[] = "MM/dd/yyyy hh:mm:ss" )
Converts the given FILETIME into a string and returns the results. By default the time will be in the format
'MM/dd/yyyy hh:mm:ss' but other formats can be used as described in the GetCurrentDateTime function. Click
here for more information on the FILETIME type. The resulting string can be separated into parts using the
SScanf function. For example:

int hour, minute, second, day, month, year;
string s = FileTimeToString( ft );
SScanf( s, "%02d/%02d/%04d %02d:%02d:%02d",
month, day, year, hour, minute, second );
year++;
SPrintf( s, "%02d/%02d/%04d %02d:%02d:%02d",
month, day, year, hour, minute, second );
Requires 010 Editor v4.0 or higher for the format parameter.

char[] IntToBinaryStr( int64 num, int numGroups=0, int includeSpaces=true )
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Takes an input an integer num and returns that number converted to a binary string. The returned string will
contain as many groups of 8 binary digits as are necessary to represent the number, and the minimum number
of groups returned can be controlled with the numGroups parameter. If includeSpaces is true, a space will be
included between each group. For example:

return IntToBinaryStr( 1132 );
would return "00000100 01101100" and

return IntToBinaryStr( 62, 2, false );
would return "0000000000111110".
Requires 010 Editor v4.0 or higher.

int Memcmp( const uchar s1[], const uchar s2[], int n )
Compares the first n bytes of s1 and s2. Returns a value less than zero if s1 is less than s2, zero if they are
equal, or a value greater than zero if s1 is greater than s2.

void Memcpy( uchar dest[], const uchar src[], int n, int destOffset=0, int srcOffset=0 )
Copies a block of n bytes from src to dest. If srcOffset is not zero, the bytes are copied starting from the
srcOffset byte in src. If destOffset is not zero, the bytes are copied to dest starting at the byte destOffset. See
the WMemcpy function for copying wchar_t data.
Requires 010 Editor v6.0 or higher for the destOffset and srcOffset parameters.

void Memset( uchar s[], int c, int n )
Sets the first n bytes of s to the byte c.

string OleTimeToString( OLETIME ot, char format[] = "MM/dd/yyyy hh:mm:ss" )
Converts the given OLETIME into a string and returns the results. By default the time will be in the format
'MM/dd/yyyy hh:mm:ss' but other formats can be used as described in the GetCurrentDateTime function. Click
here for more information on the OLETIME type and see the FileTimeToString function for an example of using
SScanf to parse the resulting string.
Requires 010 Editor v4.0 or higher for the format parameter.

int RegExMatch( string str, string regex );
int RegExMatchW( wstring str, wstring regex );
Attempts to match the Regular Expression regex with the string str. For the RegExMatch function both strings are
assumed to be in ASCII+ANSI format and for the RegExMatchW function both strings are in Unicode format.
These functions return 1 if the regular expression completely matches the string, 0 if they do not match, or -1 if
regex is an invalid regular expression. To match just part of a string see the RegExSearch function. For example,
to test if an email address is valid use:

if( RegExMatch( "test@test.ca",
"\\b[A-Za-z0-9.%_+\\-]+@[A-Za-z0-9.\\-]+\\.[A-Za-z]{2,4}\\b" )
== false )
{
Warning( "Invalid email address" );
return -1;
}
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Requires 010 Editor v6.0 or higher.

int RegExSearch( string str, string regex, int &matchSize, int startPos=0 );
int RegExSearchW( wstring str, wstring regex, int &matchSize, int startPos=0 );
Searches for an occurrence of the Regular Expression regex within the string str. Use RegExSearch to search
ASCII+ANSI strings or the RegExSearchW function to search Unicode strings. These functions return the index of
the first matching character in str if a match is found, -1 if no match is found, or -2 if the regular expression is
invalid. The number of characters in the match will be stored in the matchSize parameter. By default the search
starts from the first character of str but to specify a different starting character use the startPos parameter. For
example, to search for an IP address within a string use:

int result, size;
result = RegExSearch(
"12:03:23 AM - 192.168.0.10 : www.sweetscape.com/",
"\\d{1,3}\\.\\d{1,3}.\\d{1,3}.\\d{1,3}", size );
Printf( "Match at pos %d of size %d\n", result, size );
This code would display: 'Match at pos 14 of size 12'.
Requires 010 Editor v6.0 or higher.

int SPrintf( char buffer[], const char format[] [, argument, ... ] )
Performs a Printf starting from format and places the result into buffer. See Printf for more information.

int SScanf( char str[], char format[], ... )
This function parses the str parameter into a number of variables according to the format string. The format
string uses the same specifiers as the Printf function. Following the format must be a list of arguments, one for
each format specifier in the format string. Note that unlike the regular C function, do not use '&' for each
argument. For example:

int a, b;
SScanf( "34, 62", "%d, %d", a, b );
would read the value 34 and 62 into a and b. The return value will be the number of successfully read arguments
(in this example the return value would be 2).

void Strcat( char dest[], const char src[] )
Appends the characters from src to the end of the string dest. The string may be resized if necessary. The +=
operator can also be used for a similar result.

int Strchr( const char s[], char c )
Scans the string s for the first occurrence of the character c. Returns the index of the match, or -1 if no
characters match.

int Strcmp( const char s1[], const char s2[] )
Compares the one string to another. Returns a value less than zero if s1 is less than s2, zero if they are equal, or
a value greater than zero if s1 is greater than s2.
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void Strcpy( char dest[], const char src[] )
Copies string src to string dest, stopping when the null-character has been copied.

char[] StrDel( const char str[], int start, int count )
Removes count characters from str starting at the index start and returns the resulting string.

int Stricmp( const char s1[], const char s2[] )
Identical to Strcmp except the strings are compared without case sensitivity.

int StringToDosDate( string s, DOSDATE &d, char format[] = "MM/dd/yyyy" )
Converts the given string into a DOSDATE and stores the results in d. The format of the date string is given with
the format parameter and is by default 'MM/dd/yyyy' but other formats can be used as described in the
GetCurrentDateTime function. This function returns 0 if it succeeds or a negative number on failure. More
information on date types is available here.
Requires 010 Editor v4.0 or higher for the format parameter.

int StringToDosTime( string s, DOSTIME &t, char format[] = "hh:mm:ss" )
Converts the given string into a DOSTIME and stores the results in t. The format of the time string is given with
the format parameter and is by default 'hh:mm:ss' but other formats can be used as described in the
GetCurrentDateTime function. This function returns 0 if it succeeds or a negative number on failure. More
information on date types is available here.
Requires 010 Editor v4.0 or higher for the format parameter.

int StringToFileTime( string s, FILETIME &ft, char format[] = "MM/dd/yyyy hh:mm:ss" )
Converts the given string into a FILETIME and stores the results in ft. The format of the time string is given with
the format parameter and is by default 'MM/dd/yyyy hh:mm:ss' but other formats can be used as described in
the GetCurrentDateTime function. This function returns 0 if it succeeds or a negative number on failure. More
information on date types is available here.
Requires 010 Editor v4.0 or higher for the format parameter.

int StringToOleTime( string s, OLETIME &ot, char format[] = "MM/dd/yyyy hh:mm:ss" )
Converts the given string into an OLETIME and stores the results in ot. The format of the string is given with the
format parameter and is by default 'MM/dd/yyyy hh:mm:ss' but other formats can be used as described in the
GetCurrentDateTime function. This function returns 0 if it succeeds or a negative number on failure. More
information on date types is available here.
Requires 010 Editor v4.0 or higher for the format parameter.

int StringToTimeT( string s, time_t &t, char format[] = "MM/dd/yyyy hh:mm:ss" )
Converts the given string into a time_t and stores the results in t. The format of the string is given with the
format parameter and is by default 'MM/dd/yyyy hh:mm:ss' but other formats can be used as described in the
GetCurrentDateTime function. This function returns 0 if it succeeds or a negative number on failure. More
information on date types is available here.
Requires 010 Editor v4.0 or higher for the format parameter.
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char[] StringToUTF8( const char src[], int srcCharSet=CHARSET_ANSI )
Takes as input a string src which uses the character set encoding srcCharSet. The string is converted to the UTF8 character set and returned. The list of character set constants is available in the ConvertString function and this
function is equivalent to 'ConvertString( src, srcCharSet, CHARSET_UTF8 );'.
Requires 010 Editor v4.0 or higher.

wstring StringToWString( const char str[], int srcCharSet=CHARSET_ANSI )
Converts the given string str into a wide (unicode) string. str is assumed to be an ANSI string but other character
sets can be specified using the srcCharSet parameter (see the ConvertString function for a list of character set
constants). See Arrays and Strings for information on wide strings and note that wstring and wchar_t[] are
equivalent.
Requires 010 Editor v3.1 or higher.
Requires 010 Editor v4.0 or higher for the srcCharSet parameter.

int Strlen( const char s[] )
Returns the number of bytes in s before the null-character.

int Strncmp( const char s1[], const char s2[], int n )
Similar to Strcmp, except that no more than n characters are compared.

void Strncpy( char dest[], const char src[], int n )
Similar to Strcpy, except that at most n characters will be copied.

int Strnicmp( const char s1[], const char s2[], int n )
Similar to Strcmp except that at most n characters are compared and the characters are compared without case
sensitivity.

int Strstr( const char s1[], const char s2[] )
Scans the string s1 for the first occurrence of s2. Returns the index of the first matching character, or -1 if no
match is found.

char[] SubStr( const char str[], int start, int count=-1 )
Returns a string containing count characters from str starting at the index start. If count is -1, all the characters
from the start index to the end of the string are returned.

string TimeTToString( time_t t, char format[] = "MM/dd/yyyy hh:mm:ss" )
Converts the given time_t into a string and returns the results. By default the time will be in the format
'MM/dd/yyyy hh:mm:ss' but other formats can be used as described in the GetCurrentDateTime function. Click
here for more information on the time_t type and see the FileTimeToString function for an example of using
SScanf to parse the resulting string.
Requires 010 Editor v4.0 or higher for the format parameter.
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char ToLower( char c )
wchar_t ToLowerW( wchar_t c )
Takes as input a character c, converts the character to lowercase and then returns the result. If the character
cannot be converted to lowercase, the unmodified character is returned. For example:

return ToLower( 'A' );
would return 'a'. The ToLowerW function operates on wide characters and handles converting Unicode characters
to lowercase.
Requires 010 Editor v4.0 or higher.

char ToUpper( char c )
wchar_t ToUpperW( wchar_t c )
Returns the given character c converted to an uppercase character. If the character cannot be converted to
uppercase the same character is returned. For example:

return ToUpper( 'c' );
would return 'C'. Use the ToUpperW function to convert Unicode characters to uppercase.
Requires 010 Editor v4.0 or higher.

void WMemcmp( const wchar_t s1[], const wchar_t s2[], int n )
Compares the first n wchar_t items of the arrays s1 and s2. This function returns a value less than zero if s1 is
less than s2, zero if they are equal, or a value greater than zero if s1 is greater than s2.
Requires 010 Editor v3.1 or higher.

void WMemcpy( wchar_t dest[], const wchar_t src[], int n, int destOffset=0, int srcOffset=0 )
Copies n wchar_t items from the array src to the array dest. If srcOffset is not zero, the bytes are copied starting
from the srcOffset index in src. If destOffset is not zero, the bytes are copied to dest starting at the index
destOffset. See the Memcpy function for copying byte data.
Requires 010 Editor v3.1 or higher.
Requires 010 Editor v6.0 or higher for the destOffset and srcOffset parameters.

void WMemset( wchar_t s[], int c, int n )
Sets the first n wchar_t items of the array s to the value c.
Requires 010 Editor v3.1 or higher.

void WStrcat( wchar_t dest[], const wchar_t src[] )
Appends all characters from the src string to the end of the dest string. Note that the string may be resized if
required and the += operator can also be used for a similar result.
Requires 010 Editor v3.1 or higher.

int WStrchr( const wchar_t s[], wchar_t c )
Searchs through the string s for the first occurrence of the character c. If the character is found, this function
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returns the index of the match, otherwise -1 is returned.
Requires 010 Editor v3.1 or higher.

int WStrcmp( const wchar_t s1[], const wchar_t s2[] )
Use this function to compare one wide string to another. Returns a value less than zero if s1 is less than s2, zero
if they are equal, or a value greater than zero if s1 is greater than s2.
Requires 010 Editor v3.1 or higher.

void WStrcpy( wchar_t dest[], const wchar_t src[] )
Copies the string src to the string dest, stopping when the null-character has been copied.
Requires 010 Editor v3.1 or higher.

wchar_t[] WStrDel( const whar_t str[], int start, int count )
Returns a string where count characters have been removed from the string str starting at the index start. Note
that the str argument is not modified.
Requires 010 Editor v3.1 or higher.

int WStricmp( const wchar_t s1[], const wchar_t s2[] )
Identical to WStrcmp except the strings are compared without case sensitivity.
Requires 010 Editor v3.1 or higher.

char[] WStringToString( const wchar_t str[], int destCharSet=CHARSET_ANSI )
Converts the given wide string str by default into an ANSI string and returns it. The string can be converted to
other character sets using the destCharSet parameter (see the ConvertString function for a list of character set
constants). Note that not all characters can be successfully converted from wide characters to other character
sets and any characters that cannot be converted will be replaced with the '?' character. See Arrays and Strings
for information on wide strings and note that wstring and wchar_t[] are equivalent.
Requires 010 Editor v3.1 or higher.
Requires 010 Editor v4.0 or higher for the destCharSet parameter.

char[] WStringToUTF8( const wchar_t str[] )
Takes as input a Unicode string str which is then converted to the UTF-8 character set and returned as a string.
Requires 010 Editor v4.0 or higher.

int WStrlen( const wchar_t s[] )
Counts the number of characters in s before the null-character is encountered and returns the result.
Requires 010 Editor v3.1 or higher.

int WStrncmp( const wchar_t s1[], const wchar_t s2[], int n )
Similar to WStrcmp, except that at most n characters are compared between the two strings.
Requires 010 Editor v3.1 or higher.
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void WStrncpy( wchar_t dest[], const wchar_t src[], int n )
Similar to WStrcpy, except that at most n characters will be copied.
Requires 010 Editor v3.1 or higher.

int WStrnicmp( const wchar_t s1[], const wchar_t s2[], int n )
Similar to WStrcmp except that at most n characters are compared and the characters are compared without
case sensitivity.
Requires 010 Editor v3.1 or higher.

int WStrstr( const wchar_t s1[], const wchar_t s2[] )
Searches through the wide string s1 for the first occurrence of the string s2. If the string is found, the index of
the first matching character is returned, otherwise -1 is returned.
Requires 010 Editor v3.1 or higher.

wchar_t[] WSubStr( const wchar_t str[], int start, int count=-1 )
Returns a wide string containing count characters from str starting at the index start. If count is -1, all the
characters from the start index to the end of the string are returned.
Requires 010 Editor v3.1 or higher.

Related Topics:
Interface Functions
I/O Functions
Math Functions
Using Regular Expressions
Tool Functions
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Math Functions
The following is a list of math functions that can be used when writing Templates or Scripts.

double Abs( double x )
Returns the absolute value of the float pointer number x.

double Ceil( double x )
Returns the smallest integer not less than x.

double Cos( double a )
Returns the cosine of the given angle. The angle is given in degrees.

double Exp( double x )
Calculates the exponential e to the power of x.

double Floor( double x)
Returns the highest integer less than or equal to x.

double Log( double x )
Calculates the natural logarithm of x. This value is also known as ln(x).

double Max( double a, double b )
Returns the larger of the numbers a and b.

double Min( double a, double b)
Returns the smaller of the numbers a and b.

double Pow( double x, double y)
Returns x to the power of y.
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int Random( int maximum )
Returns a random integer between 0 and maximum-1 inclusive.

double Sin( double a )
Computes the sine of the given angle. The angle is given in degrees.

double Sqrt( double x )
Calculates the positive square-root of the number x.

data_type SwapBytes( data_type x )
Swaps the bytes of the variable and returns the result. Any of the basic data types can be specified (byte, short,
int, int64, float, or double).

double Tan( double a )
Calculates the tangent of the given angle. The angle is given in degrees.

Related Topics:
Interface Functions
I/O Functions
String Functions
Tool Functions
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Tool Functions
The following is a list of functions that allow running many of the tools in the Tools Menu or Search Menu, as well
as functions for working with drives and processes.

int64 Checksum(
int algorithm,
int64 start=0,
int64 size=0,
int64 crcPolynomial=-1,
int64 crcInitValue=-1 )
Runs a simple checksum on a file and returns the result as a int64. The algorithm can be one of the following
constants:

















CHECKSUM_BYTE - Treats the file as a set of unsigned bytes
CHECKSUM_SHORT_LE - Treats the file as a set of unsigned little-endian shorts
CHECKSUM_SHORT_BE - Treats the file as a set of unsigned big-endian shorts
CHECKSUM_INT_LE - Treats the file as a set of unsigned little-endian ints
CHECKSUM_INT_BE - Treats the file as a set of unsigned big-endian ints
CHECKSUM_INT64_LE - Treats the file as a set of unsigned little-endian int64s
CHECKSUM_INT64_BE - Treats the file as a set of unsigned big-endian int64s
CHECKSUM_SUM8 - Same as CHECKSUM_BYTE except result output as 8-bits
CHECKSUM_SUM16 - Same as CHECKSUM_BYTE except result output as 16-bits
CHECKSUM_SUM32 - Same as CHECKSUM_BYTE except result output as 32-bits
CHECKSUM_SUM64 - Same as CHECKSUM_BYTE
CHECKSUM_CRC16
CHECKSUM_CRCCCITT
CHECKSUM_CRC32
CHECKSUM_ADLER32

If start and size are zero, the algorithm is run on the whole file. If they are not zero then the algorithm is run on
size bytes starting at address start. See the ChecksumAlgBytes and ChecksumAlgStr functions to run more
complex algorithms. crcPolynomial and crcInitValue can be used to set a custom polynomial and initial value for
the CRC functions. A value of -1 for these parameters uses the default values as described in the Check
Sum/Hash Algorithms topic. A negative number is returned on error.

int ChecksumAlgArrayStr(
int algorithm,
char result[],
uchar *buffer,
int64 size,
char ignore[]="",
int64 crcPolynomial=-1,
int64 crcInitValue=-1 )
Similar to the ChecksumAlgStr function except that the checksum is run on data stored in an array instead of in a
file. The data for the checksum should be passed in the buffer array and the size parameter lists the number of
bytes in the array. The result from the checksum will be stored in the result string and the number of characters
in the string will be returned, or -1 if an error occurred. See the ChecksumAlgStr function for a list of available
algorithms.
Requires 010 Editor v4.0 or higher.
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int ChecksumAlgArrayBytes(
int algorithm,
uchar result[],
uchar *buffer,
int64 size,
char ignore[]="",
int64 crcPolynomial=-1,
int64 crcInitValue=-1 )
Similar to the ChecksumAlgStr function except that the checksum is run on data in an array instead of in a file
and the results are stored in an array of bytes instead of a string. The data for the checksum should be passed in
the buffer array and the size parameter lists the number of bytes in the array. The result of the checksum
operation will be stored as a set of hex bytes in the parameter result. The function will return the number of
bytes placed in the result array or -1 if an error occurred. See the ChecksumAlgStr function for a list of available
algorithms.
Requires 010 Editor v4.0 or higher.

int ChecksumAlgStr(
int algorithm,
char result[],
int64 start=0,
int64 size=0,
char ignore[]="",
int64 crcPolynomial=-1,
int64 crcInitValue=-1 )
Similar to the Checksum algorithm except the following algorithm constants are supported:

























CHECKSUM_BYTE
CHECKSUM_SHORT_LE
CHECKSUM_SHORT_BE
CHECKSUM_INT_LE
CHECKSUM_INT_BE
CHECKSUM_INT64_LE
CHECKSUM_INT64_BE
CHECKSUM_SUM8
CHECKSUM_SUM16
CHECKSUM_SUM32
CHECKSUM_SUM64
CHECKSUM_CRC16
CHECKSUM_CRCCCITT
CHECKSUM_CRC32
CHECKSUM_ADLER32
CHECKSUM_MD2
CHECKSUM_MD4
CHECKSUM_MD5
CHECKSUM_RIPEMD160
CHECKSUM_SHA1
CHECKSUM_SHA256
CHECKSUM_SHA512
CHECKSUM_TIGER

The result argument specifies a string which will hold the result of the checksum. The return value indicates the
number of characters in the string, or is negative if an error occurred. Any ranges to ignore can be specified in
string format with the ignore argument (see Check Sum/Hash Algorithms). The crcPolynomial and crcInitValue
parameters are used to set a custom polynomial and initial value for the CRC algorithms. Specifying -1 for these
parameters uses the default values as indicated in the Check Sum/Hash Algorithms help topic. See the Checksum
function above for an explanation of the different checksum constants.

Copyright © 2003-2016 SweetScape Software

203

010 Editor - Reference Manual

int ChecksumAlgBytes(
int algorithm,
uchar result[],
int64 start=0,
int64 size=0,
char ignore[]="",
int64 crcPolynomial=-1,
int64 crcInitValue=-1 )
This function is identical to the ChecksumAlgStr function except that the checksum is returned as a byte array in
the result argument. The return value is the number of bytes returned in the array.

TCompareResults Compare(
int type,
int fileNumA,
int fileNumB,
int64 startA=0,
int64 sizeA=0,
int64 startB=0,
int64 sizeB=0,
int matchcase=true,
int64 maxlookahead=10000,
int64 minmatchlength=8,
int64 quickmatch=512 )
Runs a comparison between two files or between two blocks of data. The type argument indicates the type of
comparison that should be run and can be either:




COMPARE_SYNCHRONIZE (a binary comparison)
COMPARE_SIMPLE (a byte-by-byte comparison)

fileNumA and fileNumB indicate the numbers of the file to compare (see GetFileNum). The file numbers may be
the same to compare two blocks in the same file. The startA, sizeA, startB, and sizeB arguments indicate the size
of the blocks to compare in the two files. If the start and size are both zero, the whole file is used. If matchcase
is false, then letters of mixed upper and lower cases will match. See Comparing Files for details on the
maxlookahead, minmatchlength and quickmatch arguments. The return value is TCompareResults structure with
contains a count variable indicating the number of resulting ranges, and an array of record. Each record contains
the variables type, startA, sizeA, startB, and sizeB to indicate the range. The type variable will be one of:






COMPARE_MATCH=0
COMPARE_DIFFERENCE=1
COMPARE_ONLY_IN_A=2
COMPARE_ONLY_IN_B=3

For example:

int i, f1, f2;
FileOpen( "C:\\temp\\test1" );
f1 = GetFileNum();
FileOpen( "C:\\temp\\test2" );
f2 = GetFileNum();
TCompareResults r = Compare( COMPARE_SYNCHRONIZE, f1, f2 );
for( i = 0; i < r.count; i++ )
{
Printf( "%d %Ld %Ld %Ld %Ld\n",
r.record[i].type,
r.record[i].startA,
r.record[i].sizeA,
r.record[i].startB,
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r.record[i].sizeB );
}
char ConvertASCIIToEBCDIC( char ascii )
Converts the given ASCII character into an EBCDIC character and returns the result.

void ConvertASCIIToUNICODE(
int len,
const char ascii[],
ubyte unicode[],
int bigendian=false )
Converts an ASCII string into an array of bytes and stores them in the unicode argument. len indicates the
number of characters to convert and the unicode array must be of size at least 2*len. If bigendian is true, the
bytes are stored in big-endian mode, otherwise the bytes are stored in little-endian mode.

void ConvertASCIIToUNICODEW(
int len,
const char ascii[],
ushort unicode[] )
Converts an ASCII string into an array of words and stores the array in the unicode argument. The number of
characters to convert is given by the len argument and the unicode argument must have size at least len.

char ConvertEBCDICToASCII( char ebcdic )
Converts the given EBCDIC character into an ASCII character and returns the result.

void ConvertUNICODEToASCII(
int len,
const ubyte unicode[],
char ascii[],
int bigendian=false )
Converts an array of UNICODE characters in the unicode argument into ASCII bytes and stores them in the ascii
array. len indicates the number of characters to convert. unicode must be of size at least size 2*len and ascii
must be of size at least len. If bigendian is true, the bytes are stored in big-endian mode, otherwise the bytes are
stored in little-endian mode.

void ConvertUNICODEToASCIIW(
int len,
const ushort unicode[],
char ascii[] )
Converts the array of words in the unicode argument to ASCII bytes and saves them to the ascii argument. The
number of characters to convert is given by len. unicode and ascii must be of size at least size len.

int ExportFile(
int type,
char filename[],
int64 start=0,
int64 size=0,
int64 startaddress=0,
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int bytesperrow=16,
int wordaddresses=0 )
Exports the currently open file to a file on disk given by filename using one of the following type formats:


















EXPORT_HEXTEXT
EXPORT_DECTEXT
EXPORT_BINARYTEXT
EXPORT_CCODE
EXPORT_JAVACODE
EXPORT_INTEL8
EXPORT_INTEL16
EXPORT_INTEL32
EXPORT_S19
EXPORT_S28
EXPORT_S37
EXPORT_TEXT_AREA
EXPORT_HTML
EXPORT_RTF
EXPORT_BASE64
EXPORT_UUENCODE

The start and size arguments indicate what portion of the file to export. If they are both zero then the whole file
is exported. startaddress indicates the starting address that is written to the file for Intel Hex or Motorola
formats. bytesperrow indicates the number of bytes written on each line of the output file. If wordaddresses is
true and the export format is Intel Hex, the file will be written using word-based addresses. See
Importing/Exporting Files for more information on exporting.

TFindResults FindAll(
<datatype> data,
int matchcase=true,
int wholeword=false,
int method=0,
double tolerance=0.0,
int dir=1,
int64 start=0,
int64 size=0,
int wildcardMatchLength=24 )
This function converts the argument data into a set of hex bytes and then searches the current file for all
occurrences of those bytes. data may be any of the basic types or an array of one of the types. If data is an array
of signed bytes, it is assumed to be a null-terminated string. To search for an array of hex bytes, create an
unsigned char array and fill it with the target value. If the type being search for is a string, the matchcase and
wholeworld arguments can be used to control the search (see Using Find for more information). method controls
which search method is used from the following options:





FINDMETHOD_NORMAL=0 - a normal search
FINDMETHOD_WILDCARDS=1 - when searching for strings use wildcards '*' or '?'
FINDMETHOD_REGEX=2 - when searching for strings use Regular Expressions

wildcardMatchLength indicates the maximum number of characters a '*' can match when searching using
wildcards. If the target is a float or double, the tolerance argument indicates that values that are only off by the
tolerance value still match. If dir is 1 the find direction is down and if dir is 0 the find direction is up. start and
size can be used to limit the area of the file that is searched. start is the starting byte address in the file where
the search will begin and size is the number of bytes after start that will be searched. If size is zero, the file will
be searched from start to the end of the file.
The return value is a TFindResults structure. This structure contains a count variable indicating the number of
matches, and a start array holding an array of starting positions, plus a size array which holds an array of target
lengths. For example, use the following code to find all occurrences of the ASCII string "Test" in a file:

206

Copyright © 2003-2016 SweetScape Software

010 Editor - Reference Manual

int i;
TFindResults r = FindAll( "Test" );
Printf( "%d\n", r.count );
for( i = 0; i < r.count; i++ )
Printf( "%Ld %Ld\n", r.start[i], r.size[i] );
To search for the floating point value 4.25 with tolerance 0.01, use the following code:

float value = 4.25f;
TFindResults r = FindAll( value, true, false, 0, 0.01 );
Type Specifiers can be used in a string as an alternate way to specify the type of data to find. For example, the
string "15.5,lf" can be used to search for the double 15.5. Using type specifiers is currently the only way to
search for hex bytes with wildcards. For example:

TFindResults r = FindAll( "FF*6A,h", true, false,
FINDMETHOD_WILDCARDS );
When searching for regular expressions with FindAll, remember to use '\\' to denote a backslash character. For
example, to find all numbers with 8 digits use:

TFindResults r = FindAll( "\\b\\d{8}\\b", true, false,
FINDMETHOD_REGEX );
Requires 010 Editor v4.0 or higher for the wildcardMatchLength parameter.
Requires 010 Editor v6.0 or higher for method=FINDMETHOD_REGEX.

int64 FindFirst(
<datatype> data,
int matchcase=true,
int wholeword=false,
int method=0,
double tolerance=0.0,
int dir=1,
int64 start=0,
int64 size=0,
int wildcardMatchLength=24 )
This function is identical to the FindAll function except that the return value is the position of the first occurrence
of the target found. A negative number is returned if the value could not be found.
Requires 010 Editor v4.0 or higher for the wildcardMatchLength parameter.
Requires 010 Editor v6.0 or higher for method=FINDMETHOD_REGEX.

TFindInFilesResults FindInFiles(
<datatype> data,
char dir[],
char mask[],
int subdirs=true,
int openfiles=false,
int matchcase=true,
int wholeword=false,
int method=0,
double tolerance=0.0,
int wildcardMatchLength=24 )
Searches for a given set of data across multiple files. See the FindAll function for information on the data,
matchcase, wholeword, method, wildcardMatchLength and tolerance arguments. The dir argument indicates the
starting directory where the search will take place. mask indicates which file types to search and may contain the
characters '*' and '?'. If subdirs is true, all subdirectories are recursively searched for the value as well. If
openfiles is true, only the currently open files are searched. The return value is the TFindInFilesResults structure
which contains a count variable indicate the number of files found plus an array of file variables. Each file variable
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contains a count variable indicating the number of matches, plus an array of start and size variables indicating
the match position. For example:

int i, j;
TFindInFilesResults r = FindInFiles( "PK",
"C:\\temp", "*.zip" );
Printf( "%d\n", r.count );
for( i = 0; i < r.count; i++ )
{
Printf( "
%s\n", r.file[i].filename );
Printf( "
%d\n", r.file[i].count );
for( j = 0; j < r.file[i].count; j++ )
Printf( "
%Ld %Ld\n",
r.file[i].start[j],
r.file[i].size[j] );
}
See Using Find In Files for more information.
Requires 010 Editor v4.0 or higher for the wildcardMatchLength parameter.
Requires 010 Editor v6.0 or higher for method=FINDMETHOD_REGEX.

int64 FindNext( int dir=1 )
This function returns the position of the next occurrence of the target value specified with the FindFirst function.
If dir is 1, the find direction is down. If dir is 0, the find direction is up. The return value is the address of the
found data, or -1 if the target is not found.

TFindStringsResults FindStrings(
int minStringLength,
int type,
int matchingCharTypes,
wstring customChars="",
int64 start=0,
int64 size=0,
int requireNull=false )
Attempts to locate any strings within a binary file similar to the Find Strings dialog which is accessed by clicking
'Search > Find Strings' on the main menu. Specify the minimum length of each string in number of characters
with the minStringLength parameter. The type option tells the algorithm to look for ASCII strings, UNICODE
strings or both by using one of the following constants:





FINDSTRING_ASCII
FINDSTRING_UNICODE
FINDSTRING_BOTH

To specify which characters are considered as part of a string, use an OR bitmask ('|') of one or more of the
following constants:
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FINDSTRING_LETTERS - the letters A..Z and a..z
FINDSTRING_LETTERS_ALL - all international numbers including FINDSTRING_LETTERS
FINDSTRING_NUMBERS - the numbers 0..9
FINDSTRING_NUMBERS_ALL - all international numbers including FINDSTRING_NUMBERS
FINDSTRING_SYMBOLS - symbols such as '#', '@', '!', etc. except for '_'
FINDSTRING_UNDERSCORE - the character '_'
FINDSTRING_SPACES - spaces or whitespace
FINDSTRING_LINEFEEDS - line feed characters 0x0a, 0x0d
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FINDSTRING_CUSTOM - include any custom characters in the customChars string

Note if the FINDSTRING_CUSTOM constant is included, any characters from customChars are considered as part
of the string otherwise the customChars string is ignored. The start and size parameters indicate the range of the
file to search and if size is zero, the file is searched starting from start to the end of the file. If requireNull is true,
the strings must have a null (0) character after each string.
The return value is a TFindStringsResults structure which contains a count variable with the number of strings
found, a start array holding the starting position of each string, a size array holding the size in bytes of each
string, and a type array which indicates FINDSTRING_ASCII if the string is an ASCII string or
FINDSTRING_UNICODE if the string is a Unicode string. For example, the following code finds all ASCII strings of
length at least 5 containing the characters "A..Za..z$&":

TFindStringsResults r = FindStrings( 5, FINDSTRING_ASCII,
FINDSTRING_LETTERS | FINDSTRING_CUSTOM, "$&" );
Printf( "%d\n", r.count );
for( i = 0; i < r.count; i++ )
Printf( "%Ld %Ld %d\n", r.start[i], r.size[i], r.type[i] );
Requires 010 Editor v6.0 or higher.

int GetSectorSize()
Returns the size in bytes of the sectors for this drive. If this file is not a drive, the current sector size is defined
using the 'View > Division Lines > Set Sector Size' menu option.

int HexOperation(
int operation,
int64 start,
int64 size,
operand,
step=0,
int64 skip=0 )
Perform any of the operations on hex data as available in the Hex Operations dialog. The operation parameter
chooses which operation to perform and these operations are described in the Hex Operations dialog
documentation. start and size indicate which range of bytes to operate on and if size is 0, the whole file is used.
The operand indicates what value to use during the operation and the result is different depending upon which
operation is used (see the Hex Operations dialog). operand can be any of the basic numeric or floating point
types and the type of this parameter tells the function how to interpret the data. For example, if a 'ushort' is
passed as an operand, the block of data is considered as an array of 'ushort' using the current endian. If step is
non-zero, the operand is incremented by step after each operation and if skip is non-zero, skip number of bytes
are skipped after each operation. This function returns the number of bytes modified if successful, or a negative
number on error. The following constants can be used for the operation parameter:


















HEXOP_ASSIGN
HEXOP_ADD
HEXOP_SUBTRACT
HEXOP_MULTIPLY
HEXOP_DIVIDE
HEXOP_NEGATE
HEXOP_MODULUS
HEXOP_SET_MINIMUM
HEXOP_SET_MAXIMUM
HEXOP_SWAP_BYTES
HEXOP_BINARY_AND
HEXOP_BINARY_OR
HEXOP_BINARY_XOR
HEXOP_BINARY_INVERT
HEXOP_SHIFT_LEFT
HEXOP_SHIFT_RIGHT
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HEXOP_SHIFT_BLOCK_LEFT
HEXOP_SHIFT_BLOCK_RIGHT
HEXOP_ROTATE_LEFT
HEXOP_ROTATE_RIGHT

For example, the following code would treat the bytes from address 16 to 48 as an array of floats and add the
value 3.0 to each float in the array:

HexOperation( HEXOP_ADD, 16, 32, (float)3.0f );
Alternately, the following code would swap all groups of 2 bytes in a file:

HexOperation( HEXOP_SWAP_BYTES, 0, 0, (ushort)0 );
Requires 010 Editor v4.0 or higher.

int64 Histogram( int64 start, int64 size, int64 result[256] )
Counts the number of bytes of each value in the file from 0 up to 255. The bytes are counting starting from
address start and continuing for size bytes. The resulting counts are stored in the int64 array results. For
example, result[0] would indicate the number of 0 bytes values found in the given range of data. The return
value is the total number of bytes read.

int ImportFile( int type, char filename[], int wordaddresses=false, int defaultByteValue=-1 )
Attempts to import the file specified by filename in one of the supported import formats. The format is given by
the type argument and may be:










IMPORT_HEXTEXT
IMPORT_DECTEXT
IMPORT_BINARYTEXT
IMPORT_SOURCECODE
IMPORT_INTEL
IMPORT_MOTOROLA
IMPORT_BASE64
IMPORT_UUENCODE

If successful, the file is opened as a new file in the editor. If the function fails, a negative number is returned. If
wordaddresses is true and the file is an Intel Hex file, the file is imported using word-based addressing. When
importing some data formats (such as Intel Hex or S-Records) these formats may skip over certain bytes. The
value to assign these bytes can be controlled with the defaultByteValue parameter and if the parameter is -1, the
value from the Importing Options dialog is used. See Importing/Exporting Files for more information on
importing.

int IsDrive()
Returns true if the current file is a physical or logical drive, or false otherwise (see Editing Drives).

int IsLogicalDrive()
Returns true if the current file is a logical drive, or false otherwise (see Editing Drives).

int IsPhysicalDrive()
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Returns true if the current file is a physical drive, or false otherwise (see Editing Drives).

int IsProcess()
Returns true if the current file is a process, or false otherwise (see Editing Processes).

int OpenLogicalDrive( char driveletter )
Opens the drive with the given driveLetter as a new file in the editor. For example, 'OpenLogicalDrive('c');'. This
function returns a negative number on failure. See Editing Drives for more information on drive editing.

int OpenPhysicalDrive( int physicalID )
Opens the physical drive physicalID as a new file in the editor (see Editing Drives). For example,
'OpenPhysicalDrive(0);'. This function returns a negative number on failure.

int OpenProcessById( int processID, int openwriteable=true )
Opens a process identified by the processID number (see Editing Processes). If openwriteable is true, only bytes
that can be modified are opened, otherwise all readable bytes are opened. A negative number if returned if this
function fails.

int OpenProcessByName( char processname[], int openwriteable=true )
Attempts to open a process given by the name processname as a new file in the editor. For example:
'OpenProcessByName( "cmd.exe" );' If openwriteable is true, only bytes that can be modified are opened,
otherwise all readable bytes are opened. A negative number if returned if this function fails. See Editing
Processes for more information.

int ReplaceAll(
<datatype> finddata,
<datatype> replacedata,
int matchcase=true,
int wholeword=false,
int method=0,
double tolerance=0.0,
int dir=1,
int64 start=0,
int64 size=0,
int padwithzeros=false,
int wildcardMatchLength=24 )
This function converts the arguments finddata and replacedata into a set of bytes, and then finds all occurrences
of the find bytes in the file and replaces them with the replace bytes. The arguments matchcase, wholeword,
method, wildcardMatchLength, tolerance, dir, start, and size are all used when finding a value and are discussed
in the FindAll function above. If padwithzeros is true, a set of zero bytes are added to the end of the replace data
until it is the same length as the find data. The return value is the number of replacements made.
Requires 010 Editor v4.0 or higher for the wildcardMatchLength parameter.
Requires 010 Editor v6.0 or higher for method=FINDMETHOD_REGEX.

Related Topics:
Check Sum/Hash Algorithms
Comparing Files
Editing Drives
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Editing Processes
Importing/Exporting Files
Interface Functions
I/O Functions
Math Functions
Regular Expressions
String Functions
Using Find
Using Find Strings
Using Find in Files
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Introduction to the Repository
The Repository is an online collection of Binary Templates and Scripts that have been created by either
SweetScape Software or other users of the software. 010 Editor can connect to the Repository, download and
install files, and upload files to the Repository which can then be shared to other users. The Repository contains
Binary Templates for a variety of formats including AVI, BMP, EXE, ICO, JPG, MP3, OGG, PNG, RAR, TIF, WAV,
ZIP, etc. To install Templates or Scripts click either 'Templates > Template Repository' or 'Scripts > Script
Repository' and see:



Using the Repository Dialog

When a file is opened in 010 Editor, if a Binary Template is found in the Repository that can help understand data
in the file then a dialog is displayed asking to install or ignore the template. For more information see:



Installing Files on Open from the Repository

Installing a Template or Script from the Repository copies the file to the Repository directory (see the Directory
Options dialog) and also adds a record to the list of Installed Templates or Installed Scripts, as stored in the
Template Options and Script Options dialogs. For more information see:




Template Options
Script Options

Once Templates or Scripts are installed they can be managed from either the Repository Dialog or from the
Repository Menu in the File Bar above each Template and Script in the editor. For more information see:



Using the Repository Menu

The Repository can even store multiple versions of the same file and allows viewing, updating, and merging
between versions. For more information see:



Updating and Merging Files

To submit new files to the Repository or submit an update to an existing file see:



Submitting Files to the Repository

010 Editor periodically downloads updates from the online Repository. For more information see:



Updating the Repository

010 Editor even contains a copy of files from the Repository in a Local Repository, meaning some files can be
installed from the Repository even when 010 Editor is used on a computer not connected to the internet. The
Repository can also be viewed on the SweetScape Software website at
'http://www.sweetscape.com/010editor/repository/'.

Related Topics:
Directory Options
Installing Files on Open from the Repository
Introduction to Templates and Scripts
Submitting Files to the Repository
Template Options
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Updating and Merging Files
Updating the Repository
Using the Repository Dialog
Using the Repository Menu
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Using the Repository Dialog
The Repository Dialog is the main way to install and uninstall Templates or Scripts in the Repository. Access the
Repository Dialog by clicking either 'Templates > Template Repository' or 'Scripts > Script Repository' on the
main menu. Once the dialog is displayed, click the Templates or Scripts tabs at the top of the screen to toggle
between the repositories.

Templates Tab
The Templates tab displays all Binary Templates in the repository in a list along the left side of the dialog. The
icon
next to a Template name indicates that Template is currently installed. By default all Templates are
displayed sorted by Category. To display only installed Templates click the Show drop-down list and select
Installed or select Uninstall to show those templates that have not been installed. Selecting Update from the list
shows only those templates that have updates available to install. To display all Templates sorted by file name
but without categories click the Sort By drop-down list and select Alphabetic from the list. Selecting Newest from
the Sort By menu shows the most recently modified Templates at the top of the list.
At the top-right of the dialog is a search field marked with the icon
. To search for a value within the
Repository click this field and type the value. Only those Templates that contain the value, either in the file name,
description or file mask, will be displayed in the list of Templates. To cancel the search either delete the find
value or click the X icon beside the search field.
Once a Template is selected from the list the information for that Template is displayed in the main part of the
dialog. Click the Install button or right-click on the Template name in the list of Templates and choose Install to
install the Template. When a Template is installed it is either downloaded from the online repository or copied
from the local repository storage (see Updating the Repository), and then copied into the Template Repository
Directory as set in the Directory Options dialog. When a Template is installed a record is added to the list of
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installed Templates as stored in the Template Options dialog and the Template will appear on the main
application Templates menu listed under its category.
To uninstall a Template that has been installed either click the Uninstall button, right-click on the Template name
in the list of Templates and choose Uninstall, or delete the Template from the list of installed Templates in the
Template Options dialog. When a Template is uninstalled using this dialog the installed file is automatically
deleted from the Template Repository Directory unless the Template has been modified, in which case a dialog is
displayed giving the option to either Delete or Keep the Template file.

Click the small down arrow to the right of the Uninstall button to access the Repository Menu. This menu has
many of the same options as the Repository Menu located in the File Bar above a Script or Template. Click the
Edit File menu option to close the Repository dialog and load the installed Template in the editor. Clicking the
View Installed Information option closes the dialog and displays the information for this Template in the Template
Options dialog. The other menu options on this menu are discussed in the Repository Menu help topic.

At the bottom of the dialog is the Available Versions table which lists all versions of the Template that exist in the
Repository. Scroll to the right to view the comments for each version. Some Templates may require a newer
version of 010 Editor to be installed as listed in the Requires Version column. Clicking the View button beside
each version loads that version in the editor as a read-only file with the version included in the file name (for
example, version 2.3 of ZIP.bt would be loaded as 'ZIP.v2.3.bt'). The file is not installed. To install a specific
version click the down arrow to the right of the View button and choose Install from the popup menu. If
modifications have been made to a file then installing a version will display a dialog box which asks to either
Overwrite the modified file or Keep the modified file. Each version can be compared with the currently installed
version by clicking the down arrow to the right of View and select Diff from the menu. To compare a version with
the previous (older) version in the table select Diff with Previous from the menu.
If a Template is not installed the Ask to install this template when opening files toggle is displayed under the
Available Versions table. If this toggle is enabled and a data file is opened in 010 Editor that matches the File
Mask field (and the ID Bytes field if non-empty), then a dialog is displayed asking to install this Template (see
Installing Files on Open from the Repository). If this toggle is not checked then the dialog box will not be
displayed.

Scripts Tab
The Scripts tab shows all 010 Editor Scripts that can be installed from the Repository. The functionality of this tab
is identical to the Templates tab as described above except that the Ask to install this template when opening
files toggle is not shown and 010 Editor will not ask to install Scripts when opening files in the main editor.
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Status Tab

The current status of the repository is listed in the Status tab of the Repository dialog. The Updates area contains
information about when the Repository was last updated and is discussed in the help topic Updating the
Repository. The Installing and Terms areas are identical to the options available in the Repository Options and
are discussed in that help topic.

History Tab
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All Repository updates are listed in a table on the History tab of the Repository dialog with the newest updates at
the top of the dialog. Scroll to the right to view additional information about each update. Some Templates or
Scripts may require a newer version of 010 Editor to be installed as listed in the Requires Version column.
Double-clicking on a Template or Script will display all the information for that file in either the Templates or the
Scripts tab.
This dialog is displayed by default when new records are downloaded from the online repository (see Updating
the Repository). To no longer display this dialog when records are downloaded uncheck the Show this dialog
when updates are downloaded toggle at the bottom of the dialog.

Related Topics:
Directory Options
Installing Files on Open from the Repository
Introduction to the Repository
Introduction to Templates and Scripts
Repository Options
Template Options
Updating the Repository
Using the Repository Menu
010 Editor v7.0 Manual - Windows Edition
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Installing Files on Open from the
Repository
When any file is opened in 010 Editor, 010 Editor checks the file name and the ID bytes at the beginning of the
file to see if any Templates exist in the Repository that can parse data in the file. If a Template is found and no
Template is already installed to parse the data file (see the Template Options dialog for a list of installed
Templates) then the following dialog is displayed:

Clicking the Install button will automatically install and run the displayed Template on the current data file.
Sometimes multiple Templates exist in the Repository which can parse the same file. In this case all the
Templates will be displayed in the above dialog and select the Template to install by clicking on it before pressing
the Install button. Alternately, double-clicking on a Template will install and run that file.
Note that some Templates exist in the repository with the File Mask '*' meaning files of this type do not have a
specific file extension (an example of this is Linux or Mac OS X executable files). 010 Editor will not automatically
display this dialog for Templates that use the '*' mask and these type of Templates must be installed directly
using the Repository Dialog.
Clicking the Ignore button will close the dialog without installing the Template and the dialog will not be displayed
again asking to install this Template. In the Repository Dialog the toggle Ask to install this template when
opening files is displayed at the bottom of each Template page. When the Ignore button is clicked this toggle is
unchecked for that Template. To no longer ignore a template when opening files, recheck the Ask to install this
template when opening files box. If multiple Templates are displayed in the above dialog box the Ignore button
instead displays Ignore All and clicking Ignore All will ignore all Templates in the list.
Click the Ask me Later button to close the dialog without installing any Templates but this dialog will be displayed
again the next time a data file is opened that this Template can parse. See the Template Options dialog for more
information on the meaning of the File Mask and ID Bytes fields. Other Templates can be installed or uninstalled
using the Repository Dialog.

Related Topics:
Introduction to the Repository
Template Options
Using the Repository Dialog
010 Editor v7.0 Manual - Windows Edition
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Using the Repository Menu

The Repository Menu appears in the File Bar above the Text Editor for each Template or Script that is opened in
010 Editor (see Working with File Interfaces and make sure Edit As is set to either Template or Script). The
Repository Menu changes if the current file has been installed from the Repository. If the current file has not
been installed from the Repository then no icon is displayed beside the Repository Menu and the menu only
contains two options: Submit File which is discussed below, and View Repository which opens the Repository
Dialog.
If the current Template or Script has been installed from the Repository then an icon beside the Repository Menu
shows its current state:







- This file has been installed from the Repository and is up to date.
- This file has been installed from the Repository and has been locally modified.
- A new version of the file is ready for install from the Repository.
- A new version of the file is ready for install from the Repository and the file has been locally
modified.
- The file contains conflicts as the result of an Update operation.

Clicking on the icon displays the Repository Dialog. The following menu options are available in the Repository
menu:
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Update - Attempts to install a newer version of the current file from the Repository. Allows a merge to
be performed if a new version has been found and the file is locally modified (see Updating and Merging
Files).
Submit File - Opens the Submit Dialog to allow uploading either a new Template or Script to the
Repository or an update to an existing Template or Script.
Check for Modifications - Either displays MODIFIED if the Template or Script does not exactly match
the file installed from the Repository, or Unmodified if the Template or Script has not been changed.
Usually the modification status can be seen from the icon shown beside the Repository menu.
Diff - Opens the Compare Dialog to allow viewing the differences between the current Template or
Script and the file that was installed from the Repository (see the dialog below). The down arrows
beside the File A and File B fields can be used to select special entries starting with Repository: that
indicate the file is read from the Repository. A variety of different comparisons can be made by
selecting the different repository versions.
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Revert - If the current file has been locally modified then this option discards all changes and returns
the file to the version that was installed from the Repository. If no changes have been made this option
has no effect.
Delete - Opens a dialog which can be used to request deletion of a file from the Repository. Enter your
name or initials in the Author field and enter the reason for the deletion in the Reason field. This
deletion request can either apply to all existing versions for a file by selecting All in the Version dropdown list or to request just a specific version be deleted select that version in the Version list. Enter
your e-mail in the E-mail field and this information will not be made public but will only be used to
contact you if there is an issue with your request.

View Installed Information - Views the active settings for the current file as listed in the Template
Options dialog for Templates or the Script Options dialog for Scripts. These dialogs display the active
Category, File Mask, ID Bytes etc. Note that the Category, File Mask and ID Bytes listed in the
comments at the beginning of the file only specify the default values when the Template or Script is first
installed and to edit the current settings click the View Installed Information menu option.
View Repository Information - Views the current Template or Script information in the Repository
Dialog.

Note that the Repository Menu is also available in the Repository Dialog in a slightly different form by clicking the
down-arrow to the right of the Uninstall button for an installed Template or Script.

Related Topics:
Comparing Files
Introduction to the Repository
Script Options
Submitting Files to the Repository
Template Options
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Updating and Merging Files
Using the Repository Dialog
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
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Updating and Merging Files
When the Repository has been updated (see Updating the Repository) and a new version of an already installed
Template or Script has been found, the special icon

appears beside the file in the Templates or Script list of

the Repository Dialog. Also, if the Template or Script is open in the editor then the icon appears in the File Bar
by the Repository Menu. To install the new version either click the Update button in the Repository Dialog or the
Update menu option in the Repository Menu of the File Bar above each editor. The Repository Dialog can display
a list of all avaiable versions of a file in the Repository and indicates which version is currently installed.

Merging and Conflicts
If the local Template or Script has not been modified then installing the update only involves downloading and
coping the new file over the old file; however, if the local Template or Script has been modified then a dialog is
displayed which gives the option to either Merge or Overwrite the file. Clicking Overwrite discards all the local
changes and copies in the new file. Clicking Merge attempts to insert all the changes from the Repository into the
current working file using a 3-way merge algorithm.
Often merges can be done with no issues; however, problems can occur when a change from the Repository
occurs in the same place that a local edit has been made and this is called a conflict. For example if the new
version in the Repository added the line:

struct HDRINFO hdr;
to the end of the file but the local Template was already modified to add the line:

struct DATARECORD data;
to the end of the file. This is a conflict and 010 Editor places both lines into the merged Template marked with
the '<<<<<<<', '========', and '>>>>>>>' tags. For example:

<<<<<<<
struct HDRINFO hdr;
=======
struct DATARECORD data;
>>>>>>>
When a conflict occurs the icon appears in the File Bar beside the Repository Menu. To resolve the conflict the
user must edit the file and remove the '<<<<<<<', '========', and '>>>>>>>' tags. Then either delete the
first option, delete the second option, or keep both options in some combination. Once the tags have been
deleted, saving the file will automatically remove the icon. Before the merge takes place the local Template or
Script is copied to a file with the extension .premerge and this file can be copied back if problems occur during
the merge.

Related Topics:
Introduction to the Repository
Updating the Repository
Using the Repository Dialog
Using the Repository Menu
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Submitting Files to the Repository
New Templates or Scripts or updates to existing Templates or Scripts can be submitted to the Repository by
clicking the Repository Menu in the File Bar above each Template or Script and selecting Submit from the dropdown menu. Files can also be submitted by e-mailing them to 'support@sweetscape.com' but please try to ensure
that the header at the beginning of the file contains the proper information as described below.

Submissions to the Repository require a special header at the beginning of the file that includes some special
information about the file. The Submit dialog reads information from the comments to ensure they are in the
correct format and any problems must be corrected before the Submit button can be clicked. An empty comment
header is created every time a new Template or Script is created with the 'Templates > New Template' or 'Scripts
> New Script' menu options. An example of the header for a Template is listed below:

//-----------------------------------------------//--- 010 Editor v7.0 Binary Template
//
//
File: Test.bt
//
Authors: SweetScape Software
//
Version: 1.0
//
Purpose: This is a test template.
// Category: Misc
// File Mask: *.test
// ID Bytes: 3F FF
//
History:
//
1.0
2016-03-04 SweetScape Software: Initial release.
//-----------------------------------------------RequiresVersion(7);
Most of this information must be entered using the editor; however, the Submit dialog contains some fields which
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make adding a Category or History item easier. The different sections of the header are described below:
















File - Must contain the name of the file that is being submitted (e.g. 'Test.bt').
Authors - List the name or the initials of the author of the file. To list an e-mail or website add a
separate line to the header marked E-mail: or Website:.
Version - Lists the current version of the file and versions must contain only numbers or periods '.'. If
submitting an update to an existing file, the highest version number is listed in the Submit dialog as
Updates Version and the current Version must be greater than that version (for example, version 1.5.1
is greater than version 1.5 and version 2 is greater than version 1.5.1).
Purpose - Describe the Template or Script.
Category - Templates and Scripts are listed by category in the Repository. Also when Templates are
Scripts are installed they are listed in categories in either the Templates or the Scripts main menu. If no
category is found in the header a Category box will appear in the submit dialog. Choose one of the
existing categories from the drop-down list and click the Add button to insert the category into the
header. To use a category that does not yet exist enter the category directly in the editor.
File Mask - (not required) For a Template this lists the file names of the data files that this Template
can parse. The wildcards '*' (matches 0 to many characters) and '?' (matches exactly 1 character) can
be used and multiple masks can be listed separated by commas. For example "*.test,test.A??" would
match all files with extension .test or any 3-digit extension starting with A.
ID Bytes - (not required) For data files which match the File Mask above, the Template will only be run
if the hex bytes listed in this field match the bytes at the beginning of the file. This provides an extra
check that the data is in a format that can be read and allows multiple Templates with the same File
Mask to exist that parse different types of data. Some formats such as Linux or Mac OS X executables
do not have an extension and in this case enter the File Mask '*'. ID Bytes uses hex notation for bytes
and to skip bytes use the special syntax [+DDD] or [+0xHHH] where DDD is a decimal number or HHH
is a hex number. Comments may also be listed in the ID Bytes using '//'. For example the ID Bytes '00
[+4] FF' would match a '00' byte at position 0 in the file and a 'FF' byte at position 5. Currently only the
first 1024 bytes of the file are checked for matches. This field can be left blank in which case the
Template will be run on all files that match the File Mask.
History - Provides a list of changes in each version of the file. On the next line after the History: line in
the comments should be a line with the current version number, the date in YYYY-MM-DD format, the
Author (either name or initials), a colon ':', and then a description of the changes in this version. The
Submit dialog provides an easy way to add this information to the Template or Script. Enter information
in the Author and Changes fields in the dialog and then click the Add button. If the submission is for a
new file please enter "Initial release." in the Changes field.
Requires Version - (not required) This is a special field which reads the first non-comment line in the
Template or Script. If the line calls the RequiresVersion function the values are extracted from that
function call. For example "RequiresVersion(3,1);" means that 010 Editor v3.1 or higher is needed to
execute this Template. 010 Editor will warn the user when trying to install a file when the
RequiresVersion is greater than the current application version. Use the RequiresVersion function when
using functions or syntax in Templates or Scripts that is only available in particular versions of 010
Editor.

Once all the information in the header has been verified the Submit button will be enabled as shown in the figure
below. Enter your e-mail address in the E-mail field and this address will not be published and will only be used
to contact you if there is an issue with your submission. Click Submit to upload your file.
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Once your file is uploaded please allow up to 48 hours for the file to be reviewed and added to the Repository.
See Updating the Repository to check if your submission has been accepted. If adding a new file to the
Repository, install the file from the Repository when it becomes available to ensure that any future update
submissions are processed correctly. If adding an update to a file then see Updating and Merging Files to update
your file to the new file in Repository.

Related Topics:
Introduction to the Repository
Updating and Merging Files
Updating the Repository
Using the Repository Menu
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Updating the Repository

By default 010 Editor automatically downloads updates from the online Repository every 3 days. To modify the
length of time either click 'Templates > Template Repository' on the main menu and then select the Status tab,
or click 'Tools > Options' on the main menu and locate the Repository section. Then enter the number of days
between updates in the Check for Updates Every field or to disable updates uncheck the Check for Updates Every
toggle. Note that the minimum time between updates is currently 1 day.
To check if updates are being downloaded successfully locate the Status tab of the Repository dialog as shown
above and then click the Update Now button. If updates fail please check that your internet connection is working
and that a firewall or anti-virus program is not blocking access to the internet for 010 Editor. Updates may also
fail if the support/maintenance period of your license has expired (usually 1 year from the date of purchase) and
see the Repository Licensing Issues section below for more information.
If updates have been downloaded successfully in the past the last update time is listed in the Updates Last
Downloaded field. The Most Recent Record field displays the date of the most recent record downloaded from the
repository and the ID is the sequential ID number of the update, starting from 1. The most recent record is also
displayed at the top of the History tab.
When updates are successfully downloaded the History tab of the Repository dialog is automatically displayed. To
disable this uncheck the Show this dialog when updates are downloaded toggle at the bottom of the History tab.
Any recent updates to the repository are also displayed on the Startup Page.

Local Repository
The 010 Editor install package currently includes part of the repository as part of the download. This is called the
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Local Repository and means that files from the repository can be installed on computers that are not internet
connected (although to download updates an internet connection is required). The Local Repository Available to
field lists the date and ID of the last record in the Local Repository and any records before that date are available
in the Local Repository. Records can be viewed sorted by date on the History tab.

Resetting the Repository
If a problem occurs with the repository then the repository can be reset by clicking the down arrow to the right of
the Update Now button and choosing Reset Repository from the menu. Performing a reset returns the repository
to the state when 010 Editor was first installed and only those records from the Local Repository will be listed.
After resetting, updates can be downloaded again by clicking the Update Now button.

Repository Licensing Issues
When a new license or upgrade license of 010 Editor is purchased the license typically includes free Support,
Upgrades and Repository Updates for 1 year from the date of purchase. The date that Support/Upgrades expires
is listed in the Free Repository Updates Expire field and the date can also be viewed in the Register Dialog. Note
that the repository can be updated after the expiry date is past, but the update will only include those records
that were uploaded on or before the expiry date. If 010 Editor is being used as a 30-day trial updates can be
downloaded until the end of the 30-day trial. If your Support/Updates period is expired see How to Buy 010
Editor for information on purchasing an upgrade.

Related Topics:
How to Buy 010 Editor
Introduction to the Repository
Using the Repository Dialog
Using the Startup Page
010 Editor v7.0 Manual - Windows Edition
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File Menu
The section lists all available menu options in the File menu:

























New - Displays a list of file types that can be created. Click on a file type to create that file in the
editor. To control which file types are displayed see the File Interface Options dialog and to control
which file type is created by pressing Ctrl+N see Editor Options.
Open File - Opens an existing file using a standard file dialog box. See Opening Files for more
information. The Directory Options dialog allows some control over the initial directory when the file
dialog box is opened.
Open Drive - Allows opening of logical or physical drives on your computer for editing. See Editing
Drives for details.
Open Process - Allows opening of the memory of a currently running process for editing. See Editing
Processes for more information. (Windows only)
Open Recent - Displays a list of files which have been recently loaded in the editor.
Save - Saves the current file to disk. If the file was created using New, the file must be given a file
name using the standard file dialog box. See Saving Files for more information.
Save As - Allows saving the current file to a different file name on disk. The name of the file will change
to the new file name after saving. Using Save As on a drive or process will allow saving an image of the
drive or process to a file. Use the Directory Options dialog to control the initial directory displayed in the
file dialog box.
Save a Copy - Saves a copy of the current file to disk. The current file name will not be modified.
Save Selection - Saves the selected bytes in the file to a new file. The start address and size of the
selection will be added to the file name to save in either hex or decimal format, depending upon which
format is choosen in the Select Bar.
Save All - Saves all modified files to disk. Any options specified with the 'Tools > Options...' dialog box
will also be saved to disk.
Close - Closes the current editor window.
Close All - Closes all open editor windows.
Revert/Refresh - Discards all changes for the file and reloads the last copy of the file from disk. If
editing a process or a drive, data will be re-read from the process or drive.
Special > Rename File - Renames the current file to a different file name. The file is changed on disk
only. Note that the file must be saved before it can be renamed.
Special > Delete File - Closes the current file and removes the file from the disk. Use with caution, as
the file will be permanently deleted.
Special > E-mail File - Opens the default e-mail program (if available) to send the current file as an
attachment. (Windows only)
Import Hex - Converts data from one of the supported data formats into a binary file for editing (see
Importing/Exporting Files for more information).
Export Hex - Converts the current file to a different format and saves it to disk (see
Importing/Exporting Files for more information).
Print - Opens the Print Dialog for sending the current document to the printer (see Printing).
Print Preview - Generates a preview of what the current document would look like if sent to the
printer (see Print Preview).
Page Setup - Sets up various options for printing the document including margins, headers, footers,
orientation, and font (see Page Setup for more information).
Exit - Closes all files and exits the program.

Related Topics:
Directory Options
Editing Processes
Editing Drives
Editor Options
File Interface Options
General Options
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Importing/Exporting Files
Opening Files
Page Setup
Print Preview
Printing
Saving Files
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Edit Menu
The section lists all available menu options in the Edit menu:





















232

Undo - Reverts the current file to the state before the last editing operation. The menu caption will
change depending upon which operation was last performed. For example, if a block was pasted into
the file, the menu will read 'Undo Paste'. All commands are stored on a stack so clicking Undo multiple
times will undo the last editing operations in reverse order.
Redo - If an Undo operation was performed, the Redo menu option will perform the edit again (Redo is
the opposite of Undo). The title of this menu option will change to indicate which editing operation will
be redone (for example: 'Redo Edit', or 'Redo Script'). Click Redo multiple times will apply the last
editing operations on the Undo stack in order.
Cut - If a set of bytes is selected in the editor, this menu option will remove the bytes from the file and
place them on a clipboard (see Using the Clipboard for more information). Note that when editing drives
or processes, the file size cannot be changed so Copy must be used instead of Cut.
Copy - The Copy menu option is similar to the Cut command except the selected bytes are copied to
the clipboard but not removed from the file.
Copy As > Copy as Hex Text - Copies the current selection to the clipboard but converts the data
from hex bytes to characters. For example, if the bytes 00 and FF were selected, 'Copy As Hex Text'
would copy the characters '0', '0', 'F', and 'F' to the clipboard. This command is useful for copying binary
data between 010 Editor and a text-only editor.
Copy As > Copy As (export_type) - This set of options allows copying the selection to the clipboard
in any of the available export types (e.g HTML, RTF, Intel-Hex, etc.). Selecting one of these options
exports the selection and then copies the results to the clipboard for easy transfer to another
application. For example, select a set of bytes, click the 'Copy as Web Page (HTML)' menu option,
switch to Microsoft Word or another HTML editor and paste the HTML directly into the application. Note
that when the data is exported, all of the options are used from the last time that type of data was
exported using the 'File > Export Hex...' menu option. See Importing/Exporting Files for an explanation
of all export types.
Paste - If data has been copied onto the clipboard, the Paste command has two possible effects: When
editing a text file or when in Insert mode (INS will appear in the Status Bar) Paste will insert the bytes
on the clipboard into the file at the cursor position. When editing hex data in Overwrite mode (OVR will
appear in the Status Bar) the bytes in the clipboard are pasted over the bytes in the file. If any bytes
are currently selected in the file, those bytes will be deleted before the paste operation. To switch
between Insert and Overwrite mode, use the Insert key. Note that the functionality of Paste can be
controlled through the Hex Editor Options dialog (see Hex Editor Options for more information). When
working with drives or processes, the file size cannot be changed so Paste will only work if the file size
remains unchanged.
Paste Special - Some applications paste data to the clipboard in a number of different formats. The
Paste Special command allows inserting of data to the current document in any of the available formats.
See Using Paste Special for more information.
Paste From > Paste from Hex Text - This command is similar to the Paste command except that
data is automatically converted from characters to hex bytes. For example, if the string "3f45" was
copied onto the clipboard, the bytes 3f and 45 would be pasted into the file (note that extra characters
included spaces are ignored). Paste From Hex Text is useful when copying binary data from other
applications, such as a text editor.
Paste From > Paste from (import_type) - This set of commands provides an easy way to import
information from data that is currently on the clipboard. Using one of these commands is the same as
clicking the 'File > Import Hex...' menu option to import data, except that the data is read from the
clipboard instead of a file. See Importing/Exporting Files for a list of all import types.
Delete - If a selection is made in the current file, the Delete menu option will remove the selected
bytes from the file. When working with a drive or process, the file size is fixed so bytes cannot be
deleted from the file.
Clipboard > (Clipboard List) - 010 Editor has a total of 10 possible clipboards, which includes the
standard Windows clipboard plus 9 custom clipboards. All Cut, Copy, and Paste commands operate on
the active clipboard (see Using the Clipboard for more information). The Clipboard menu indicates which
clipboard is currently active by placing a check mark beside the clipboard name. Other clipboards can be
selected by clicking on the list. The current clipboard is also displayed in the Status Bar.

Copyright © 2003-2016 SweetScape Software

010 Editor - Reference Manual

















Clipboard > Clear All Clipboards - Clears the data on all of the available clipboards. This command is
useful to remove large blocks of memory on the clipboard that are no longer needed.
Select All - Selects all bytes in the current file.
Select Range - Shows the Select Bar at the bottom of the current editor that can be used to select a
set of bytes in a file (see Selecting a Range for more information). If a selection is already made, the
Select Bar displays the start address and size of the selection.
Insert/Overwrite > Insert File - Opens a file dialog box that can be used to insert a file into the
editor at the current cursor position. See Inserting or Overwriting Files for more information. Files
cannot be inserted into a drive or process since the file size is fixed.
Insert/Overwrite > Insert Bytes - Displays the Insert Bytes dialog that is used to insert a set of
bytes into the current file. See Inserting or Overwriting Bytes for more information. Bytes cannot be
inserted into a drive or process since the file size is fixed.
Insert/Overwrite > Overwrite File - Similar to the 'Insert Files' command except that once a file is
chosen using the standard file dialog box, data from the selected file is written over the current file
starting from the cursor position. See Inserting or Overwriting Files for more information. This operation
can be used to write data to a drive or a process.
Insert/Overwrite > Overwrite Bytes - Sets all selected bytes to a single byte value. See Inserting
or Overwriting Bytes for more information.
Insert Color - Opens a standard color selection dialog to select a color. After selecting a color and
clicking OK the color is converted to a text string and inserted into the file at the current cursor position.
By default the HTML color text format '#RRGGBB' is used but other formats can be specified with the
Text Editor Options dialog. Note that 'RR', 'GG', and 'BB' represent the red, green, and blue color
components in hex notation respectively.
Insert Date/Time - Converts the current date and time into a string and inserts the string at the
current cursor position. The format of the date string can be controlled via the Text Editor Options
dialog.
Set File Size - Allows setting the exact size of the current file through the Set File Size dialog (see
Setting the File Size). The file size cannot be modified for drives or processes.
Read Only - Marks that no edits should be made to the current file. When set, 'Read Only' will appear
after the file name in the title bar and a lock icon will appear beside the file name in the File Tabs.
Keep File Time - Marks that the file timestamp should not be changed when the file is saved to disk.
'Keep Time' will appear in the title bar when and a clock icon will appear on the File Tab beside the file
name. Keep File Time only works for regular files and not for drives or processes.
Properties - Shows the Properties dialog, displaying information about the current file, drive, or
process.

Related Topics:
File Properties
Hex Editor Options
Importing/Exporting Files
Inserting or Overwriting Bytes
Inserting or Overwriting Files
Introduction to the Data Engine
Selecting a Range
Setting the File Size
Status Bar
Text Editor Options
Using the Clipboard
Using Paste Special
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Search Menu
The section lists all available menu options in the Search menu:


























Find - Opens the Find Bar below the current editor to search a file for a string or data type. See Using
Find for more information.
Find Next - Searches for the next occurrence of a target value in the current file using the last
performed Find operation from the Find Bar. Note that if no find operation was performed, the Find Bar
will be displayed.
Find Previous - Searches for the previous occurrence of a target value in the current file using the last
performed Find operation. If no find operation has been performed, the Find Bar will be displayed.
Replace - Opens the Replace Bar below the current editor that can be used to find and replace strings
or data types in the current file. See Using Replace for more information.
Replace Next - Repeats the last Replace operation. Replaces a match of the target value and then
searches the file for the next occurrence. If no Replace operation has been performed, the Replace Bar
will be shown. A combination of 'Find Next' and 'Replace Next' can be used to step through the file,
making replacements as necessary.
Replace Previous - Performs the last Replace operation again. Once the replacement has been made
the file is then searched for the previous occurrence of the target value. The Replace Bar will be shown
if no replacement operation has been performed. Use 'Find Previous' and 'Replace Previous' to skip
through a file going up, making replacements as necessary.
Find Strings - Attempts to locate strings within a binary files using the Find Strings dialog.
Find in Files - Opens the Find in Files Bar below the editor that can be used to search for a string or
data type across multiple files. See Using Find in Files for more information.
Replace in Files - Displays the Replace in Files Bar below the editor that can be used to search and
replace a string or data type across multiple files. See Using Replace in Files for more information.
Goto - Shows the Goto Bar below the editor that can be used to set the cursor to a specific address
within the current file. See Using Goto for more information.
Goto Again - Repeats the last Goto operation. If the last Goto operation was from the current position
(using either '+' or '-'), this command can be used to step through the file. If no Goto operations have
been performed, the Goto Bar will be displayed.
Add/Edit Bookmark - Shows the Add/Edit Bookmark dialog that is used to add a bookmark to a file at
the current location. If a bookmark already exists at the current cursor location, the bookmark is
displayed in the dialog for editing. See Using Bookmarks for more information. Created bookmarks are
shown in the Bookmarks tab of the Inspector.
Toggle Bookmark - If the cursor in the Editor Window is positioned over an existing bookmark,
clicking 'Toggle Bookmark' will delete the bookmark from the file. If no bookmark exists at the cursor, a
quick bookmark will be created at that position. More advanced bookmarks can be created using the
'Add/Edit Bookmark' option.
Next Bookmark - Moves the cursor to the next bookmark in the file.
Previous Bookmark - Moves the cursor to the previous bookmark in the file.
Clear All Bookmarks - Removes all bookmarks from the current file.
Jump to Template Variable - If a template has been run on the current file, clicking 'Jump to
Template Variable' will try to locate a template variable at the current cursor position. If a template
variable can be found, it will be shown either in the Template Results panel, or the Variables tab of the
Inspector, which ever panel was last used. See Working with Template Results for more information.
Previous Sector - When editing a drive, this menu option allows moving the cursor to the previous
drive sector. See Editing Drives for more information on sectors.
Next Sector - Moves the cursor to the next drive sector when editing a logical or physical drive. See
Editing Drives for more information on sectors.

Related Topics:
Editing Drives
Using Bookmarks
Using Find
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Using Goto
Using Replace
Using Replace in Files
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010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com

Copyright © 2003-2016 SweetScape Software

235

010 Editor - Reference Manual

View Menu
The View Menu is used for controlling the current File Interface. The File Interface (which includes the Font,
Character Set, Linefeeds/Line Width, Tabs, Addresses, Group By, Division Lines, Areas, Highlighting, Ruler, and
Status Bar) tells the program how each Editor Window should display data (see Working with File Interfaces for
more information). When one of the interface options is modified, this affects all files that use that interface
(except for the Endian and Word Wrap setting as discussed below). The View menu will display different options
when a text-based File Interface is active as opposed to a hex-based File Interface because some options are
only applicable to one type of interface. By default, 010 Editor comes installed with a number of File Interfaces as
displayed on the 'View > Edit As' menu; however, different interfaces can be created for different files based on
the file name or extension. Note that all File Interfaces are saved automatically upon exit. The View Menu is also
used to control which panels are displayed and controls options for the Tool Bars. This section lists all available
menu options in the View menu:
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Edit As > (File Interface List) - Shows a list of possible File Interfaces (see Working with File
Interfaces) that can be used to edit files. A check mark is placed beside the interface that is applied to
the current file. To create more interfaces, see the 'Create New File Interface' or 'Edit File Interfaces'
menu option.
Edit As > Toggle Hex Interface - If editing a file using a text-based File Interface clicking this option
chooses a hex-based File Interface to edit the file. Similarly, if the current interface is a hex-based File
Interface the File Interface is switched to a text-based interface.
Edit As > Create New File Interface - Creates a new interface for all files with the same extension as
the current file. For example, if the current file has a '.bmp' extension then all files that are opened with
a '.bmp' extension will use the created interface and the interface will be named 'bmp' on the Edit As
menu.
Edit As > Edit File Interfaces - Displays the File Interface Options dialog that is used to modify,
create, or delete File Interfaces.
Font - Sets the font for the current interface. This menu will display either Use Default Text Editor Font
or Use Default Hex Editor Font depending upon if this Interface is for text or hex files. If this toggle is
enabled, the default font is used from the Font Options dialog, otherwise this interface uses its own
custom font. Clicking Change Font displays the standard Font dialog that allows setting of the font type,
size, and style. Use the Enlarge Font (Ctrl++) or Shrink Font (Ctrl+-) menu options to increase or
decrease the size setting for the font. If this Interface is using one of the default fonts, the Change
Font, Enlarge Font and Shrink Font menu options affect the default font, otherwise these options affect
the custom font for this Interface.
Character Set - This option controls which character set is used when displaying characters in the Char
area. The options are ASCII, ASCII+OEM, ASCII+ANSI, EBCDIC, Unicode, UTF-8 and Macintosh. The
OEM and ANSI character sets only affect bytes with values between 128 and 255. Bytes that have no
representation in the Char area (e.g. control characters) are displayed as the character '.' in hex-mode
or a square in text-mode. When using Unicode character sets every two bytes indicate one character
and the endian for the characters is determined using the 'View > Endian' menu option. The actual
characters for the Unicode display depend upon which font is currently in use. Characters sets for
different nationalities are also available by clicking on the 'International' menu option and selecting
Arabic, Baltic, Chinese (Simplified), Chinese (Traditional), Cyrillic (Russian), Eastern Europe, Greek,
Hebrew, Japanese, Korean (Johab), Korean (Wansung), Thai, Turkish, or Vietnamese. Note that most of
these character sets only affect bytes values between 128 and 255 and the actual characters displayed
depend upon the fonts installed on the system.
Linefeeds (text only) - Controls how a text file is divided into lines. Currently this menu is used to
control how Word Wrap is applied to files. When Word Wrap is enabled, any lines that go beyond the
edge of the Text Editor Window are wrapped onto a new line. Click the Word Wrap option to turn
wrapping on or off and the text /wrap will appear beside the File Interface name in the File Bar when
enabled (see Word Wrap for more information). Note that whether Word Wrap is turned on is stored
separate to the File Interface and the current Word Wrap state is remembered for files if the Remember
Last Used Interface toggle is set in the Editor Options dialog. If a file has not been opened before (or
the Remember Last Used Interface toggle is turned off), the wrap state can be set with the Initial Wrap
State menu option to On, Off or Auto-detect. For Auto-detect, 010 Editor will automatically turn on
Word Wrap if it finds the file contains long text lines. Wrapping is usually done at the edge of the Text
Editor Window but can be set to occur at a specific column with the Wrap Width menu option. Wrapping
can be set to Column 80 or any other column number by choosing Custom Column. When wrapping
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occurs at a set column, a line will be drawn in the Text Editor Window to indicate the wrap width. When
applying Word Wrap, by default whole words are always kept together but wrapping can be done on any
letter by choosing Wrap on Letters on the Wrap Method menu. Select Wrap on Words to return to
keeping whole words together. The Column Mode menu item switches the editor to or from Column
Mode and see the separate Column Mode help topic for more information.
Line Width (hex only) - Specifies how many bytes are displayed on each line of the Hex Editor. For
example, if Fixed 16 Bytes is chosen the file is displayed with 16 bytes per line. When the linefeeds are
set to Auto Width the number of bytes to display is automatically chosen to fill the width of the Hex
Editor Window. The width can be set to 4, 8, 12, 16, 20, or Custom Width. When setting to a Custom
Width a dialog will be displayed for entering any width (values between 1 and 1024 are allowed). Note
that the number of bytes per line must be divisible by the number of bytes in the Group By option.
Tabs/Whitespace (text only) - When editing a text file the columns of the file are divided into a
number of tab stops. Enable the Show Whitespace menu option to display symbols indicating where all
spaces and tabs exist in the file (the color of the symbols can be controlled using the Color Options
dialog). Choose the number of characters between each tab stop using the Tab Size: menu options
(click the Tab Size: Custom menu option to set a specific tab size using an input dialog). When a tab
character is encountered in a file the next character is drawn at the next tab stop. The number of
characters to insert when the Tab key is pressed can be controlled through the Indent Size: menu
options. Note that the Indent Size may be different than the Tab Size. If the Insert Spaces toggle is
enabled (the default) spaces are inserted into a file to simulate the tab positions. To insert actual Tab
characters disable the Insert Spaces option and make sure the Tab Size and Indent Size are set to the
same amount. An easy way to access this menu is by clicking the Tab: section of the status bar.
Addresses - Sets the format of the addresses for the current File Interface as displayed on the left side
of the Editor Window. The address can display either the current Byte Number, Line Number, Sector
Number or Short Number (note that a Short is a group of two bytes in a hex file). Some addresses can
be displayed in either Hex, Decimal, or Octal format as indicated in brackets to the right of the address
type. Note that when editing a hex file the line number displayed depends upon the number of bytes
per row in the editor (set the Line Width option above). When Sector Number is chosen the address is
displayed in the format '< sector number >|< sector offset >' (see Editing Drives for more information
on sectors). If None is chosen no addresses are displayed for the file.
Group By (hex only) - When using a hex-based File Interface this option sets how many bytes are
grouped together in the display. Bytes that are grouped together are displayed without spaces. The
default value is Byte, meaning that each byte is displayed with spaces around it. A custom Group By
value can be set by clicking the Custom option and entering a value. Note that the number of bytes per
line (see Line Width above) must be divisible by the number of bytes per group. The Hex Editor Window
has a special mode that allows groups of bytes to be visually swapped without modifying the underlying
data. This mode can be enabled by clicking the Swap Little-Endian Bytes by Group toggle and choosing
a Group By other than Byte. See Swapping Bytes for more information.
Division Lines (hex only) - When using a hex-based File Interface the Division lines allow drawing
lines on the Hex Editor Window to visualize how data is grouped into sections. Currently there are two
types of lines that can be displayed: Division Lines and Sector Lines. By default Division lines are
displayed every 4 bytes of the file and are drawn in a light gray color (use the Color Options dialog to
modify the color). The top portion of the 'View > Division Lines' menu is used to control Division Lines.
Choose 1, 2, 4, 8, or Custom to set the division spacing, or select None to hide the lines. The 'Set
Starting Division Offset' allows starting the division lines on an address other than the beginning of the
file. This feature is useful if your file contains a header at the beginning of the file and then a number of
fixed size records (the starting offset can be used to skip over the header).
Sector Lines are meant to visualize the sectors of a hard drive (usually 512, 1024, or 2048 bytes in
size), but can be modified by the user to visualize other types of data when not editing a hard drive. By
default, Sector Lines are displayed as dark gray lines but this can be modified in the Color Options
dialog. Use the bottom portion of the 'View > Division Lines' menu to control the Sector Lines. Show or
hide the Sector Lines by clicking the 'Show Sector Lines' menu option. When editing a hard drive, the
sector size is determined from the physical device (see Editing Drives); however, when editing a regular
file, the sector size can be user defined by clicking the 'Set Sector Size' menu option (this option is
useful if you are editing a file which is an image of a drive). When a regular file is being editing a
starting address for the sector lines can be specified using the 'Set Starting Sector Offset', similar to the
Division Lines.





Left Area (hex only) - If the current File Interface is for hex-based files, this option controls which
numeric format is used to display the bytes in the left side of the Hex Editor Window. The options are
Hex, Char, Octal, Binary, and Decimal. See Introduction to Number Systems for more information.
Right Area (hex only) - When using a hex-based interface, this option controls which numeric format
is used to display the bytes in the right side of the Hex Editor Window. The options are Hex, Char,
Octal, Binary, and Decimal. As well, the Hide option can be selected to only display the left area.
Highlighting - Controls which bytes are highlighted in the current interface using a color scheme.
When a color scheme is enabled by clicking on an item in the Highlighting menu, the background color
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of all bytes that match that scheme are modified. A check mark will appear beside an active highlight,
and the highlight can be turned off by clicking on the highlight name again. Note that multiple highlights
can be turned on at the same time (highlights at the top of the list take precedence over highlights at
the bottom). The default Highlight options are 'Linefeed Characters' (0x0d and 0x0a), 'Alphanumeric
Characters' (all letters and numbers), 'Control Characters' (any of the bytes from 0 to 31), and 'NonASCII Characters' (any of the bytes from 128 to 255). Custom highlights can be generated by clicking
the 'Edit Highlights...' menu option (see Highlight Options for more information) and highlights can also
be created for highlighting Shorts (a Short is a group of two hex bytes).
Highlighting > Syntax Highlighting - Different types of highlighting can be applied to text files based
on a number of syntax rules. 010 Editor has its own syntax highlighting rules for Scripts and Templates
(select 010 Editor Script/Template) but also has built-in rules for C/C++ source code, HTML, PHP, and
XML. The syntax highlighting rules can be customized using the Syntax Options dialog. Select the None
menu option to not apply any syntax highlighting.
Ruler - Specifies whether the Ruler is displayed above each file. The ruler is a band with tick marks,
indicated byte offsets from the first byte in a line. The units used for the ruler can be set to hex or
decimal using Hex Units or Decimal Units.
Status Bar > File Position - Controls the format of the current cursor position as displayed in the
Status Bar as either Byte Number, Line Number, Sector Number, or Short Number (a Short is a group of
two bytes within a hex file). See Status Bar for more information.
Status Bar > File Size - Sets the format of the file size displayed in the Status Bar as either Byte
Count, Line Count, Sector Count, or Short Count.
Status Bar > Selection Size - When a selection is made, the number of selected bytes is displayed in
the status bar with the label Sel:. This menu option controls the format used to display the selection
size.
Endian - Controls which byte-ordering is used for the current file (see Introduction to Byte Ordering).
The ordering can either be Little Endian (Intel machines), or Big Endian (Motorola Machines). When the
current file is in little endian mode, the Status Bar will contain the letters LIT and when the file is in big
endian mode, BIG will be displayed (see Status Bar). Use the Toggle Endian menu option to switch
between the two endians. The Endian setting is different than the other options in the File Interface
since this option contains only the default Endian setting when a file is opened. Changing the Endian
does not modify other files that are using the same File Interface (for example, you can have a big
endian file and a little endian file open at the same time both using the Unicode File Interface).
Workspace - Toggles whether the Workspace panel is displayed in the main window.
Inspector - Hides or shows the Inspector panel in the main window.
Output - Hides or shows the Output panel that is used to display output from the Find, Find in Files,
Compare, Histogram, Checksum, and Open Process tools.
Template Results - Toggles whether the Template Results panel is displayed at the bottom of the
current Editor Window. See Working with Template Results for more information.
Floating Tab Group - Toggles the display of the Floating Tab Group as discussed in Using File Tabs.
Tool Bars - Allows control of which Tool Bars are displayed in the program.
Other Windows - Allows display of other miscellaneous windows for 010 Editor: the Startup Page and
the initial Welcome dialog.

Related Topics:
Color Options
Column Mode
Editing Drives
Editor Options
File Interface Options
Font Options
Highlight Options
Introduction to Byte Ordering
Introduction to Number Systems
Status Bar
Syntax Options
Using the Inspector
Using the Workspace
Working with File Interfaces
Working with Template Results
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Format Menu
The section lists all available menu options in the Format menu:


















Uppercase - Converts all letters in the current selection to their uppercase form (e.g. 'a' -> 'A'). All
other characters will not be modified.
Lowercase - Modifies each letter in the current selection to their lowercase form (e.g. 'A' -> 'a'). All
other characters will not be modified.
Capitalize - The command will capitalize the first letter of each word in the current selection and make
all other letters lowercase (e.g. 'the title' -> 'The Title'). All non-letter characters will not be changed.
Tabify - When working with text files, this command converts any set of two or more spaces into tab
characters if the conversion can be done to preserve the spacing of each line. If no selection is made
this operation converts the whole file, and if a selection is made the operation converts all lines that
contain all or part of the selection. To view the current tabs and spaces in a file see the Show
Whitespace menu option.
Untabify - The Untabify command converts all tab characters into their equivalent in spaces. If no
selection is made the whole file is converted, and if a selection is made only those lines that intersect
the selection are modified. Note this command is only available when working with text files. All tabs
and spaces in the file can be shown using the Show Whitespace menu option and the number of spaces
per tab can be controlled using the View > Tabs/Whitespace menu.
Comment Selection - Adds characters to the file so that the currently selected bytes are considered as
comments in a file. If no selection is made the line the cursor is on will be commented. The Comment
Selection command supports two different types of comments: line comments (for example '//' in C++)
and multi-line comments (for example '/*' and '*/' in C++ or '<!--' and '-->' in HTML). The commenting
used is derived from the current syntax highlighting (specifically by looking for rules using the 'codecomment' or the 'tag-comment' rule in the Syntax Options dialog). If no commenting characters can be
determined from the current syntax highlighting, C/C++ comments are used. Line comments will be
inserted on each line if possible, but if not possible then multi-line comments will be inserted.
Comments can be deleted using the Uncomment Selection command.
Uncomment Selection - This command attempts to remove commenting from the current selection
and if no selection is made comments are removed from the current line. Both line comments and
multi-line comments are supported as described in the Comment Selection command above. If the
bytes to be uncommented contain line comments, those comments are removed first. If no line
comments exist then multi-line comments are removed instead.
Increase Line Indent - Adds tab or space characters to the start of each line that lies all or partially
within the selected bytes. If no selection is made, tabs or spaces are added to the current line. Whether
tabs or spaces are inserted is controlled using the 'View > Tabs/Whitespace > Insert Spaces' menu
option. The number of spaces or tabs inserted is controlled using 'View > Tabs/Whitespace > Indent
Size' (see the View Menu for more information). This command has the same effect as pressing the Tab
key in the editor while bytes are selected (see Using the Text Editor).
Decrease Line Indent - Removes tabs or spaces from the beginning of each line that intersects the
current selection. If no selection is made, tabs or spaces are removed from the current line. The
number of tabs or spaces deleted is controlled using 'View > Tabs/Whitespace > Indent Size' (see the
View Menu. This command is equivalent to pressing the Shift+Tab key in the Text Editor when a
selection is made (see Using the Text Editor).
Trim Trailing Whitespace - This command deletes all spaces and tabs that occur after the last visible
character on each line. If no selection is made the whitespace will be trimmed from every line in the file,
but if a selection is made each line that lies completely or partially within the selection will be trimmed.

Related Topics:
Syntax Options
Using the Text Editor
View Menu
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Scripts Menu
Scripts are short programs similar to C that can be used to edit text or binary files (see Introduction to Templates
and Scripts). This section lists all available menu options in the Scripts menu:












New Script - Creates a new script file and opens it for editing in the interface.
Open Script - Displays a file dialog box for loading an 010 Editor Script file (usually with file extension
".1sc").
Edit Script - If a script has been associated with the current file, the script is opened in the application
for editing. If no script is associated with the current file, the last accessed script will be opened and if
no script has been opened you will be asked to create a new script or open an existing script. Scripts
can be associated with the current file by using the Run Script or the Run on File section of the File Bar
above each editor. See Running Templates and Scripts for more information.
Run Script - If the currently selected file is not a script, clicking the 'Run Script' menu option will run
any script that is associated with the current file. If the current file is a script then clicking this option
will execute the script on the selected file. See Running Templates and Scripts for more information. If a
script modifies a file, the 'Edit > Undo' menu option will undo any changes.
(Installed Script List) - Displays a list of installed scripts sorted by category such as 'Randomize',
'IsASCII', 'MultiplePaste', 'SplitFile', and 'JoinFile'. Clicking on an item in this menu usually executes the
script but can also be configured to load the script into the interface for editing. See Script Options for
more information on adding scripts, changing script options, or using the default custom scripts. Scripts
can also be installed using the Repository Dialog.
View Installed Scripts - Opens the Script Options dialog that can be used to add or customize scripts
on the Installed Script List.
Script Repository - Displays the Repository Dialog which can be used to install Scripts other people
have uploaded. Please consider uploading to the Repository any useful scripts you have developed. The
Repository can also be accessed online at 'http://www.sweetscape.com/010editor/repository/'.

Related Topics:
Introduction to Templates and Scripts
Running Templates and Scripts
Script Options
Using the Repository Dialog
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Templates Menu
The Templates menu allows loading and running Binary Templates (see Introduction to Templates and Scripts).
This section lists all available menu options in the Templates menu:












New Template - Creates a new Binary Template and opens it for editing in the interface.
Open Template - Opens a file dialog box to load a Binary Template (usually with file extension ".bt").
Edit Template - If the current file has a template associated with it, that template is displayed for
editing in the interface. If there is no template associated with the current file, the last accessed
template is opened and if no template has been opened you will be asked to create a new template or
open an existing template. Templates can be associated with the current file by using the Run Template
or the Run on File section of the File Bar above each editor. See Running Templates and Scripts for
more information.
Run Template - If the currently selected file is not a template, clicking the 'Run Template' menu option
will run any template that is associated with the current file. If the current file is a template, clicking the
option will execute the template on the selected file. See Running Templates and Scripts for more
information. The results are displayed either in the Template Results panel below the Editor Window or
in the Variables tab of the Inspector (see Working with Template Results for more information).
(Installed Template List) - Displays the list of installed templates, such as 'BMP', 'ZIP', and 'WAV',
sorted by category. Clicking on an item on the list usually executes the template but can also be
configured to open the template for editing in the interface. Templates can be added to the list by
clicking the 'View Installed Templates' menu option or by using the Repository Dialog. Note that
templates can be configured to load automatically based on the opened file type (see Template Options
for more information).
View Installed Templates - Displays the Template Options dialog that can be used to add templates
to the Installed Template List for easy access.
Template Repository - Displays the Repository Dialog which can be used to install Templates other
people have uploaded to the Repository. Please consider uploading any templates you have created that
may be useful to other people. The Repository can also be accessed online at
'http://www.sweetscape.com/010editor/repository/'.

Related Topics:
Introduction to Templates and Scripts
Running Templates and Scripts
Template Options
Using the Inspector
Using the Repository Dialog
Working with Template Results
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Tools Menu
The Tools menu contains a number of powerful tools for editing, plus the Options and Register dialogs. This
section lists all available menu options in the Tools menu:












Calculator - Opens the 010 Editor Calculator that uses a syntax similar to C (see the Calculator for
more information).
Compare Files - Opens the Compare tool that is used to compare two files (see Comparing Files for
more information).
Hex Operations - Performs a mathematic operation, such as Add or Multiply on a set of bytes in the
file (see Hex Operations for more information).
Convert - Used to convert the current file into other formats (see Converting Files for more
information).
Histogram - Performs a histogram (byte count) operation on the current file (see Histograms).
Check Sum - Opens the Check Sum dialog to perform a set of check sum or hash algorithms on the file
(see Check Sum/Hash Algorithms for more information).
Base Converter - Displays a tool used to convert between Hex, Decimal, Octal, and Binary numeric
formats (see Base Converter for more information).
(Custom Tool List) - Displays a list of custom external programs that can be run. Clicking Windows
Notepad loads the currently open file in that program. Other tools can be added to the list and see
Program Options for the list of standard tools.
Register - Displays the Register Dialog that is used to enter your Name and Password after purchasing
010 Editor (see How to Buy 010 Editor for more information).
Options - Displays the options for 010 Editor (see General Options more information).

Related Topics:
Base Converter
Calculator
Check Sum/Hash Algorithms
Comparing Files
Program Options
General Options
Histograms
How to Buy 010 Editor
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Window Menu
The Window menu is used to manage all open files. This section lists all available menu options in the Window
menu:



















Duplicate Window - Opens another Editor Window that can be used to view the current file. The title
of the window will change to include a ':' followed by a number to indicate that there are multiple
windows open for the same file. Note that if a change is made in one file, the change will also appear in
the additional view. See Opening Files for more information.
Split Window - Divides the current Editor Window into two areas, a top and a bottom area. These two
areas can be used to edit two different portions of a file at the same time. The window can also be split
by grabbing the small button above the vertical scroll bar in the Editor Window (see Using the Text
Editor or Using the Hex Editor for more information). If the Editor Window has already been split into
two areas, clicking this menu option will remove the split and display only one area.
Synchronize Scrolling - This menu option is a toggle that can be enabled or disabled by clicking on it.
When the toggle is enabled and one Text Editor Window is scrolled up or down, then all other Text
Editor Windows that are currently visible will scroll by the same amount. Likewise if one Hex Editor
Window is scrolled, all other visible Hex Editor Windows will be scrolled as well. This option is useful to
visually compare large sections of two different files. When using the Compare Files tool, an options
exists in the Compare dialog to automatically enable Synchronize Scrolling after a comparison is run.
Next Window - Selects the next Editor Window in the interface as the active Window.
Previous Window - Selects the previous Editor Window in the interface as the active Window.
Move to New Horizontal Tab Group - If multiple Editor Windows are open, they may be separated
into multiple horizontal Tab Groups. Selecting this option creates a new horizontal Tab Group and places
the current Editor Window into that group. See Using File Tabs for more information on Tab Groups. If
any Tab Groups are laid out vertically, they will be switched to horizontal.
Move to New Vertical Tab Group - Multiple Editor Windows may be separated into different vertical
Tab Groups. This option creates a new vertical Tab Group containing the current Editor Window. See
Using File Tabs for more information on Tab Groups. Clicking this option will change any Tab Groups laid
out horizontally to be laid out vertically.
Move to Floating Tab Group - An additional Tab Group in a moveable window is available by clicking
the 'View > Floating Tab Group' menu option. The current Editor Window can be moved to this Tab
Group by clicking on this option (see Using File Tabs).
Move to Next Tab Group - If multiple Tab Groups have been created by clicking the 'Move to New
Horizontal Tab Group' or 'Move to New Vertical Tab Group' menu options or by dragging the File Tab to
a new position, this option can be used to move the current Editor Window to the next Tab Group.
Move to Previous Tab Group - This command is similar to the 'Move to Next Tab Group' option except
the current Editor Window is moved to the previous Tab Group.
Merge All Tab Groups - Clicking the 'Merge All Tab Groups' option takes all open Editor Windows
(including any Editor Windows in the Floating Tab Group) and places them into a single Tab Group in
the main interface.
Window List - Displays a dialog containing a list of all open windows. Double-click on a window, or
select a window from the list and click the Activate button to focus that window. Click the Cancel button
to close the dialog.

At the bottom of the Windows menu a list of all open windows is displayed with a check mark beside the active
window. Select a file from the list to activate that file.

Related Topics:
Comparing Files
Opening Files
Using File Tabs
Using the Hex Editor
Using the Text Editor
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Help Menu
The Help menu gives access to the documentation, website, and support for 010 Editor. This section lists all
available menu options in the Help menu:















Help Topics - Displays this help file.
SweetScape Homepage - Loads an Internet browser (if available) and visits
'http://www.sweetscape.com/'.
010 Editor Homepage - Loads an Internet browser (if available) and visits
'http://www.sweetscape.com/010editor/'.
Buy Now - Visits the website 'http://www.sweetscape.com/store/' which allows you to purchase a copy
of 010 Editor. See How to Buy 010 Editor for more information.
Tutorials > Introduction to Binary Templates - Displays a short tutorial on how Binary Templates
work, including how to run templates and how to use the Template Results panel.
Tutorials > Writing Binary Templates - Shows a tutorial on how to create your own Binary
Templates.
Tutorials > Using the Repository - Displays a tutorial on the basics of the 010 Editor Repository.
Check for Updates - Checks if a new version of 010 Editor is available if the computer is internet
connected. Note that a popup window will automatically be displayed if 010 Editor detects a new version
is available and this can be turned off using the General Options dialog.
View Release Notes - Displays the list of changes for the current and previous versions of 010 Editor
(see Release Notes).
View Shortcut List - Displays a list of shortcut keys in the application sorted by shortcut name. See
Keyboard Options for more information.
Support on the Web - Obtain support by visiting the website 'http://www.sweetscape.com/support/'.
Support by E-mail - Opens a web form which can be used to send an e-mail message to
'support@sweetscape.com'.
About - Displays the About dialog containing version information for 010 Editor.

Related Topics:
General Options
How to Buy 010 Editor
Introduction to the Repository
Keyboard Options
How to Get Support
Release Notes
010 Editor v7.0 Manual - Windows Edition
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General Options

The General Options dialog contains options for the whole application. Access this dialog by clicking the 'Tools >
Options...' menu option and selecting General from the list.

Startup
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Startup Action - This drop-down list indicates what 010 Editor should display when first started. The
default is Show startup page and restore open files meaning that all open files are reloaded from when
010 Editor was last run but the Startup Page is focused. If Show startup page is selected just the
Startup Page is shown and no files are reloaded. If Restore all open files is selected, all files will be
reloaded and the last file being edited will be focused. Alternately, 010 Editor can create a new file or
display no tabs at all by selecting the Create new file or Display empty interface options respectively.
Allow Only One Instance of 010 Editor - If this flag is set, only one copy of 010 Editor is allowed to
run at a time. If new files are opened from the Windows Explorer or elsewhere, they are loaded into the
already-running program.
Hide Splash Screen on Startup - If enabled, this toggle will prevent the splash screen from displaying
while 010 Editor is starting up. This option is only available if you have purchased a license of 010
Editor and entered your license information in the Register dialog.
Add 010 Editor to Windows Explorer right-click menu - If this toggle is enabled, an entry that
says 010 Editor will be added to the Windows Explorer popup menu when you right-click on a file.
Clicking the 010 Editor option will cause the file to be opened in 010 Editor.
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Clipboard


Leave Large Blocks on Clipboard on Exit - When this toggle is set and the clipboard contains a large
block of data on exit (over 4 megabytes), 010 Editor will copy this block onto the system clipboard.
When not set, large blocks are discarded and will be unavailable to other programs after 010 Editor
exits. Note that small blocks (under 4 megabytes) are automatically copied. 010 Editor supports
copying large blocks (gigabytes in some cases) that the Windows clipboard cannot handle (the limit is
about 16 megabytes on some systems). Therefore some blocks may not copy onto the clipboard
properly if too much data is copied.

Updates




Check For Updates/News Every - If this toggle is enabled 010 Editor will download any news,
including notification of new releases, from our website and display it on the Startup Page. Enter the
number of days between downloads in the Days field and note that new updates are not installed
automatically. See the Startup Page for more information.
Show Popup when New Version is Available - When this toggle is enabled and 010 Editor discovers
a new version is available while checking for updates, a popup window will be displayed. If the Check
for Updates toggle is turned off a popup will not be displayed. Updates can also be checked manually by
clicking the 'Help > Check for Updates' menu option on the main menu.

History


History List Size - Specifies the number of items to appear in the recent file history list. This affects
the number of items on the 'File > Open Recent' list and the number of Recent Files in the Workspace
(see Using the Workspace for more information).

Auto-Hide


Auto-Hide Bar Time - Some tools in 010 Editor are displayed as a bar at the bottom of the editor
including the Find Bar, Replace Bar, Goto Bar, Select Bar, etc. When any of these bars are not used for
a period of time, they will be automatically hidden. Enter the number of seconds of inactivity in the
Auto-Hide Bar Time field before a bar is hidden. If the toggle to the left of Auto-Hide Bar Time is
disabled, the auto-hide time will be ignored and bars will never be automatically hidden.

Click the Reset button to return all of the General Options to their default values.

Related Topics:
Introduction to the Data Engine
Using the Workspace
010 Editor v7.0 Manual - Windows Edition
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Editor Options

The Editor Options dialog is used to modify options that affect both the Hex Editor Window and the Text Editor
Window. Open the Editor Options dialog by clicking 'Tools > Options...' and selecting Editor from the list.

Creating Files


Default New File Interface - When a file is created by clicking the New icon in the Tool Bar or by
pressing Ctrl+N, the created file is assigned a File Interface (see Working with File Interfaces for more
information). Select which File Interface the created file should have from the drop-down list. This
option determines which File Interface in the 'File > New' menu list has the shortcut Ctrl+N.

Opening Files
When a file is opened in 010 Editor, the file is assigned a File Interface based on the masks in the list of
interfaces (see File Interface Options). If no mask matches the file name, 010 Editor can automatically try to
detect the correct File Interface (select Auto-Detect File Interface) or 010 Editor can assign a specific interface
(select Use File Interface and choose the interface from the drop-down list). When the Remember Last Used
Interface toggle is set, 010 Editor will remember the last used File Interface, Endian and Word Wrap setting for a
file last time it was closed and will restore those settings when the file is opened again.
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Closing Files


Hide Floating Tab Group when All Files are Closed - When all tabs are closed in the Floating Tab
Group, it will automatically be hidden if this toggle is enabled. If this toggle is turned off, an empty
Floating Tab Group will be displayed when all tabs are closed. The Floating Tab Group can be displayed
by clicking 'View > Floating Tab Group' on the main menu.

Mouse Wheel


Mouse Wheel Scroll Speed - If your mouse is equipped with a scroll wheel, the Editor Window can be
scrolled by rolling the wheel forward or backward. By default, for every click of the wheel the window
scrolls two lines; however, to change the scroll speed enter a value in the Mouse Wheel Scroll Speed
field. Higher values scroll faster and lower values scroll slower.

Highlighting



Highlight Current Line - By default, the line the cursor is on in the Editor Window will be highlighted a
yellow color. When this option is turned off, the highlight will no longer be displayed. Note that the color
of the line can be controlled from the Color Options dialog.
Shadow Cursor - When an editor is not currently focused, a vertical gray line will appear where the
cursor was. This line is called the Shadow Cursor and can be disabled by turning the Shadow Cursor
toggle off.

The Reset button can be used to return all of the Editor Options to their default values.

Related Topics:
Color Options
File Interface Options
Introduction to Templates and Scripts
Using the Clipboard
Using the Hex Editor
Working with File Interfaces
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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Text Editor Options

Use the Text Editor Options dialog to control how the Text Editor Window operates (see Using the Text Editor for
more information). Options for the Text Editor Window are also controlled by the Editor Options and the File
Interface Options dialogs. To display the Text Editor Options window, click 'Tools > Options...' and select Text
Editor from the list.

Cursor Keys


Home Key Always Moves to First Column - By default, when the Home key is pressed in the Text
Editor Window the cursor moves to the first non-space character on the current line. If the cursor is
already at the first non-space character, pressing the Home key moves the cursor to the first column. If
the Home Key Always Moves to First Column toggle is enabled the cursor will always move to the
beginning of the line when Home is pressed.

Insert Formats
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Insert Date Format - This option controls the format of the date when inserted with the 'Edit > Insert
Date/Time' menu option. The following character codes can be used when setting the date format:
 h - hour without leading zero
 hh - hour with leading zero
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m - minute without leading zero
mm - minute with leading zero
s - second without leading zero
ss - second with leading zero
AP - either AM or PM
ap - either am or pm
d - day without leading zero
dd - day with leading zero
ddd - short day (e.g. 'Mon')
dddd - long day (e.g. 'Monday')
M - month without leading zero
MM - month with leading zero
MMM - short month (e.g. 'Jan')
MMMM - long month (e.g. 'January')
yy - 2-digit year
yyyy - 4-digit year
Insert Color Format - This option determines the format of a color when inserted using the 'Edit >
Insert Color' menu option. The following special codes are available for use within the color format:
 RR - insert the red component of the color in hex notation
 GG - insert the green component of the color in hex notation
 BB - insert the blue component of the color in hex notation

Line Length


Maximum Line Length - When using the Text Editor with Word Wrap turned off, any long lines in the
file will be split into multiple lines in the editor. Any line that is generated by splitting a long line is
indicated by a '-' mark in the Address area on the left side of the editor. The maximum length of each
line before it is split can be specified using the Maximum Line Length field. Any line length can be used
but note that using very long lines may cause performance issues on some computers.

Press the Reset button to return all Text Editor Options to their default values.

Related Topics:
Editor Options
File Interface Options
Using the Text Editor
010 Editor v7.0 Manual - Windows Edition
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Hex Editor Options

The Hex Editor Options dialog controls options when using the Hex Editor Window (see Using the Hex Editor for
more information). Open the Hex Editor Options window by clicking 'Tools > Options...' and choosing Hex Editor
from the list.

Insert





Always Insert Blocks - By default, when a block is pasted into the current editor using 'Edit > Paste'
or Ctrl+V, two results are possible: The block will be inserted when in Insert mode, or written over the
current bytes when in Overwrite mode (see Using the Clipboard for details). When this toggle is
enabled, the block will always be inserted, regardless of the current mode.
Select Block After Paste - When this toggle is enabled and a block is pasted using 'Edit > Paste' or
Ctrl+V, the inserted bytes will be selected. If the toggle is disabled, no bytes will be selected.
Warn on Insert - Every time that data is inserted into a file (either using 'Edit > Paste' or typing in the
editor while in Insert mode), the Status Bar will show a warning message in orange that bytes were
inserted. If this toggle is turned off, just a regular message will be displayed in the Status Bar.

Delete
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Allow Delete in Overwrite Mode - When this toggle is turned on and the Delete key is pressed while
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the hex editor is in Overwrite mode, the current selection will be deleted from the file. If no selection is
made, the byte the cursor is on will be deleted. When this toggle is disabled no deletions will be allowed
in Overwrite mode and switch to Insert mode to delete bytes.

Highlighting



Highlight Current Byte - There are two possible areas in the Hex Editor Window: the left area, and
the right area. When the cursor is in one area, the current byte in the other area will be highlighted
gray by default. If the toggle is turned off, the byte will no longer be highlighted.
Highlight Modified Bytes - As changes are made to a file, the text in the Hex Editor will change to
orange to indicate where modifications were made. By turning this toggle off, modified bytes will be
displayed the same as unmodified bytes.

Separator


Separator Width - The Separator is a vertical line that separates the left and right editing areas in a
Hex Editor Window. Enter the width in pixels of the Separator in this field.

Addresses



Minimum Address Digits - Controls the minimum number of digits displayed for addresses on the left
side of the Hex Editor Window (see Using the Hex Editor). Usually the number of digits is 4 and expands
if the address is too large. Enter a value between 4 and 16 inclusive.
Show Colon In Addresses - If this toggle is enabled, colons are inserted into hexadecimal addresses
to divide the addresses into groups of 4 digits. If the toggle is disabled, no colons are displayed.

Template Variables




Highlight Variables - After a Binary Template has been run on a file (see Introduction to Templates
and Scripts and Working with Template Results), moving the mouse over the Hex Editor Window will
display brackets to indicate where the declared template variables exist. If this toggle is disabled, the
brackets will not be shown. The color of the brackets can be controlled from the Color Options dialog.
Show Variable Hints - After a Binary Template has been run on a file, positioning the mouse over the
Hex Editor Window where a template variable is defined will cause a hint to popup showing the value of
the template variable. Turn this toggle off to prevent the hint from displaying. See Working with
Template Results for more information.

The Reset button can be used to return all of the Hex Editor Options to their default values.

Related Topics:
Color Options
Introduction to Templates and Scripts
Using the Clipboard
Using the Hex Editor
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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File Interface Options

A File Interface includes all of the following options: Font, Addresses, Character Set, Linefeeds/Line Width,
Tabs/Whitespace, Addresses, Group By, Areas, Highlight, Division Lines, Ruler, and Endian (basically all options
in the top part of the View menu). Consult Working with File Interfaces for more information. Each file that is
loaded is assigned a File Interface from the File Interfaces list; however, different interfaces can be generated
and applied automatically to different files by file type. The File Interface Options dialog allows creating or
deleting interfaces for editing. Access this dialog by clicking the 'Tools > Options...' menu option and selecting
File Interfaces from the list, or by clicking 'View > Edit As > Edit File Interfaces...'.
A list of all available file interfaces is displayed at the top of the dialog. Clicking the New button will generate a
new file interface and you must specify whether you would like to create a text-based file interface or a hexbased file interface. Select an item from the list and click Delete to remove an interface. Clicking the up or down
arrows will change the position of the interface in the list.
After a file interface is selected from the list, options for that interface will be displayed in the File Interface
Options box. Enter a name for the interface in the Name field. This name will appear under the 'View > Edit As'
menu and the Edit As drop-down list in the File Bar above each editor. Clicking the Visible toggle provides any
easy way to show or hide the interface on the menu.
When a file is opened, it is automatically assigned an interface based on the Mask field. The file mask may
contain the characters '*' or '?' to indicate wildcards and is not case sensitive. For example, use '*.bmp' to match
all BMP files, or 'C:\temp\*.0??' to match all files under the temporary directory with an extension starting with
'0'. If multiple masks match a file, the last matching interface in the list will be applied to the file. Note that if no
file mask matches the file, 010 Editor will automatically try to detect the correct file interface to use (see Opening
Files in the Editor Options dialog for more options). 010 Editor can remember the last used File Interface for a file
so this method of applying File Interfaces only applies to files that have not been opened before in 010 Editor.
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If the Use Default toggle is enabled, the file interface uses either the default text editor font or the default hex
editor font from the Font Options dialog. If the Use Default toggle is disabled, a custom font can be set for the
interface by clicking the Font button and using the standard font dialog to select a font. If the file interface is for
a text-based file the Default Linefeeds drop-down list is used to choose which linefeeds to insert when a new file
is created using this File Interface. The linefeeds to choose depend upon which type of character set is chosen
with the Character Set option:





Unicode - Linefeed choices include DOS (CR+LF - 0x000D000A), UNIX (LF - 0x000A), Mac (CR 0x000D), NEL (0x0085), FF (0x000C), LS (0x2028), or PS (0x2029).
EBCDIC - Linefeed choices include DOS (CR+LF - 0x0D25), UNIX (LF - 0x25), or NEL (0x15).
All other Character Sets - Linefeed choices include DOS (CR+LF - 0x0D0A), UNIX (LF - 0x0A), or Mac
(CR - 0x0D).

If the file interface is for a hex-based file the Line Width drop-down list can be used to indicate Fixed Width or
Auto Width. When using Fixed Width mode the field to the right of the Line Width drop-down list is used to enter
the number of bytes per line. Choose the character set using the Character Set drop-down list and if the Add
BOM to New Files toggle is enabled, a Byte-Order Mark will be added to files when they are created (note that
Byte-Order Marks are only used for Unicode or UTF-8 files and see Byte-Order Marks for more information).
Options for the tabs can be controlled through the Tab Size, Indent Size and Insert Spaces fields. See Working
with File Interfaces for more information on tabs. If the Add To New Drop-Down Menu toggle is enabled, an entry
will be added to the 'File > New' menu and to the New drop-down menu which is accessed by clicking the small
arrow to the right of the New icon in the Tool Bar.
All created file interfaces can be accessed by clicking the 'View > Edit As' menu option or the Edit As drop-down
list in the File Bar above each editor. The 'View > Edit As > Create New File Interface' menu option provides any
easy way to generate a new file interface for a file type (see View Menu for more information).
The following File Interfaces are available by default:
















Text - used for editing text (ASCII) files.
Hex - used for editing hex (binary) files in hexadecimal notation (e.g. FF 3A).
Binary - used for editing hex (binary) files in binary notation (e.g. 00101001).
Script - used for editing an 010 Editor script file.
Template - used for editing an 010 Editor Binary Template.
EBCDIC - used for editing EBCDIC text files.
Unicode - used for editing Unicode text files.
UTF-8 - used for editing UTF-8 text files.
Drive - used for editing physical and logical drives.
Process - used for editing processes.
C/C++ - used for editing C/C++ source and header files.
HTML - used for editing webpages.
PHP - used for editing PHP code included on webpages.
XML - used for editing XML tagged files.

The Reset button will restore all file interfaces to their original values.

Related Topics:
Editor Options
Font Options
View Menu
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
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Color Options

The Color Options dialog allows control over many colors in the Editor Window (see Using the Text Editor and
Using the Hex Editor for more information). Open the Color Options dialog by clicking 'Tools > Options...' and
selecting Colors from the list.
Many of the color options have a Foreground color (Fore) and a Background color (Back) that are used when
drawing text on the screen. The Foreground color indicates the color of the text, and the background color
indicates the color of the background behind the text. Usually darker colors are used for the foreground and
lighter colors are used for the background.
Click on a color box to open up the Color Selector Box. Select a color from the box, or click the More Colors...
button to open the standard Color Selector Dialog. When using the Color Selector Dialog, select a color from
either the color boxes on the left or the color area on the right and click the OK button. Clicking the Add to
Custom Colors button adds the current color to the list of 16 colors on the bottom left. The Cancel button will
close the dialog without selecting a color. Some colors may be set to None, which means that the foreground or
background color will not be modified.
The following lists each of the color options and what they control:

Editor Colors
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Editor - Indicates the foreground and background colors of the main Editor Window. The default is
black text on a white background.
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Modified - When bytes are modified in the Hex Editor, the colors of those bytes are changed. By
default, the text color is changed to orange and the background color remains unchanged.
Selected - After selecting a set of bytes (see Selecting Bytes), the colors of those bytes are modified.
By default, the text color is changed to white and the background to blue.
Addresses - Specifies the color of the addresses along the left side of the Text Editor or Hex Editor
Window. By default, the text color is black and the background color is the window color.
Ruler/File Bar - Indicates the color of the ruler and the File Bar along the top of each Editor Window
(when enabled). By default, the foreground color is black and the background is the window color.
Highlighting - This highlighting color is used when highlighting a set of bytes using 'View >
Highlighting' (see Working with File Interfaces for more information).
Find - After clicking the Find All button in the Find Dialog (see Using Find), all occurrences in the file
that match the target are colored according to this rule.
Difference - After performing a comparison between two files (see Comparing Files), those bytes that
are different between the files will be colored. This option controls which color will be applied to the
bytes in the Hex Editor Window.
Only In - After a comparison between two files (see Comparing Files), bytes that are only in one file
and not the other will be colored according to this rule.
Input Method Editor - Some languages use an Input Method Editor (IME) to insert characters into the
Editor Window. When the IME is displayed, its color will be controlled by this option.
Find Selection Lock - When using the Find Bar or Replace Bar, it is possible to limit the Find or
Replace to a selected range of bytes. When a Find or Replace is locked to a selection by clicking the
Lock to Selection button in the Options dialog, the selection will then be drawn in this color until the
range is unlocked.
Show Whitespace - When Show Whitespace is enabled for a text file, special symbols are drawn in the
editor to indicate where space and tab characters exist. This option controls the color of the symbols
that are drawn.

The following colors are displayed on the right side of the dialog and only have a single color box:
















Alternating Hex Lines - When using the Hex Editor, alternating lines are displayed in a different color
(by default light blue). Change this color to match the Editor background color to obtain a single color in
the background.
Separator - The Separator is the line that separates the left area from the right area in a Hex Editor
Window. Click this color to change the Separator color. The default color is light gray.
Highlight Line - By default, the line the cursor is located on will be colored yellow. Click this color to
change to a different color. The Highlight Line option can be turned on or off (see Editor Options).
Highlight Byte - When the cursor is in the left or the right editing areas, the current byte will be
highlighted in the other editing area. The byte is colored light gray by default, but can be changed by
clicking the color box.
Highlight Variable - After a Template has been run on a file, moving the mouse over the Hex Editor
Window will cause brackets to display indicating where the template variables were declared (see
Working with Template Results). The color of the brackets can be modified by clicking this color box
(the default color is dark gray). The Highlight Variable option can be turned on or off using the Hex
Editor Options dialog.
Right Area - The color to the far right of both editing areas in the Hex Editor Window can be controlled
by clicking this color box. The default color is the color of the window.
Division Lines - Division Lines are lines that are drawn on the Hex Editor Window that indicate groups
of bytes. By default, Division Lines are drawn every 4 bytes and they are colored light gray. Use the
'View > Division Lines' menu to adjust the division lines (see Working with File Interfaces). Clicking this
color box allows changing the color of the Division Lines.
Sector Lines - Sector Lines are similar to Division Lines except they are usually used to visualize where
sectors are located on a drive. Sector Lines can be controlled on the same menu as Division Lines 'View
> Division Lines' (see Working with File Interfaces). The color of the sector lines can be changed from
the default dark gray using this color box.
Status Warning - If an error occurs when performing an operation, an error message is sometimes
displayed in the Status Bar. The background of the error message will be displayed as this color (by
default orange).
Ruler Column Marker - The color of the small arrow which indicates the current column in the Text
Editor Window ruler can be controlled with this option. The default color is gray.
Caret - This option controls the color of the caret (the blinking cursor) in either the Hex Editor or Text
Editor Window. The default color is black.

Clicking the Reset button will return all of the colors to their default values.
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Related Topics:
Comparing Files
Editor Options
Hex Editor Options
Selecting Bytes
Using Find
Using the Hex Editor
Using the Text Editor
Working with File Interfaces
Working with Template Results
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Font Options

The Font Options dialog allows setting a number of the different fonts used within 010 Editor. Open the Font
Options dialog by clicking 'Tools > Options...' on the main menu and selecting Fonts from the list. Click the
button to the right of each font description to set the font for that item using the standard font dialog. The
following fonts may be set using this dialog:









Default Text Editor Font - By default, all text files open in 010 Editor will use this font for editing;
however, different fonts can be assigned for editors by using File Interfaces and turning off the Use
Default toggle for the File Interface.
Default Hex Editor Font - By default, all hex files open in 010 Editor will use this font for editing. By
using File Interfaces, other fonts can be assigned to Editor Windows by turning off the Use Default
toggle.
Workspace Font - Allows changing the font for the Workspace.
Inspector Font - Sets the font for the Inspector.
Output Font - Sets the font for all tabs of the Output Window except the Output tab (see Output Panel
Font below). The Output Window displays the results from operations such as Find, Find in Files,
Compare, Histograms, Checksums, etc.
Output Panel Font - Controls the font used for the Output tab of the Output Window. This Output tab
displays results from running scripts or templates as well as any output from the Printf function.
Template Results Font - Sets which font to use in the Template Results panel below each editor.

Clicking the Reset button will restore all fonts to their default values.

Related Topics:
File Interface Options
Interface Functions
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Using the Inspector
Using the Workspace
Working with File Interfaces
Working with Template Results
010 Editor v7.0 Manual - Windows Edition
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Backup Options

The Backup Options controls the creation of backup files when a file is saved in the editor. Access the Backup
Options by clicking 'Tools > Options...' and selecting Backups from the list.
To enable the creation of backups, click the Backup File on Save toggle box. If the Backup toggle is set, the
Backup Size Limit lists the size limit in megabytes for automatically making backup files. For example, if the size
limit is 10 megabytes, then a backup will not be made when saving a file that is over 10 megabytes. The Backup
Directory field lists the directory where backups will be saved. If this field is blank, the backups will be saved in
the same directory where the file is located. Click the folder button beside the field to use a browse dialog to
select a directory.
A number of options exist for controlling the extension of the backup file. If the No Extension Change toggle is
selected, the backup file name will be the same as the original file name (this is only valid when a directory is
specified in the Backup Directory field). If the Append Extension toggle is set, an extension will be added to the
end of the file name when the backup is written. For example, if the original file was 'file.dat', the backup file will
be 'file.dat.bak'. To replace the file's extension with the backup extension, select the Replace Extension toggle.
For example, if the original file was 'file.dat', the backup file would be 'file.bak'. To change the backup extension,
enter a new extension into the Backup Extension field (without the period).
Note that backups will not be made when saving drives or processes.
Clicking Reset will return the backup options to their original values.

Related Topics:
010 Editor v7.0 Manual - Windows Edition
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Directory Options

The Directory Options dialog controls the location of various directories used in 010 Editor. To open the Directory
Options dialog click the 'Tools > Options...' menu option and select 'Directories' from the list.
010 Editor stores file data in a cache in memory which can be controlled using the Cache Options dialog. Once
too much data is loaded into the cache, data will be written to a swap file on disk. Enter the directory where the
swap file should be stored in the Swap Directory field. Click the folder button to use a dialog to select the swap
directory from a list. 010 Editor occasionally uses temporary files. Enter the directory where these files should be
stored in the Temp Directory field or click the folder button to select a directory with a dialog box.
The Script Directory field lists the default location where local scripts are assumed to exist on disk (this is used
for the ($SCRIPTDIR) variable in the Script Options). Similarly, the Template Directory field lists the default
directory where local templates are stored (this is equivalent to the ($TEMPLATEDIR) variable in the Template
Options).
The Script Repository Directory and Template Repository Directory fields control where Scripts and Templates are
placed when they are installed from the Repository (see Using the Repository Dialog). These directories can be
accessed using the constants ($SCRIPT_REPOS_DIR) or ($TEMPLATE_REPOS_DIR) in the Script Options or
Template Options dialogs.
Note that if the Script Directory, Template Directory, Script Repository Directory, or Template Repository
Directory fields are modified, you must physically move the script or template files to the new location otherwise
you may get a 'file not found' error when attempting to run a file.
Clicking Reset will return all directory options to the default values.
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Related Topics:
Cache Options
Script Options
Template Options
Using the Repository Dialog
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File Dialog Options

Use the File Dialog Options dialog to set the initial directory when opening a file dialog box. Click the 'Tools >
Options...' menu option and select 'File Dialogs' from the list to view this dialog.
The File Dialog Directories section of the dialog controls the initial directory when various file dialogs are opened
in the application (for example, when using 'File > Save As'). The Open File and Save File options control the
directory when opening a file or saving a file. Note that when saving a template or script, the initial directory is
controlled by the Save Template or Save Script options respectively. The Import File and Export File options
control the initial directories when importing/exporting hex data. When opening templates or scripts (for
example, by using 'Templates > Open Template' or 'Scripts > Open Script'), the initial file dialog directories are
controlled with the Open Template and Open Script options. For file dialogs used for opening files there are two
options:




Last Used Directory - The file dialog is opened in the application global last-used directory. This
directory is remembered from the last time a dialog was used to open or save a file which is set to use
the Last Used Directory option.
Last Used ??? Directory - where ??? is Open, Save, Import, Export, Template or Script. This option
allows the file dialog to use a last-used directory specific to that option and the application global lastused directory is not touched. For example, by default when opening or saving templates a special lastused templates directory is used instead of the global last-used directory.

When saving files two additional options are available:



Current File Location / Last Used Directory - If the file being saved contains a valid directory, the
file dialog is opened in that directory. If the file being saved does not contain a valid directory (for
example, when a file is first created), the file dialog is opened in the application global last-used
directory. To ignore the current file location when saving, click the drop-down list and select Last Used
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Directory.
Current File Location / Last Used ??? Directory - Similar to the Current File Location / Last Used
Directory option, if the file being saved contains a valid directory the file dialog will be opened in that
directory. If the file does not contain a directory it will be opened in a directory as described in the Last
Used ??? Directory option above. To ignore the current file location, select the Last Used ??? Directory
option from the list.

Clicking Reset will set all File Dialog options to their default values.

Related Topics:
Importing/Exporting Files
Introduction to the Data Engine
Opening Files
Saving Files
Script Basics
Template Basics
010 Editor v7.0 Manual - Windows Edition
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Keyboard Options

Keyboard Options allows customization of shortcut keys (also called hotkeys) for many of the operations in 010
Editor. Access the Keyboard Options by clicking the 'Tools > Options...' menu option and selecting Keyboard from
the list.
Select an action from the Actions list to edit the shortcut for that action. All actions are organized into categories
by which menu they exist under in the main application window. Double-click on the category name (e.g. File,
Edit, etc.) to show or hide all the actions in that category. The current shortcut key for each action is listed in the
Shortcut column.
After an action is selected from the list, click the Press Shortcut field and type the shortcut key on your keyboard
you would like to use for this action (for example, to use 'Ctrl+L' for a shortcut hold down the 'Ctrl' key and press
the 'L' key). Any action that has been modified will appear bold in the Actions list. Clicking the Clear Shortcut
button will remove any shortcut key from the selected action, and clicking the Reset Shortcut button will return
the action to its original shortcut as indicated by the Original Shortcut field. If the shortcut for the current action
is already in use by another action, the conflicting action name will be displayed below the Original Shortcut field.
Usually actions only have a single shortcut key but this dialog can be used to assign muliple shortcuts to the
same action by enabling the Allow Multiple toggle. For example, on Windows both 'Ctrl+C' and 'Ctrl+Ins' can be
used for the Copy command. When the Allow Multiple toggle is on, pressing a shortcut key in the Press Shortcut
field will add the shortcut to the field separated by a comma. When editing using this method, click the Clear
Shortcut button to remove the shortcuts from the list.
Clicking the Reset button will reset all shortcut keys to their original values. Click the List Shortcuts button to
display a dialog showing all shortcuts in the application sorted by the shortcut name. Any actions that have been
modified will be displayed as bold in the list. This dialog is also accessible by clicking the 'Help > View Shortcut
List' menu item. When the dialog is displayed from the Help menu an Edit button will be displayed at the bottom
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of the dialog and clicking this button will display the Keyboard options dialog.

Related Topics:
010 Editor v7.0 Manual - Windows Edition
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Program Options

The Program Options dialog allows adding custom programs on the Tools menu (see the Tools Menu for more
information). Click the 'Tools > Options...' menu option and select Programs from the list to view this dialog.
The upper area of the dialog contains a list of all custom programs available. Click the New button to add a new
program to the list, or select an item and click Delete to remove a program from the list. The up and down
arrows will change the order of items in the list.
After selecting a program from the list, the program's details will be shown in the Program Options box. The
Name field indicates the caption that will appear on the Tools menu and may contains an '&' to indicate the
default character. The Program field should contain the file name of the program to be run. Click the folder
button beside the Program field to use a file dialog box to select a file. The arguments for the program can be
specified in the Arguments field. The following special codes can be used in the argument list and will
automatically be replaced by the correct values:






File Name (%f) - Indicates the full path to the currently selected file. This is empty if no file is
currently open. If the file name contains a space, quotes will automatically be added around the file
name if necessary.
Cursor Position (%c) - Gives the address of the cursor in the file.
Selection Start (%s) - If a selection exists, gives the address of the first byte of the selection.
Selection Size (%z) - If a selection exists, gives the size of the selection.

Note that all positions and sizes are specified in decimal format but can be specified in hex format by enabling the
Hex Addresses toggle. Clicking the Insert button provides an easy way to insert different codes into the argument
list. A working directory can be specified for the program by entering a directory into the Working Dir field. Click
the folder button beside the field to use a directory browser to select the directory. Note that any environment
variables can be included in the fields by using the '$' symbol (for example: '($WINDIR)' ). The special symbol
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($PROGDIR) can be used to indicate the path where 010 Editor exists.
By default, the following custom programs are installed:




Windows Calculator... - Displays the standard Windows Calculator.
Windows Notepad... - Runs the standard Windows Notepad program with the currently loaded file.

Click the Reset button to restore all Program Options to the default values.

Related Topics:
Tools Menu
010 Editor v7.0 Manual - Windows Edition
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Highlight Options

Highlighting provide a way of coloring certain bytes or shorts in a file for identification (a short is a group of two
hex bytes). For example, with highlighting all of the bytes with values 128 to 255 could be colored to identify
non-ASCII bytes. The Highlight Options dialog can be accessed by clicking the 'Tools > Options...' menu option
and selecting Highlights from the list, or clicking 'View > Highlighting > Edit Highlights...'. Highlights can be
turned on or off by clicking on them in the 'View > Highlighting' menu. The enabled highlights are associated with
a File Interface (see Working with File Interfaces for more information).
All available highlights are displayed in a list at the top of the dialog. Click New to generate a new highlight, or
select an item in the list and click Delete to remove the highlight. Clicking the up or down arrows will change the
selected item's position in the list.
When a highlight is selected from the list, its details will be displayed in the Highlight Options box. The name
entered in the Name field will appear on any menu where the highlight will be accessed. If the Visible toggle is
turned off, the highlight rule will not appear on any menus. If the Method drop-down list indicates Highlight
Bytes, the Ranges field contains which byte values will be highlighted by this rule (values range from 0 to 255).
Enter a value in any of the available numeric formats (see Introduction to Number Systems). Multiple values can
be separated by the ',' character, or a range of values can be specified using '..'. For example, '0..31,127' will
highlight bytes 0 to 31 inclusive, and 127. If the Method drop-down list specifies Highlight Shorts, enter the
range of Shorts to highlight in the Ranges field (values range from 0 to 65535). Note that a Short is a group of
two hex bytes in a file and how the Shorts are interpreted depends upon the current Endian of the file. Use the
Highlight Shorts method when applying coloring rules to Unicode files.
The bytes in the current file that match this highlight rule will be colored. If the Use Default Highlight Color toggle
is enabled, the bytes are colored according to the Highlighting color in the Color Options dialog. If the Custom
Color toggle is enabled, the bytes are colored according to the Fore and Back color boxes. Using custom colors,
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multiple highlights can be turned on at the same time using different colors.
The following Highlight rules are available by default:






Linefeed Characters - 0x0d and 0x0a
Alphanumeric Characters - all letters and numbers
Control Characters - any of the bytes from 0 to 31 and byte 127
Non-ASCII Characters - any of the bytes from 128 to 255

Click the Reset button to restore all Highlight rules to their original values.

Related Topics:
Color Options
Introduction to Number Systems
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
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Syntax Options

The different Syntax Highlighting schemes in 010 Editor can be controlled using the Syntax Options dialog.
Access the Syntax Options dialog by clicking 'Tools > Options...' and selecting Syntax from the list of options.
A Syntax Highlight allows coloring of textual data according to a number of rules. When a rule is active, it applies
colors to the data using a Style. Syntax Highlighting is applied to a file using the 'View > Highlighting > Syntax
Highlighting' menu option. Note that the chosen Syntax Highlight is automatically remembered by the current File
Interface. By default, 010 Editor contains Syntax Highlights for C/C++, 010 Editor Scripts/Templates, HTML, PHP
and XML. 010 Editor also has File Interfaces which automatically apply the Syntax Highlights (for example, when
loading a file with extension .html, that file is assigned the File Interface 'HTML' which then applies the HTML
Syntax Highlight scheme).
The list of existing Syntax Highlights is located in a table at the top of the dialog. Create a new Syntax Highlight
by clicking the New button or remove a Syntax Highlight by selecting it from the list and then clicking the Delete
button. The Up and Down arrows beside the Syntax Highlight list can be used to reorder the Syntax Highlights.
Select a Syntax Highlight from the list to edit the name and the rules for that Highlight. Modify the name of the
Syntax Highlight using the Name text field. How the highlighting is applied depends upon the rules listed in the
Rules table. The rules are applied in order from top to bottom and the rules on top take precedence over the
rules beneath. Create a new rule by clicking the '+' icon or delete the selected rule by clicking the 'X' icon. Rules
can be moved up or down by clicking the Up and Down arrows above the Rules table.
Once a rule is selected in the Rules table, its details are displayed in the Rule Details area. The Rule Type dropdown list chooses how the rule is applied to characters and is discussed further below. Any text in a file that
matches this rule will be coloring according the style chosen using the Style drop-down list. Using styles means
that multiple rules can share the same style and see the Style Options dialog to edit the list of styles. Note that
an icon indicating the foreground (text) and background color of the style is displayed on the Style drop-down
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list. The Keywords table lists a set of keywords, one per line. How the keywords function depends upon the type
of rule being used:












Multi-Line Block - This is the most flexible rule within the syntax highlighting rules. When the first
keyword in the Keywords list is found in the file text, this rule is considered active. The rule will remain
active until the second keyword in the Keywords list is found. Each following pair of keywords in the
Keywords list can be used to indicate an alternate start and end keyword (i.e. the 1st, 3rd, 5th, etc.
keywords indicate the starting markers and the 2nd, 4th, 6th, etc. keywords indicate the end markers).
This rule can span multiple lines and can also be used as the parent rule for Sub-rules as discussed
below.
Single-Line Comment - If the text of the file matches any of the keywords in the list then this rule is
active until the end of the current line. For example, this rule can be used to implement C++-style line
comments with the keyword "//".
Keywords - When using this type of rule, if any of the words in the Keywords list match the text of the
file they will be colored according to the chosen style. For example, use this rule to color reserved words
in C++ such as 'if', 'for', 'while', etc.
Single-Line Block - This rule is considered active when the first keyword in the Keywords list is found
in the text of the file and will end when the second keyword in the list is found or the end of the line is
found. For example, use the keywords " and " to implement a regular single-line string. Multi-line
strings can be implemented with the Multi-Line Block rule above. Each following pair of keywords in the
Keywords list can be used as additional start and end delimiters for this rule.
C-Style String - Similar to the Single-Line Block rule type except this properly handles escaped quotes
(i.e. '\"') in strings as well as using '\' at the end of a line to create a multi-line string.
Tag Name - This rule is used when highlighting XML or HTML tags. The first word found is highlighted
according to this rule and the Keywords list is ignored.
Tag Attribute - This rule is used when highlighting XML or HTML tags. Every word found except the
first word is highlighted according to this rule. The Keywords list is ignored.
Regular Expression - If any of the regular expressions listed in the Keywords match text in the file,
the text will be coloring according to this rule. See Using Regular Expressions for more information on
regular expressions. For example, use a regular expression of '\b[0-9]+\b' to applying coloring to
numbers. Note that regular expressions that span multiple lines are currently not supported.

The use of Sub-rules is a powerful method of only applying syntax highlighting to parts of a file. A sub-rule
always has a parent rule and the sub-rule will only be applied when the parent rule is active. For example, this
could be used to apply PHP and Javascript highlighting to the same file, as long as there are delimiters indicating
where the different styles of code exist. Currently the parent rules can only be of the type Multi-Line Block but
any rule can be a sub-rule. To designate a rule as a sub-rule, first ensure it is located below a Multi-Line Block
rule in the Rules list and then enable the Sub-rule toggle button (the sub-rule will appear indented in the Rules
list). For example, in the PHP Syntax Highlight the PHP highlighting rules are not applied until the parent rule '<?'
'?>' is encountered which indicates a block of code.
Enabling the Ignore Case toggle at the bottom of the dialog means that the keywords are case independent.
Clicking the Reset button will restore all Syntax Highlights to their original values.

Importing and Exporting Syntax Highlights
The list of Syntax Highlights can be exported to a file by clicking the Export List... button. The exported file
contains all the syntax highlighting rules and styles and will have the extension ".1hl". To import a list click the
Import List... button and select a file. Next in the dialog that is displayed, select which Syntax Highlights to
import and click the Import > button. If a Syntax Highlight is imported which already exists, it will overwrite the
current rules for that Syntax Highlight. Any new styles contained in the file will be automatically added. If the
imported file contains styles which have the same name as an existing style but different colors, you will asked
whether to keep the original colors or accept the colors from the imported file.

Related Topics:
Style Options
View Menu
Using Regular Expressions
Working with File Interfaces
010 Editor v7.0 Manual - Windows Edition
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Style Options

Use the Style Options dialog to control the color scheme for all of the Syntax Highlighting Rules. Open the Style
Options dialog by clicking the 'Tools > Options...' menu option and selecting Styles from the list.
The use of styles allows multiple Syntax Highlighting Rules to share a single color scheme (see Syntax Options to
control the Syntax Highlighting Rules). For example, both commenting in C++ and PHP share the 'code-comment'
style. Changing the 'code-comment' style affects the colors of all rules that use that style. All styles that begin
with 'code-' are typically used in programming languages while all styles that being with 'tag-' are used in tagbased (e.g. XML, HTML) languages. The 'none' style can be used to apply no coloring to a rule.
A list of available styles is located in a table at the top of the dialog. After a style has been selected from the list,
the style name can be changed using the Name field. Change the foreground (text) color of the style by clicking
the Fore color box and selecting a color using the Color Selector Box. The background color of the style can also
be changed by clicking the Back color box and selecting a color.
Additional styles can be created by clicking the New button and styles can be removed by clicking the Delete
button. Note that if a style is in use by a Syntax Highlighting Rule is deleted, the style will remain in the Syntax
Highlighting Rule until the rule is changed. Clicking the Up or Down icons will rearrange the styles in the list. Note
that styles are exported automatically when the list of Syntax Highlighting Rules is exporting using the Syntax
Options dialog.
Click the Reset button to restore all styles to their original settings.

Related Topics:
Syntax Options
View Menu
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Compiling Options

The Compiling Options dialog is used to control some options for running scripts and templates. For more
information about compiling see Running Templates and Scripts. The Compiling Options dialog can be accessed
by clicking the 'Tools > Options...' menu item and selecting 'Compiling'.
The Compile Options group controls how both scripts and templates are run. If the Show Warnings toggle is
enabled, any warnings generated during compilation will be displayed in the Output tab of the Output Window. If
the toggle is disabled no warnings will be displayed. If the Auto Show Output Panel for Scripts toggle is enabled
and a script calls the Printf function to display data, the Output tab of the Output Window will automatically be
displayed. If this toggle is disabled, the Output Window will not automatically be shown but can be accessed by
the 'View > Output' menu option. Similarly the Auto Show Output Panel for Templates controls whether the
Output Window is automatically shown when Printf is called in a template.
By default, when a script or template is loaded in 010 Editor it is displayed in the Floating Tab Group (see Using
File Tabs) for more information. Scripts and templates can also be loaded in the main tab group by enabling the
Main Interface toggle.
The Includes field contains a list of all directories to be searched when a file is included using the #include
command in a template or script (see the Includes help topic for more information). Enter all directories to be
searched separated by spaces in the Includes field. If a directory contains spaces, place double quotes around the
directory in the field. Clicking the Browse button with the '+' symbol will allow adding a directory to the list using
a standard directory select dialog. To control the directories where Scripts or Templates are stored see the
Directory Options dialog.
Click the Reset button to reset all options to their original values.
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Related Topics:
Directory Options
Includes
Running Templates and Scripts
Script Options
Template Options
Using File Tabs
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Script Options

The Script Options dialog lists all Scripts that have been installed, either from the local drive or from the 010
Editor Repository. Installed Scripts are listed on the main application Scripts menu and can be set to run on
startup or shutdown or when certain files are loaded. Click 'Tools > Options...' and select Scripts from the list, or
click the 'Scripts > View Installed Scripts...' menu option to view the Script Options dialog.
A list of scripts is contained in the upper portion of the dialog displayed in the format 'Category > Script Name'.
Click the Add button to add a Script from the local drive into the list (note that multiple scripts can be added at
the same time using the file dialog that is displayed). Select a script and click Delete to remove the script from
the list (the file is not deleted from disk). The up or down arrows can be used to change the order of the scripts
in the list.
Selecting a script will show its attributes in the Script Options box. Enter a name for the script in the Name field.
This name will appear on the main Scripts menu (see the Scripts Menu) listed under the given Category. If the
Category is empty the Script will be listed near the top of the Scripts menu. Turning off the Visible toggle
provides an easy way to hide a script from the menu without having to delete it. Enter the script file name in the
File Name field. Scripts usually have the extension '.1sc' and are very similar to C files. Click the folder button
beside the field to select a script using a file dialog box or press the Edit button to close the Options dialog and
view the view in the editor.
If a mask is entered in the File Mask field the script will automatically be loaded when a file is opened that
matches this mask. File masks may contain the characters '*' and '?' to specify wildcards and multiple masks may
be separated by commas. If a value is given in the ID Bytes field then the Script will not be loaded unless the File
Mask matches the file name and the ID Bytes match the bytes at the beginning of the file (see Template Options
for more information on the ID Bytes). If the selected Script has been installed from the Repository then the
version number will be listed in the Status field. Clicking the Show button will hide this dialog and display
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information about the script in the Repository Dialog.
If the Run on Load toggle is set, the script will automatically be run when it is loaded. Note that if a template is
set to load automatically for the same file, the template will be loaded and run before the script. If the Show
Editor on Load toggle is set, the script will be opened for editing in the interface. Enabling the Run on Startup
toggle causes the script to be run when 010 Editor is started. The script can also be run while 010 Editor is
closing by enabling the Run on Shutdown toggle.
The following scripts are available by default:







JoinFile - Combines a number of smaller files created with the SplitFile script into one large file. The
files to join must contain an order number in their filename (for example, file0000.dat, file0001.dat,
etc).
Randomize - Randomizes the current selection. Allows setting a minimum and maximum byte value.
SplitFile - Splits a large file into a number of smaller files (for example, file.dat could be split into
file.dat.001, file.dat.002, etc). The size of each file to create can be specified when running the script.
MultiplePaste - Allows data on the clipboard to be pasted multiple times.
IsASCII - Reports whether the current file contains only ASCII characters.

The Set Shortcut button can be used to set a shortcut key for the selected script using the Keyboard Options
dialog. Click the Reset button to restore all scripts to their default values.

Importing and Exporting Lists of Scripts
The Script Options dialog can export a list of scripts to a file and this list can then be imported into another copy
of 010 Editor. The list of scripts can be exporting by clicking the Export List... button. Select the file to write using
the standard file dialog and the exported script list will have the extension ".1sl". Lists can also be imported by
clicking the Import List... button. Exporting and importing scripts works the same way as exporting or importing
templates. See the Template Options dialog for more information about exporting and importing using and the
Import Script List dialog.

Related Topics:
Introduction to Templates and Scripts
Introduction to the Repository
Template Options
Scripts Menu
Using the Repository Dialog
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Template Options

The Template Options dialog lists all Binary Templates that have been installed, either from the local drive or
from the 010 Editor Repository. When a Template is installed it is listed on the main Templates menu and can be
set to automatically run when certain files are opened. Access the Template Options dialog by clicking the 'Tools
> Options...' menu item and selecting Templates, or by clicking 'Templates > View Installed Templates...'.
The upper part of the dialog contains a list of templates displayed in the format 'Category > Template Name'.
New templates can be added from the local drive by clicking Add and selecting a template file (note that multiple
templates can be added at the same time using the file dialog that is displayed and information such as the
Category, File Mask and ID Bytes will be extracted from the file comments). Remove a template from the list by
selecting an item and clicking Delete (the file will not be deleted on disk). Click the up or down arrows to arrange
the templates in the list.
When a template is selected from the list its attributes are displayed in the Template Options box. Enter a name
for the template in the Name field. This name will appear on the Templates Menu listed by Category. If the
Category is empty the template will be displayed near the top of the Templates menu. Disabling the Visible toggle
allows the template to be hidden from the menu without deleting it. Enter the file name for the template in the
File Name field and Binary Templates usually have the extension '.bt'. The folder button beside the File Name
field can be used to select a template using a file dialog box. Press the Edit button to close the Options dialog and
view the file in the editor.
The File Mask and ID Bytes fields indicate which data files this template can parse. The File Mask field matches
the file name of a file and can use the wildcard characters '*' (zero or more matches) or '?' (exactly one match)
and can use the comma character to separate multiple masks. For example the File Mask "*.o,?.dylib" would
match either "test.o" or "a.dylib". The ID Bytes indicates a set of bytes at the beginning of the data file that the
file must contain before the Template is loaded. The bytes are listed in hex notation and the '//' characters
indicate the start of a comment which is ignored when matching bytes. The special notation [+DDD] or
[+0xHHH] can be used where DDD is a decimal number or HHH is a hex number to skip over bytes in the file. For
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example the ID Bytes '00 [+4] FF' means the data file must have a '00' byte at the beginning of the file and a 'FF'
byte at position 5. Currently only the first 1024 bytes in the file are matched against the ID Bytes. If ID Bytes is
empty or the Require toggle is unchecked then only the File Mask will be used.
If the template has been installed from the 010 Editor Repository then the Status field lists the version that was
installed. Clicking the Show button will hide this dialog and display the Template information in the Repository
Dialog. If the Run on Load toggle is enabled, this template will be run automatically when it is loaded. When the
Show Editor on Load toggle is set, the template will be opened for editing in the interface.
The following templates are installed by default:





ZIP - Template used to parse ZIP archives. Loads the 'ZIP.bt' file.
WAV - Template used to parse a WAV sound file. Loads the 'WAV.bt' file.
BMP - Template used to parse bitmap files. Loads the 'BMP.bt' file.

Click the Set Shortcut button to jump to the Keyboard Options dialog to set a shortcut key for the selected
template. The Reset button can be used to reset all templates to their original values.

Importing and Exporting Lists of Templates
The Template Options dialog can be used to export the current list of templates so that they may be importing
into another copy of 010 Editor. To export the current list of templates click the Export List... button at the
bottom right corner of the dialog. Choose the location to save the template list using the standard file dialog.
Exported template lists contain two things: the list of Template Records (all the information displayed in the
Template Options group) plus the actual template files. Exported template lists have the extension ".1tl".
To import an existing template list click the Import List... button. Choose a template list to import and the Import
Template List dialog will be displayed.

Choose which templates to import from the list at the top of the dialog. If the Import Template Records toggle is
selected, all the template records are read (a template record includes all information in the Template Options
area of the main Options dialog). By default any existing template records are not modified but they may be
overwritten by enabling the Overwrite Existing Records toggle. If the file to import contains the actual template
files (the text 'includes files' should appear beside the template name in the list), then the actual template files
can be written to disk. Enable Import Template Files to write the files to disk and enable the Overwrite Existing
Files option to overwrite template files on disk. By default the template will be written to the same directory
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where it was exported from but if that directory does not exist on this machine, enable the Use Directory toggle
and choose which directory to place all the template files.
Clicking the Import button will perform the import and will display a Results text area with information about the
import. If any errors occurred while writing files, the errors will be displayed in the Results. Click the Close or
Cancel button to dismiss the dialog. This dialog works the same way as the Import Script List dialog except the
dialog operates on templates instead of scripts.

Related Topics:
Introduction to Templates and Scripts
Introduction to the Repository
Templates Menu
Using the Repository Dialog
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Repository Options

Use the Repository Options dialog to control some settings of the 010 Editor Repository. Access the Repository
Options dialog by clicking the 'Tools > Options...' menu item and selecting Repository from the list. Many of these
options are also available in the Status tab of the Repository Dialog.
010 Editor periodically downloads updates from the online Template and Script Repository. Set the number of
days between updates using the Check for Updates Every field or turn off updates by unchecked the Check for
Updates Every toggle. See Updating the Repository for more information about when updates are downloaded.
Clicking the Check Status button hides this dialog and displays the Status tab of the Repository Dialog.
When opening a file in 010 Editor and a template is found in the Repository which can parse the file, a dialog
asking to install the template is displayed. To disable checking files when they are opened uncheck the Ask to
Install Templates when Opening Files toggle and see Installing Files on Open from the Repository for more
information.
The 010 Editor Repository contains Templates and Scripts that have been uploaded by 3rd parties. To install files
from the Repository you must agree to the Terms of Using the 010 Editor Repository and to upload files to the
Repository you must agree to the Terms of Submitting Files to the 010 Editor Repository. These terms can be
viewed by clicking the Terms labels and check the I Agree toggles to signify that you agree to these terms. If you
do not agree to these terms you will not be able to download or upload files to the Repository.
Click the Reset button to set all Repository options to their original values.

Related Topics:
Installing Files on Open from the Repository
Introduction to the Repository
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Updating the Repository
Using the Repository Dialog
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Permission Options

A Binary Template usually only reads data from one file at a time and cannot modify any files; however, it is
sometimes useful to have a Binary Template read from or write to another file (for example, if a dataset is split
across multiple files or to write log files). Templates must be granted permission to read from or write to other
files and these permissions can be controlled with the Permission Options dialog, as accessed by clicking 'Tools >
Options...' on the menu and selecting Permissions from the list. As one exception, a Template is allowed to create
a new file with the FileNew function and write to that file without special permissions (using FPrintf for example),
but to save the file to disk the Template must have write permissions.
If the Global Permissions are set to Ask for permission when Templates read or write other files, when a Template
attempts to open a file (see FileOpen) the user will be asked to grant read permissions (see the figure below) and
if any of the write functions or FileSave is used on a file, the user will be asked to grant write permissions. If the
Global Permissions are set to Ask for permissions when Templates read other files, deny when writing files, the
user will be asked to grant permissions when attempting to read other files but will automatically be denied when
writing to files (the Write Other column will have no effect in the Template Permissions section below). If Global
Permissions are set to Deny Templates from reading or writing other files then all read and write operations to
other files will automatically be denied and the Template Permissions table below will be ignored.

When no permissions exist for a Template or the permissions are set to Ask and a Template attempts to read
from or write to another file, a dialog box such as in the figure above will be displayed. Clicking Allow or Deny will
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create an entry in the Template Permissions table as explained below. If the operation is denied the Template will
be stopped. Clicking Deny All when attempting to read from a file will set the Global Permissions to Deny
Templates from reading or writing other files and deny all further read and write operations. Clicking Deny All
when attempting to write to a file will set the Global Permissions to Ask for permissions when Templates read
other files, deny when writing files and deny all further write operations to other files. Clicking the Cancel button
will stop Template execution.
The Template Permissions table at the bottom of the Permission Options dialog display any permissions that were
allowed or denied for individual Templates. Additional permissions can be set by clicking the New button and
choosing a Template in the standard file dialog box that is displayed. By default, the permissions are set to Ask
for ReadOther and WriteOther but can be changed to Allow or Deny by clicking on a permission and using the
drop-down list to select a new value. Click the Delete button to remove a permission or the up and down arrows
to reorder permissions.
A special warning is displayed when a Template that is installed from the public Repository asks for permission to
read or write to other files. Typically these Templates should be denied but only grant permissions to read or
write if you understand what the Template is doing and why it needs special access.
Clicking the Reset button removes all Template Permissions and resets the global permissions to ask for
permission for reading or writing.

Related Topics:
Interface Functions
Introduction to Templates and Scripts
Introduction to the Repository
I/O Functions
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Importing Options

The Importing Options dialog controls various options when importing files using the 'File > Import Hex...' menu
option (see Importing/Exporting Files for more information). Open the Importing Options window by clicking
'Tools > Options...' and selecting Importing from the list.
When importing data, some formats (such as Intel Hex or Motorola S-Records) may skip over some bytes. By
default, the skipped bytes are assigned the byte value zero, but a different value can be specified by entering a
number between 0 and 256 in the Default Import Byte field.
In some Intel Hex files, the addresses are given in terms of Words instead of Bytes. 010 Editor handles these
files by converting the Word-based addresses to Byte-based addresses by multiplying them by two. Click the
Words toggle in the Intel Hex Address Format area to perform the conversion on Import, or click the Bytes toggle
to leave the addresses unmodified. Addresses can be converted to Word-based when exporting via the Export
Options dialog (see Importing/Exporting Files).
When dragging and dropping Intel Hex or Motorola S-Record files from the Windows Explorer onto 010 Editor, the
files are automatically imported. To disable auto-importing and just display the original files, uncheck either the
Auto-Import Intel Hex Files on Drag and Drop option or the Auto-Import Motorola Files on Drag and Drop option.
Clicking the Reset button restores all Importing options to their default values.

Related Topics:
Importing/Exporting Files
010 Editor v7.0 Manual - Windows Edition
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Inspector Options

Use the Inspector Options dialog to control how the Inspector operates. View the Inspector Options window using
'Tools > Options...' and selecting Inspector from the list or by right-clicking on the Auto Inspector and choosing
Customize....
The Auto tab of the Inspector allows interpreting binary data in a file in a number of different formats. If the Use
Built-in Auto Inspector toggle is enabled then the normal list of data types will appear in the Auto Inspector;
however, to modify which data types are displayed enable the Use Custom Template option. The custom
Inspector usually uses the file 'Inspector.bt' which comes included with 010 Editor (if this file does not exist it will
be created when clicking OK or Edit). A different Inspector template can be chosen by clicking the Browse button
to the right of the text file and selecting a template. Clicking the Edit button will close the Options dialog and
open the Template for editing.
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When editing the 'Inspector.bt' file, each variable is defined to start at the current cursor position or at the start
of the current selection, if a selection exists. Variables are defined this way by including the statement 'FSeek(
pos );' before each variable definition. The different data types of the Inspector may be modifying by reordering
or deleting the lines in the 'Inspector.bt' file. Additionally, other data types including structs or unions may be
added using any of the regular techniques for writing templates (see Introduction to Templates and Scripts) but
ensure the statement 'FSeek( pos );' exists before each variable. Even custom data types can be added to the
Inspector file using Custom Variables. Every time the cursor position is moved in a file, the 'Inspector.bt' file will
be rerun to move the variables to their new position.
Click the Reset button to restore the Inspector options to their default values. If the 'Inspector.bt' file has been
modified, when the Reset button is clicked you will be asked if you wish to delete all modifications and return to
the original 'Inspector.bt' file.

Related Topics:
Custom Variables
Introduction to Templates and Scripts
Using the Inspector
010 Editor v7.0 Manual - Windows Edition
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Toolbar Options

The Toolbar Options dialog is used to to control which operations appear in the application Toolbars (see Using
Tool Bars for more information). Open the Toolbar Options dialog by clicking 'Tools > Options...' and selecting
Toolbars from the list or by right-clicking on a Toolbar and selecting Customize....
All available actions that can be added to Toolbars are located in the Actions list. The actions are sorted into
categories and double-click a category name (e.g. File, Edit, etc.) to view all actions in that category. To add an
action to a toolbar click the action in the list and while holding the mouse button down, move the mouse over the
Toolbars list until a red line indicates the position to insert the action (see 1 below). Releasing the mouse will
insert the action at the chosen location (see 2 below). Note that if no icon is associated with an action, a text
label will be inserted into the Toolbar. Actions can also be moved within Toolbars by clicking an action in a
Toolbar and dragging the action to a new position while the mouse button is pressed.
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To remove an action from a Toolbar, click the action in the Toolbar and with the mouse button pressed down,
drag the mouse out of the window (see 1 below) until the mouse cursor changes to a circle with a slash or an X.
Then release the mouse button to delete the action (see 2 below).

To create a new Toolbar in the list, click the New button and enter the name of the Toolbar in the dialog that is
displayed. The name of each Toolbar is displayed in the Toolbars list and also in the 'View > Tool Bars' menu. A
Toolbar name can be changed by clicking a Toolbar in the Toolbars list and then clicking the Rename button.
Toolbars can also be deleted by selecting a Toolbar and then clicking the Delete button. Note that the original list
of Toolbars cannot be deleted or renamed, only Toolbars that have been created using the New button.
Click the Reset button to restore all Toolbars to their original list of actions and delete any custom created
Toolbars.

Related Topics:
Using Tool Bars
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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Menu Options

Menus in 010 Editor can be customized using the Menu Options dialog. Access the Menu Options by clicking 'Tools
> Options...' and choosing Menus from the list or by right-clicking on a Text Editor or Hex Editor window and
choosing Customize... from the right-click menu.
All actions which can be placed on menus are located in the Actions tree. The actions are sorted into categories
and double-clicking on a category name will show all actions in that category (e.g. File, Edit etc). Currently only
the Editor Right-Click Menu can be customized (see Using the Text Editor or Using the Hex Editor) but other
menus will be added in the future. To add actions to the right-click menu first locate an action to add in the
Actions tree. Next click the action and with the mouse button pressed, drag the action onto the Editor Right-Click
Menu and a red line will indicate the insertion point (see 1 below). Releasing the mouse button will add the action
to the menu (see 2 below).
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To delete an action from the menu, click the action name in the Menus area and then with the mouse button
pressed down, drag the mouse out of the window (see 1 below) until the mouse cursor turns into a circle with a
slash or an X. Release the mouse button to delete the action (see 2 below). Note that actions can also be
dragged within a menu by clicking and dragging an action name in the Menus tree.

Two special items exist at the bottom of the Actions tree: Separator and Submenu. Dragging and dropping a
Separator onto a menu will insert a horizontal line into the menu. Dragging and dropping a Submenu will add a
new menu item that can function as a container for other actions. Submenu items have no action of their own but
actions can be dragged into a submenu. When dragging and dropping an action onto a submenu, the regular red
insertion line will turn into a red box around the submenu. Submenu items that contain children can be opened
by clicking the icon to the left of the submenu name. To change the name of submenu double-click the submenu
name, enter a new name, and then press the Enter key. When dragging a submenu item to a new location, all
the children of the submenu will be moved as well.
Click the Reset button to restore the menu to its original state.

Related Topics:
Using the Hex Editor
Using the Text Editor
010 Editor v7.0 Manual - Windows Edition
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Cache Options

010 Editor features a powerful data engine that enables loading huge files and cutting and pasting large blocks of
memory very quickly (see Introduction to the Data Engine for more information). The Cache Options dialog
controls various options of the data engine. Open the Cache Options dialog by clicking the 'Tools > Options...'
menu option and selecting 'Cache' from the list.
When accessing files, data that is loaded into memory is stored in a cache. The size of the cache can be specified
using the Memory Limit options. Select the MB toggle and enter the cache limit in number of megabytes.
Alternately, select the % of Physical Memory toggle and enter the percentage of physical memory that should be
used for the cache (between 1 and 100). Note that physical memory does not include any system virtual memory
(using the Windows swap file). Once too much data is loaded into the cache, data will be written to a swap file on
disk and see the Directory Options dialog to control where the swap file is written.
Clicking Reset will return all cache options to their default values.

Related Topics:
Directory Options
Introduction to the Data Engine
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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How to Buy 010 Editor
Thank you for considering purchasing 010 Editor. We are committed to providing a top-quality, professional
text/hex/disk editor with a full set of powerful editing tools.
After using this program for 30 days, you must purchase a license to continue using the software. Licenses can
be purchased using all major credit cards, cheque, PayPal, fax, or phone. To purchase, click 'Tools > Register...'
and click the Purchase a license of 010 Editor link in the Register dialog, or click the 'Help > Buy Now...' menu
option. You may also directly visit 'http://www.sweetscape.com/store/' with any web browser. Once at the
website, follow the on screen instructions to complete your purchase. All purchases are secure and backed by a
60-day money-back guarantee.

Register Dialog

After your purchase you will receive a license password that must be entered in the Register dialog. This dialog
automatically displays if your evaluation period has ended, or can be accessed on the menu from 'Tools >
Register...' or from the Welcome dialog. The following is a list of the fields in the Register dialog:






Status - Lists the current registration status of the program. This will say 'Registered' if the program
has been successfully registered or 'Evaluation Period Expired' if your 30 day trial has ended. If still
within the evaluation period, this field will display the number of days left. The status may also display
'Upgrade Required' if the license you entered is for an earlier version of 010 Editor (see below).
Name - Enter your name exactly as you entered it when purchasing the product. Your password will
only work for your name.
Password - Enter the password that was emailed to you when you purchased the product.

Clicking the Check License button will test if your entered name and password are valid. If you experience any
problems, please visit 'http://www.sweetscape.com/support/'. A number of links are also available at the bottom

298

Copyright © 2003-2016 SweetScape Software

010 Editor - Reference Manual

of the dialog:






Purchase a license of 010 Editor - Visits the online store where you can purchase a license of 010
Editor.
Purchase an extension to support/maintenance - If your support/maintenance period has expired
(see the Support/Maintenance information below), clicking this link allows you to purchase an extension
to your maintenance so you can continue to have access to support and free upgrades for 010 Editor.
I lost my license code - Retrieves a lost license using our webpage
'http://www.sweetscape.com/010editor/retrieve_password.html'. You will be required to enter the email address used to purchase 010 Editor.
Remove my license from this machine - Removes the current license from this computer. Warning:
If you remove your license you will no longer to be able to use this software until you enter another
valid license.

Below the list of links is the Support/Maintenance expiration date (this is displayed only after a valid license is
entered). After purchasing 010 Editor, you are entitled to free support and maintenance (maintenance includes
access to all patches and new versions of the software) and free Repository updates for a certain amount of time
after your purchase, usually one year. This section of the dialog lists the date that support and maintenance
expires and will display the text EXPIRED if the date has already passed. If a new version of 010 Editor is
released and your support/maintenance is not expired, you may upgrade to the new version for free. See
Updating the Repository for more information about your license and Repository updates.

Upgrading a License

If the license you have entered is for a previous version of 010 Editor, you will be presented with the upgrade
dialog as shown above (some variations may exist in the dialog depending upon what type of license is entered).
You may use the software free for 30 days but after that time you will need to enter an upgraded license to
continue using the software. In addition to the usual links at the bottom of the dialog the following links may be
displayed:



Purchase an upgrade for 010 Editor - If you are not eligible for a free upgrade you will need to
purchase an upgrade to continue using the software. Click the Purchase an upgrade for 010 Editor link
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to visit our online store or visit the webpage 'http://www.sweetscape.com/store/'.
If you have any questions please contact us by visiting 'http://www.sweetscape.com/support/'. Thank you!

Related Topics:
How to Get Support
Updating the Repository
010 Editor v7.0 Manual - Windows Edition
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How To Get Support
At SweetScape, we are committed to providing quality, bug-free software. If you experience any problems with
our software or find any bugs, please don't hesitate to email 'support@sweetscape.com' with a detailed
description of your problem. Be sure to include which operating system you are running and the current version
of 010 Editor (found in the 'Help > About' dialog box). Alternately, an email can be sent by clicking the 'Help >
Support by E-mail...' menu option.
Support can also be obtained by visiting our website at 'http://www.sweetscape.com/support/'. This page
contains a list of frequently asked questions and articles stored in a searchable knowledgebase that might solve
your problem. The support website can be accessed by clicking the 'Help > Support on the Web...' menu option.
If you have any other inquires, comments, ideas, or suggestions on things you would like 010 Editor to do, you
can email 'feedback@sweetscape.com'. We want to hear from you!

Related Topics:
How to Buy 010 Editor
010 Editor v7.0 Manual - Windows Edition
Copyright © 2003-2016 SweetScape Software - www.sweetscape.com
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License Agreement
The following is the end-user license agreement (EULA) to which you agreed while installing 010 Editor:

SWEETSCAPE SOFTWARE
SOFTWARE LICENSE AND LIMITED WARRANTY AGREEMENT
Notice: You should carefully read this Software License and Limited Warranty Agreement before continuing to
install this program. By installing, downloading, copying, or otherwise using this software package ("Software"),
you agree to all the terms and conditions of the Software License and Limited Warranty Agreement. You must
indicate your agreement to be bound by the terms of this agreement by clicking the 'I accept the agreement'
button on the Software License Agreement page during the installation process. If you do not agree with the
terms of this license, do not continue this installation or otherwise use the Software. You may delete the
downloaded Software or return it within 60 days, with any accompanying documentation or other components
and a copy of your invoice to the place of purchase. You will be reimbursed or credited in accordance with the
current policy of SweetScape Software or the representative from whom you acquired the Software.
COPYRIGHT: This software product is protected by copyright laws and international copyright treaties, as well as
other intellectual property laws and treaties. All title and copyrights in and to the software product (including but
not limited to any programs, images, text, or documentation incorporated into the Software) are owned by
SweetScape Software. Purchase of this license does not transfer any right, title or interest in the software to you
except as specifically set forth in this agreement. Except as permitted by such license, no part of the
accompanying documentation may be reproduced, stored in a retrieval system, or transmitted, in any form or by
any means, electronic, mechanical, recording, or otherwise, without the prior written permission of SweetScape
Software.
GRANT OF LICENSE: Subject to the condition that you have paid the license fee and are in compliance with the
terms of this agreement, SweetScape Software grants you and only you a non-exclusive license to install and use
this Software simultaneously on multiple computers running any of the supported operating systems. No other
use, copying, or distribution of the Software product is allowed. If more than one user wishes to operate this
Software, a separate License and fee is required for each user. You may not rent the Software nor may you offer
use of it to others through any service provider. If you have purchased a Home/Academic License you may not,
either directly or indirectly, use this Software for commercial purposes (commercial purposes may include but are
not limited to any money-making activity) unless you are a member of a registered non-profit organization. Also,
a Home/Academic license may not be used at any government or military organization. If you have purchased a
Commercial License, this Software may be used for any commercial purposes. Alternately, a Site License may be
purchased that allows any employee of the licensed business to use the Software on any machine. If you are
installing this Software package as an upgrade or enhancement of a previous release of the same Software that
was installed on the same computer, your rights under the prior license agreement are terminated and you are
now bound solely under the terms of this license agreement.
LIMITATIONS: You may not reverse engineer, disassemble, or decompile this Software product. This Software is
licensed as a single product and its components may not be separated for use on more than one computer. You
may not modify, amend, adapt, translate, or create any derivative works based on, the Software or the provided
documentation.
TERM: If the Software was distributed to you as an EVALUATION VERSION, the license granted under this
agreement commences upon the installation of the Software and is effective for 30 days following the date you
install the Software. Evaluation Version Software may include program code to disable their functionality after the
expiration of the evaluation term. You may take no actions to circumvent the operation of such code, and you
accept all risks that might arise from such disabling code. If you do attempt to disable this code, through
backwards engineering or changing the system date, SweetScape Software reserves the right to immediately end
your evaluation period. If the Software was not distributed as an Evaluation Version, or you converted an
Evaluation Version to the Full-License Version by registering the Software, this agreement is effective until
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terminated by the terms of this agreement.
TERMINATION: Upon the expiration of the Evaluation Period (if any), your rights under this agreement will
terminate automatically without notice from SweetScape Software. This agreement may also be terminated (a)
by you, by returning the original Software and accompanying documentation, or (b) by SweetScape Software
upon your breach of any of the provisions of this agreement. Upon termination of your rights under this
agreement for any reason, you must destroy all copies of the Software and all components (including
documentation) in your possession.
TRANSFER: You may permanently transfer all of your rights under this agreement to another individual, provided
you retain no copies, you transfer all copies of the Software (including all component parts, and documentation),
and the recipient agrees to be subject to the terms of this agreement. Upon the occurrence of such a transfer,
your rights under this agreement terminate immediately.
LIMITED WARRANTY: SweetScape Software warrants to you (and only you) that the Software will perform
substantially in accordance with the accompanying documentation (if any) for a period of (90) days from the date
of original purchase from an authorized retailer or directly from SweetScape Software (or the date you obtained
authorization from SweetScape to convert an Evaluation version product to a Full-License product). Implied
warranties on the Software, to the extent required by applicable law, are limited to ninety (90) days from the
purchase date. The Limited Warranty is void if failure of the Software has resulted from accident, abuse,
misapplication, use of the Software other than described in the documentation, use of the Software in
combination with other products that are not described as compatible in the documentation, or your breach of the
terms of this agreement. No individual and no reseller or retailer has any authority to amend or add to any of the
above representations and disclaimers.
CUSTOMER REMEDY: Your exclusive remedy for any breach of the Limited Warranty is for you to send notice of
the breach by returning to SweetScape Software a copy of your purchase receipt for your copy of the Software
and a description of the alleged breach. Then, at SweetScape's option, SweetScape shall either: (a) terminate the
license agreement and refund the license fee upon return of the Software and accompanying documentation or
(b) repair or replacement of the Software that does not meet SweetScape's Limited warranty and which is
returned. The Limited Warranty period for any replacement product will be extended for the remainder of the
original warranty period or thirty (30) days after the replacement is delivered to you, whichever is longer. If your
license is for an Evaluation version, your exclusive remedy for any breach of this agreement, including a breach
of the Limited Warranty, shall be to terminate your rights under this agreement.
THIRD PARTY WORKS: This software includes the Onigurama Regular Expression Library, Copyright (c) 2013,
K.Kosako. ("Library") THIS LIBRARY IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT HOLDER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
LIMITATION OF LIABILITY: TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL
SWEETSCAPE SOFTWARE OR ITS SUPPLIERS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR
CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, DAMAGE TO EQUIPMENT,
OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, EVEN IF
SWEETSCAPE SOFTWARE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITED
WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS.
IN ANY CASE, SWEETSCAPE SOFTWARE'S ENTIRE LIABILITY UNDER ANY PROVISION OF THIS AGREEMENT
SHALL BE LIMITED TO THE AMOUNT ACTUALLY PAID FOR THE SOFTWARE.
NO OTHER WARRANTIES: TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, SWEETSCAPE SOFTWARE
DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO
IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT
AND/OR ACCURACY OF INFORMATION, WITH REGARD TO THE SOFTWARE, AND THE PROVISION OF OR FAILURE
TO PROVIDE SUPPORT SERVICES.
This agreement is governed by the laws of the province of Prince Edward Island, Canada.
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Release Notes
Version 7.0 - March 23rd, 2016
The following is an overview of the new functionality in version 7.0 of 010 Editor:











New 010 Editor Repository holds an online collection of Binary Templates and Scripts that have been
submitted by users of the software.
Files from the Repository can be downloaded and installed or uninstalled in 010 Editor with the click of a
button.
Templates or Scripts can be submitted to the Repository directly from 010 Editor.
Can handle multiple versions of files in the Repository including updates, diffs, merges, etc.
Updated the style of a number of dialogs including the Startup page and Welcome page.
Added 'Using the Repository' tutorial to teach the basics of the repository.
Major upgrade to UI library resulting in a number of minor bug fixes and visual fixes.
New webpage 'http://www.sweetscape.com/010editor/repository/' shows the Repository in real time.
New 'Repository' menu displayed in the File Bar above a Template or Script.

The following is a list of all new features in version 7.0 of 010 Editor:



Repository
 New Repository Dialog accessed by clicking 'Templates > Template Repository' or 'Scripts >
Script Repository'.
 Repository dialog lists all files in the repository and can sort by Category, Alphabetic, or
Newest.
 Install or Uninstall files from the Repository Dialog with the click of a button.
 Can search for Scripts or Templates in the Repository Dialog with the search field.
 Licenses for 010 Editor now include free Support, Upgrades, and Repository Updates for 1 year
from the date of purchase.
 When opening a file a dialog pops up if a Template is found in the Repository that can parse
the file (can install the Template or ignore).
 Repository can check for 'ID Bytes' for data files before asking to install.
 New webpage 'http://www.sweetscape.com/010editor/repository/' shows the Repository in
real time.
 Download package includes a number of files from the Repository (called the Local Repository)
so files can be installed even on computers not connected to the internet.
 Online Repository checked for new updates every 3 days (can be changed or turned off).
 Renamed a number of files in the repository (e.g. "BMPTemplate.bt" => "BMP.bt").
 Recent repository updates are listed on the Startup page (double-click on an item to view) or
on the History tab of the Repository Dialog.
 Can submit files to the Repository directly from 010 Editor (see 'Submit File' in the 'Repository'
menu above a Script or Template).
 Submission dialog checks the header for errors and provides an easier way to add Category or
History information to the submission.
 Note that all submissions are reviewed by SweetScape Software before being allowed in the
repository.
 New 'Repository' menu in the File Bar above each Template or Script in the editor.
 Icon in the File Bar shows the file repository status (Installed from Repository, Modified,
Update Available, Conflict).
 Use the Repository Menu to Update, Check for Modifications, Diff, Revert, Delete, or View
Repository.
 Full update engine including powerful 3-way merge algorithm and showing conflicts.
 'Available Versions' table in the Repository Dialog can show multiple versions of files in the
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Repository. The different versions can be viewed, installed or compared.
Display a special warning if a template installed from the Repository asks for permissions to
read or write to other files.
 History tab of the Repository Dialog is displayed when new updates downloaded (can be
turned off).
 Included new tutorial 'Help > Tutorials > Using the Repository'.
 Default Templates and Scripts (e.g. 'BMP.bt', 'IsASCII.1sc', etc) are now installed from the
Repository.
Templates/Scripts
 New Template and Script repository allows installing and submitting Templates and Scripts
easily.
 Templates and Scripts can be listed by Category in the Templates and Scripts menu.
 Standard templates have been renamed (e.g. "BMPTemplate.bt" => "BMP.bt").
 Templates can now have 'ID Bytes' which provide an extra check that a template can parse a
data file. For example, the 'ZIP.bt' file has ID Bytes '50 4B //PK'.
 Renamed 'Templates > Online Template Repository' to 'Template Repository' which now shows
the Repository Dialog.
 Renamed 'Scripts > Online Script Repository' to 'Script Repository' which now shows the
Repository Dialog.
 Renamed 'Templates > Edit Template List' to 'View Installed Templates'.
 Renamed 'Scripts > Edit Script List' to 'View Installed Scripts'.
 The Output panel is no longer shown by default when Printf is called in a template (this can be
controlled using the Compiling Options page).
 New standard comment header at the beginning of Templates or Scripts created with
'Templates > New Template' or 'Scripts > New Script'. New header includes History, Category,
File Mask, and ID Bytes.
 Local strings are now displayed using the character set from the current file (used to always
be ANSI).
 #include now searches the Template and Script Repository Directories.
General
 Updated style for a number of dialog boxes.
 Inspector and Workspace are now docked to the right side by default (just drag-and-drop to
move to the left side).
 Updated Welcome Page with information about the repository.
 Changed default selection background color.
 A dialog now pops up when Support, Free Upgrade, and Free Repository Updates are about to
expire (about 30 days left) and when expired.
 Updated Startup page with modified style and Repository news.
 License information is now displayed on the lower-right corner of the Startup page (click to
display the Register dialog).
 Downloading application news/updates is now done in the background instead of when the
application was shut down.
 Small modifications to the default colors for the editor.
 Read-only state of files is saved with the workspace.
 When a new license is entered a dialog displays the end dates for Support, Free Upgrades and
Free Repository Updates.
 About page now displays current license info and has a button to show the Register dialog.
 Major upgrade to UI library resulting in a number of minor bug fixes and visual fixes.
Options
 Template Options and Script Options now display the list of installed files, including files that
have been installed from the Repository.
 Include the category name in the list of installed templates and scripts.
 Easier way to add local Templates and Scripts to the list. Clicking the 'Add...' button displays a
multi-select file dialog box.
 When adding local Templates or Scripts information such as File Mask, ID Bytes, and Category
can be extracted from the comments at the beginning of the file.
 Templates and Scripts now have an 'Edit...' button to load the file in the editor.
 Added 'ID Bytes' for Templates as an extra way to check that data files can be parsed by a
Template (ID Bytes can be turned off by unchecking the 'Require' toggle).
 Added 'Status' info for Templates and Scripts and click the 'Show...' button to display the
Repository dialog if installed from the Repository.
 Added 'Set Shortcut' button on Scripts and Templates Options for an easy way to set a
shortcut for these items.
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New Repository Options page displays options for the Repository (some options are duplicated
in the Repository Dialog).
Directory Options now allows setting the default Template and Script directory (moved from
the Compiling Options).
Directory Options can set the directory where Scripts and Templates are installed from the
Repository.
Moved File Dialog settings to a separate File Dialog Options page.
Added an option on the Compiling page to control whether the Output panel is displayed
automatically when Printf is called in a Script or Template.
List of options on the left side of the Options Dialog is now resizable (you may need to enlarge
the dialog first).
Options Dialog remembers its size when 010 Editor is shutdown and restarted.
New constants $TEMPLATE_REPOS_DIR and $SCRIPT_REPOS_DIR can be used in file names in
the Options dialog.

Mac







New installation method. Just drag-and-drop to install.
Now support OS X 10.7 and higher (sorry 10.6 users, we tried).
Help viewer now renders fonts better on retina displays.
Fixed some font spacing issues on dialogs on the Mac.
For OS X 10.7 and 10.8 the default hex editor font is now Andale Mono (there is a rendering
bug using Courier New on these systems).

Bugs






























Fixed a crash in the Help Viewer when doing a search for certain keywords.
Fixed problem on Linux using Save As to save a large file in certain cases.
Fixed issue with multiple warnings when running scripts or templates are split onto separate
lines.
Fixed bug in dialog asking to save a file which is marked as read-only was not displaying the
file name correctly.
Fixed issue using the regular expression anchor '$' on files with DOS linefeeds.
Fixed using increment or decrement on a variable inside a variable accessor could sometime
be called multiple times.
Fixed issue where the Addresses for the last line of a large text file were not displayed
correctly using 'Byte Number (Decimal)'.
Fixed issue with wrong the background color sometimes being set when defining structs within
structs.
Fixed bug with the FindFirst function incorrectly wrapping when starting the search from the
end of the file.
Fixed crash when using an invalid regular expression in the FindFirst function.
Fixed using ReadByte/ReadInt/etc with no arguments and positions greater than 0xFFFFFFFF.
Fixed possible crash in FindOpenFile function after using FileClose.
Fixed when a custom name function had an error an empty string was being displayed for the
name.
Fixed problem allocating a local variable after a struct definition sometimes having the
improper scope.
Fixed FindInFiles and FindFiles now return strings in UTF-8 format.
Fixed possible crash assessing types defining by a call to RunTemplate.
Fixed FindFirst and FindAll would incorrectly search the whole file when size was zero.
Fixed crash using more than 15 parameters to SScanf.
Increased the maximum parameters for SScanf from 15 to 30.
Fixed bug with WMemSet function when the value to set was more than 255.
Fixed a problem viewing process names that contained non-ASCII characters.
Fixed a memory leak in user functions in certain cases.
Fixed a crash when a script or template ends with an unmatched '*/'.
Fixed an error message when trying to allocate an array more than 4 GB.
Fixed a bug using the '+' operator to add strings and single characters in certain cases.
Fixed some focus issues on Windows when opening a file and 010 Editor was minimized to the
task bar.
Fixed restoring the application to the correct monitor when 010 Editor was maximized and
then closed.
Fixed typing a backslash character when using the Japanese character set on Mac OS X.
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Fixed issue when FileOpen failed and afterwards an incorrect file was selected.

Version 6.0.3 - Sept 25th, 2015










Fixed a crash when a find occurrence was found on a line containing more than 65535 characters.
Fixed the line number was not being properly displayed in the Find in Files results for text files.
Fixed a problem opening file names on Mac OS X containing certain characters.
Fixed a bug using the number constant 0xffffffffffffffff in a script or template;
Fixed a crash when starting 010 Editor during the 30-day trial period and the system clock was set back
(an error is now displayed).
Fixed a crash when using an invalid regular expression in a syntax highlighting rule.
Fixed the wrong number of pages being printing in certain cases when printing a hex file.
Fixed Export CSV of the Find results for Hex Bytes sometimes improperly included an extra linefeed.
Fixed the AddBookmark function was not properly using the UTF-8 character set for the 'name'
parameter.

Version 6.0.2 - April 13th, 2015









Fixed problem opening physical drives on Linux.
Fixed error using 'Copy As > Copy as Base64' and 'Copy As > Copy as Uuencoding'.
Now display an error when an invalid character constant is encountered in a script or template.
Fixed FILETIME error in the Inspector on Linux/Mac 64-bit.
Fixed error in the first result using Find Strings on a custom range.
Updated color for the Welcome and New Version dialogs.
Fixed error in the documentation for the Exec function about the function's return value.
Fixed error message in the footer of the Manual on the Mac.

Version 6.0.1 - January 28th, 2015







Fixed crash on exit on some Mac OS X machines.
Fixed problem opening processes on 64-bit Windows.
Made the color of the Startup page darker (was too bright on some monitors).
Can now change or reset the color of the Startup page by clicking the 'Options' button on the Startup
page.
Fixed some issues using some IME's with the hex editor.
Fixed bytes not being swapped correctly when printing and swap by group is enabled.

Version 6.0 - December 16th, 2014
The following is an overview of the new functionality in version 6.0 of 010 Editor:
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010 Editor is now available as a 64-bit program on Windows, Mac and Linux.
Searching with Regular Expressions.
Improved Find speed, up to 10 times faster in some cases.
Changed the style of the Startup page, Welcome page, and File Bar.
Added new 'Writing Binary Templates' tutorial to teach the basics of creating Binary Templates.
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Can export the Template Results in XML format.
Can import Find results.

The following is a list of all new features in version 6.0 of 010 Editor:







General




010 Editor is now available as a 64-bit program on Windows, Mac and Linux.
Redesigned Startup page which is automatically shown on startup (this can be changed with
the Startup Action section on the Startup page).
 The Startup page is automatically shown when all files are closed (this can be turned off with
the Options button on the Startup page).
 Redesigned Welcome page with a link to the new Writing Binary Templates tutorial.
 When asking to save changes to multiple files (for example, when closing 010 Editor), all the
files to save will be listed in a single dialog.
 Redesigned style for the File Bar/Ruler at the top of each Editor Window.
 When a file is modified by an external program, the dialog asking to reload changes has two
new options: Always Reload and Always Ignore. Always Reload will continually reload the file if
changes are detected and Always Ignore will not prompt for reloading any more.
 The Floating Tab Group is automatically hidden when all tabs in it are closed (this can be
turned off in the Editor Options dialog).
 Moved Save Selection command to the File menu.
 A popup message is shown when a new version of 010 Editor is available (this can be turned
off with the General Options dialog).
 Added 'Help > Check for Updates' to check if a new version of 010 Editor is available.
 When created new files, the default linefeeds to use are now specified in the File Interface (see
the File Interfaces page of the Options dialog).
 When editing a word-wrapped line in the Text Editor, pressing the Home key twice goes to the
very beginning of the line and pressing the End key twice goes to the very end of the line.
 Exporting CSV from tables now exports strings as UTF-8.
 When using Import Hex, the directory where the file was imported is remembered when using
Save As to save the file.
 'Highlighting > Control Characters' now includes ASCII 127 by default (will need to reset the
Highlighting options to take effect).
 Clicking 'Help > Support by Email' now opens a web form which allows sending a message on
all platforms instead of trying to use a local email client.
 The current version number is now displayed in the Register dialog.
 Increased maximum line width in the Hex Editor from 1024 to 16384 bytes.
 Syntax Highlighting can now apply rules based on Regular Expressions.
 Made text in the About dialog easier to read.
Mac OS X
 Better support for fonts on Mac Retina displays.
Linux
 Linux can now use Gtk styles if available.
Find
 Can search with Regular Expressions (click Search with Regular Expressions on the Options
panel of the Find Bar).
 Improved Find speed, up to 10 times faster in some cases.
 Default Find type for text files is now Text which searches for strings in the current character
set of the file, whether that be ASCII, Unicode, UTF-8, etc.
 The Find type ASCII is now just used for finding ASCII+ANSI strings (use the Find type Text to
search for other character sets).
 Can Import find results that were exported from the Find or Find in Files tabs (Import and
Export can be done from the right-click menu of the results table).
 Added a toggle to the Find Bar Options to prevent the Find Bar from disappearing after search.
 Display a warning when more than 10000000 find occurrences are found (this limit can be
changed or turned off using the Find Bar Options).
 In the Find Bar Options, use the Use Custom Color toggle to apply a custom color for any
search.
 Fixed issues searching for very long arrays of hex bytes (more than 16384 bytes).
 Now display an error when a read-error is encountered when searching on a Windows hard
drive.
 Increase the maximum line length in the Find results from 4096 to 65535.
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Tutorials
 Added new 'Writing Binary Templates' tutorial to teach the basics of creating Binary
Templates.
 Moved Tutorials to the Help menu.
Templates/Scripts
 Can export the Template Results in XML format.
 Can layout Template Results to the right of the Hex Editor Window by right-clicking the
Template Results and choosing Template Results Position.
 Exporting Template Results as CSV or XML exports strings in UTF-8 format.
 Default file name for exporting Template Results now includes the file name.
 Preprocessor #define now works with symbols that have previously been defined.
 Added note to the manual about preprocessor constant _010_LINUX being defined on Linux.
 New Functions
 Added RegExMatch, RegExMatchW, RegExSearch, and RegExSearchW functions for
searching within strings for regular expressions.
 Added ExportXML function to export Template Results as XML.
 Added FindStrings function to perform a string search similar to 'Search > Find
Strings'.
 New functions GetBackColor and GetForeColor can be used to query the currently
active color.
 Added GetMouseWheelScrollSpeed and SetMouseWheelScrollSpeed to get or set the
current mouse wheel speed.
 Function Updates
 Can use regular expressions in the FindAll, FindFirst, FindInFiles or ReplaceAll
functions with the 'method=FINDMETHOD_REGEX' parameter.
 Memcpy/WMemcpy functions now have extra parameters 'int destOffset=0, int
srcOffset=0' that can be used to read or write from the middle of an array.
 Functions ReadLine, TextReadLine, TextWriteLine, TextReadLineW, TextWriteLineW,
TextGetLineSize all have an option 'int includeLinefeed=true'. When this parameter is
false, linefeeds are not included in the read, write, or size operation.
 ReadByte/ReadInt/ReadShort/etc. now default to the position 'FTell()'.
 Can retrieve the error code from a process called using the Exec function with the
errorCode parameter.
Command Line
 Use -line: to jump to a specific line in a text file.
 Use -goto: to jump to a byte address, sector, line or short in a file.
 -goto: supports the syntax from the Goto Bar (for example, use '-goto:+10,s' to skip ahead 10
sectors).
 Set a selection from the command line using -select:<start>:<size> or -select::<size>.
 Old syntax of using @ after a file name to set the cursor or selection is still supported but will
be deprecated in the future.
Options
 New option on General page: Show Popup when a New Version is Available.
 Can set default linefeeds when creating new files on the File Interface page instead of the Text
Editor page.
 New Directories page used to control the initial directory when opening a file dialog box (open
file, save file, import, export, open template, save template, open script, save script).
 New option on Editor page: Auto-hide Floating Tab Group when All Files are Closed.
 Moved options for the cache into a separate Cache page.
 Ruler Color now effects the File Bar color as well.
Bugs
 Fixed problem on Mac using the %Lx format specifier in Printfs.
 Fixed some drives on Windows were not correctly displaying the last few sectors.
 Fixed Find on some Windows drives would stop before reaching the end of the drive.
 Fixed crash exporting a very large Find results from a text file.
 Fixed Histogram percentages not always totaling 100% with some types of histograms.
 Fixed problem displaying histogram for int64's.
 Fixed crash calling a function in a script when the first character in the argument list was a
comma.
 Fixed issue where focus could be incorrectly grabbed from other applications in some cases.
 Fixed cannot delete bookmarks that exist beyond the end of the file.
 On Windows, fixed using file masks '.*' and '.' should match files with no extension.
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Fixed crash using bookmarks on files with file names longer than 128 characters (no limit
now).
Fixed a case where it was possible to cancel a Find in Files directory scan and get an incorrect
progress state.
Fixed Replacing text with nothing did not show any text in the Find tab of the Output panel.
Fixed replace two spaces with nothing can cause a crash in certain cases.
Fixed right-click and Mark Selection End on an existing selection sometimes did not work as
expected.
Fixed highlighting issue using Lock to Selection on the Find Bar with selections greater than 2
GB.
Fixed ensuring Inspector.bt is called when the selection size is changed.
Fixed opening a single file from the Windows Explorer right-click menu would sometimes not
correctly restore previously open files.
Fixed crash with long Comparisons when sorting set to the Result column.
Fixed some address issues using Copy as Text Area.
Fixed bug writing 0x0d0a to a text file from a script when two linefeeds would be displayed
instead of one.
Fixed bug with the FindFirst function searching up when a match occurs at the very top of the
file.
Fixed some progress issues when doing a long Replace operation.

Version 5.0.2 - July 28th, 2014

















Fixed problem writing to drives on Windows 7 and later versions. Windows now requires that all open
file handles be closed before changes can be saved.
If all file handles are not closed when a drive is opened, a warning is displayed and the drive is marked
as read-only (Windows only).
In the Open Drive dialog each physical drive shows a list of logical drives it contains (Windows only).
Added 010 Editor to Mac Finder 'Open With' right-click menu for most file types.
Changed Chinese Simplified encoding from GB2312 to GB18030 (GB18030 is a superset of GB2312).
Fixed using Printf/FPrintf and %s with strings more than 4096 characters long.
Fixed error message on some machines about regsvr32 in the Windows installer.
Fixed crash with sizeof operator on certain structs declared with a size attribute.
Fixed not being able to cancel a script after the RunTemplate function was called.
Fixed Find in Files was not properly releasing some file handles.
Functions InputNumber/InputFloat/InputString properly resize the dialog before it is displayed.
Fixed problem using Exec function on Linux and Mac with file names than contain spaces.
Using %f parameter in External Programs now auto-adds quotes for file names containing spaces.
Now show a warning when attempting to open Template Results hierarchies deeper than 31 levels.
Fixed 010 Editor unable to run on some Linux machines due to a Qt library issue.
Fixed crash on Mac with duplicate enums.

Version 5.0.1 - June 19th, 2014










Fixed Copy As Hex Text crash when the hex editor Line Width is set to Auto Width.
Fixed possible text corruption in Linux when deleting.
Fixed crash using SHA-512 on certain large files.
Fixed setting a shortcut key for a script starting with a lowercase letter.
Fixed possible crash with Allow Multiple Find Ranges and large files.
Fixed Hex Operation dialog becoming uneditable after first operation on the Mac.
Fixed crash with certain non-terminated strings in scripts or templates.
Fixed problems opening files larger than 4 GB on Linux.
Fixed clicking the upgrade link in the Register dialog when the licensee name contains certain nonASCII characters.
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Added instructions on running 010 Editor on Ubuntu 14.04 64-bit.

Version 5.0 - June 24th, 2013
The following is an overview of the new functionality in version 5.0 of 010 Editor:














Syntax highlighting for HTML, XML and PHP.
Customizable syntax highlighting.
Column mode (hold Ctrl while dragging the mouse to select columns).
Customizable toolbars and right-click menu.
Available for Linux, Windows and Mac OS X.
New format menu with options for Uppercase, Lowercase, Capitalize, Tabify, Untabify, Comment
Selection, Uncomment Selection, Increase Line Indent, Decrease Line Indent, and Trim Trailing
Whitespace.
Show whitespace.
Better interface for customizing shortcut keys.
Added SHA-512 algorithm.
Added 16-bit half-float data type (hfloat).
Support for importing and exporting binary text.
19 new functions for Scripts and Templates.

The following is a list of all new features in version 5.0 of 010 Editor:
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Syntax Highlighting
 Added syntax highlighting for HTML, XML and PHP.
 New Syntax Highlights can be created or existing Highlights modified using the Syntax page of
the Options dialog.
 Support styles for Syntax Highlights so multiple rules can share a single color.
 Edit styles using the Styles page of the Options dialog.
 Easily modify the list of highlighted keywords for a Syntax Highlight.
 Support multiple rule types including Multi-Line Block, Single-Line Comment, Keywords,
Single-Line Block, C-Style String, Tag Name, and Tag Attribute.
 Rules can be applied with Ignore Case for case insensitivity.
 Support multi-line C-style strings with '\'.
 Import or export the list of Syntax Highlights including styles using the Import List or Export
List buttons.
 Support sub-rules so that different types of syntax highlighting can be applied to the same
file.
Column Mode
 Support Column Mode for editing the columns of text or hex data.
 Easily make a column selection with the mouse by holding down Ctrl while dragging.
 Enter column mode using Alt+C or click the Column Mode icon in the Toolbar.
 Make column selections and copy or paste them using the clipboard.
 Make a column selection and start typing to insert text on each line at the same time.
 Column selections supported in Hex mode as well.
 Click and drag straight down to create a special column insert line.
 When the clipboard contains just a single line of data, pasting the data with a column selection
pastes the data on each line of the selection.
Linux Version
 Added Linux version with installer.
 Officially support Ubuntu 10.04 and later.
 Available as a 32-bit program (can be installed on 64-bit OS as well).
 Can load scripts and templates by double-clicking them in the Ubuntu File Manager.
 Support Unix-style middle-click clipboard.
Toolbar Customization
 Can customize Toolbars by using the Toolbars page of the Options dialog.
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Access the Toolbars page by right-clicking on a Toolbar and selecting 'Customize...'.
Drag-and-drop actions to the Toolbar list to insert items into the Toolbars.
Insertion point marked with red line.
Drag icons out of the Toolbar list to delete items from the Toolbars.
Create, delete and rename custom Toolbars.
Menu Customization
 Customize the Editor Right-Click menu using the Menus page of the Options dialog.
 Can also access the Menus page by right-clicking on an Editor Window and choosing
'Customize...'.
 Drag-and-drop actions from the Actions tree to the menu to insert actions.
 A red line marks the action insertion point.
 Drag items out of the menu to delete actions from the menu.
 Add separators to the menu using the special Separator action.
 Add sub-menus to the menu with the Submenu action.
 Double-click on a sub-menu name to rename the sub-menu.
Format Menu
 Added new Format menu for working with text data.
 Can convert text to Uppercase, Lowercase, or Capitalize (e.g. APPLE, apple, Apple).
 Converts spaces to tabs using Tabify or tabs to spaces using Untabify.
 Can add or remove comments from the selection using Comment Selection and Uncomment
Selection.
 Commenting supports line comments (e.g. '//') and multi-line comments (e.g. '/*' and '*/')
based off the current Syntax Highlighting scheme.
 Format menu supports Increase Line Indent to add tabs or Decrease Line Indent to remove
tabs (similar to using Tab or Shift+Tab in the editor).
 Trim Trailing Whitespace removes any spaces or tabs from the end of each line.
 Tabify, Untabify and Trim Trailing Whitespace operate on the whole file if no selection is made.
Show Whitespace
 Use 'View > Tabs/Whitespace > Show Whitespace' or the icon in Toolbar to display
whitespace.
 Shows symbols in a text file where spaces and tabs exist.
 The color of the symbols can be controlled in the Colors page of the Options dialog.
 The Show Whitespace setting is remembered with the current File Interface.
Shortcut Keys
 New, easier-to-use interface for changing Shortcut keys in the Options dialog.
 Better support for Shortcut keys on the Mac.
 Enter a Shortcut key by pressing the key on your keyboard instead of having to type out
'Ctrl+M'.
 Use 'Help > View Shortcut List' or click the List Shortcuts button in the Options dialog to view
a list of all shortcuts sorted by shortcut name.
 The list of shortcuts shows any customized shortcuts as bold.
 Allow multiple shortcut keys to be assigned to a single action.
 Better interface for removing shortcut keys from actions.
 Can see any conflicting actions when assigning shortcut keys.
New Functions
 Converts a set of hex bytes to a double, float, or hfloat with ConvertBytesToDouble,
ConvertBytesToFloat, or ConvertBytesToHFloat.
 Support copying an array of hex bytes to or from the clipboard with CopyBytesToClipboard
and GetClipboardBytes.
 Save a portion of a file with the FileSaveRange function.
 Access the custom clipboards with the GetClipboardIndex and SetClipboardIndex functions.
 Access other properties of bookmarks with the GetBookmarkArraySize,
GetBookmarkBackColor, GetBookmarkForeColor, GetBookmarkMoveWithCursor, and
GetBookmarkType functions.
 Added a radio button box input dialog using the function InputRadioButtonBox.
 Ask the user for a directory with the InputDirectory function.
 Can overwrite a block of bytes using the OverwriteBytes function.
 Added ReadHFloat and WriteHFloat for working with half-floats.
 Set environment variables within the working process with the SetEnv function.
Functions Updates
 FileClose was improperly asking to save changes on a modified file.
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GetClipboardString, CopyStringToClipboard, and ClearClipboard uses the current clipboard
(see GetClipboardIndex and SetClipboardIndex).
 CopyStringToClipboard has a charset parameter to inform the clipboard of the type of data
being copied.
 Can specify a custom polynomial or initial value with the Checksum functions.
 Added an optional number of bytes to read to the ReadWString, ReadString, ReadLine, and
ReadWLine functions.
 FileNew has a new makeActive parameter to control if the created file is set as the active file.
 Added an optional fill character to the InsertBytes function.
 InputOpenFileName, InputOpenFileNames, and InputSaveFileName functions now use UTF-8
strings.
 The Sleep function now refreshes the screen before long sleeps (more than 1000
milliseconds).
 Added SHA512 algorithm to the checksum functions.
 Added Binary Text format to the Import/Export functions.
 TextGetNumLines now returns -1 if the current file is a hex file.
 Update help that Strlen returns the number of bytes instead of the number of characters.
Templates/Scripts
 Added 16-bit Half-float (hfloat) data type.
 Automatically cast between hfloat, float and double data types.
 Tooltips now properly use any custom <name=> functions.
General
 Updated visual style of the interface and updated some icons.
 Added new File Interfaces HTML, PHP, and XML.
 When selecting more than one line in a text editor, the number of selected lines is now shown
by default in the status bar.
 Added SHA-512 hash algorithm.
 Able to delete individual recent files or clear the list of recent files by right-clicking on the
Recent Files list in the Workspace or the Startup page.
 Added Goto button to the Goto Bar.
 Added new File Interfaces to the New list.
 Auto-detect XML files.
 Added -readonlyall command line option to mark all files as read only.
 Added 'Selection > Goto Selection Start' and 'Selection > Goto Selection End' for jumping to
the beginning or the end of a selection from the right-click menu.
 Synchronized scrolling now only works between all hex files or all text files.
 Faster Undo/Redo for operations which contain a large number of small operations.
 Renamed 'Toggle Word Wrap' action to 'Word Wrap'.
 Renamed configuration file to '010Editor50.cfg'.
 Removed 3-computer limit in the End-User License Agreement.
Import/Export
 Added Import/Export option for the Binary Text format (e.g. 10100010 11110000).
 Added Copy As Binary Text and Paste From Binary Text to the Edit menu.
 'Copy as <format>' now uses the displayed number of bytes per line (it was using the number
of bytes from the last export).
Options
 Can disable the auto-import of Intel Hex or Motorola files when dragging and dropping from
the system File Manager (see the Importing page).
 Added option to disable the Backspace/Delete key in Overwrite mode for hex files (see the Hex
Editor page).
 Can control the color of the Show Whitespace characters on the Colors page.
Bugs
 Fixed bug with Save Selection on a newly created file.
 Fixed crash with -compare command line option when the file names were the same.
 Fixed issue with updating the Recent Files list when scripts or templates were opened.
 Deleting a file from the Workspace Recent Files list did not update the Startup Page Recent
Files list.
 Fixed up Insert Date/Insert Color on big endian unicode files.
 Fixed up 'Move to New Vertical Tab Group' missing after a Compare.
 Fixed warning dialog for optimized structs cannot be dismissed on Mac.
 Fixed crash when an improper argument was passed to a function inside a script in certain
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cases.
Fixed error message in the Windows installer about Regsvr32.
Possible to delete part of a DOS linefeed in certain cases.

Version 4.0.4 - March 20th, 2013





Fixed
Fixed
Fixed
Fixed

Find Strings finding unicode strings on odd byte boundaries.
crash assigning to a non-existent variable from a script.
crash in find hex bytes when using ',a'.
crash when checksum functions are used inside custom read/comment functions.

Version 4.0.3 - November 8th, 2012









Fixed crash with Printf when using certain combinations of parameters.
Fixed problem using Goto on the Mac.
Fixed using on-demand structs within custom read functions in certain cases.
Fixed printing multiple copies of files.
Disabled redirection of files within the main Windows directory.
Fixed some progress issues when using Find functions inside of scripts.
Show error instead of crashing when trying to copy huge blocks of data to other applications.
Fixed order of some items in the View menu in 'Tools > Options > Keyboard'.

Version 4.0.2 - July 24th, 2012









Fixed a crash using Find on certain long text files.
Fixed a bug with using Export Hex and more than 256 bytes per line.
Fixed issues using on-demand structs inside arrays.
Fixed color picker issues on the Mac.
Fixed last two lines of a customized Inspector disappearing in certain cases.
Fixed background colors not being cleared properly when a template was cleared.
Fixed a notification during installation about an expired license.
Now signing the installer using SHA-1.

Version 4.0.1 - June 6th, 2012











Fixed crash with a custom Auto-Inspector and certain long operations.
Fixed crash with wordwrap on very long lines.
Fixed Paste from Hex Text on Mac OS X.
Fixed clicking on a bookmark, variable, or find result will always select bytes in the editor.
Fixed editing bookmarks that contain arrays.
Fixed issues with the Find results when searching for text containing linefeeds.
Fixed enums and different numeric formats when displaying local variables.
Fixed adding or removing 010 Editor from the Windows Explorer right-click menu using the Options
dialog.
Fixed the Output tab automatically scrolling down as text is added.
Fixed the FindNext function should not be selecting data.
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Fixed the FindNext function when used with DeleteBytes in a loop.
Fixed crash with the HexOperation function on a new file.
Fixed the Short type specifier in the Goto Bar.
Fixed allowing hotkeys to be set for Mark Selection Start/End.
Fixed misplaced cursor when changing the endian of a Unicode file.
The Goto and Select Range Bars now accept extra whitespace.

Version 4.0 - May 14th, 2012
The following is an overview of the new functionality in version 4.0 of 010 Editor:
















Streamlined interface with a simplified tool bar.
Easier, more intuitive way to run Templates or Scripts using the File Bar above each editor.
Added support for word wrap and text files with a huge number of lines.
Tools such as Find, Replace, Find in Files, Goto, Select Range are now displayed in a bar below each
editor for a better workflow.
Can customize the Auto Inspector using a custom Template.
Revamped Find tool allows searching for variables in the Template Results.
When a Find All or Find in Files is done on a text file, all text lines that contain a match are listed.
Added 'Search > Find Strings' dialog for listing all strings in a hex file.
Can visually swap bytes in the hex editor without modifying the underlying data.
Can restore all open files when 010 Editor is restarted (select 'Restore all open files' on the Startup
page).
Comments can now specify a custom function using '<comment=<function_name>>'.
Printf function now does type checking and automatically casts parameters.
Templates can now read from or write to other files when granted special permission.
Over 45 new functions for Scripts and Templates.

The following is a list of all new features in version 4.0 of 010 Editor:



General
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Simplified the tool bars and updated some icons.
File Bar above each editor provides a more intuitive way to run Templates or Scripts.
Can restore all open files when 010 Editor is restarted (select 'Restore all open files' on the
Startup page).
View menu now shows different options when using a text-based interface or hex-based
interface.
In the Workspace, can sort the list of recent files by Name or by Time using the right-click
menu (sort by Time is the default now).
Startup page has been redesigned with resizable sections.
Can customize the polynomial and initial value for CRC checksums.
Added more options to the 'View > Addresses' menu.
Use 'View > Addresses > Shorts' for displaying addresses as words (all addresses are divided
by 2).
Can switch File Interfaces using the Edit As section of the File Bar.
Right-click on the Output panel to Copy All, Export Text, or Clear.
Can apply Highlighting rules by Shorts.
The Welcome dialog allows inputting a license when 010 Editor is in trial mode.
Added '-saveall' command line option.
Added 'Copy File Path' command to the File Tab right-click menu.
Synchronize Scrolling now only scrolls files that are visible.
Cannot change a hex-based interface to a text-based interface or vice versa.
When opening a file that is already opened, the file is selected before being asked to create a
duplicate.
Right-click on the application when all tabs are closed for an option to show the Startup Page.
Removed comment column for bookmarks (currently unused).
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010 Editor configuration file is saved more often.
Configuration file now stored in 'Users\<Username>\AppData\Roaming\SweetScape\010
Editor\010Editor.cfg' on Windows.
 Windows Explorer right-click menu now lists '010 Editor' instead of '010 Editor v3'.
 Updated help viewer.
Text Editor
 Added support for text files with huge numbers of lines.
 Any long text lines over the maximum line length will be split into multiple lines and marked
by '-' in the address column.
 The maximum line length can be set using the Text Editor Options dialog.
 Clicking after the last line always moves the cursor to the last byte.
 Hide the Group By, Division Lines, Left Area, Right Area, Line Width options in the View menu
for text files.
 Word Wrap
 Can automatically wrap lines that are longer than the text editor window with 'View
> Linefeeds > Word Wrap' or Ctrl+;.
 Word Wrap can be turned on automatically using 'View > Linefeeds > Initial Wrap
State > Auto-detect'.
 '/wrap' is displayed in the Edit As section of the File Bar above each editor when
Word Wrap is turned on.
 Can wrap on the window edge or a custom column using 'View > Linefeeds > Wrap
Width'.
 Can wrap on letters instead of words using 'View > Linefeeds > Wrap Method'.
 Word Wrap is supported for files with a large number of lines.
 Byte-Order Marks
 Added better support for working with Byte-Order Marks (BOMs).
 Auto-detect UTF-8 BOMs.
 Status Bar displays '+B' when a BOM is present.
 Add or remove BOMs using 'Tools > Convert'.
 Can auto-add BOMs to new files using the File Interface Options dialog.
Hex Editor
 Can visually swap bytes in the hex editor without modifying the underlying data.
 Bytes can be swapped in groups of 2, 4, 8, etc. (use 'View > Group By' menu to enable).
 Display 'LIT<>' in the status bar when swapping bytes is enabled.
 Set the number of bytes per line in a hex editor using 'View > Line Width'.
 Hide the Linefeeds and Tabs/Whitespace options in the View menu for hex files.
Find
 Find/Replace/Find in Files/Replace in Files now performed from a bar at the bottom of the
editor.
 When a Find All or Find in Files is done on a text file, all text lines that contain a match are
listed.
 Revamped Find/Replace tools with icons for Find/Replace Next/Previous.
 Added 'Search > Find Strings' dialog for listing all strings in a hex file.
 Can search for Variables in the Template Results using the Find Bar.
 Selecting a Find occurrence in the editor highlights that occurrence in the Find results.
 Can list all replacements after doing a Replace All (see 'Show All Replacements' in the Find Bar
Options).
 Lock Find/Replace to a selection using 'Lock Selection' in the Find Bar Options.
 The locked selection will be colored brown and used for Find/Replace until unlocked.
 Can display the address in the Find results in more formats.
 Show or hide the size column in the Find results (hidden by default).
 Ignoring case and match whole word work better when finding extended unicode characters.
 Find in Files list updates automatically when the files are edited.
 Can turn off wrapping for find (see Find Bar Advanced Options).
 Can list all files when doing a Find in Files operation.
 Can turn off the use of Find Specifiers using the Find Bar Advanced Options.
 When searching for Unicode, selected Unicode text is automatically copied to the Find Bar
when it is opened.
 Default to Unicode Find type when finding in a Unicode file.
Scripts/Templates
 Use 'Run Script', 'Run Template' or 'Run on File' sections above each editor for running scripts
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and templates.
Comments can now specify a custom function using '<comment=<function_name>>'.
Templates can now read from or write to other files when granted special permission.
Permissions can be controlled using the Permissions section of the Options dialog and can be
turned off for all files.
 Support searching in the Template Results (use 'Variable Name'/'Variable Value' in the Find
Bar).
 From the Template Results right-click menu, can either expand all nodes of the selected node
(Expand all Children of Node) or expand all nodes in the tree (Expand All Nodes).
 Right-click on a numeric template variable and choose 'Goto > Goto Address' or 'Goto > Goto
Sector'.
 Can override the string displayed in the Name column of the Template Results using
'<name="<string>">' or '<name=<function_name>>'.
 On Windows can right click on a script or template in the Scripts or Templates menu and
select 'Edit Script' or 'Edit Template'.
 Updated included scripts to using RequiresFile and GetScriptName functions.
 Can run a script on no file by selecting '(none)' in the Run on File section of the File Bar.
 When doing a CSV export or Copy of the Template Results, the Color field will be converted to
a hex color instead of being left blank.
 An integer with <format=binary> will now show all bytes if zero instead of just the first byte.
 'L' string constants now support UTF-8.
 Prevent running a template on a template.
 Generate a warning if defining a large number of template variables.
 Removed variable mouse-over brackets on a text file (was being displayed incorrectly).
New Functions
 Can convert between a binary string and an integer (BinaryStrToInt, IntToBinaryStr).
 Added functions to perform checksums on arrays (ChecksumAlgArrayStr,
ChecksumAlgArrayBytes).
 Can convert strings between various encodings (ConvertString).
 Added functions to extract path, extension, or base name from a file name (FileNameGetBase,
FileNameGetBaseW, FileNameGetExtension, FileNameGetExtensionW, FileNameGetPath,
FileNameGetPathW, FileNameSetExtension, FileNameSetExtensionW).
 Can search for an open file in the editor (FindOpenFile, FindOpenFileW).
 Can retrieve environment variables (GetEnv).
 File attributes for Windows or Unix files can be retrieved or changed (GetFileAttributesUnix,
GetFileAttributesWin, SetFileAttributesUnix, SetFileAttributesWin).
 Retrieve the character set of the current file (GetFileCharSet).
 Get or set which file interface is being used for the current file (GetFileInterface,
SetFileInterface).
 Retrieve the name of the current script or template being run (GetScriptName,
GetScriptNameW, GetScriptFileName, GetScriptFileNameW, GetTemplateName,
GetTemplateNameW, GetTemplateFileName, GetTemplateFileNameW).
 Provided function to get a temporary file name (GetTempFileName).
 Can get or set the current working directory (GetWorkingDirectory, GetWorkingDirectoryW,
SetWorkingDirectory, SetWorkingDirectoryW).
 Provided function to perform any of the Hex Operations in the Tools menu (HexOperation).
 Can calculate the length of a null-terminated string in a file (ReadStringLength,
ReadWStringLength).
 Provided function to ensure that a script is being run on a target file (RequiresFile).
 Can write a message to the status bar (StatusMessage).
 Convert strings easily to UTF-8 format (StringToUTF8, WStringToUTF8).
 Can convert characters to upper or lower case (ToLower, ToLowerW, ToUpper, ToUpperW).
 Can convert from a text column to an address (TextColumnToAddress).
Function Updates
 Printf function now does type checking and automatically casts parameters.
 Interface type can be specified for the FileOpen and FileNew functions.
 GetFileName returns a UTF-8 string.
 FileOpen will now accept a UTF-8 string.
 FileOpen no longer pops up an error message if the file could not be found.
 Better handling of opening duplicate files with the FileOpen function.
 Can specify a different character set in the StringToWString and WStringToString functions.
 MessageBox supports UTF-8 encoding.
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RunTemplate can be run with no arguments to rerun the Template associated with the current
file.
 Added argument to the RunTemplate function to prevent clearing the Output panel.
 SubStr/WSubStr now default to -1 instead of 0.
 Can specify a custom date format in the functions GetCurrentTime, GetCurrentDate,
GetCurrentDateTime, StringToDosDate, StringToDosTime, StringToFileTime, StringToOleTime,
StringToTimeT, DosDateToString, DosTimeToString, FileTimeToString, OleTimeToString, and
TimeTToString.
 Can set the maximum wildcard length in the FindAll, FindFirst, FindInFiles, and ReplaceAll
functions.
 Removed HTML tag processing from Printf.
Selections
 'Edit > Select Range' tool now displays a Select Bar at the bottom of the editor.
 When selecting bytes while the Select Bar is open, the Select Bar will update to display the
selection.
 Right click on an editor and choose 'Select > Mark Selection Start' or 'Select > Mark Selection
End' to set the selection.
 Added Save Selection to the editor right-click menu.
 Save Selection automatically appends the start/size of the selection to the file name.
Inspector
 Can customize the Auto Inspector (right-click the Inspector and choose 'Customize...').
 Auto Inspector can be set to use a custom template (by default the 'Inspector.bt' file is
included with 010 Editor).
 Data types can be reordered or deleted from the Auto Inspector using the custom template.
 Any data type (including Custom Variables) can be added to the Auto Inspector using the
custom template.
Goto
 'Search > Goto' tool now displays the Goto Bar below the editor.
 Use the Goto Bar to jump to a byte, line, sector or short in a file.
Options
 Can set the maximum line length for text files.
 Can set the auto-hide time for bars in the application (Find Bar/Replace Bar/Goto Bar/Select
Bar/etc.).
 Added option to remember the last used File Interface, Endian, and Word Wrap for a file.
 Allow setting the color for the Find Selection Lock.
 Must specify whether a File Interface is text-based or hex-based when the interface is created.
Mac OS X
 Now use Ctrl+G for Find Next and Ctrl+Shift+G for Find Previous on the Mac.
 Now use Ctrl+L for Goto and Ctrl+Shift+G for Goto Again on the Mac.
 Add File Proxy icons to the Application Window (drag to other Windows to open).
 Removed icons on the menu for Mac.
 Removed icons on sub-windows for Mac.
 Fixed order of some OK/Cancel buttons on the Mac.
 Fixed Windows Clipboard should be called Macintosh Clipboard on the Mac.
Hotkeys
 Ctrl+E now toggles between Big and Little Endian.
 Word Wrap can be toggled on or off using Ctrl+;.
 Can access Options dialog using Ctrl+, on Windows.
 Changed close window hotkey to Ctrl+W.
 Changed close all window hotkey to Ctrl+Alt+W.
 Fixed issue with Previous Tab shortcut.
 Can show or hide the File Bar above each editor using Ctrl+/.
Bugs
 Fixed bug copying large blocks of data to other applications.
 Fixed issues with editing UTF-8 characters.
 Fixed crash when a startup script was missing.
 Fixed constants in the form 0B?h.
 Fixed crash in certain invalid assignments to a struct.
 Fixed bug with extra character when casting from a string to a wstring.
 Fixed bug with switch statement when default was the first statement.
 Fixed a case where a non-terminated string could potentially cause a crash.
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Fixed case where the Close All icon enabled state was not correctly set.
Fixed case when Close All could cause the Floating Tab Group to be displayed.
Fixed case where Close All Except This could close the wrong files.
Fixed bug with assigning to a negative float or double.
Fixed issue with using return in a function with no return value.
Fixed OutputPaneCopy/OutputPaneSave missing the last row if no linefeed.
Fixed case where commented lines were colored incorrectly when jumping through a file.
Fixed crash in the Inspector with certain rare Unicode strings.
Fixed bug with FindFirst/FindAll when size=0 and start>0.
Fixed bug with FindFirst/FindAll and finding Unicode values.
Fixed bug with FindNext/FindAll using dir=-1.
Fixed FPrintf(newFile,"%c",0) now works properly.
Fixed issue with all red text in the Output panel.
Fixed case when a Hex file is split and then scroll down, the ruler would not be displayed
correctly.
Fixed InputOpenFileName/InputOpenFileNames not using the default file name.
Fixed AddBookmark can add bookmarks in any of the base types without first running a
template.
Fixed bug with '//' after #define.
Fixed constants COMPARE_SYNCHRONIZE and COMPARE_SIMPLE were switched.
Fixed rare crash when running templates and progress issues.
Fixed crash calling TextReadLine with an empty string.
Fixed possible crash with MessageBox function when using only two parameters.
Fixed issues with Copy/Paste from Hex Bytes with Unicode files.
Fixed DOS linefeeds being transformed to Unix linefeeds when copying to the Find Bar.
Fixed running a comparison can cause empty an Floating Tab Group to be displayed.
Fixed a possible crash with an infinite recursion script.
Fixed issues with character sets in the Find results window.
Fixed correctly detecting when a file read-only flag is changed outside 010 Editor.
Fixed Export CSV automatically adds quotes around items containing commas.
Fixed in split-view mode, the selection could move after editing.
Increased amount of memory the undo stack is allowed to use.

Version 3.2.2 - August 8th, 2011





Added support for Mac OS X Lion.
Fixed losing registration problem on Mac OS X Lion.
Fixed problem with loading the help file on the Mac.
Now generate an error when accessing member variables inside a 'size' function.

Version 3.2.1 - July 13th, 2011
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Mac OS X version is now a 32-bit program instead of 64-bit.
Changed close window hotkey on the Mac to Command+W.
Fixed Windows context menu in 3rd party applications including Directory Opus.
Fixed problem with Unicode searches and wildcards.
Fixed showing the help file when minimized and then a topic is loaded.
Fixed showing 010 Editor when minimized and the Windows context menu is clicked.
Fixed inputting certain floats or doubles in the Inspector on Windows.
Fixed Copy As and then paste to other applications with big-endian Unicode text.
Fixed date in release notes.
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Version 3.2 - June 17th, 2011
The following is an overview of the new functionality in version 3.2 of 010 Editor:











010 Editor is now available for Mac OS X.
On-demand parsing of templates using <size=...> for lower memory usage.
Can set fonts for the Template Results, Inspector, etc in the Options dialog.
'New' on the file menu now lists all types of files available for creation.
Can pass arguments into scripts or templates from the command line.
New functions for accessing process information in scripts or templates.
New functions for easier reading and writing of text files.
Can export or import a list of scripts or templates from the Options dialog.
New help viewer with tabs.

The following is a list of all new features in version 3.2 of 010 Editor:











General











010 Editor is now available for Mac OS X.
Can set fonts for the Template Results, Inspector, etc in the Options dialog.
'New' on the File menu now lists all types of files available for creation.
Each file interface can either use the default text or hex font or a custom font.
Separate insert/overwrite state for text and hex files.
Can click INS/OVR in the status bar to toggle insert state.
Histogram hotkey changed to Ctrl+Shift+T.
Added option on the Help Menu to view the Release Notes.
010 Editor does a better job converting text data between formats when copying text between
files with different character sets.
 Can set a custom color format for 'Edit > Insert Color' in the Options dialog.
 Non-ANSI characters now supported in Bookmark names.
 Release notes added to the manual instead of separate text file.
Command Line
 Can pass arguments to a script or template using the form: -script:File.1sc:(arg1,arg2)
 Added ',a' specifier to the '-replace' command to replace in all open files.
 '-h' now displays the manual command line page instead of a separate dialog.
Templates and Scripts
 On-demand parsing of templates using <size=number> or <size=function_name> for lower
memory usage.
 Can export or import a list of scripts or templates from the Options dialog.
 Added ifdef constant for Windows (_010_WIN) and Mac OS X (_010_MAC).
 Added ifdef constant for 64-bit versions (_010_64BIT).
 Non-ANSI characters now supported in comments (use UTF-8).
Functions
 Added GetFileNameW function to get the wide-string version of the current file name.
 FileSave function can accept a wide-string or no string at all to save to the current file name.
 Added ExpandAll function to open all nodes in the Template Results.
 Added ExportCSV to save the Template Results to a comma-delimited file.
 GetNumArgs, GetArg, and GetArgW functions can be used to retrieve special arguments
passed from the command line.
 IsNoUIMode function returns true if 010 Editor is being run in '-noui' mode.
 RunTemplate function now returns the return value from the template that was executed.
 FileOpen now returns the file index of the file that was opened.
 Process information can be returned using the functions ProcessGetHeapLocalAddress,
ProcessGetHeapModule, ProcessGetHeapSize, ProcessGetHeapStartAddress,
ProcessGetNumHeaps, ProcessHeapToLocalAddress, and ProcessLocalToHeapAddress.
 Added functions to read or write text data in the editor including TextAddressToLine,
TextAddressToColumn, TextGetNumLines, TextGetLineSize, TextLineToAddress, TextReadLine,
TextReadLineW, TextWriteLine, TextWriteLineW.
Bug Fixes
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Fixed some foreign characters in names not working in the Register dialog.
Fixed the temp directory displaying a short path name.
The documentation listed the incorrect return value for the StringToDosDate,
StringToDosTime, StringToFileTime, StringToOleTime, and StringToTimeT functions.
Fixed bug with multi-line defines and dos-style linefeeds.
Fixed bug resetting shortcuts where the interface was not updating properly.
Insert Date/Color should work now for Unicode files.
Fixed issues with certain input method editors that caused them to not work properly.
Now display error message when trying to set linefeeds to 'Auto Detect' while in binary mode.
Fixed bug where the Close All icon should be available when the startup tab is selected.
Fixed InputSaveFileName function not properly using the default file name.
Fixed an undefined variable in a script could be displayed as an error in an associated
template.
Fixed redraw bug in the Base Converter.
Fixed some code examples in the help file.
Fixed occasional problem drawing underscores.
Fixed template variables sometimes not accessible after calling RunTemplate.
Fixed open icon in the tutorial on Windows 7.
Fixed Histogram panel initial size on Windows 7.
Fixed the size of the Hex Operations dialog on Windows 7.
Fixed accessing new file created during a call to RunTemplate.

Version 3.1.3 - November 10th, 2010









Fixed possible Windows DLL exploit (see
https://www.microsoft.com/technet/security/advisory/2269637.mspx).
Fixed crash using Export CSV with very large datasets.
Fixed compile errors using DOS style linefeeds after preprocessor statements.
Fixed crash on comparing large files.
Fixed occasional problems with button labels in message boxes.
Fixed some button sizes on Windows 7.
Now opening .lnk and .url files will load those files directly, not the files to which they link.
Updates for installing from a CD.

Version 3.1.2 - May 21st, 2010



Fixed crash with 'Run as administrator' on Windows 7 x64 machines.
Fixed some constants being incorrectly identified as 'int64' instead of 'int'.

Version 3.1.1 - May 5th, 2010
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Fixed Windows Explorer shell extension on Windows 7 x64 machines.
Template results now display ASCII strings in the current file character set.
Fixed error if a script or template included more than 16 files.
Fixed error using sizeof operator to calculate the size of a struct.
Fixed error message with -replace command line option when no values found.
Fixed behavior comparing int -1 to 0xffffffff to be consistent with 3.0.
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Version 3.1 - February 16th, 2010
The following is an overview of the new functionality in version 3.1 of 010 Editor:









Support for the UTF-8 character set.
Support preprocessor directives #define, #ifdef, #ifndef, #else, etc.
Support for wstring and wchar_t in Scripts/Templates (unicode strings).
Use -noui to run 010 Editor without a user interface for batch files.
Template variables can now have comments (e.g. <comment=""> after a variable).
New options when defining template variables: <fgcolor=???>, <bgcolor=???>,
<open=true|false|suppress>, <hidden=true|false>.
Can pass arguments into structures.

The following is a list of all new features in version 3.1 of 010 Editor:













Editor







Support the UTF-8 character set.
Added 'UTF-8' and 'Binary' to the 'Edit As' drop-down list.
Added support for Ctrl+Ins(Copy), Shift+Ins(Paste), and Shift+Del(Cut).
Shows a current column position arrow in the text editor ruler.
Soft hyphen (0xAD) displayed as hyphen instead of space.
Command Line
 Use -noui to run 010 Editor without a user interface for batch files.
 Added -nowarnings to disable display of message boxes when using -noui.
 Can run comparisons from the command line with -compare.
 Added -exitnoerrors to close 010 Editor only if there are no script or template errors.
Histogram
 Char column in histogram displays the current file character set.
Bookmarks
 Toggle Bookmark (Ctrl+F2) makes a bookmark for the whole selection, not just the selected
byte.
Compare
 If exactly two files are open, they will automatically be filled in the Compare dialog when
opened.
 Can run comparisons from the command line.
 Increased number of internal allowed differences in comparison algorithm.
Options
 Can hide the splash screen on startup (only when the software is registered).
 Control the color of the caret.
 Can change the input-method editor (IME) color.
 Can control the ruler column marker arrow color.
Templates and Scripts
 Can display comments for variables using <comment=""> syntax after a variable.
 Can set the color of a variable using <fgcolor=???> or <bgcolor=???> after a variable (for
example, <fgcolor=cBlack, bgcolor=0x803020>).
 Can use <open=true|false> after a variable to have a variable open by default.
 Can use <hidden=true|false> after a variable to hide variables.
 Can use <open=suppress> after a variable to prevent it opening during Expand All.
 Can pass arguments into structures.
 Support #ifdef, #ifndef, #define, #undef, #endif, #else, #warning, #error preprocessor
directives.
 Added support for unicode strings (wstring/wchar_t).
 Can use L to indicate wide-string constants (e.g. L"dog").
 Bitfields and enums can now work together.
 Can now call functions in templates from scripts.
 Enum values can now be any expression.
 Better handling of int64 constants (auto-detect).
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Added current template directory to include path search.
Use Ctrl+Left/Right/Enter for better navigation in the template results tree.
Double-click on an error or warning takes you to the source code line.
Enum list items can be selected on single-click instead of double-click.
Support showing local variables inside a struct.
Correctly update focus highlight in Variables tab when switching files.
Can cast time types to ints or floats.
Updating variable coloring rule so colors are properly propagated from parents to children.
Exec function is no longer allowed in a template.
New Functions
 Can run a template from a script (RunTemplate).
 Can set bookmarks from a script or template (AddBookmark, GetBookmarkName,
GetBookmarkPos, GetNumBookmarks, RemoveBookmark).
 Added new clipboard functions (ClearClipboard, CopyStringToClipboard, GetClipboardString).
 Get the current time (GetCurrentTime, GetCurrentDate, GetCurrentDateTime).
 Added an Assert function.
 Convert a variable such as int or float to bytes (ConvertDataToBytes).
 Retrieve the current temporary directory (GetTempDirectory).
 Control the output panel where Printf data is displayed (OutputPaneClear, OutputPaneSave,
OutputPaneCopy).
 Can wait for a certain number of milliseconds (Sleep).
 New wstring (unicode string) functions: InputWString, ReadWLine, ReadWString,
StringToWString, WMemcmp, WMemcpy, WMemset, WriteWString, WStrcat, WStrchr,
WStrcmp WStrcpy, WStrDel, WStricmp WStringToString, WStrlen, WStrncmp WStrncpy,
WStrnicmp, WStrstr, WSubStr.
 Can determine if a function exists with 'function_exists' keyword.
 Exec function has a parameter to wait until execution is finished before returning.
 FileOpen can execute the template associated with a file.
 Can access the current structure variable with 'this' keyword.
 Can access the parent of a structure variable with 'parentof' keyword.
General
 Installer can warn user if installing a version that will require an upgrade.
 Register dialog button displays 'Cancel' instead of 'Continue' to prevent confusion.
 Temp directory can pick up the TEMP system variable.
 Add Ctrl+Enter shortcut in Find in File results (keeps focus on Output Window).
 Better handling of multiple versions of the configuration file.
 Configuration file should be less prone to corruption.
Bug Fixes
 Fixed templates variable arrays if the size of the array is greater than 2 GB.
 Fixed bug where a file could display no data after canceling a script or template.
 Fixed bug drawing the ruler when certain fonts are chosen.
 Now correctly report physical disk size on Windows XP or higher.
 Improved error message when using shift operators.
 Improved error message when defining a structure twice with typedef.
 Fixed empty structure warning when using bitfields and no padding.
 Fixed bug with drawing Fg: in the template results.
 Fixed bug selecting bytes in Unicode.
 Fixed bug extending a selection with Shift+click.
 Fixed reading bookmarks containing enums.
 Fixed opening files containing '@'.
 Fixed importing a hex text containing very long lines.
 Fixed using bitfields mixing named and unnamed variable.
 Fixed auto-detect of decimal import text.
 Fixed bug using post increment during array access.
 Fixed printfs sometimes being colored red after an error.
 Fixed syntax highlighting issue with quotes.
 Fixed possible crash with the FileClose function.
 Fixed error message when defining struct variables incorrectly.
 Fixed a typo in the welcome dialog.
 Fixed issue with the syntax highlighting menu.
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Fixed an issue with double-clicking on find-in-file results.
Fixed Variables Tab not being updated correctly after running a script.
Fixed issue working with files that are deleted.
Fixed issue passing strings to functions which are then passed to other functions.
Fixed selecting issue by dragging over the last line in the text editor.
Fixed negative enums.
Fix for optimizing warning on struct that just contains a 'string' variable.

Version 3.0.6 - October 26th, 2009





Fixed
Fixed
Fixed
Fixed

importing hex text with very long lines.
templates which mixed bitfields and regular variables.
Printf with '%%'.
issues on Windows 7.

Version 3.0.5 - April 13th, 2009













Now support Input Method Editors (IMEs) for multi-byte character sets.
Fixed bug with Find dialog and multi-byte character sets.
Fixed problem with backspace and multi-byte character sets.
Fixed possible buffer overruns running templates and scripts (as reported by Bach Khoa Internetwork
Security (Bkis) - http://security.bkis.vn/).
Fixed problems with the FindFirst and ReplaceAll functions.
Scripts and templates now support '0h' as well as '00h'.
Fixed bug in displaying warning message about optimized arrays.
Fixed crash using Overwrite Bytes on a large drive.
Fixed possible crash when closing a file after a comparison.
Fixed not being able to open certain logical and physical drives.
Fixed bookmarks being deleted when overwriting a block of data.
Fixed being able to open Unicode filenames from the Windows Explorer right-click menu.

Version 3.0.4 - February 6th, 2009










Fixed issues with displaying Japanese and Chinese character sets.
Updated character handling engine for non-ASCII character sets.
Fixed restoring the maximized state of 010 Editor on restart.
Fixed possible crash when opening files from Windows Explorer right-click menu.
Fixed issues with properly refreshing the Inspector values.
Fixed crash in Replace dialog.
Fixed crash when setting certain Group By values.
Fixed issue with certain foreign characters in the Register dialog.
Fixed typo in the calculator.

Version 3.0.3 - October 17th, 2008


Improved memory handling for running very large templates.
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Fixed possible crash with syntax highlighting.
Fixed possible crash running a script with a long line.
Fixed some Unicode rendering issues in the hex editor.
Fixed crash with exporting a text area from a Script in certain cases.
Fixed the find in selection not working properly in certain cases.
Fixed disabled/enabled problems with buttons in the find dialog.
Fixed a problem with the ',' constant in scripts.
Fixed error message for attempting incorrect operations on structs.
Fixed possible crash using the StrDel function.
Fixed typo in script cancelled error message.
Can now copying Unicode data to the clipboard correctly.

Version 3.0.2 - August 28th, 2008








Automatically hide empty floating tab group on startup.
Fixed crash with inspector when displaying certain characters.
Fixed focus issues when loading files via the Windows explorer right-click menu.
Fixed potential crash with -exit command line option.
Bug fix for Keep File Time functionality.
Fixed crash closing deleted files in certain cases.
Allow custom read/write functions to work with equivalent types.

Version 3.0.1 - July 16th, 2008




Bug Fixes
 Fixed periodic hangs when using the Explorer tab to browse a network drive.
 Fixed international character set issues.
 Fixed some keyboard keys not working on international keyboards.
 Fixed possible crash with Copy As Hex Bytes.
 Fixed replace up missing some occurrences in certain cases.
 Fixed visual issues editing Unicode hex data.
 Fixed using the clipboard when some specialized clipboard managers were installed.
 Fixed progress update on running some scripts.
 Fixed issues with the scope of local variables between functions and structs.
 Fixed problem with empty statements inside a switch statement.
 Fixed a reporting issue with Byte by Byte comparisons.
 Fixed being able to run the Calculator on other files in the interface.
 Fixed occasional crash when opening files when all windows were closed.
 Fixed display glitch with Output tab showing red text.
 Fixed tool bar undocking issues.
General
 Each Tool Bar can now be resized to be smaller than its contents.
 Visual changes on Vista machines for more consistency.

Version 3.0 - May 19th, 2008
The following is an overview of the new functionality in version 3.0 of 010 Editor:
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Includes a text editor with syntax highlighting.
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Improved interface with new icons.
Improved file tabs with close buttons that can be dragged to new positions.
Can have multiple scripts/templates open at the same time.
Find/replace, goto, etc. can be applied to templates or scripts.
Full support for Unicode file names and strings in the application.
Scripts and Templates now stored in "My Documents\SweetScape" directory.
Official support for Windows 98/Me/NT has been dropped.
A whole range of other improvements.

The following is a list of all new features in version 3.0 of 010 Editor:




















Text Editor
 Can now edit text, Unicode, or EBCDIC files.
 Basic support for syntax highlighting for C/C++ files.
 Support indenting or unindenting text with Tab or Shift+Tab.
 Added insert date/time and insert color commands.
Hex Editor
 Improved visual style for hex editing.
 Can display addresses in sectors.
File Tabs
 Improved tab-based interface with close buttons.
 Added a floating tab group.
 Can drag and drop file tabs (even between the floating tab group).
 Able to have multiple tab groups laid out horizontally or vertically.
Startup Page
 Optional startup page shows recent files, latest application news, and tips.
File Interfaces
 Added 'Edit As' combo box to switch between editing text, hex, C++, etc. files.
 Added Ctrl+H shortcut to toggle between text and hex files.
 Use Ctrl++ or Ctrl+- to enlarge or shrink fonts.
 Can set status bar and ruler display formats for different file interfaces.
Find/Replace
 Added Replace in Files command.
 Find dialog automatically copies selected bytes to the Value field.
 Improved status bar for doing long replace operations.
 Find results update when bytes inserted/deleted.
Goto
 Can use goto dialog to jump to an address, line or a sector.
 Use ',a', ',l' or ',s' options in Goto combo box for address, line or sector.
Bookmarks
 Added a Toggle Bookmark command (can be used to add quick bookmarks).
 Bookmark positions properly update when bytes inserted/deleted.
Printing
 Enhanced Print Preview dialog.
 Printing now works with text files (including Templates and Scripts).
Tools
 Improved calculator with input buttons for performing quick calculations using the mouse.
 Improved conversion utility can be used to convert character sets and/or linefeeds.
 Improved checksum tool can treat data as ushorts, uints, or uint64s.
 Improved histogram tool can treat data as other data types.
Workspace
 Enhanced the 'Explorer' tab of the Workspace.
Inspector
 Added Unicode string to the Inspector.
 Moved list of available functions to the 'Functions' tab of the Inspector.
Scripts and Templates
 Can have more than one script or template open at a time.
 Find, print, other operations can all be applied to a script or template.
 Select which script or template to run using drop-down list in the Tool Bar.
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Results from Printf now displayed in 'Output' tab in the Output panel.
Code Editor has been removed and replaced with a Floating Tab Group.
Can display local variables in the template results.
Add RequiresVersion, ReadInt64, ReadUInt64, WriteInt64, WriteUInt64 functions.
Variables defined in script are now displayed in the 'Variables' tab of the Inspector.
List of functions now displayed in the 'Functions' tab of the Inspector.
Removed size limitation for scripts and templates.
Scripts now stored in "My Documents\SweetScape\010 Scripts" directory.
Templates now stored in "My Documents\SweetScape\010 Templates" directory.
Added default import byte to 'ImportFile' function.
Register Dialog
 Improved register dialog lists when Support/Maintenance expires.
 Can look up forgotten passwords.
 Can remove license from the current machine.
General
 Added tutorial for using Binary Templates.
 Updated some hotkeys for various tasks.
 Show current character set, linefeeds, and tabs in the status bar.
 Synchronized Scrolling now synchronizes scrolling horizontally and vertically.
 Added Overwrite File and Overwrite Bytes commands.
 Many dialogs have an expandable 'Options' section.
 Improved New and Open tool buttons with drop-down list.
 Full support for Unicode file names and strings in the application.
 Can use 'File > Revert/Refresh' to update processes or drives.
 Added -reset and -resetall command line options to reset the interface.
 Official support for Windows 98/Me/NT has been dropped.
Options
 Can control the mouse wheel scroll rate.
 Can control the directories where Scripts and Templates are stored.
Bug Fixes
 Fixed problems with different DPI settings.
 Fixed problem imported certain base64 files.
 Fixed occasional crash on shutdown.
 Fixed disappearing columns on some multi-monitor systems.
 Fixed crash when deleting multiple files that were open in 010 Editor.

Version 2.1.4 - February 22nd, 2008





Bug fix with assigning to dates in a script.
Bug fix with importing long lines.
Bug fix with memory leak in FPrintf.
Updated licensing to support version 3 licenses.

Version 2.1.3 - April 5th, 2007


Workaround for startup problems caused by faulty Microsoft hotfix.

Version 2.1.2 - March 10th, 2007
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Bug fix for 'FindAll' function.

Version 2.1.1 - March 9th, 2007



Added support for Windows Vista.
Fixed bug with string compare in scripts and templates.

Version 2.1 - March 5th, 2007












General




Improved right-click menu in Windows explorer.
Updated some icons.
Import/Export
 Added ability to export as HTML, RTF, or a text area.
 Can import or export Base64 and uuencoded data.
 Can use 'Copy As' or 'Paste from' for many different types of data.
Tab Menu
 Added right-click menu to file Tabs.
 Can middle-click on a tab to close a file.
Command Line
 Can Replace a string or set of bytes from the command line.
 Added ability to save or close a file from the command line.
Scripts and Templates
 Improved bitfield mode without padding (see BitfieldDisablePadding).
 Added 'Always on Top' toggle for the Code Editor (from right-click menu).
 Check to reload script/template if modified by an external program.
Editor
 Now able to input characters more than 0x80 into the character area.
 Added option to remove ':' separators in file addresses.
New Functions
 BitfieldEnablePadding/BitfieldDisablePadding for bit streaming.
 Function for locating files in a directory (FindFiles).
 Added directory manipulation functions (DirectoryExists, MakeDir).
 Added function to convert an enum to a string (EnumToString).
 Functions to convert Dates to strings and vise versa.
 Exit function can be used to return errorlevel to a batch file.
Bug Fixes
 Fixed problem exporting Intel-Hex 16-bit files with custom addresses.
 Fixed printf functions occasionally detecting the wrong number of arguments.
 Importing files now properly imports last line if it does not have a carriage return.
 Fixed sign of variables when doing divisions.
 Fixed template hints occasionally not displaying correctly.
 Fixed bug in FileSave function saving to a different filename.

Version 2.0.3 - November 28th, 2006




Fixed bug with FileSave function.
Fixed bug with allowing more than one instance.
Fixed problem with exporting hex text and long lines.
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Now use Exit function to set global errorlevel return value.
Allow bookmarks on consecutive bytes.
Fixed bug exporting data from disk or process.

Version 2.0.2 - June 9th, 2005






Fixed problem in help index with function names not jumping directly to function help.
Fixed using copy and paste when editing a template variable.
Fixed problems using Printf on some strings.
Fixed bugs with custom read functions and forward structs.
Added uninstall survey.

Version 2.0.1 - April 28th, 2005





Fixed issues with custom read/write functions.
Fixed issues with minimize/maximize behaviour.
Fixed issues with time data formats.
Bug fixes with canceling operations, resizing, window order, and divisions.

Version 2.0 - March 30th, 2005
The following is an overview of the new functionality in version 2.0 of 010 Editor:









Added hard drive editing for logical and physical drives.
Added editing of system processes.
More powerful interface for viewing template results (results displayed in panel below each hex editor,
mouse-over hints, reverse lookup for template variables).
More powerful scripts/templates syntax (custom functions, custom data types, more standard keywords
supported, union support, include support, 44 new functions).
New Windows XP style.
Many improvements in tools (new Find in Files tool).
A whole range of other improvements.

The following is a list of all new features in version 2.0 of 010 Editor:
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Hard Drive Editing
 Open entire logical or physical hard drives using 'File > Open Drive'.
 Make disk images for drive using 'File > Save As'.
 Jump to next or previous drive sector with Alt+Down, Alt+Up.
 Get properties of the drive using 'Edit > Properties'.
 Open hard drives from the command line.
Process Editing
 Open processes using 'File > Open Process'.
 Select which heaps or modules to open.
 Make image of process using 'File > Save As'.
 Get properties of the process using 'Edit > Properties'.
 Open processes from the command line.
 List of current heaps displayed in 'Process' tab of the Output Window.
Templates/Scripts
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Templates/Scripts Interface
 Templates results can now be displayed in the 'Template Results' panel below each
hex editor.
 Application contains links to an online repository for scripts and templates.
 Display hint for template variable when the cursor is over bytes in the hex editor.
 New 'Jump to Template Variable' command to lookup a template variable from a file
address.
 Scripts and templates can be opened by double-clicking them in Windows Explorer.
 Scripts and templates can be run from the command line.
 Can mark scripts to be run on startup, shutdown, or when certain files are opened.
 Speed improvements for scripts and templates.
 Added default shortcut for saving a script or template.
 Context sensitive help in the Code Editor.
Templates/Scripts Syntax
 Define your own custom functions.
 Use '#include' keyword to include files.
 Support for switch, case, break, and continue keywords.
 Support for unions.
 Default custom variables using the syntax <read=[functionname],
write=[functionname]>.
 Control whether arrays of structures are optimized with <optimize=true|false>.
 Specify display format for variable using the syntax
<format=hex|decimal|octal|binary>.
 sizeof now works properly on simple structures.
 Special new keywords 'exists' and 'startof' for template variables.
 Array initializers work properly (e.g. int a[3] = {1, 2, 3};).
 No need to use 'return' when doing simple expressions in the calculator.
 Changed how scoping works in structs - automatically look up a level.
 44 new functions: Checksum, ChecksumAlgStr, ChecksumAlgBytes, Compare,
ConvertASCIIToUNICODE, ConvertASCIIToUNICODEW, ConvertUNICODEToASCII,
ConvertUNICODEToASCIIW, DeleteFile, Exit, ExportFile, FindAll, FindFirst,
FindInFiles, FindNext, FPrintf, GetBytesPerLine, GetReadOnly, GetSectorSize,
Histogram, ImportFile, InputOpenFileName, InputOpenFileNames,
InputSaveFileName, InsertFile, IsBigEndian, IsDrive, IsEditorFocused, IsLittleEndian,
IsLogicalDrive, IsModified, IsPhysicalDrive, IsProcess, OpenLogicalDrive,
OpenPhysicalDrive, OpenProcessById, OpenProcessByName, RenameFile, ReplaceAll,
SetReadOnly, SScanf, StrDel, SubStr, Terminate.
New Templates/Scripts
 New default scripts for splitting or joining binary files.
 New default template for parsing a WAV sound file.

General








New Windows XP Style.
New 'File > Special > Save Selection' command to save selected bytes.
Show selection start and size in the status bar.
Click on position or size in status bar brings up an edit dialog.
Many tables have an 'Export CSV' option on right-click menu to write a comma-delimited file.
Can change read-only plus other flags in file properties.
Hex Editor
 Cursor size changes in Insert/Overwrite mode.
 UNICODE character set support.
 International character sets support.
 Can split the hex editor into two parts using 'Window > Split Window' or button above scroll
bar.
 Scrolling can be synchronized between windows with 'Window > Synchronize Scrolling'.
 Division lines can be used to indicate blocks of data.
 Sector lines are drawn to indicate sectors on a hard drive.
 Addresses can be displayed as octal format or as a line number.
Tools
 Find in Files tool
 Can recursively search a directory or all open files for a set of bytes.
 Display find in files results in 'Find in Files' tab of Output Window.
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Can expand or hide results for each file.

Find





Can search with wildcards '*' and '?'.
Allow multiple find ranges to color the same file.
Find works with UNICODE.
 Highlights
 Allow multiple highlights to be applied at the same time.
 Assign different colors to highlights.
 Comparison
 Can limit which bytes are compared in a file (use to compare two regions in the
same file).
 Comparison results are sortable by clicking on the table headings.
 Add color indicator box to the type column.
 Can enable synchronized scrolling after running a comparison.
 Base Converter
 Support for Float, Double, ASCII strings, EBCDIC strings, UNICODE strings in base
converter.
 Checksum
 Can exclude a set of bytes in the file from the checksum.
 Can display the checksum results in decimal format.
Inspector
 String type in inspector.
 Display start address as local (offset from parent) from right-click menu.
 Template variable name can be 'Type + Name' or just 'Name' (use Column Display Format).
Bookmarks
 Bookmarks can now use custom data types defined in Templates.
 Bookmarks can be set to move when the cursor changes position.
Importing
 Do checksum when importing an Intel-hex file.
 In import file dialog box, can set file type as 'All Supported Import Types'.
 Can import multiple files at the same time.
 Support for reading and writing Intel Hex files that use word-based addresses.
Options
 Specify color of right area, separator lines, sector lines, and variable highlight.
 Specify additional include directories.
 Specify minimum number of digits in address.
 Option for turning on/off mouse over and hints.
 Option for adding 010 Editor to the Windows Explorer right-click menu.
Command line
 Can open a drive or process from the command line using '-drive:' or '-process:'.
 Run a script or a template from the command line using '-script:' or '-template:'.
 Mark a file as readonly using '-readonly'.
 Exit the application using '-exit'.
 Can use wildcards when opening files or importing files on the command line.
Help
 New improved help file.
Bugs
 Bug with window opening at zero height (in special cases).
 Bug with a slow-down when defining large arrays in scripts.
 Bug with divisions and the resulting types in scripts (in special cases).
 Bug with replace all never finishing on certain replaces.
 Other minor bug fixes.

Version 1.3.2 - April 19th, 2004
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Added functions ConvertASCIIToEBCDIC, ConvertEBCDICToASCII
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Added functions BitfieldLeftToRight, BitfieldRightToLeft
Bug fixes with Printf, Operations, and local arrays in Templates

Version 1.3.1 - April 6th, 2004



Changed header for templates and scripts
Bug fixes for the system path, and the Inspector

Version 1.3 - April 1st, 2004






Templates
 Added bitfield support to templates.
 Added DisplayFormatBinary and DisplayFormatOctal functions.
 Can disable warnings under 'Tools > Options > Code Editor'.
General
 Now use the new XP file dialog boxes.
Clipboard
 Can use 'Paste Special' command to paste in different formats.
Bug fixes
 Fixed problems with workspace, filling bytes, running templates, pasting large blocks, and
selecting bytes on NT machines.

Version 1.2 - Jan 24th, 2004






Inspector and Output Windows
 Added 'Copy Column', 'Copy Row', and 'Copy Table' to right-click menu.
 Added 'Column Display Format' to right-click menu - set the format to hex or decimal.
Scripts
 Fixed scripts to work better when writing out large files.
 Any of the 'Write' functions now automatically expand the file size when writing past the end
of the file .
 A single variable (i.e int x) defined in a template can be accessed as x[0].
 Added 'DisableUndo' and 'EnableUndo' to turn on or off undo - speeds up script when writing
large files.
 The 'FileNew' function now returns the file number of the created file.
Import/Export
 Added the ability to import or export 'Decimal Text'.
Bug Fixes
 Fixed 'Invalid Pointer Operation' bug in the Code Editor.
 Fixed a bug with the 'GetFileNum' function.
 A few other minor bug fixes with hotkeys and Templates.

Version 1.1.1 - Dec 19th, 2003


Minor bug fixes with bookmarks and the inspector.
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Added Expand All option to template right-click menu.

Version 1.1 - Nov 1st, 2003








Templates
 Support for enums (e.g. 'enum <ushort> MYENUM { COMP_1, COMP_2=5, COMP_3 } var1;').
 Enums variables are displayed with a drop-down list in the Inspector.
 Forward declared and recursive structs work properly.
 Defining local variables inside structs works better (proper scope).
 Zero-length arrays generate no variable (but do generate a warning).
 Can specify hex or decimal display in Inspector with DisplayFormatHex() or
DisplayFormatDecimal() functions.
 Zip template now contains an example of enums.
Installer
 010 Editor can be added to the system path automatically.
 Can automatically associate with Intel Hex or Motorola S-Record files.
Explorer
 Can drag-and-drop files from Windows Explorer to open them.
 Drag-and-drop for Intel Hex or Motorola S-Record files will automatically import them.
Importing
 Added default import byte under General Options (used for Intel Hex files).
Comparison
 Improved comparison algorithm.
Bug fixes
 Minor bug fixes with the Code Editor.

Version 1.0.1 - Sept 26th, 2003


Minor bug fixes with printing and inspector

Version 1.0 - Sept 16th, 2003


Initial Release
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